2 Replies Latest reply on Nov 23, 2016 7:39 AM by David Shealey

    Replace subassy with one from different directory

    David Shealey

      There is probably a simple answer, but I have not been able to find it.  I have an assembly with some subassemblies and parts that need to be replaced.  I cannot find out how to do it.  "Replace Component" seems to only be able to replace a part with an assembly, or an assembly with a part!  I want to replace an assembly with another assembly, and a part with another part. 

       

      Somehow we got some subassemblies and parts in a larger assembly that are in the wrong directory, need to fix it.

        • Re: Replace subassy with one from different directory
          Glenn Schroeder

          David Shealey wrote:

           

          There is probably a simple answer, but I have not been able to find it. I have an assembly with some subassemblies and parts that need to be replaced. I cannot find out how to do it. "Replace Component" seems to only be able to replace a part with an assembly, or an assembly with a part! I want to replace an assembly with another assembly, and a part with another part.

           

          Somehow we got some subassemblies and parts in a larger assembly that are in the wrong directory, need to fix it.

           

          I'm afraid that's not correct.  I don't know what's going on, unless when you Browse for the new component the filter is set to only show Parts or Assemblies.  Try having the new assembly open when activating the "Replace Component" function.  Then you can select it from the Property Manager instead of needing to Browse.

           

          Also, make sure you're right-clicking on the sub-assembly in the tree to activate the command, not on a component of the sub-assembly in the graphics area.