AnsweredAssumed Answered

Failing Features

Question asked by David Walker on Nov 21, 2016
Latest reply on Nov 22, 2016 by David Walker

I have a question.  I am modeling a product using a multi-body part.  I can't share any files or a screenshot because of the confidentiality of the product.  If you could imagine a cylinder (for example), I started by modeling the cylinder and split it into three halves (front (left and right) and rear.  I am snapping the front and rear halves together and have used the snap feature.  I have separate configurations of the part (front left, front right, rear and default) and have noticed that I spend a great deal of time correcting errors for the snap feature in some of the configurations AFTER the feature has successfully solved in the default configuration.  I used the "delete body" command to eliminate the halves that I don't need for a specific configuration.  In the default configuration, all the parts are present and It is serving as the complete assembly so that I can easily locate mating features (screw holes, bosses, etc.).  Does anyone have and reason why the snap feature would fail in one or more configurations after it has successfully solved in the default config?  I seem to be chasing my tail here...after solving it in, say, Front Left, I will get an error in Front Right.  When solving Front Right, it will error in Rear, and so on.  Am I doing something wrong?  The last features in the model tree are the "delete body" and it seems as though my last resort would be to re-create the configurations from the Default, after deleting the body that is not needed for that specific configuration.

 

Any help would be greatly appreciated.

Outcomes