AnsweredAssumed Answered

Smart dimension preselect effects caplock/numlock keys

Question asked by John Christensen on Nov 15, 2016
Latest reply on Nov 15, 2016 by John Christensen

The following is a simple macro to initiate smart dimensioning, yet also disable the pre-selection of entities.  It does this, except that it also, for some reason, is effecting the numlock/caplock keys by turning them on and off as well.  Why is it doing this.  What would I need to change or add to prevent this.

 

 

'to circumvent smart dimension preselect
'escape 3 times, initiate smart dimension
'
Option Explicit
Dim swApp As SldWorks.SldWorks
Dim swModel As SldWorks.ModelDoc2
Dim swModelDocExt As SldWorks.ModelDocExtension

Sub main()

Set swApp = Application.SldWorks
Set swModel = swApp.ActiveDoc
Set swModelDocExt = swModel.Extension

SendKeys "{ESC}"
SendKeys "{ESC}"
SendKeys "{ESC}"
swModelDocExt.RunCommand swCommands_SmartDimension, ""

End Sub

Outcomes