5 Replies Latest reply on Nov 12, 2016 8:35 AM by Jim Wilkinson

    smart dimensioning interface issue

    Jason Dye

      Hello All,

       

      I am using SW 2015 and have a issue when I Smart Dimension. When I select the item to be dimensioned the Modify box pops up. However it is the top entry that is highlighted and not the units.

       

       

      I have never seen this before and it is super annoying. Just takes that extra button click, but I know that the unit dimension should be highlighted.

       

      I recently moved into this computer, it is a Win10 Home Edition. Is there a registry that needs to be set?

       

      Thanks in advance

      -Jason

        • Re: smart dimensioning interface issue
          Tony Cantrell

          Try un-checking the "Input dimension value" under System Options

          • Re: smart dimensioning interface issue
            Jim Wilkinson

            Hi Jason,

             

            What service pack are you running? This was changed in a later service pack or SOLIDWORKS 2015 so that the dimension value is highlighted by default rather than the dimension name. Unfortunately, I am not sure exactly which service pack of SOLIDWORKS 2015 this was changed in, but I did test SOLIDWORKS 2015 SP05 and it highlights the dimension by default. Therefore, I would suggest you upgrade to SOLIDWORKS 2015 SP05 or later to resolve the issue.

             

            I hope this helps,

            Jim

              • Re: smart dimensioning interface issue
                Jason Dye

                Thanks Jim,

                 

                I am running service pack 0. However I don't think this is the root of the problem. I moved from a Win7 computer to this Win10. On my Win7 laptop and when I first moved into Win10 it was not doing this. I think the root problem is being caused by my GPU (NVidia GeForce GTX950M). This laptop has a 4K screen and it causes me other issues (Scaling and clipping) when docked or running multiple monitors. I keep working with updates and display settings to get the display correct and consistent when I am using just one screen or multiple.

                 

                As mentioned the Smart Dimension worked correctly when I first installed SW2015 on this laptop, then it started this behavior. I did make some changes to the display settings and it started working correctly, but I just made some more changes yesterday and the odd behavior started again, hence the reason I came to the forum.

                 

                 

                You can see from this picture and the one in my original post that some things get clipped. Not sure how to resolve this problem. Sometimes the clipping is so bad I cant see anything in the dialog popups, which is why I keep working with different display settings.

                 

                Thanks again.

                -Jason

                  • Re: smart dimensioning interface issue
                    Jim Wilkinson

                    Hi Jason,

                     

                    SOLIDWORKS did not fully support 4k monitors until SOLIDWORKS 2016, so in SOLIDWORKS 2015, you can try to work around the clipping issues by reducing the DPI (text scaling) settings to something lower, but you likely will still face problems since the code was not changed to support 4k monitors and scale things correctly based on DPI until SOLIDWORKS 2016.

                     

                    As for the original problem of the dimension name being highlighted instead of the value, I have no idea how that could be affected by display settings as it was a known problem of our code actually setting the dimension name as the default rather than the number when we introduced the dimension name to that dialog. So, I can't see how there would be a way to fix it without updating to a later service pack.

                     

                    Thanks,

                    Jim