AnsweredAssumed Answered

SolidWorks 2017 SP0 ignoring 3D Sketch

Question asked by Xavior Bryth on Nov 5, 2016
Latest reply on Nov 10, 2016 by Ryan McVay

Not sure how to phrase this, but SolidWorks is literally ignoring a 3D sketch I made when it comes to making lofted surfaces, etc.

 

So the 3D sketch consists of a single spline on a cylindrical surface (BTW, adjusting the handles is a nightmare--when you move one, the others don't want to stay still--I don't know if this is due to the mathematics of a curve on a surface, perhaps related to the curve's degree, or a bug in SW).

When I try to click on it in the loft feature (with SelectionManager or not) I cannot select it.  Graphics settings are set to high, and I can click on every other edge, visible sketch, etc.  (Graphics card is AMD HD7850 2GB.  I know, not ideal for SW in theory, but I have no problems selecting anything else).  Outside of the feature, right clicking and choosing Select Other doesn't let me pick the sketch.

I eventually discovered a workaround--create an extruded surface from the 3d Sketch, which gives me the edge. I can select that.

Outcomes