9 Replies Latest reply on Oct 26, 2016 11:57 AM by Glenn Schroeder

    Display state problem

    Alexandre Gragnano

      I have a problem with the display states:

       

      I have a part which contain a single body and two display states of this body:

      part-display-states.png

      - "Visible" display state is "Shaded With Edges" display style

      - "Hidden" display state is "Hidden Lines Removed" display style

       

      I have an assembly which contains multiple instances of this part and three display states of this component:

      assy-display-states.png

      - "First" display state shows 0°, 30°, 60°, 90°, 120°, 150° components in "Visible" display state and other components in "Hidden" display state

      - "Second" display state shows 15°, 45°, 75°, 105°, 135°, 165° components in "Visible" display state and other components in "Hidden" display state

      - "All" display state shows all components in "Visible" display state

       

      I have a drawing which contains 1 view of this assembly:

      drawing-view.png

      drawing-display-state.png

       

      I am unable to obtain the "First" or "Second" display state in the view.

      The display style of the view seems to override the display style of the bodies in different display states.

       

      This simple example is for demonstration only.

       

      How can I obtain the desired display state?

      I can sometimes obtain it on the screen but never after save as PDF.

       

      Best regards,

      Alexandre

       

      Edit 1) See the video in attachement

       

      Edit 2) I finally obtain the display state "First" or "Second" in my drawing:

      To do it, I forced "Shaded With Edges" display style in my "Visible" display state (previous value was "Default").

       

      But I am unable to export the drawing as PDF correctly:

      There is always a difference between what I see on the screen and what is exported.

       

      I join related files to this post.