AnsweredAssumed Answered

Cut-Sweep with solid doesn't work

Question asked by Max Crittenden on Oct 7, 2016
Latest reply on Oct 10, 2016 by Rob Edwards

I'm trying to do a Cut-Sweep with a solid body following a spline path, and it just doesn't work. I've tried varying the extent of the path that I follow, varying the plane on which I build the solid body, and varying the shape of the solid body. Either (most often) I get a message along the lines of "Sweep failed to complete", or Solidworks crashes, or I get an incomplete cut as in the attached model. Even following a short portion of the path, I believe the solid body sweep shouldn't leave so much of the part untouched.

 

The curve that makes the sweep path was generated with a motion study in a different assembly. I've tried changing the density of points along this curve when I generate it, and that doesn't seem to help either.

 

I'm following the same procedure I used to make a very similar previous part, when it worked fine. Now, no dice.

 

Any ideas what's going wrong? Thanks for any pointers.

Outcomes