4 Replies Latest reply on Sep 3, 2014 11:41 AM by Anthony Irwin

    Solidworks Document Manager Library

    Jeff Taylor
      Has anyone else reeceived the following error while trying to rename a file or while trying to use Pack and Go?

      "The Solidworks Document Manager library is invalid. Please see your administrator."

      Anyhelp in fixing this problem would be greatly appreciated.

      This problem just showed up oneday, it was not after an upgrade or update.
      • Reply
        • Solidworks Document Manager Library
          Paul McGarr
          I had that probelm all of the sudden too with SolidWorks 2008 SP3.0. There was no way to fix it, and it fixed itself with the update to SolidWorks 2008 SP4.0.

          I tried using the forum and my VAR to straighten it out. I belive my VAR also contacted SolidWorks.
            • Solidworks Document Manager Library
              Daniel Eelman
              I had this issue, and my VAR gave me the following response, which worked for me:


              Question:
              What causes the error, "The Document Manager library is invalid? Please see your PDMWorks administrator" when trying to use Pack and Go?

              Answer:
              This error message, "The document manager library is invalid. Please see your PDMWorks administrator." is caused by version mismatch of the 'SwDocumentMgr.dll ' file located in C:\Program Files\CommonFiles\SolidWorks Shared. The Pack and Go functionality relies on this file.

              To fix this issue, rename the file SwDocumentMgr.dll, and then repair the SolidWorks Explorer Installation.



              I don't know if this will work if you are seeing it other than using Pack and Go, but it's worth a shot.
            • Re: Solidworks Document Manager Library
              Josiah Lund

              I had this issue as well. After digging around for a little bit, I found an easy solution.

               

              1. Click the start button and search "CMD"
              2. Right click the program and run as administrator
              3. type regsvr32  "<disk>:\Program Files\Common Files\SolidWorks Shared\SwDocumentMgr.dll" and hit enter

               

              After doing this and closing and reopening SolidWorks, the issue was solved for me.