AnsweredAssumed Answered

GetFileCopy Issues

Question asked by John Groft on Sep 7, 2016
Latest reply on Sep 8, 2016 by John Groft

Hi Everyone,

I'm running into an issue with the GetFileCopy() method.  I've got a class that I use for working with EPDM.  One of the methods within that class (GetLatestVersion) uses GetFileCopy() to copy the latest version of a file to the local cache.  This method works just fine when I call it from a WPF application.  However, I'm trying to use it within a WCF web service hosted in IIS and it times out.  It doesn't 'fail' - no error is generated; it just doesn't finish.  I ran into a similar issue with LoginEx() but that was just permissions.  Now the login works and so do calls to get search results etc., but GetFileCopy() is giving me problems.

 

Now, the first parameter of GetFileCopy()  is actually supposed to be the parent window handle.  In IIS, there is no interactive session, so I don't have a window handle to pass.  I'm just passing zero instead.  I'm not sure if that's the source of the issue.  I've seen a number of examples on the web where zero is passed as the parameter, but none of the examples that I've seen specify whether they're being run in a WPF/Windows Forms application or if they're in web service, etc.

 

Has anyone tried this before?  Any insights?  This is my last obstacle so I'm hoping someone else has run into this and resolved it.

Outcomes