4 Replies Latest reply on Sep 27, 2016 2:45 PM by Andrew Gore

    Solidworks 2016 won't open

    Chris Castle

      I just installed Solidworks 2016 on a brand new workstation running Windows 10 Professional.  When I go to start Solidworks, the window asking me to activate the product opens up.  I say 'next' to activate and it brings me to the next window to choose which products to activate and how to activate (automatically, or manually via email - for what it's worth I have tried both methods).  I say 'next' and the next window shows the activation has succeeded.  When I click 'finish' the Solidworks window closes.  Solidworks shows up briefly in the task manager during this.  No error messages are shown on the screen.  When I try to open Solidworks again it brings me right back to product activation.  I've tried uninstalling and reinstalling a couple times and nothing has changed.

       

      Any help would be greatly appreciated.

        • Re: Solidworks 2016 won't open
          Gianluca Mattaroccia

          Chris, I would say call your VAR they will be able to solve it quickly.

          I am sure it is not the case but make sure you are connected to the internet.

          • Re: Solidworks 2016 won't open
            Deepak Gupta

            Try using the Rx tool and see if you can find something.

             

            Disable your anti virus and see if that lets you start SW?

            • Re: Solidworks 2016 won't open
              Andrew Gore

              I have the same issue.  Were you able to solve your problem?  My personal guess for my situation is that I had installed Solidworks on my laptop a few months ago, and didn't activate it in the 30 day allotted window.  Now I can activate Solidworks, but not open it just like you.  I've done 2 full uninstall\reinstalls on the machine with no luck.  I have a support call in with my reseller, so will see what they say tomorrow.

               

              Andrew

              • Re: Solidworks 2016 won't open
                Andrew Gore

                My reseller tech support got back to me and helped solve the problem today.  I had to do the following:

                Navigate to C:\ProgramData\FLEXnet

                Delete the 3 files in the folder (Event\*.data\*.001)

                You can probably try activating through Solidworks normally there, but they had me activate manually through command line.

                Open CMD

                Navigate in to your Solidworks Install Folder to the following path: (C:\Program Files\Solidworks Corp\Solidworks\Setup\i386)

                Run the following: swactwiz.exe /dellic/primprod:solidworks

                You'll get a prompt to Deactivate\Activate-Reactivate\View Licenses.  In my case, I chose to Activate\Reactivate.

                Solidworks then opened correctly for me.  It seems that since my 30 day license ran out, something got stuck in the Flexnet log files, not allowing the reactivation to take.

                 

                Hope that helps!

                Andrew