14 Replies Latest reply on Feb 22, 2018 12:04 PM by David Matula

    Projected view alignment

    Jeff Hamilton
      From time to time, today in fact, I have seen projected drawing views that are not correctly aligned. Most of the time the alignment can be broken and then redone, but not always.
      Anyone know what causes this. I have seen it for years...
        • Projected view alignment
          Eddie Cyganik

          Jeff,

          If I ever experienced this problem, I believe my Boss and I would be on a flight to Concord.

          Honestly, I've never had any issues with projected or aligned views that have lost there alignment.

          If I were you, I'd be doing more than just posting here!!!
          • Re: Projected view alignment
            Timo Ukkonen

            I just had similar incident. In my case I made a projected view on the right side of the main assy, I had a left projection that worked just fine but the new projection was misaligned. In one of the parts there was a sketch that I used to align this part and the sketch was considerably larger than the assembly itself. Somehow it screwed the alignment, I suppressed the sketch, made a new projection and it worked as it should. The question is why this sketch did not misalign the left projection in the first place...

            • Re: Projected view alignment
              Elmar Klammer

              True...still happens on and off. SW 2017 SP5 at least.

                • Re: Projected view alignment
                  Josh Brady

                  Just as info... It happens every single time you create a projected view.  Every projected view you ever create is wrong because the default view alignment is by the center of the view instead of by origin.  You're just lucky most of the time because usually you get the same result as by origin.  Unless the view you're projecting from is (as mentioned)  broken, or it has an alternate position view that makes the parent view extents larger than the child view.

                    • Re: Projected view alignment
                      Elmar Klammer

                      I didn't know that. But it makes sense now. I always wondered what causes the problem.

                      That is indeed weird, since the function to align by origin does exist within the software.

                       

                      Just one of those bugs....I don't mind this one too much as long SW focuses their effort on significant issues. I wished they would reduce the number of enhancements down from 200 to something like 20,30 or 50 maybe.

                      And in turn significantly boost specific features & functions or program areas that have a history of bottlenecks and pitfalls.

                      I would settle for same functionality if SW could boost performance by 15-20+ percent with each version.

                       

                      But thanks anyways,

                       

                      Elmar

                  • Re: Projected view alignment
                    David Matula

                    Does this problem happen on the same sheet format?  more than others?

                    When was the last time that you had the sheets resaved or modified?

                      • Re: Projected view alignment
                        Josh Brady

                        David Matula wrote:

                         

                        Does this problem happen on the same sheet format? more than others?

                        When was the last time that you had the sheets resaved or modified?

                         

                        It happens every time.  All the time.  It's a known bug with an SPR number and no plan to fix.  You only SEE the bug when your parent view has weirdness in its geometry. Doesn't matter anything about the sheet format.

                         

                        "Workaround", if you can call it that, is to RMB the wonky view and set alignment by origin to parent.

                         

                        See attached...

                          • Re: Projected view alignment
                            Jim Sculley

                            Josh Brady wrote:

                             

                            David Matula wrote:

                             

                            Does this problem happen on the same sheet format? more than others?

                            When was the last time that you had the sheets resaved or modified?

                             

                            It happens every time. All the time. It's a known bug with an SPR number and no plan to fix. You only SEE the bug when your parent view has weirdness in its geometry. Doesn't matter anything about the sheet format.

                             

                            "Workaround", if you can call it that, is to RMB the wonky view and set alignment by origin to parent.

                             

                            See attached...

                            Or, don't hide components in a drawing view.  Use display states in the model.

                              • Re: Projected view alignment
                                Josh Brady

                                Jim Sculley wrote:

                                 

                                Or, don't hide components in a drawing view. Use display states in the model.

                                 

                                This is just  the simplest demonstration of this behavior.  Also occurs when the parent view is an alternate position view showing a "larger" position or configuration.  Setting alignment is still the correct workaround, and is simpler than using a display state anyway.

                              • Re: Projected view alignment
                                David Matula

                                Josh... must be why I do not see it...Thanks for explaining that there is weirdness in the geom....  I could see that being a cause...

                                Just had the thought that it could be from old templates...