22 Replies Latest reply on Jan 15, 2009 7:07 PM by Adam Meyer

    PDMWE Templates

    Jeremy Schmidt
      Is anyone using the PDMWE templates to generate automatic part numbers? Is there any way to access these template through SW - File - New rather than a right click in the vault view? Thanks for the help.
        • PDMWE Templates
          richard lock
          Hi,

          So long as you have standard default templates defined in SolidWorks then you will get an additional tab on the SolidWorks file New dialogue giving access to PDMWE templates. Don't know why you have to have default templates assigned but you do.

          Regards,
          Richard

          PS. & your actually logged into a vault
          • PDMWE Templates
            Jeremy Schmidt
            I was able to get them to show up, but is there anyway to organize and/or rename them. It tacks on the name of the vault and any sub-folder structure you put into it, on top of the name of the template. So for example, my template named "Part" is lengthened to "(PDM_Vault)Part_English_Part.ctf". This is a little cumbersome to sift through. Not to mention that you loose the ability to divide the templates between different tabs.
            • PDMWE Templates
              Devon Sowell
              Hello Jeremy-

              Login into your Enterprise Vault as an Admin.

              Open SolidWorks and Enable the PDMW Enterprise Add-In

              In the SolidWorks Add-In PDMW Enterprise Toolbar, Select Options

              In the Options dialog Box, look at the bottom, Serial Number Options for Parts, Assemblies, and Drawings. Only the Admin can set these settings.

              Perhaps this might be useful to you. Sorry I don't have any screenshots, I'm using a client's computer today. This applies to version 2008.
                • PDMWE Templates
                  Jeremy Schmidt
                  Devon,

                  That's perfect. I was not aware that the users couldn't change those options. Do you know if they are machine specific or globally set? If they are machine specific, does the SW Copy Settings Wizard account for the PDMWE settings? Thanks for the help.

                  Jeremy
                    • PDMWE Templates
                      Devon Sowell
                      Hi Jeremy-

                      Most of the time, I'm a single seat User, so I can't answer your question until I'm working for certain clients. My advice is to just go ahead and try it, there's no harm if the Copy Settings Wizard doesn't capture the settings, you'll just have set it manually.

                      My best guess is that it won't.

                      Good Luck,
                      Devon
                        • PDMWE Templates
                          Calvin Nelson
                          This appears to be a database setting. Set it for one client and it applies to all.

                          However, I have not been able to create a PDMWE template which generates only one file when run thru the SW template window. It will generate the file with the proper name and properties, but it saves it, and then opens up another file from the template, assigns the properties and leaves that one open in the SW window with a generic name Part1.sldprt.
                          The template works fine if I run it thru the PDMWE right-click|New... interface.
                          Anybody else had success with setting up a PDMWE template to run thru the SW interface?
                          I have sent the issue on to my VAR. They said it looks like a bug, but they haven't issued an SPR, as of yet. It's only been a day.

                          Thanks,
                          Calvin
                            • PDMWE Templates
                              Devon Sowell
                              Hello Calvin-

                              What version of Enterprise are you using?

                              Do you have a Template Folder in the Enterprise Vault?

                              In SolidWorks, File, New, do you see the Templates in the Enterprise Vault?
                                • PDMWE Templates
                                  Calvin Nelson
                                  Devon,

                                  I'm running SW/PDMWE '08 SP3

                                  The template folder is in the vault. The SW template files do not show in the SW|File|New window, b/c I did not add that path in the SW Options.

                                  However, I created a PDMWE template to create a SW file from one of the templates in the vault and fill in the data card based on the user input to the PDMWE template form. These PDMWE templates auto-magically show up in the SW|File|New window, if you associate them with an .sld*** extension in the PDMWE Template wizard.
                                  As mentioned above, if I run the PDMWE template from the PDMWE interface, it grabs the user input and creates the file just fine and will open right up to that file if you click on the "Open File" button at the conclusion of the template.
                                  However, if you start the template thru the SW|File|New window, then it results in two files with the same metadata, one named per the PDMWE template, the other named Part1.sldprt, as if you had created it thru a normal SW template file.

                                  It sounds a little confusing with SW and PDMWE both using the terminology "Template."
                                • PDMWE Templates
                                  Adam Meyer

                                  Calvin Nelson wrote:

                                   

                                  Anybody else had success with setting up a PDMWE template to run thru the SW interface? I have sent the issue on to my VAR. They said it looks like a bug, but they haven't issued an SPR, as of yet. It's only been a day.

                                  I'm having this same issue. Has your VAR addressed it yet?
                                    • PDMWE Templates
                                      Joy Garon


                                      In your template defintion, what is the source file? a .sldprt file?

                                      Joy
                                        • PDMWE Templates

                                          PDMWE uses a .ctf file it get generated when you run the template manager.


                                          SW 2008 sp3.1

                                          Frank

                                            • PDMWE Templates
                                              Joy Garon
                                              Hi Frank -

                                              Not sure if you were answering my post or not...

                                              I was specifically asking about the definition of the template in Enterprise.
                                              What is the source file being used?

                                              Joy
                                                • PDMWE Templates
                                                  Joy,
                                                  I was answering your post, but you will have to give me a push,
                                                  Where would I find it, It has been a while since I messes with PDW and
                                                  as they say if you dont use it you will loose it.

                                                  Thanks
                                                  Frank
                                                    • PDMWE Templates
                                                      Joy Garon
                                                      Hi Frank -

                                                      Actually my question was directed to Calvin (I should have said so).
                                                      ---snip----
                                                      However, I created a PDMWE template to create a SW file from one of the templates in the vault and fill in the data card based on the user input to the PDMWE template form. These PDMWE templates auto-magically show up in the SW|File|New window, if you associate them with an .sld*** extension in the PDMWE Template wizard.
                                                      As mentioned above, if I run the PDMWE template from the PDMWE interface, it grabs the user input and creates the file just fine and will open right up to that file if you click on the "Open File" button at the conclusion of the template.
                                                      However, if you start the template thru the SW|File|New window, then it results in two files with the same metadata, one named per the PDMWE template, the other named Part1.sldprt, as if you had created it thru a normal SW template file.

                                                      It sounds a little confusing with SW and PDMWE both using the terminology "Template."
                                                      ---end snip---

                                                      When defining the an Enterprise template (via the admin tool), the 'source' file should be a .sldprt file not a .prtdot file.

                                                      Joy
                                        • PDMWE Templates
                                          Joy Garon
                                          Hi Jeremy -

                                          The options at the bottom of the page (which are only accessible when logged in as the admin user) are global - the options on the top half of the page are user specific.

                                          Cheers,
                                          Joy
                                      • PDMWE Templates
                                        One of our machines had this issue and was cuased it was that the user had 'Hide extensions for known file types' checked in Windows Explorer's file options. After clearing the checkbox, the user was able to use templates fine. Worth a shot.
                                          • PDMWE Templates
                                            Adam Meyer

                                            Lee Young wrote:

                                             

                                            One of our machines had this issue and was cuased it was that the user had 'Hide extensions for known file types' checked in Windows Explorer's file options. After clearing the checkbox, the user was able to use templates fine. Worth a shot.

                                            Thanks for the suggestion, but it didn't work for me.


                                            Is there a way to remove the extra tab that Enterprise adds to SW>>>File>>>New?
                                              • PDMWE Templates
                                                Jeremy Feist
                                                If you turn off the PDMWE add-in, the tab with enterprise templates goes away, but then so does everthing else that the add-in adds.

                                                why would you need the tab to go away? if you want to use a template from another tab, just select that tab...
                                                  • PDMWE Templates
                                                    I can get the auto numbers to work either by RMC in the vault or in SW file>new, but I can not make any changes to the templates,
                                                    they will not be recognized even though I run thru the template manager.

                                                    I think this coincides with my other post, importing files and the correct templates are not being used.

                                                    http://forum.solidworks.com/fo...=y&keyword1=templates


                                                    Frank


                                                    • PDMWE Templates
                                                      Adam Meyer

                                                      Jeremy Feist wrote:

                                                       

                                                      If you turn off the PDMWE add-in, the tab with enterprise templates goes away, but then so does everthing else that the add-in adds.



                                                      why would you need the tab to go away? if you want to use a template from another tab, just select that tab...

                                                      I was thinking of the CAD users who might use this tab accidentally and not get what they were expecting.