7 Replies Latest reply on Jun 11, 2008 6:02 PM by Dan Whitaker

    SW2008 Refuses to save my settings

    Dan Whitaker
      Hi everyone,
      I have been using solidworks for about five years now and have never come across this problem. I am hoping someone can help me out! When I change a system setting, for example, I turn on shaded planes, I open a template up and the change is good for one time, then I close out and open up a template again the second time and its as if solidworks "resets" its settings and my shaded planes are now off, or whatever setting I had changed becomes unchanged. I have made sure all my access rights are set correctly, so what is going on!!!!
        • SW2008 Refuses to save my settings
          Albert Whatmough
          In order for SolidWorks to Save "settings" you need to close SolidWorks down. If SolidWorks crashes (not that it ever does) before you close it down then your settings will not be saved.
          • SW2008 Refuses to save my settings
            Charles Culp
            For some reason my parts/assemblies always open up in "shaded with edges" instead of just shaded. I quit trying to figure it out and assumed it was just a bug. I have not noticed this with any other settings. Which settings are not saving for you?
            • SW2008 Refuses to save my settings
              Dan Whitaker
              SW will save my settings if I simply open up solidworks change a setting and re-open sw. My problem is that I put on shaded planes and it saves that setting but then when I open a document it it turns them off again? Why, its a system setting not a document setting, if it is a bug then it is an annoying one. Also, when I customize my toolbars it keeps the icons but seems to change the location of where I put them everytime I re-open the file.
              • SW2008 Refuses to save my settings
                Dan,

                Has this happened since the very first time you used it after your last install of SW?

                If so, I've seen this before - rarely. You might want to check your SW reg keys in your registry file that you have permission to right to them. Only check this if you're comfortable editing the Windows Reg file by going to START>Run>regedit. Backup your reg file before making any changes.

                Normally when SW installs, they should ALLOW you to read and write or FULL CONTROL or special permissions>. The keys to check are:

                HKEY_CURRENT_USER>Software>SolidWorks
                and
                HKEY_LOCAL_MACHINE>Software>SolidWorks



                • SW2008 Refuses to save my settings
                  Dan Whitaker
                  Yes, it has happened since I first installed it. I have tried reinstalling but it didn't do anything. I have checked the regedit and everything is good and still it is doing the same thing....
                  • SW2008 Refuses to save my settings
                    Dan Whitaker
                    thanks for all the help so far, I have checked my reg already, all my permissions are there. It is really strange because when I click on shaded planes and open up my template it works for the first time I open it up, but then if I close my part file and open up again, it takes off the shaded planes, it does this consistantly, over and over again. I deleted my template and made a new one, still have the same problem.