5 Replies Latest reply on May 16, 2008 7:41 AM by Anand Ramalingam

    Russian language

    Anand Ramalingam
      Hi

      Is that PDMWEnterprises supports Russian language.When i enter some russian text in a folder card it's shows me like "||||||||" this.

      But when i directly enter the property in DB it shows perfect so there is no problem in DB.....i hope.
        • Russian language
          Svetlana Antiperovitch
          Anand
          I don't use Russian here. Just wanted to salut Russian user.
          No wonder. Russian font don't work here on forum as well. Have to edit my message from Russian to English.
            • Russian language
              Anand Ramalingam
              ohoooooooo..... PDMWE is having any restriction on Russian language?

              Though i'm not a russian....... in my projects i have to use the language...
                • Russian language
                  richard lock
                  Don't know if this will help but is taken from the knowledge base;

                  Q: How is it possible to troubleshoot problems with changing the default language used in PDMWorks® Enterprise clients?

                  A: The user interface language in PDMWorks Enterprise is connected with the setting of the logged in user. Depending on which user you are logging in with the first time, that language will then be used in the interface. Note however that if logging in the first time as a user with a different language setting, then the changes will only take effect after Explorer is completely unloaded from memory and restarted - i.e. rebooting the client.

                  To set the language for a user, right-click on the user in the administration tool, select Settings and then set the language under the Language tab. A reboot will be required if the file vault view has been in use.

                  If a user for example were logged in as a user with English language set the last time the view was used, logging in as a user with German language set may not change all the interfaces at once (i.e. it will still be English menus). After a reboot, the German interface will be used and so on.

                  If the interface language switches back to a different language on a client, most likely they have initially logged in as some other user with another language setting and the system switches to that language again. Make sure the same user has same language set in all vaults if there are multiple file vaults available.

                  If there are multiple file vaults with multiple users in them, and there is one particular language that should be used for all vaults/users, the following trick will ensure the language setting "stick":
                  1. Close all explorer windows and exit PDMWE from the system tray
                  2. Select Start > Programs > PDMWorks Enterprise > PDMWorks Enterprise Administration
                  3. Expand the file vault
                  4. Right-click on the Users container, select Settings, select the Language tab and set the language to use (note if the language drop list already show the correct language, temporarily select another language, press OK, then open the settings again and set back to the correct language). Close the administration tool. (Repeat on additional vaults if you have any).
                  5. Restart client.
                  --
                  You can also check that the "default" language setting is set to the required language on the system, it sets that value when installing the client software and it could be that the administration tool reverts to default language when it is started without being logged in to a vault. Set the "defaultlanguage" to "D" for German for example:
                  HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\Applications\PDMWorks Enterprise

                  The following settings change when you set the language for the user, so when the user logs in the first time it will use this setting:
                  -Set the "language" to "D" for German for example under here: HKEY_CURRENT_USER\Software\SolidWorks\Applications\PDMWorks Enterprise

                  - Set the "0" value to "D" for German for example here: HKEY_CURRENT_USER\Software\SolidWorks\Applications\PDMWorks Enterprise\Vaults\_-Global\Settings

                  After changing values, a reboot may be required.

                  List of language codes (note that the registry value should be the language code):
                  English:GB, Czech:CS, German , Spanish:E, Italian:I, French:F, Japanese:J, Korean:KO, Russian:RU, Swedish:S, Portuguese-Brazilian TB, Polish L, Chinese simplified:ZHS, Chinese Traditiona:ZHT