16 Replies Latest reply on Dec 11, 2009 9:38 AM by Evert Schuttert

    Failed to launch server application

    Steindor Eiriksson
      We are getting alot of this "Failed to launch server application" working with design tables after moving to SW2008, we have tried all kinds of tricks such as disable all add-ins in Excel and so on, this happens both with Office 2003 and 2007.
      Any suggestions ?
        • Failed to launch server application
          Mauricio Martinez-Saez
          That is happening to us also. It normally happen the seccond time you try to open a Design Table.

          Report this to your VAR and make a lot of noise... belive me we try everithing possible and we work a lot with design tables, after many hours trying to detect the root of the problem we are convinced this is some new BUG inside SolidWorks.

          On every version the fix few things and some other that work before stop working... maybe is job security for the guys doing the programs... :-) but we are suffering the problems.
            • Failed to launch server application
              Mohamed Abdel Moniem
              If you got this message. lunch Excel manually and it will works.
              this happened when you solidworks tries to lunch other application like Excel, eDrawings....., it's something like a little conflicts between programs.
                • Failed to launch server application
                  Mauricio Martinez-Saez

                  This problem happen with Excell allready open, our API programs to update all DT's of large assemblies used to work perfectly on 2006 and 2007 now they crash due to the "failed to launch server application", This happen with Excel open and with Excel open the seccond time you try to open the same design table, if that design table is linked to another file and if any value of the DT chages and update the model.

                  The problem with all this nonsense is that we have a lot of work to do in order to keep a factory with over 400 people working and we do not have time to tinker with bugs... we aslo have other CAD applications, each one with his own load of bugs, but SW is the champion, the probelm is that we like to work with SolidWorks, so please report this to your VAR and ask him to make noise in order to at least get this on the "to-be-fixed-sometime-in-the-future" list.
                • Failed to launch server application
                  Steindor Eiriksson
                  Yes this is the same feeling we are having, I will definitely report this.
                  I have already got some unusable answers from VAR regarding this issue.
                  Thanks for your reply.
                  • Failed to launch server application
                    Hello boys and girls.

                    I have been having this problem since SW2007 and it is incredibly frustrating when you see this screen poping after you spent a lot of time mdifying something an loose all your work...

                    I realised lately that if I just let it run when the message pops up and wait until there is no more activity in the software, the message will disappear when clicking on the retry button and it seems to update correctly all the files. I think this only works with assemblies containing no subassemblies.

                    I'm taking a look now towards a tweek to extend some windows delay for hanging applications to be determined as such or something like that in the registry. I'll let everybody know if I find something.

                    See this macro I'm using to update the open files to an Excel master design table to which the embedded tables in solidworks files are linked. I only open the assembly and use the macro to update it and all of it's included parts at once.
                    Quite impressing. The master design table has to be open though as I couldn't find a way to have it open automatically. Hope this helps some of you.

                    Keep the faith !!!

                    Regards to all,

                  • Re: Failed to launch server application
                    We were getting a "Failed to launch server application" message when we tried to insert a bill of material and couldn't put BOMs in assembly drawings.  It turns out that we had downloaded a minor add-on program to excel.  Once the add-on was removed the problem was completely resolved.
                    • Re: Failed to launch server application

                      I am having the same issue here.


                      XP Pro, SW 2007 SP3, Office 2003. Design tables worked well, but do not work anymore.


                      I suspect Adobe Creative Suite 3, that installed Adobe Connect, PDF creation and possible other plug-ins to Excel.


                      Does anybody habe met that issue?

                        • Re: Failed to launch server application
                          Evert Schuttert

                          We also have the same problem, from the beginning (SW2008 for us). Now we have SW 2009 SP3 and PDMWE SP3. Still the same problem, we used to have Office 2003, but now we have 2007. No difference.

                          It happends the most when we have an assembly opened, and a part in it has a design table. You can't open the table, it says "Failed to launch server application" Or "unable to open design table using excel 2007". We then have to close all open files, reopen the part without opening the assambly it's in and then we can edit the table.


                          Other similar problem: A collegue had changed a lot in one assembly, was finished, pushed save and got "unable to save file". Only option is to close it and do it again. Or maybe try to save it on another filename and later save it as the original, but I'm not sure that would work.