1 Reply Latest reply on Apr 24, 2008 2:53 PM by Xinkai Yang

    Hole note callout

    Robert Berry
      What's up with the hole note callout?

      I get a space between the numerical instance and then a lower case X, then there is a space between the Dia symbol and the size callout, when I put a tolerance on the hole it comes out as full size text, not 50% less like I want it.

      I called the VAR and they said this is the way it comes from Solidworks, if I want to change it I can edit the calloutformat.txt file and change hundreds of lines of code to get what I want.

      Is there another way to do this besides editing this file?

      Personally I think it should come out of the box to the standard.

      I can get it to look like I want and to standard if use the smart dim command and add the instance callout along with the tolerance, but that is a work around.

      For me the hole callout command is usless as it is and not to the ASME standard.

      I also know I can edit the properties after I put in the hole note to change the text and get rid ot the thru, thru all etc.

      I know there has been discussion about the thru text in earlier threads, but the standard states if there is no depth it is intrerpreted as thru, period.

      This is also annoying to me as it should be an option and not the rule.

      Again I was told if I want to spend a considerable amount of time editing text files I can get what I want.

      Thanks for listining to my rant, any and all help will be welcome, as the VAR has been useless. Value added my eye.

        • Hole note callout
          Xinkai Yang
          Bob,

          I am running SW08 SP3.1, and assume you are using the same one.

          I always have upper case X. So, I don't know any other way other than change it manually to upper case, in your situation.

          For the tolerance font size issue, there should be two ways to modify the size:

          1.1 - Go to Tools>Options and select "Document Properties" tag on top.
          1.2 - Under "Detailing" on the subwindow on the left, select "Dimensions"
          1.3 - On the right, click "Tolerance..." button, and in the new window deselect "Use dimension font" under "Font" section. Select Font scale and put in your preference. i.e. 0.5 for 50%.

          However, this may not affect the dimensions that are already on the sheets. so another way is:

          2.1 - Select the dimension you want to change on the sheet
          2.2 - On the left window, select the tag "Other"
          2.3 - Similar stuff shows up, uncheck "Use dimension font" and enter your Font scale.

          I hope this works for you.