4 Replies Latest reply on Mar 4, 2008 1:17 PM by Matthw Wendlr

    SW06 Mesh Help

    Matthw Wendlr
      So I am trying to finish my thesis for school so I can graduate. Its due end of this month and I just can't seem to get the FEA I need done to work. I am just trying to run the static study on the complete assembly.

      The complete assembly will mesh just fine, I have used element size from .20 up to .40 however when you get that high it doesnt include some pieces. So I have been trying to stay around .375. Well when you go to run the study it gives me a "improper mesh around node n" message. So I play with the element size, and it still gives it to me. I have probed the mesh for that certain node and have created a control mesh around that node using much smaller element size. Go to run the study again and it gives me the same message around a different node.

      Can someone PLEASE help me. I need to figure this out so I can write my paper! I have spent the last 2 weeks trying to troubleshoot and get this to work myself.

      Thanks in advance.
        • SW06 Mesh Help
          I looked at your model breifly, but do not have time now to investigate further. I would suggest trying to simplify the assembly a bit, you may have done this already, but if not try suppressing any components that are not providing any structure to the assembly. That should make meshing a little easier.
          Another suggestions would be to try mixed meshing, but I'm not sure is '06 supports that. A surface mesh would work very well for the 4-link brackets.

          Good luck! I'll try to take a closer look, but can't promise anything. I've spent days on similar problems.

          You may also want to bug a VAR about this (thats what I usually do).
          • SW06 Mesh Help
            Bill Reuss
            I also looked at your model files and the CW setup. I cannot get the error to duplicate on my machine. As James mentioned, can you simplify the assembly? Or, can you utilize symmetry to run your analysis on half of the model? I can get the assembly to mesh and run with an element size of 0.375".

            Another option you can try is "Automatic Looping of Solids". In CW2007, from the pull-down menus - COSMOSWorks... Options... Default Options Tab... Mesh. Then look for the radio button for 'Automatic Looping of Solids'. Set the number of loops, global element size and tolernace factor for each successive loop. The CW help files describe what the options are doing for you. Using this method, starting at a global element size of 0.625", CW meshed the part with a global element size of 0.32" on the third loop (starting at 0.5" global element size).

            While watching the mesh progress, two parts appeared to be causing issues with the mesh: 1.25 Center Tube and Tie Down Tube. I would look into applying mesh control on these parts along with looping.

            Hope this helps.

              • SW06 Mesh Help
                Matthw Wendlr
                Ok I have taken out whatever components that should provide just minimal structural integrity. When looking into the "auto looping" that is how it was setup for default. So I just bumped the global element size upto .625, the loop # was at 3 and the tolerance was at .1

                So I created the mesh with a .375 global size, and .01875 tolerance when asked the parameters to create the mesh. I was then able to run the assembly. So hopefully that has fixed my problem, thanks alot guys.

                Now all I have to do, is figure out how to constrain the two cones to the 4link brackets on the back side!

                Thanks guys,
                -Matt
                  • SW06 Mesh Help
                    Matthw Wendlr
                    AHH, well after it worked yesterday I decided to call it a day. So when I got to work on it this morning, I added 1 constraint, created a new study. Made sure everything else was the same, and now it is giving me a improper mesh around node n again.

                    Nothing has changed besides that 1 constraint, so I deleted that and it still gives me the error again. I am so lost why it is doing this. Is there any end out there?
                    -Matt