0 Replies Latest reply on Feb 13, 2008 10:28 AM by Christopher Thorn

    Sketches not visible in parts after switching from Assembly back to Part

    Christopher Thorn
      Hi, thanks for taking the time help.

      Another apparently random issue has now manifested itself in SW2008 x64 SP2.1.

      I've noticed over the last couple of days that sketch features become hidden (not RMB > Show/Hide, I mean View > Sketches) on parts after I have opened the part from an assembly.

      For example, let's say I draw a simple cube by sketching a square and then extruding it. On the top surface of the cube let's say I sketch a circle. I save the part as Part1.SLDPRT. The circle sketch is still visible on the top of the cube. I then go File > Make Assembly from Part. I insert Part1.SLDPRT into the new assembly and save the assembly as Assem1.SLDASM.

      When I click on the View menu at the top, I can see Sketches is 'ticked'. If I now right-click on the cube component and choose Open Part the part will open, but the circle sketch won't be visible. If I check the View menu, Sketches is now unticked.

      I have tried it with new and existing components, and each time it's the same.

      The curious thing is that it only tends to happen after I have saved the assembly document, and then clicked Open Part, not when I just go File > Open > Part1.SLDPRT.

      I have made sure that no 'Open Lightweight'-type options are ticked in the Options dialog, and I have checked my file templates to ensure that both the *.asmdot and *.prtdot files have View > Sketches ticked.

      I had different issues last week and spoke to my VAR, who got me to make sure my graphics drivers were the same as those recommended on the SW website.

      I have just tried running SW in OpenGL mode, but it made no difference.

      I've run out of ideas now, so any help would be appreciated!

      Edit: I have just updated SW to SP3.0EV, and it has had no effect on the problem.