Declan McTiernan

Error 1904.Module [filepath] Failed to Register.

Discussion created by Declan McTiernan on Jan 8, 2008
Latest reply on Dec 22, 2015 by Joseph Finney
Hi All,
I was installing SP5.0 onto our 6 Solidworks workstations (all are identical Dell Precision workstations) this evening. All was going fine until I got to the last workstation. When the progress bar was nearing completion and the installation manager was registering components/dlls and finalizing the installation, an error dialog popped up:

Error 1904.Module [filepath] Failed to Register.

C:\Program Files\Common Files\SolidWorks Shared\DwgDocumentMgr.dll
C:\Program Files\Common Files\eDrawings2007\EModelReviewer.dll
C:\Program Files\Common Files\eDrawings2007\EModelView.dll
C:\Program Files\Common Files\eDrawings2007\EModelXlator.dll

Clicking "OK" on these errors the installation finished however as I suspected E-Drawings and SW Explorer failed to run, SW also threw up an error but it ran. I tried manually registering these dll's through regsvr32 without success.

I then uninstalled everything and ran a SW clean uninstall utility to clean up all the registry remains. Manually deleted any remaining SW Folders and cleaned out all temp file locations. Rebooted and then turned off Anti-spyware and Antivirus services and tried a fresh install from DVD at SP0.0. What happened.......only the same darn error dialogs on the same files. This time I was able to manually register all the dll's and now everything's back running again.

This is the first time I have ever experienced such a headache when doing an installation or installing a SP. Im just wondering has anybody else experienced this before and can maybe can offer an explanation for future reference.

Outcomes