5 Replies Latest reply on Aug 16, 2009 10:14 PM by Emilio Graff

    CosmosXpress Choking

    Jeff Mowry
      In optimizing a part (molded spring) for production, I'm making incremental changes to its structure. Anyway, I've been checking iterations of the changes and saving the CosmosXpress data as I go along and exporting files out to eDrawing format.

      I just completed some fairly major changes, and am now getting an error when I go to Tools > CosmosXpress to run things again. The error says "There is no solid body to process", which is clearly wrong since my solid body folder shows the body named as the last feature in my tree (normal).

      Any ideas? I'm thinking this could be a result of saving the CosmosXpress data as I've made changes to the part and now (after big changes to the geometry) it has some false assumptions about my part file (such as the solid body name). Is there a way to clear such data from the part file and start fresh?
        • CosmosXpress Choking
          Jeff Mowry
          OK, I just saved the part as a parasolid and imported/saved back to SW format. CosmosXpress works fine for the "new" part--so this seems to be what I suspected--saved CosmosXpress data is now hosed and incorrectable.

          Any ideas on how to clear such data with my original file? Perhaps using something like an OLE-removal file compressor?
          • CosmosXpress Choking
            Jeff Mowry
            I didn't see any means for clearing or accessing any sort of data--it seemed it was saved into the part file (somewhere). However, after more modifications to the model (later), it again began to work. (I don't have full CosmosWorks, since I rarely use this stuff for designing parts.)

            So CosmosXpress was able to eventually "see" the obvious solid body in the part and use it again for analysis--but I don't know what the trigger was that made the change. I'd love to have better control over this sort of thing so I could directly knock out the problem and not do all that parasolid noise--especially when doing fast iteration checks. It was nice that the work-around (hack) got what I needed.

            By the way, I also shut down SolidWorks to clear the RAM and tried with the original model, but that didn't work. ??? It was only later after even more changes that the original model began working again.

            • CosmosXpress Choking
              Vince Adams
              Jeff, have you sent the model that CX failed on into tech support. I've never heard of this problem so the odds that it will come up again in the near future are small. That said, I'd really like to maximize the value of your problem by getting the model into development.

              If you haven't talked to your reseller about it, can you zip it and send it to me for internal QA? We will keep it confidential and I'll post back anything we learn to this forum.

              Thanks!!!!

              Vince
                • Re: CosmosXpress Choking
                  Emilio Graff

                  I just ran into this with SW 2009. Going by the hints people gave, I was able to get SimulationXpress to work again by rolling back the model to the feature where I thought I last used it. Note that this will rename the solid body to the last active feature, which may be the problem.

                   

                  Now I hope by running a "study" and telling it not to save the data it will clear whetever keeps it from working beyond this feature.... It works!

                   

                  So what worked for me:

                   

                  1. Roll back the model to where you think Cosmos/Simulation Xpress last worked. I suppose trial and error will do well here in most cases.

                  2. Run a study, view the results, whatever, and when you close it, make sure you tell it not to save the data.

                  3. "Unroll" your model to the latest version. Hopefully you'll be able to run a new study.

                   

                  Lesson learned: don't save Xpress data!