3 Replies Latest reply on May 27, 2016 3:18 PM by Jeff Sweeney

    EPDM notification function doesn't work?

    George Huang

      hi everyone,i found that my notification function doesn't work at all time. Firstly,i am sure that is nothing to do with my PDM, because everything goes well under the new vault which i  created for testing.

      Every time when i finish one workflow, i hope the system send messages automatically to colleague who involve ,but it doesn't. so i wonder why ,and wanner  fix this trouble.What's more, i found the email system has worked normally previously, but  it has the same problem with the notification recently.So ,begging for your help.

        • Re: EPDM notification function doesn't work?
          Jeff Sweeney

          Sending notifications is a two step process. First the message is created and queued up in the DocumentActionInfo table in your database, next the PDM database service sends the emails from the list in that table.

           

          Are there records in the DocumentActionInfo table? If so, then there is something wrong with the service. (Try restarting it.)

           

          If not, are records being put in there in the first place? If not, there is probably something wrong with your configuration settings.

           

          I assume you are using PDM Pro? If they are being put in there, the service is taking them out, but still no notifications, there is probably something wrong with your SMTP settings. See if you can send an email via TELNET-ing to your SMPT server and sending a message manually.

            • Re: EPDM notification function doesn't work?
              George Huang

              waiting your reply for day long,first thanks to your advice .

              First of all,there has no  any records  about it while i've opened the SQL table.

              second,i use database for my messages system instead of smtp.as i mentioned above that if i created a new vault ,everything be OK.

              What's more,i don't really understand being put in there in the first place? you told above, can you give me more detail about it ,

              i am very sure i am so close to fix the problems with your great help.

              many thanks

                • Re: EPDM notification function doesn't work?
                  Jeff Sweeney

                  Watch that SQL table as you do something that should generate a notification. If you never see records go in, then you do not have PDM configured properly, nothing is triggering the creation of the notification in the first place.

                   

                  If you see a record appear, then after a few seconds disappear...then you have the notifications being properly triggered, the service is picking them up and creating the messages, but they aren't being sent. --Test the email settings. Do the users have their email address defined in the user properties?