2 Replies Latest reply on May 5, 2016 10:40 AM by Timothy Taby

    turn off hidden view while creating mates

    Timothy Taby

      In 2015 when I go to mate a part in an assemble the part stays solid, but in 2016 SP3 once I select a part to mate it turns hidden / transparent, which is really causing a lot of lag to select other edges.  Is there a way to turn this off so the model stays solid while mating?

       

      hiddenlines.png

        • Re: turn off hidden view while creating mates
          Alin Vargatu

          This is actually a good thing, because you do not need to mate a part with itself. This functionality allows you to select through the part.

           

          But you can turn it off.

           

            • Re: turn off hidden view while creating mates
              Timothy Taby

              In the past if I wanted to mate to a hidden edge I would just turn the part hidden and then mate it.  Most of the time I use visible edges, surfaces or planes to mate things in Solid works, it causes a lot less issues doing that.

               

              I did uncheck the box you showed and it is not hidden anymore, but my performance while having the mate command open still has not improved.  I assumed it was the hidden view on my part that was causing my lag while in the mate command, but apparently that was not the issue.  The assembly zooms and rotates normally when not in the mate command.