AnsweredAssumed Answered

Linear Pattern using equation fails when there is an evaluated .5?

Question asked by Simon Wilkins on Apr 14, 2016
Latest reply on Apr 21, 2016 by Simon Wilkins

I have been having a complete nightmare trying to figure this one out - I have registered this with my VAR and they have logged it as SPR930247... no comeback yet!

I am using a linear Pattern in a Part to generate some holes. They are a set distance 100mm from each end and then patterned inbetween with an equation for both the number of instances and also the spacing. It all works perfectly...except when the equation for the number of instances evaluates to an exact .5 figure. I think the problem is that Solidworks rounds the instance count down whilst the equation for the spacing uses "round()" which rounds the .5 figure up. This then causes all sorts of craziness as when you exit the equation manager and visually look at the pattern it doesn't reflect what is evaluated within the equation manager and seems to contradict the values it displays within the feature of the Linear Pattern itself. It is complicated to explain so I apologise if I am doing a bad job! I have attached the part... try altering the profile length to 1800 and look at the pattern - everything looks fine - now alter the length of the part to 1775 or some other length where the equated value in the instance count of the linear pattern ends up being exactly a .5 figure (1075 or 1425 profile lengths). That is when it all goes a bit crazy! I then thought that if I used "round()" in the equation for the instance count that would beat Solidworks as it would have to round the figure itself but that seems to cause inconsistencies as well! The equations work at all other lengths! If anyone can help that would be more than fantastic!

Attachments

Outcomes