3 Replies Latest reply on Mar 31, 2016 5:12 PM by Paul Salvador

    Surface wont thick unless I trim one edge of it

    Dallin Shaw

      Thickening a surface seems to be somewhat spotty as to how well it works for me, hopefully this post will clarify a few things.

      The attached model is a surface that has been thickened. What cost me hours was that it wouldn't thicken unless I did a surface trim, making the surface arbitrarily smaller. After the trim, the thicken works fine, but if i suppress the trim, the surface wont thicken.

       

      Using the check tool, I don't get any alerts with or without the surface trim.

       

      I would love to resolve what is going on here, because the thicken tool could really save me some time on a lot of projects if it would work more predictably.

       

      Thanks for any input.

        • Re: Surface wont thick unless I trim one edge of it
          Paul Salvador

          hmm,.. yeah, offset surface seems to work ok for both sides so you would think the mid thicken would work.... since we can not see the refence geometry, I'd guess that top trangent surface and adjacent surface just don't want to extend to trim?...  anyhow, I've attached what I saw and the workaround would be to replace face the ends (but you'd need to cut back the top first)..

            • Re: Surface wont thick unless I trim one edge of it
              Dan Pihlaja

              So, I started playing with your surface trim.

               

              I started reducing the trim offset plane (that you had to about .5").

               

              I reduced that dimension to .4604 and both the trim and the thicken worked.  I reduced it to .4603 and the trim did NOT work because the plane no longer intersected the surface, so the trim could not happen, and consequently, the thicken.

               

              I am running SW 2015 SP3 here, so maybe you will get a different result, but I think that the issue is specifically the corner points:

               

              I suspect that there is some issue here.  The reason why I say that is, BEFORE the trim happens, I cannot select the those points.....at all.  Not even with my selection filter set to vertices.

              AFTER the trim happens, I CAN select them.  And in my situation, the trim is trimming less than .0001" off.

              So, I think that the issue is that, your trim is conveniently doing away with the two points that Solidworks does not know what to do with.

              Do I understand why?  No.....however...

               

              In this situation, whenever I run into something similar, I try to model the part differently to get the same result without the errors.  Programs are sometimes finicky.

               

              If this is a translation from something else (step, igs, etc...) then you might be SOL, but if this is something that you modeled, maybe you can go about it a slightly different way and get the same result.