7 Replies Latest reply on Mar 24, 2016 2:00 PM by Ty Toney

    Hole callout issues

    Ty Toney

      We just recently upgraded from SW 2014 to 2016 and are now having some issues with hole callouts in both new and old drawings. It used to show like this:

      Now it shows as: 2X <MOD-DIAM> 4.200 <HOLE-DEPTH> 10.000

                                    M5X0.8-6H <HOLEDEPTH> 10.000

       

      Any idea as to what is going on? Some of our computers are doing this, some aren't.

        • Re: Hole callout issues
          Andrew Miller

          Have you tried recreating the callout?

            • Re: Hole callout issues
              Ty Toney

              Yes. I have also created a new part & drawing, to see if it was just old drawings that were showing incorrectly. It does it on everything. The pic in the above post was from a PDF. I opened the document properties to check settings, can't find one related to it but it shows in the same format.

            • Re: Hole callout issues
              Deepak Gupta

              Check and make sure you hole call out file in the correct location and it is mapped correctly under Tools > Options > File Locations

                • Re: Hole callout issues
                  Ty Toney

                  It is mapped correctly. when I opened the txt file it shows the same format:

                  Blind Hole

                  COUNTERBORE-BLIND=<MOD-DIAM> <hw-diam> <HOLE-DEPTH> <hw-depth>;\

                  <HOLE-SPOT><MOD-DIAM> <hw-cbdia> <HOLE-DEPTH> <hw-cbdepth>

                   

                  Is this correct?

                    • Re: Hole callout issues
                      Matt Peneguy

                      That is a weird problem.

                       

                      My text in the file looks very similar, but it appears there is a tab on the second line.

                       

                      COUNTERBORE-BLIND=<MOD-DIAM> <hw-diam> <HOLE-DEPTH> <hw-depth>;\

                            <HOLE-SPOT><MOD-DIAM> <hw-cbdia> <HOLE-DEPTH> <hw-cbdepth>

                       

                      If inserting a tab doesn't work, maybe try copying a calloutformat.txt file from a working computer to one of the computers that has this problem, and remapping to the new file.  If that doesn't work, if you have a maintenance contract, the VAR may be able to help.

                  • Re: Hole callout issues
                    Ty Toney

                    From Hawkridge:

                    In a similar fashion to what you tried on the forums, try launching 2016 and
                    navigate to Options > System Options tab > File Location > "Show
                    folders for" drop-down menu > Symbol Library File. This will list the
                    location of the currently used graphics symbol file.

                    If you have an installation with no custom file paths, then the default folder
                    path shown at the top of this list should be:
                    C:\ProgramData\SolidWorks\SOLIDWORKS 2016\lang\english. If the folder listed
                    does not match this path for your year version of SOLIDWORKS, delete the
                    existing path, and add the correct path.

                     

                    The symbol library file was still pointing to the 2014 folder tree, I remapped and it worked.