19 Replies Latest reply on Mar 28, 2016 9:29 PM by John Layne

    2016 sp3 EV, tangent edges problem

    Paul Salvador

      tangent edges showed fine in sp2... something has changed in sp3 EV.  (comparing 2015sp5)

      2016tang.png2015tang.png

        • Re: 2016 sp3 EV, tangent edges problem
          Paul Salvador

          ..this seems to happen with previously saved shaded models (NOT CONSISTENT)... if the model was saved un-shaded (wireframe).. the tangent edges show properly when re-opened.

          but,.. unfortunanely with ALL the saved shaded models... the tangent edge will NOT show properly?...

          I've tried supressing/ctrl-q... save as wire save a shaded...  WTH!?

          • Re: 2016 sp3 EV, tangent edges problem
            Anna Wood

            Figures 2016 SP3 EV drops the day after I install SP2.  Couldn't wait another day as I had customer files I needed to open.  SIGH....

            • Re: 2016 sp3 EV, tangent edges problem
              Andy Sanders

              I'm on 2015, but does playing with this setting in 2016 help?  Maybe it got flipped in the update?

               

              2016-03-23_16-17-16.jpg

                • Re: 2016 sp3 EV, tangent edges problem
                  Paul Salvador

                  Andy, thanks for the response... but,... unfortunately,.... no, that view setting has not changed.. and as noted.. it seems to be something new.... something they BROKE for this version/sp...   so, the programmer has some job security... and, we will have to wait until the next release......................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................... 

                • Re: 2016 sp3 EV, tangent edges problem
                  Tom Siemaszko

                  Paul, thank you for bringing this problem to our attention. I've just completed some testing and found that this problem is indeed new to SOLIDWORKS 2016. It occurs in all service packs of 2016 and appears to be unique to surface geometry. The problem occurs when the following is enabled: Tools > Options > System Options > Display/Selection > Edge display is shaded with edges mode > Optimize for thin parts. Turning this option off should resolve the problem for you.

                   

                  This problem has been reported to our R&D team for further review, but please be sure to report it to your VAR so that we can formally associate you to the bug report, and so that you'll be notified by email when the bug is fixed.

                    • Re: 2016 sp3 EV, tangent edges problem
                      Paul Salvador

                      I'm NOT reporting this to my var... it is YOUR JOB TO FIX IT!

                       

                        • Re: 2016 sp3 EV, tangent edges problem
                          John Layne

                          Couldn't agree more Paul, I've given up on reporting stuff to VAR's it's a waste of time. Two years wait it just way too long, for an answer.

                           

                          Just upgraded to 2015 SP 5 from 2014 SP 5, biggest mistake I've made in years. 2015 is buggy piece of @#$@#%$@. At this stage I think we'll skip 2016

                            • Re: 2016 sp3 EV, tangent edges problem
                              Jeff Holliday

                              As frustrating as it may be, some things do take longer than it seems like they should to get resolved.

                               

                              The report to the VAR accomplishes 2 things. First, if they have heard about a solution, they can pass it on to you. Second, they will file a report to SW. The report does not guarantee a solution will be coming soon. The bugs are assigned priority levels based on the seriousness of the problem and the cumulative number of people affected by it. The VAR does not do the software rewrite to solve the problem.

                               

                              You certainly have a right to expect help from the VAR. If you do not feel they are working hard enough on your behalf you can change to another VAR. All it takes is some paperwork.

                               

                              As you have indicated, you always have the right/choice to not use the current version.

                                • Re: 2016 sp3 EV, tangent edges problem
                                  Paul Salvador

                                  ok,.. here it goes...........I'm VAR INTOLERANT.    ..that is my best way of saying it. 

                                   

                                  Each user/owner mileage/perspective varies... but imho the var system is useless and flawed in so many ways.. but.. hey, I've just been using/buying 3D software for >25yrs.

                                   

                                  and sure,..  if you're not part of the solution, you're part of the problem...  personally sounds more like a user sorority paddle,... thank you sir may I have another.... or user conformity collaboration,..... win-win or lose-lose or win-lose-win-lose....... it depends on the users perspective and tolerance.

                                   

                                  as a user/buyer of this software... I've WASTED more TIME/MONEY with VAR's then I ever-ever wished...

                                  A VAR is a ménage à trois from years past..  I NEVER WANTED the link to a VAR and I don't want my $$$ going to a VAR..... they are ABSOLUTELY USELESS TO ME.

                                   

                                  Their system is flawed..  it's not in my interest to encourage it.

                                  • Re: 2016 sp3 EV, tangent edges problem
                                    John Layne

                                    I should probably clarify, the bugs I used to log with my VAR were bugs with the software. My VAR reported them to SolidWorks, one of which took 2 years to fix, hence my apathy.

                                     

                                    2015 has a number of strange little bugs that I've managed to find workarounds for, but I can't be bothered reporting them to my VAR.

                                    I'll list a couple.

                                    1/ Updating one largish assembly from 2014 SP5 to 2015 SP5 all concentric mates, relating to a fastener failed (no problems with 2013 and 2014) had to update about 70 mates.

                                    2/ Under certain conditions doing a "save as" will delete the description custom property. I now copy the description property, to notepad, before any save as to save time retyping description.

                                    3/ SolidWorks PDM Workgroup, is not honoring  "Bind ownership to SolidWorks read-write / read-only access". When I open an assembly despite having the items checked out and having ownership in pdm, SolidWorks opens some files as read-only (this has caused the most grief, but I'm getting used to double checking every sub component for write access (it's adding hours to my week).

                                     

                                    There are a few other bugs here and there, that I can work around. Fingers crossed, 2017 SP5 will be a functional release, once they fix the broken interface in 2016.

                                     

                                    Note before upgrading I did a complete clean uninstall of SolidWorks 2014 including editing the registry and I have full Admin access to my Windows 7 PC.

                                • Re: 2016 sp3 EV, tangent edges problem
                                  Glenn Schroeder

                                  Paul Salvador wrote:

                                   

                                  I'm NOT reporting this to my var... it is YOUR JOB TO FIX IT!

                                   

                                  He didn't say they aren't going to fix it.  He only said that reporting it to your VAR will get it associated with you so you get an e-mail when it's fixed.  If you don't want the e-mail then don't report it to them.