2 Replies Latest reply on Jun 7, 2016 7:28 PM by José Roberto Sánchez Hernández

    Decimals problem in DriveWorkXpress

    Clément Hauser

      Hi, I'm currently designing an automated 3D model of conveyors using DriveWorksXpress add in of Solidworks.

       

      Everything is working fine except for one issue.

      When i'm doing a dimension rule, if the result is not a finite number, it supress the comma.

      For example a rule that would be:

      "A= Lenght + 6.45"

      With Lenght = 500mm, the result would normally be A=506.45mm,

      (that's what DWX is indicating me as result), but inside Solidworks, the final value is 50645.

      As if the comma never existed !

       

      First i thought it could be a unit issue, but everything seems normal (MMGS).

      I already tried to change computer, same issue.

      I tried also using the next VBA functions to fix the comma's position: 

      -ROUND(x,y)

      -FIXED(x,y)

      I got the same results, no decimals are possible.

      With the FIXED function, for example when i do:

      "A = FIXED( Lenght, 2)" the result would normally be A = 500.00, but solidworks is giving me A = 50000

      With "A = FIXED( Lenght, 5), solidworks give me 50000000 instead of 500.00000, etc...

       

      I looked a bit in the internet, i'm not the only one to get that issue, but i did not find any viable solution.

      The fact to be limited to finite number is very limitating.

       

      I'm using Solidworks 2013 with windows 7 in Portuguese. 

       

      Do you have any technical solution to fix or  by-pass this issue ? 

       

      Kind regards.