1 Reply Latest reply on Jul 6, 2016 4:04 PM by Mike Apostol

    Bizarre Graphics Framerate Issue

    Mike Apostol

      So I've been running SolidWorks 2016 for a few weeks now, and then just last week it slowed to a crawl.

      Basically it looks like the frame rate drops very low. The caveat is, is if I open up a drop down menu, it acts normally again.

      I made a quick video of it: Solidworks Problem - YouTube

       

      In task manager, when it is in "stuttering" mode, cpu usage is 5-7%, when i open up a menu and it's operating normally cpu usage is 15-16%. Additionally I do not have this issue with 2014, it runs fine. 2015 does have this issue though which is why we skipped over it in my company. 2016 decided to just develop this problem for me only last week.

       

      Computer: Lenovo W540 with K1100M gpu and integrated Intel HD 4600

       

      Stuff I've tried:

      • Completely uninstalling and reinstalling all graphics drivers with the ones from Lenovo (official optimus drivers) as well as the official ones from Solidworks and the latest ones from NVidia. No change.
      • Repairing 2016, uninstalling 2016, reinstalling 2016

       

      Any advice would be great appreciated!

        • Re: Bizarre Graphics Framerate Issue
          Mike Apostol

          Solved the problem. Basically the Macrovision FlexLM licensing software some how got messed up, maybe from the multiple versions of solidworks I had on the computer or something.

           

          What I missed noticing previously was that when it was stuttering it was also at 100% hard drive usage and the fnplicensingservice64.exe was the root cause of it underneath ntoskrnl.exe

           

          I fully uninstalled everything related to solidworks, the licensing manager and FlexLM / Macrovision including everything I could find in the registry as well. Then once reinstalling solidworks 2016 it's back to being smooth!

           

          Hope that helps someone else!

           

          Cheers,

          Mike