AnsweredAssumed Answered

Unable to save to .vbproj

Question asked by Dennis Bacon on Feb 22, 2016
Latest reply on Feb 22, 2016 by Dennis Bacon

I know nothing about API so please bear with me. I have done quite a bit of autolisp programming years ago and was very happy with what I was able to accomplish. I thought I would get to know something about creating, writing, and editing macros so I shelled out some bucks for a book (SolidWorkks 2015 Using Macros). I ran into an issue right off the bat. The book asks you to record a simple macro and save it as .vbproj. When I stop recording I get a "save as" and select the .vbproj extension and name it then save. When I go to edit it there is nothing in the directory I saved it to (not a filter thing). If I save it as .swp it does save and is there but the code does not look anything like what I see in the book but works well when I run it. I'm using Windows 7 64 bit Prof..... What am I missing?... I do see VSTA as an Installed program but I do not see Visual Basic.. Could it be I'm missing something that was supposed to be installed with SolidWorks? I'm using 2014, 2015, 2016 Professional.

 

I know you can guide me in the right direction and I certainly appreciate the help.

Outcomes