0 Replies Latest reply on Feb 18, 2016 3:12 PM by Tony Thompson

    Property Tab Builder Linking To Data In An Excel Files

    Tony Thompson

      Hi all

       

      I have some tab builder templates we use for part and assembly files and I have all of the data for the drop down list currently linked to an Access database in SolidWorks 2015 but after installing SolidWorks 2016 on my backup laptop to test before upgrading everyone I found out the SolidWorks has for some reason dropped support to using Access so I am converting everything over to Excel. I have a single Excel file with 4 columns with different data like a list of our customer names starts in cell A2 and has over 200 different customers then I also have a column with all of the Engineers initials and so on. I linked this in SolidWorks 2016 with no issues but I can't get SW 2015 to work and I keep getting an error that says "Error opening excel document with given range. Range should be denoted with a colon." and I am using the same syntax that I am in SW 2016. I have the customer list denoted like this A2:A250 and I have tried adding spaces before and after the colon, I have tried parentheses but I keep getting the error. The Excel file is in the 2010 format with the file extension .xlxs

       

      I was on SW 2015 SP3 and I just updated to SP5 and though this might fix the problem but I am still getting the same error. Has anyone else had this problem?

      This is very frustrating and makes no sense because I have the colon in the specified range but it will not link to it. I even tried saving the Excel file to the 2003 .xls format but I still get the error that I am missing the colon. Why will this work in SW 2016 but not in SW 2015? I am using the EXACT same syntax in both versions.

       

      Also I never changed the default sheet name it is still Sheet1 and I have also tries the syntax Sheet1(A2:A250) like the example in the tab builder describes but I still keep getting the same error. I do have the first row with a description of what the list is for example in cell A1 I have Customer List as a header but it is only text I have no special characters in the description name.

       

      SWX Custom Tab Builder Error.JPG

       

      Thanks

      Tony