AnsweredAssumed Answered

Equations: Warning but still Working / Gleichung mit Warnung aber funktionieren noch

Question asked by Brendan Owen on Feb 12, 2016
Latest reply on Feb 15, 2016 by Brendan Owen

We recently upgraded to SW2015 and now some weird stuff is happening with some equations. I have an assembly containing two sub assemblies. The Top level assembly has a configuration table that allows the user to change the global variables A-Y. Those variables are referenced by the top level assembly, the two sub assemblies and their parts. This whole setup worked fine in 2012. For 2015 I adapted the equation set so that everything is run from the top assembly level. The first thing that happened was that all Part level equation lit up in red and I got the warning that the ref. dimension no longer exists. I clicked on some of the dimensions in question and all the red warnings disappeared. Sporadically the warning comes back but I can get rid of it. The second problem is shown below. The warning translates to something like: "The dimensions used for the equation are possibly not using the correct references. The assembly may contain components that have similar names or are not numbered.....blabla". In any case, the full text is below. We use the German version hence the attempt to translate this mess. Anyway, I cannot figure out what is suppose to be wrong. I have the instance IDs in the equations, the equations work and update properly but I still get the warning. Also, the warning shows up even if I reference a Dimension in a part that only exists once in the assembly. There are more equations that I have to add but every new one shows this warning. This also just started in 2015. Any Suggestions as to what I am doing wrong? I am not criticizing the functionality because it still works but I have to hand this model on to people who not have the background and freak when the lights go on in the feature manager. Any input is appreciated, thanks in advance.

Outcomes