AnsweredAssumed Answered

Solidworks will not load, hanging on loading registry

Question asked by Peter Medina on Feb 4, 2016

Hi everyone,

 

My machine has been down for the last 2 days and unable to load Solidworks.  It was all working fine the night before, the next day, Solidworks would not load.  It was hanging on Loading Registry.  I tried all the tricks in RegEdit, including renaming the Solidworks key and still no progress. I attempted to do a repair through the control panel and repair was taking over 12 hours and still not completing.  Finally, I logged into another profile on the machine and Solidworks loaded on that profile.  After trying to fix the other profile on the registry, the profile that would load stopped working and had the same issue.  I created a new profile, and Solidworks was able to load with that one.  I could not even perform a clean uninstall of the program to re-install it clean.  It would hang forever.  Finally, I thought to run the anti-virus because I was simply dumb-founded and my last resort was to manually delete directories and registry keys before a re-install.  No spyware or virus.  But there was an option for a performance tweak/evaluation from the free program I was using AVG.  Instead of being my usual skeptical self, I actually downloaded and ran it.  The scan indicated 245 bad registry entries, I proceeded to let it fix those bad entries.  Ta da!  Solidworks was now loading simply because of the free software.  I don't know if other scan software have this registry fix option, but I'll give credit where it is due and AVG Free saved my butt when it comes to Solidworks.

 

I hope this helps someone else out, or if anyone knows how to prevent this in the future, feedback would be much appreciated.

Outcomes