1 Reply Latest reply on Feb 5, 2016 12:24 PM by Jay Seaglar

    Solidworks crashes when trying to load simulation results

    Simon Czarnota

      Hi, I'm currently trying to run a flow simulation on an HP EliteBook 8760w but it keeps crashing when I try to load the results. It works fine on another computer that has much worse specification which is very puzzling. The simulation runs fine, everything else seems to be working correctly, but when I right click on "Results (Not loaded)", no matter how I try to load them, the program crashes. Again this only happens on the EliteBook, I tried doing it on an old Vaio and it works just fine. I reinstalled and tried to purge solidworks from the machine a dozen times and it still doesn't work.

        • Re: Solidworks crashes when trying to load simulation results
          Jay Seaglar

          In one case, the cause of similar symptoms was found to be older versions of resource files 'tbb.dll' and 'tbbmalloc.dll' present on the system. This specific case is characterized by entries similar to the following appearing in the SOLIDWORKS Journal File (swxJRNL.swj):

           

          'The stack trace for this error is:

          'Build: d140929.002.EH sw2015_SP0

          '{tbb:45603146:00013146} tbb:tbb::internal::allocate_additional_child_of_proxy::allocate

          '{~VWR1:CB75E155:000DE155} ~VWR1:CreateViewer

          '{tbb:45603C88:00013C88} tbb:tbb::internal::allocate_root_proxy::allocate

           

          Please try the following on the affected system:

           

          1) Close all sessions of SOLIDWORKS

          2) In Windows Explorer, browse to C:\Windows\System32 and locate the two files: 'tbb.dll' and 'tbbmalloc.dll'

          3) Rename BOTH of these files (e.g. 'tbb-old.dll')

          4) Browse to the binCFW folder within the Flow installation directory (e.g. C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Flow Simulation\binCFW)

          5) Copy both tbb and tbbmalloc files from this folder and paste them into C:\Windows\System32

          6) Reboot the system and test to see if the issue has been resolved

           

          (steps above are from KB Solution S-067291).

           

          It could also be due to non-certified graphics card/driver. Please see Graphics Card Drivers | SOLIDWORKS.