AnsweredAssumed Answered

Cannot draw using mouse

Question asked by Martyn Simmons on Feb 1, 2016
Latest reply on Feb 8, 2018 by Dave Johnson

I decided to try Draftsight Free for personal, not for profit work, but could not, initially, get it to work.  I have, in the past, used AutoCad.

Firstly; it will not install to My desktop, which is running Win XP SP3. I just get an Installer Error 1722 and the installation rolls back.  I have never seen this before with any other installation and have tried various suggestions on the web but to no avail. I have posted on another forum but no-one seems interested - https://swym.3ds.com/#community:70/iquestions:29389

Secondly; I have installed, successfully, onto my laptop (i5 Processor, 8Gb RAM, Nvidia graphics). The program runs but I cannot draw using either a mouse or the touchpad.  The mouse/touchpad will select menus and select drawing buttons (line, rectangle, circle etc) but I never get past the prompt to specify the start point. The only way I can draw, say, a line is to use the keyboard to input a start and end point vector. The line then appears.

I managed to fix the second fault by forcing Draftsight to run with the Nvidia GeForce GPU rather than the Integrated GPU. However; after I powered down for a few days (I normally just close the lid) it reverted to its old ways and I can now not use it again. I cannot even print from a Window or selection.  I have tried forcing the GPU selection to Nvidia and have even uninstalled and re-installed but to no avail.  I am not even sure that anyone is interested.

This is not a good start. I had hoped for a lot more than this rather poor start and am just glad that I did not pay for the Pro version. Please help.

 

 

 

Outcomes