12 Replies Latest reply on Oct 19, 2007 11:35 AM by Pete Yodis

    Search Tab

    Pete Yodis
      I just installed SolidWorks 2008 yesterday to test out. How come I don't have the search tab in my Task Pane? It is missing. I searched the help, tools options, and this forum and can't find why it would be missing. Desktop search is definitely installed on my machine. Any ideas why I have no search tab in SolidWorks 2008?

      Pete
        • Search Tab
          Devon Sowell
          Hi Peter-

          Have you Opened 2008 SolidWorks Explorer and set up the Search Options there, yet?

          9:46am:

          I believe you have to set the Options for Search in both SolidWorks and SolidWorks Explorer. Then, "Index" the selected Drives, and Folders. After that, I recommend a system ReStart, then the Search tool should appear in SolidWorks.
            • Search Tab
              Pete Yodis
              Thanks for the reply Devon, but that hasn't fixed it for me...

              Pete
                • Search Tab
                  Devon Sowell
                  Hi Peter-

                  Double Check the Index Status, if it was completed, then it's a different problem.

                  Bummer,

                  OK, do you comfortable editing the Registry?

                  If not, call your VAR and they'll walk you though it.

                  One of my clients had this problem so we "renamed" the registry, rebooted, and then Opened SolidWorks, SolidWorks wrote a new Registry and this worked.

                  Good luck.
                    • Search Tab
                      Pete Yodis
                      Devon,

                      It may not be done scanning... I will let it go for today and see what its like tomorrow.

                      Pete
                        • Search Tab
                          Pete Yodis
                          Devon,

                          Let the indexer run overnight. Restarted - no luck. What is the registry hack?

                          Pete
                            • Search Tab
                              Devon Sowell
                              1. Start>Run>regedit.

                              2. Rename the Key
                              HKEY_CURRENT_USER\Software\SolidWorks to
                              HKEY_CURRENT_USER\Software\SolidWorksxxxx
                              *If you have multiple versions of SolidWorks installed, your Key Path may look different.* **You may lose custom ToolBar, File Locations, and View Settings**

                              3. Exit regedit.

                              4. When you restart SolidWorks it will write a new Registry Key, with the default settings.

                              5. If there is a problem, just Delete the new Registry Key and rename the old Key back to the old name.

                              Also, Search this forum for other Postings about this method.

                              Good luck.
                                • Search Tab
                                  Pete Yodis
                                  Yeah, thought it would be that one... That would erase all my file locations for templates, BOMs, etc... Was trying to avoid that. Maybe a repair on the install would keep my settings and fix the issue?

                                  Pete
                                    • Search Tab
                                      Devon Sowell
                                      RE:"Maybe a repair on the install would keep my settings and fix the issue?"

                                      I don't know.
                                      • Search Tab
                                        Jorn Bjarning

                                        Peter Yodis wrote:

                                         

                                        Yeah, thought it would be that one... That would erase all my file locations for templates, BOMs, etc... Was trying to avoid that.

                                        Peter,
                                        To avoid loosing your settings: Backup you SW settings first using the Copy Settings Wizard. After hacking the registry import the settings again using the same tool.

                                        Jorn
                                          • Search Tab
                                            Pete Yodis
                                            Jorn,

                                            Didn't work for me. When I copied the settings out, it copied the issue with the registry. When I copied the registry settings back in, it just copied the problem right back in. Devon's suggestion did work, however, so I may just have to re-establish all my customizations the long way.

                                            Pete
                                              • Search Tab
                                                Wayne Tiffany
                                                If you want to dig into it more, save out your settings with the bad behavior and also with the clean settings. Then rename those two files as .txt and open both with a text comparing program. It will then go down through them and highlight the differences. Since you had made customizations, there will be many, but the key is to look at each one and see if it maybe has some relevance to the issue.

                                                WT
                                                  • Search Tab
                                                    Pete Yodis
                                                    thanks for the tip Wayne. I searched the knwoledge base and found this...

                                                    The SolidWorks Search Toolbar is controlled by the registry key: [HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2007\Search\Show Search]

                                                    Set this key to 1 from a 0. If it does not exist, create a new DWORD registry entry "Show Search".


                                                    This works for 2007, but it did not work for 2008.

                                                    Pete