8 Replies Latest reply on Jan 15, 2016 11:43 AM by Hetal Gustafsson

    Trouble attaching a file from EPDM in IBM Notes

    Hetal Gustafsson

      Hi,

       

      We have trouble attaching a file from EPDM in IBM Notes. Has anyone else has similar issue? The workaround solution we use is to save the file on the desktop and attach the file in IBM notes from there instead of getting the attachment directly from EPDM.

        • Re: Trouble attaching a file from EPDM in IBM Notes
          Charley Saint

          Hey Hetal,

           

          I don't know the first thing about Notes, but what is the problem you are seeing? Does it produce anything in the EPDM client log located in the administration tool? Have you modified the registry? A common problem with 32-bit applications is that people usually modify keys in

           

          HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\Applications\PDMWorks Enterprise

           

          and forget to modify the same keys that 32-bit applications pull from in

           

          HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SolidWorks\Applications\PDMWorks Enterprise

            • Re: Trouble attaching a file from EPDM in IBM Notes
              Hetal Gustafsson

              Hi Charley,

               

              Thanks for your reply. The problem I am seeing is that IBM Notes freezes when trying to attach a file from EPDM. It doesn't show anything in the EPDM client log in the Administration Tool either. No, we did not modify the registry and we know if we modify it in HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\Applications\PDMWorks Enterprise  then the same goes for in HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SolidWorks\Applications\PDMWorks Enterprise

            • Re: Trouble attaching a file from EPDM in IBM Notes
              Michael Marshall

              Interesting.

               

              We're running EPDM 2015 SP 2.1, and my PC is running IBM Notes 9.0.1FP2 (an in-place upgrade from 8.5.3 FP3, or something like that).

               

              Have you tried just the drag-n-drop method?

               

              I can't find anyone here who remembers using the File -> Attach menu picks in Notes to put an attachment in an e-mail message. Everyone I asked does the same thing I do...Windows Explorer window open on one side with files, Notes e-mail message open on the other side, and just drag-n-drop. No issues reported.

               

              I tried the Notes File -> Attach menu pick, and it allows me to navigate into our vault, select, and attach files to an e-mail message without issue. At first I thought the issue may be one of non-cached files causing a problem, but in our setup if I don't have the file(s) in cache (say -/x), EPDM will Get Latest of all files referenced by the file I'm grabbing (even if it's a drawing and I only grabbed the underlying part model), then attach the selected file to the e-mail message.

               

              What's ever weirder is let's say I have V. 17/35 of a model, V. 13/24 of a related drawing, and V. -/13 of another related drawing. If I navigate through Notes' File -> Attach and select just that model, it will in fact leave that V. 17/35 model in cache and attach it to the e-mail message. But that other drawing that I had V. -/13? It will Get Latest for that drawing file, even though I had not interacted with it directly in picking that part model for attaching.

               

              But, it works fine over here in our setup.