3 Replies Latest reply on Dec 10, 2015 3:43 AM by Feroz Mahomed

    Macro file corrupted. Cannot open in 2012 or 2015

    Sean Fan

      We started this macro in Solidworks 2012 x86. It had been perfect before we had 2015 installed.

       

       

      After we upgrade to 2015 this year, we start to get corrupted macros.

       

      We worked around it by opening it with Solidworks 2012, uncheck references, and save.

       

      Then we opened it in 2015, and change most objects to late binding.

       

       

      But from last week, the corrupted file can neither be open in 2012 nor 2015.

       

       

       

       

      Very frustrating.

       

      Is there any other software we can use to open swp file?

       

      I tried NotePad, and NotePad++. the outcome is not readable just like below.

       

      Please help.

       

       

       

      ication?    SldWorks$?  ?     swModel[?   activedoc趻 
      ?     swModelDocExt╯    Extension ?  ?     swDeInitiation ?  ?     swInsertCustomProperty猚    str椪    val葩    ModelDoc2    CustomPropertyManager b    Delete竫    Add2伧   ?     swCustomInfoText k   ?     swReadCustomPropertya?   ValOut=    value銴    Get4v?  ?     swReturnFilePath)?   filePath琌    filetype佬    MsgBox桼    GetPathName      ChrK~   ?     swReturnRevisionBuild.8    aX     Revision深    Build螮  ?     swUserDateV?   Userü    GetType)J   ?     swDocDrawingV?   LCase:?   Environ , 
      ?     swRenderImage血    ImageHeight幻 
      ImageWidth妟    ImageFormatv[ 
      ContourOption?    Suffix_M    swRayTraceRenderer猬    RayTraceRenderer ?   swRayTraceRenderOptions链    RayTraceRendererOptions棔    Errors徬    Warnings ?   sfile8a    tfileE?   status?    GetRayTraceRenderer<.   ?     swPhotoView ?   PreviewRenderQualityc?   FinalRenderQuality僙    BloomEnabledY?   BloomThresholdTV    BloomRa