5 Replies Latest reply on Oct 19, 2007 12:39 PM by Shawn Applegate

    Add File to Vault option

    Tim Turpin
      Periodically when moving/saving file to PDMWE file appears grayish in the folder and user is required to rt click and select 'Add File to Vault'. Once done file appears correct in folder and you can now search and find it in the vault.

      What causes this to happen? Can not find anything in help regarding this option.

      Thanks, Tim...
        • Add File to Vault option
          Joy Garon

          Hi Tim -

          For the most part the vault is 'listening' tocertain actions (i.e.: File Save, Drag & Drop) andautomatically adding files to the vault. There are cases wherefiles are not automatically added to the vault (i.e.: unzipping)and hence there is a need to use 'Add File to Vault'.

          For more information look in theAdministration Guide under the topic   Adding Files tab

          Excerpts from the admin guide....

          When a fileis saved to a file vault view from the save as dialog of anapplication, the file will be saved and added to the file vault.The PDMWorks Enterprise tray icon will show a green plus sign asthe files are added to the database and when the file has beenstored successfully a notification balloon will show how many fileswere added.

           

          Forapplications not using the standard Windows save as dialog (forexample, saving directly to a folder without prompting), the filemight not be detected and will only be stored locally (you wouldhave to right-click the file and select Add to file vault inthe file vault view).

           

          To makesure the file is detected and added to the file vault, you can addthe file extension to this list. Some applications will not triggerthe add question as well when saving new files unless theextensions are included in the list. Separate each extension with asemicolon. (You must specify each extension - wildcards do notapply.)

          Forexample, whenever you create a new Inventor Project file and pointit to a file vault path, the file is not added to the file vaultand ends up as a local file. Add the extension ipj to thelist, and it should now be added.

           

          Regards,

          Joy

            • Add File to Vault option
              Tim Turpin
              Attached is a screenshot of my PDMWE vault. I have just created (3) new parts in SW and from SW I saved them to the desired vault location ( not drag/drop, not copy paste, SAVE ). All (3) files are grayish and need to be 'Added to File Vault'.

              This does not happen all the time, only periodically and typically with file formats other than SW (corel, inventor, pdf). Why did/does this happen?

              Joy, Thanks for your response. I will look into it further.



                • Add File to Vault option
                  Shawn Applegate
                  We have the same problems.  When I save files from Solidworksto the vault, it adds it directly to PDMWE about 90% of the time. Sometimes it just doesn't work.  I have an open SR withmy VAR related to this.
                    • Add File to Vault option
                      Jeff Barker
                      If you have verified the info that Joy provided earlier in the string and the issue still exists, one possibility could be related to a time syncing error between the database server, archive server, and clients. All three need to sync to the time clock source (i.e. atomic clock). The file will not be added to the vault and will remain as a local file if any one of the machines drifts more that 30 seconds in either direction. Depending on your settings, you will usually you will get an error window. It should be noted that this is related to system architecture and not PDMWE functionality.

                      Joy,
                      Do you have any documentation that you could pass along on this subject? I couldn't find anything in the Knowledge Base.
                        • Add File to Vault option
                          Shawn Applegate

                          Jeff Barker wrote:

                           

                          If you have verified the info that Joy provided earlier in the string and the issue still exists, one possibility could be related to a time syncing error between the database server, archive server, and clients. All three need to sync to the time clock source (i.e. atomic clock). The file will not be added to the vault and will remain as a local file if any one of the machines drifts more that 30 seconds in either direction. Depending on your settings, you will usually you will get an error window. It should be noted that this is related to system architecture and not PDMWE functionality.



                          Joy,

                          Do you have any documentation that you could pass along on this subject? I couldn't find anything in the Knowledge Base.

                          When the time un-synchronizes, we get an error message indicating it. So, I'm not so sure if that is the cause.
                          http://forum.solidworks.com/fo...did=6988&enterthread=y

                          As far as the file not adding, I have this happen probably 10-15 times a month. Only happens when I save directly from Solidworks directly into PDMWE. I had Solidworks and our VAR remoted into my computer and I demonstrated this phenomenon (last Friday). We checked all my settings, and all was good. They didn't have any solution, except told us to document when and how we got to this problem. I've attached pictures for anyone curious what we are talking about.