5 Replies Latest reply on Dec 1, 2015 10:57 AM by Jim Wilkinson

    Can't Hide Hidden Edges...

    Ben Mitchell

      Hi,

       

      I've had this problem a couple of times and I haven't been able to figure out what triggers it or how to reverse it.  I'm hoping someone can help.

       

      I've built a complicated part, and somehow along the way it started showing a lot of edges that should be hidden.  I'm in the Shaded with Edges view option, but it's showing stuff it shouldn't show.  This is what it's displaying.  I just want it to look like a normally shaded part without all the hidden lines cropping up.

       

      I've plowed through the UI and the Googles a bit and can't find an answer.  Can anyone help me figure out how to get back to the default appearance?

       

      Thanks,

      -Ben

       

      Screen Shot 2015-11-30 at 3.42.53 PM.png

        • Re: Can't Hide Hidden Edges...
          Jim Wilkinson

          Hi Ben,

           

          I can think of two possible things that are going on. Here is what I would check:

          1. There may be a problem with the geometry. Do the following to see if there is:
            1. Use Tools, Check to see if it reports any problems. If there is, it may highlight the problematic geometry and you can start to look into why. 2015 SOLIDWORKS Help - Check Entity
            2. Another way to make sure the geometry is good is to turn on additional "body checking". See this help topic for details about body checking: 2015 SOLIDWORKS Help - Checking Model Geometry
            3. Another simple way to find if there is a specific problem is to use the roll back bar to roll back to a very early feature and then step through one feature at a time until you see the problem occurring. Then you know approximately when in the geometry creation the problem occurred, although the problem may have occurred with an earlier feature and it wasn't until other features were built on top of it that the symptoms caused by that original problem really start to show.
          2. If there doesn't seem to be anything wrong with the geometry, then these types of problems can also be caused by the graphics card/driver not interpreting the faces/geometry properly. In this case, you should check to make sure you are using an approved graphics card and the correct approved driver for the version of SOLIDWORKS that you are running. Here are some help topics on running SOLIDWORKS Rx which can help you tell whether your graphics card is supported and the driver is up to date.
            2015 SOLIDWORKS Help - SOLIDWORKS Rx
            2015 SOLIDWORKS Help - SOLIDWORKS Rx

           

          I hope this helps,

          Jim

            • Re: Can't Hide Hidden Edges...
              Ben Mitchell

              Hi, Jim!

               

              Thanks for your thorough reply.  I should have clarified that I'm on SW 2012, not the most recent version, but I doubt that's the issue for something this fundamental.

               

              In any event, I tried your rollback trick and found the sketch that's creating problems.  That said, I can't imagine how this sketch was the issue, but I've solved the problem.

               

              I had a sketch that placed a construction line through the center of the part that I used as an axis for revolution for subsequent operations.  That sketch was the problem.  When I deleted it and put in a reference geometry axis instead, everything started looking okay again.

               

              Thanks again, Jim!  Very helpful.

               

              -Ben

                • Re: Can't Hide Hidden Edges...
                  Jim Wilkinson

                  Hi Ben,

                   

                  Great. I'm glad you solved it. I've never heard of that problem even in the older versions so I'm not sure what may have caused it; maybe a bug. Glad you can move on from it and have learned some new troubleshooting techniques!

                   

                  Thanks,

                  Jim

                    • Re: Can't Hide Hidden Edges...
                      Ben Mitchell

                      Yep.  The really useful learning here is that this was related to a model problem, and not some view setting that I'd accidentally toggled through an inadvertent keyboard shortcut or something.

                       

                      It never occurred to me that something about the model geometry would be the root cause of what seemed like a display problem!

                       

                       

                      Thanks again, and Happy Holidays!

                        • Re: Can't Hide Hidden Edges...
                          Jim Wilkinson

                          Hi Ben,

                           

                          Just so you know the root of why that can be the case. The display of the edges is very dependent upon what the model information says for what is "inside" and "outside" the model. So, if the model is supposed to be a solid body with all faces pointing outward (which is normal), but something gets a-miss so the normal of one or more faces is pointing in rather than out, or if faces are intersecting one another other than at their edges, then the display algorithms can also get very confused because they don't know what is in or out (and therefore, don't know which edges are behind faces vs. in front of them).

                           

                          Thanks,

                          Jim