1 Reply Latest reply on Nov 30, 2015 1:36 PM by Charley Saint

    SW EPDM 2014SP4 - dispatch error "can't access elements in database"

    Jörg Loewenstein

      System ran fine for years, then we bought a new server, mirrored the db to the new server. Files were on the new server, logins were still managed from the old server as far as I can tell.

      Now we wanted to upgrade to EPDM2015. Old server had to go because the OS and SQL were too old, so we moved everything to our new server first.

      We also created a new windows domain on the new server and moved all users into it.

      We started upgrading to 2015 but failed because we had no 24-digit SN (we got it by now), so used our backups and put everything back. So far everything seems to work just as before, with following exception:

       

      Now we're getting some error messages from dispatch which say (roughly translated from german: "unexpected error. cannot access elements in the database. 0x80040207"

      We had some similar messages but quickly found some references to the old server in the client-side windows registry and fixed those.

      swepdm_dispatch_error.jpg

      It seems only this action is causing problems, but it worked for a long time before.

      Reading the log shows following entry:

      "Error running query in SpDbOdbc
      State=22008
      Msg=[Microsoft][ODBC SQL Server Driver][SQL Server]Bei der Konvertierung eines nvarchar-Datentyps in einen datetime-Datentyp liegt der Wert außerhalb des gültigen Bereichs."

      (translated: value out of bounds while converting nvarchar-type to datetime-type)

       

      Assuming from the log entry it can only be this command, which worked fine until recently:

      swepdm_dispatch_action.jpg

      Deleted and recreated this action already. checked the whole registry (client and server registry) for more references pointing to the old server but couldn't find anything.

       

      Does anyone know a possible solution to this? I assume there to be some more references, or it might be access-rights-violation because of the new windows domain, but we really can't find anything.