8 Replies Latest reply on Feb 17, 2016 4:27 PM by Peer Larson

    WPDM api reference in 2016

    Matt Martens

      Does anyone with 2016 installed use macros to access the WPDM vault from outside of solidworks?

       

      I upgraded my SW version last week and now my macros in excel and MS access that utilize the WPDM API do not work. The ActiveX can't create a connection to WPDM. I thought the reference just needed to be reloaded so I went and unchecked it, ok'd the references dialog, then came back in to try to reestablish it and I get an error in loading DLL message.

       

      I opened SW and tried my WPDM macros there and they work fine. It seems to only have affected the macros that run outside of SW. I even tried reloading the reference like in excel  and access. It didn't have any problems. Any suggestions would be appreciated.

        • Re: WPDM api reference in 2016
          Matt Martens

          Apparently, when SW2016 installed the IM only put the PDMWorks .dll in the 64-bit shared folder and not in the 32-bit shared folder. By copying the .dll into the 32-bit folder I was able to get past the "Error in loading .dll" dialog. However, my code still won't run because the ActiveX still can't create the PDMWorks connection component.

           

          Any suggestions?

            • Re: WPDM api reference in 2016
              Peter Farnham

              Hi Matt,

               

              I have my VAR looking into this at this moment.

              He copied all the dll's to the shared folder, but it still does not work.

              He then registered these dll's though cmd (ran as administrator). still not working.

               

              Through he has said that he can create the activex on his machine.

              His and mine are both Solidworks 2016 sp1.0.

               

              The only difference so far that is seen, is that he is running Office 2013 as 64bit, whilst I am running Office as 32bit.

              Microsoft (on their web site) do not recommend updating Office 64bit as a lot of other program will not work correctly!

              Also you would have to totally uninstall Office 32bit and then re-install Office 64bit.

               

              I will let you know of any progress.

               

              Pete