0 Replies Latest reply on Oct 28, 2015 1:36 AM by Leroy Jenkins

    Specifications on Toolbox Components not applying

    Leroy Jenkins

      So earlier today I decided to do a little (lot) of cleaning up on my computer and I think I may have deleted something important from my program files...

       

      When I open up a new blank assembly, I can go to Design Library > Toolbox > ANSI Inch, Metric, etc.. > and then, for example, Gears. Let's say I wanted a helical gear from the ansi inch folder with a diametral pitch of 10 and 60 teeth. So I drag and drop the helical gear icon into the workspace and the "Configure Component" window pops up on the right with all my options like pitch, number of teeth, etc. I can change diametral pitch, number of teeth, pressure angle, face width, shaft diameter, helix angle, pressure angle, etc all I want, but the gear won't change from the specs it had when I first dragged it into the workspace. Interestingly, changing helix direction from left<->right does affect the component. Same goes for adding a hub to the gear - for some reason I'm allowed to add a hub and size it as usual.

       

      After I initially drag/drop a component and then input my desired specs, I'm given the opportunity to click elsewhere in the workspace to place another of that same component. Unfortunately, this one also does not have any of my desired specs applied to it.

       

      I then tried opening a simple assembly I had saved that contained a few random gears I made in the past with the toolbox feature. The model opens correctly and the gears are sized right, immediately followed by a prompt saying that there's a missing toolbox size and would I like toolbox to automatically create the missing size. Saying yes, no or cancel doesn't matter because every choice makes the gears revert to the "default" gear that you get when you first drag/drop from the toolbox. If I go to edit toolbox component on a gear, it still indicates whatever specifications I had. Right now I'm looking at a bunch of gears that supposedly have 300 teeth, but only show in the workspace as having about 17 or however many you get when you drag/drop the "default" gear from the toolbox.

       

      In the folder: C:\Solidworks Data\lang\english  I have "swbrowser.sldebd" and "swbrowser.mdb" both I'm pretty sure are supposed to be there. Next I tried going to C:\Program Files\Solidworks Corp\Solidworks\ and ran "sldtoolboxupdater.exe" as administrator but that seemed to have no effect

       

      This isn't making much sense to me. It seems like the core toolbox files are stored in the solidworks corp folder within program files, but the ones being referenced by SW while using the program are the toolbox files in the C:\Solidworks Data folder?

       

      I found this thread Spur Gear will not update when creating part

       

      Seems to be exactly the same problem, except I'm using 2015. Anyone know of a fix for this? I've been going around in circles for hours now.