AnsweredAssumed Answered

Solidworks pack and go now working giving me an error

Question asked by Rob Docter on Sep 28, 2015

Hello I have been having this problem for a while and I can not seem to fix it at all.  I have tried all of the responses given to me in the last post but realized that I have this error too.  When I go into Solidworks and do a file pack and go I get this error. "Could not load Solidowrksdoll:sldshellutils."  So I googled the error and go a lot of responses due to Microsoft's update I think so I followed these directions.

1.  CATI Tech Notes: How to Fix SOLIDWORKS Microsoft Security Patch KB3072630 Issues

That did not work at all and I got a different error when I tried to fix the Solidworks install.  This was the error message I got "The installation manager failed to register sldsearchifileter.dll"  Then it gave me a long line of listings of where the registry was located on the drive.

 

So I then tried this method that I saw a lot of people had success with.

2.  https://customerportal.solidworks.com/eservice_enu/start.swe?SWECmd=Login&SWEPL=1&SRN=&SWETS=1267144948839  

This did not work also as I go the same exact error message as I got in the last one when trying to fix the install. 

 

So with all my searching I do not know what to do but keep working on this faulty Solidworks that will not let me pack and go as I do not have very urgent assemblies that need pack and go at the time but it would be nice if they worked.

 

Also if you need more information I when I try and open Solidworks explorer I get this error

"The DWG document Manager library is invalid or missing please see your administrator.

 

And I followed the steps to fix this too and I still get this error so could anyone tell me if I can fix this without doing a complete uninstall reinstall of Solidworks or is that my only option at this point?  And if that is my only option how to I reinstall it without this happening again.

 

Thank you guys for all of your help

Outcomes