7 Replies Latest reply on Oct 6, 2015 9:19 AM by Stan McLean

    DXF creation task not scaling 1:1

    Wayne Easton

      If I create a drawing with a sheet for laser cutting, I would like the DXF task which runs on approval to save the sheet out in such a way that the items to be laser cut are scaled 1:1. Currently I have to set the scale of the view in the actual drawing to 1:1 in order for the dxf to be scaled at the correct size. The result of this is a drawing sheet with most of the view off the drawing sheet.

       

      If you save a file as a dxf out of Solidwork, you have the ability to set the scaling options but I can't see how to do this on the EPDM task side. The option dialog in the the task are grayed out.

       

      Thanks

        • Re: DXF creation task not scaling 1:1
          Prasad Bhonsule

          Hi Wayne, unfortunately it seems that there is a open SPr about this issue:

           

          SPR 518763

           

          Conversion (export) options (Scale, Fonts, Multisheet etc.) are missing for DXF and DWG when configuring conversion settings in a Convert task

          • Re: DXF creation task not scaling 1:1
            Jeff Sweeney

            This used to work, though I haven't tried lately....

             

            Go to the machine that will be executing the task, open a drawing and export the dxf with the settings you want1to1.JPG

            Then close SW. As I recall, SW will save those settings and use them until they are manually changed. So that should force a 1:1 task output. (Until someone changes the settings.)

              • Re: DXF creation task not scaling 1:1
                Wayne Easton

                I will have to try this, however, it doesn't leave me feeling very comfortable with the idea as a user could inadvertently make a change and next thing you know the auto dxf exports are all scaled incorrectly.

                 

                This type of setting should be controlled globally from the task settings in EPDM.

                  • Re: DXF creation task not scaling 1:1
                    David Hinners

                    Can you run a macro instead of the task?  The API has the ability to set the export settings at run time so you get consistent results regardless of user changes.

                      • Re: DXF creation task not scaling 1:1
                        Shawn Pantzke

                        Unless you have a custom addin for EPDM the tasks are typically macros that can be modified.

                         

                        If you go into the task in the scipt section if it is a custom task, or the 'Output File Details' section for tasks like a file conversion, in the 'Advanced Scripting Options' you will see a text editor that is no more than some VBA code.

                         

                        From here you can modify the task as you see fit. I personally set the sheet scale and the view scale to 1:1 before I export a dxf and then using the api tell SW to enable 1:1 scale output.

                         

                        SLP

                  • Re: DXF creation task not scaling 1:1
                    Bob Van Dick

                    When exporting a dxf file to the laser (or any CAM program), I do it from the model mode, not the drawing mode.  I believe exporting from the model mode scales the file 1:1 as a default.  I have never had a problem with a dxf file not being 1:1 when exported from the model mode.

                    • Re: DXF creation task not scaling 1:1
                      Stan McLean

                      You can leave the flat pattern on your drawing so it will fit in the borders of your drawing, but do not scale your flat drawing view separately to fit.  Scale it by changing the sheet scale (RMB on the sheet and select properties).  This will effect all of your views.  When you export the drawing the flat pattern will be scaled 1:1 by the option available in the export options.  I personally never use this method as several properties can by changed by anyone that will effect the output.  I always export the flat pattern from the model.