Solidworks – Hints, Tips, Tricks and Best Practices.
A comprehensive list of useful tips and techniques.

A collection of hundreds of Solidworkstips, tricks, best practices and useful techniques collected from the internet, Solidworks Forums and other fora. Most of it is edited with my own experiences with Solidworks and also to create a more consistent look. The subjects are listed and sorted by the Solidworks main chapters; Sketches, Parts, Weldments, Surfaces, Sheet Metal, Assemblies and Drawings. Most of the subjects are written for beginner’s level (CSWA and CSWP) and requires some basic understanding of Solidworks.

Henk de Bruijn
2019-01-20

Solidworks - Hints, Tips, Tricks and Best Practices – 3rd edition
SOLIDWORKS

Table of Contents

1 General settings .................................................................................................................. 7
  1.1 Screen settings of your monitor for properly functioning of Solidworks....................... 7
  1.2 The User interface: ........................................................................................................ 8
  1.3 Feature tree icons .......................................................................................................... 9
  1.4 Customizing the Solidworks User Interface .................................................................. 9
  1.5 Common settings for the Keyboard-shortcuts: .............................................................. 10
  1.6 File Locations and default Templates: .......................................................................... 10
  1.7 Copy settings and customizations before updating or new installation. ...................... 12

2 General tips ......................................................................................................................... 13
  2.1 Rules of thumb .............................................................................................................. 13
    2.1.1 General rules of thumb .......................................................................................... 13
    2.1.2 Rules of thumb for Sketches in Parts .................................................................... 13
    2.1.3 Rules of thumb for Part-Features .......................................................................... 14
    2.1.4 Rules of thumb for Assemblies ............................................................................ 15
    2.1.5 Rules of thumb for Drawings ............................................................................... 15
    2.2 Display the triad .......................................................................................................... 15
    2.3 Create a new Coordinate System .............................................................................. 16
    2.4 Other Tips .................................................................................................................. 16

3 Solidworks and AutoCAD ................................................................................................. 17
  3.1 Importing .dxf- or .dwg-files ...................................................................................... 17
  3.2 Exporting to .dxf-format ............................................................................................... 17
  3.3 Importing layers ........................................................................................................... 17

4 File management ................................................................................................................ 18
  4.1 Renaming of files ........................................................................................................ 18
  4.2 Option “File save as” explained .................................................................................. 19
  4.3 Macro’s ......................................................................................................................... 19
  4.4 The “Split Feature” explained .................................................................................... 19
  4.5 Saving bodies as a Part file ........................................................................................ 21
  4.6 Create a Library with custom materials ...................................................................... 21
  4.7 Importing STEP-files .................................................................................................. 22
  4.8 Importing coordinates from an Excel sheet (ScanTo3D) ............................................. 23

5 Part modelling .................................................................................................................... 24
  5.1 Sketch .......................................................................................................................... 24
    5.1.1 Creating “virtual sharps” in sketches .................................................................... 24
    5.1.2 Dimensioning to circular entities .......................................................................... 24
    5.1.3 Dimension Diameters of a cylindrical object in a profile view (eg a Revolve) ....... 25
    5.1.4 Move a Sketch ...................................................................................................... 25
    5.1.5 Copy a Sketch ....................................................................................................... 25
    5.1.6 Use colors in Sketches ......................................................................................... 25
    5.1.7 Creating 3D-sketches by projecting 2D-sketches on each other ............................. 26
    5.2 Features ...................................................................................................................... 26
      5.2.1 Creating an “opposite hand version” of a Part ....................................................... 26
      5.2.2 Create tapered (conical) threads with the Hole Wizard ...................................... 28
      5.2.3 The Flex Feature explained ................................................................................ 28
    5.3 Surfaces ...................................................................................................................... 28
      5.3.1 Converting surfaces to solid bodies ..................................................................... 28
      5.3.2 Coating of Parts ................................................................................................. 29

Solidworks - Hints, Tips, Tricks and Best Practices – 3rd edition

Page 2 of 135
6 Assembly modelling ........................................................................................................ 69

6.1 Flexible sub-Assemblies in the main Assembly ............................................................... 69
6.2 Interference Detection ........................................................................................................ 70
6.3 Subtract one component from another and keep both in an Assembly ......................... 70
6.4 Create a new subAssembly from a selection of components ........................................ 71
6.5 Positioning of identical Components in an Assembly, like bolts in holes .................... 71
6.6 Often used fasteners like washers, bolts and nuts .......................................................... 71
6.7 Breaking the references of components downloaded from the Toolbox ....................... 72
6.8 Error- and external reference symbols .............................................................................. 73
6.9 Display States .................................................................................................................... 74
6.10 Sketch Layout .................................................................................................................. 74
6.11 Mates ............................................................................................................................... 74
6.12 Easy Mates in Assemblies ............................................................................................. 75
6.13 Modelling methods .......................................................................................................... 75
6.14 The Skeleton Sketch Part-method (SSP) ........................................................................ 77
6.15 Circular reference errors and rebuilds ............................................................................ 79
6.16 Best practices for Assembly mates ................................................................................ 79
6.17 Global variables .............................................................................................................. 80
6.18 Creating intelligent models ............................................................................................. 81
6.18.1 Linking “Global Variables” to “Custom File Properties” ............................................ 83
6.18.2 Linking a GV to an Annotation (Note) of a Drawing ................................................. 83
6.18.3 Linking a GV (Global Variable) to a dimension of a different Part ......................... 83
6.18.4 Renaming of Global Variables in the Equations Manager ........................................ 84
7 General Part- and Assembly practices .............................................................................. 85

7.1 Mirror vs Opposite hand version ..................................................................................... 85
7.2 Optimizing Solidworks performance .............................................................................. 88
7.3 Optimizing performance in “Large Assemblies” ............................................................. 91
8 Drawings .............................................................................................................................. 94

8.1 Creating a “virtual sharp” in a Drawing ............................................................................ 94
8.2 1st Angle vs 3rd Angle Projection in Drawings ............................................................... 94
8.3 Inserting Surfaces in Solidworks Drawing Views ............................................................ 94
8.4 Align the Drawing view by an edge of the model ............................................................ 94
8.5 Create Notes with Multiple Leader Lines in Drawings .................................................... 95
8.6 Moving or copying dimensions from one view to another ............................................. 95
8.7 Color of Drawing items like Lines and Dimensions ....................................................... 97
8.8 Dimensioning the “Arc Length” in a Drawing view ......................................................... 98
8.9 Timesaving by “reusing” Drawings of similar Parts ......................................................... 98
8.10 Timesaving with “automatic dimensioning” ................................................................... 99
8.11 Auto arrange dimensions ............................................................................................... 100
8.12 Inserting chamfer dimensions into a Drawing ............................................................... 101
8.13 Create an annotation with multiple arrows .................................................................. 101
8.14 Create multiple instances of annotations ..................................................................... 101
8.15 Center marks .................................................................................................................. 102
8.16 Changing the fontsize of the roughness symbol .......................................................... 103
SOLIDWORKS

8.17 Foreshortened dimensions ........................................................................... 103
8.18 Dual dimensions e.g. mm and inches ................................................................. 104
8.19 Section views ................................................................................................... 105
8.19.1 Section view on specific positions: ................................................................. 105
8.19.2 Half-section view ......................................................................................... 105
8.19.3 Create a Broken-Out section view .................................................................. 107
8.19.4 The two types of Section Views with cutting lines explained ....................... 108
8.19.5 Alternate Position View ............................................................................... 108
8.20 Working with hatches ....................................................................................... 109
8.21 Create colored hatches in Drawings .................................................................. 110
8.22 Create a watermark in a Drawing ...................................................................... 110
8.23 Inserting a Block in a Drawing ......................................................................... 110
8.24 Perspective View on a Drawing ......................................................................... 110
8.25 Change the orientation of a dimension of an isometric view ......................... 111
8.26 Create a custom view in a Part or Assembly for using in a Drawing ............... 111
8.27 Inserting “End Treatment” Symbols in Drawing Documents ......................... 111
8.28 Defining a thread callout in a Drawing .............................................................. 111
8.29 Show a model’s sketch in the Drawing ............................................................... 112
8.30 BOM tables or BOM-lists .................................................................................. 112
8.30.1 General tips for BOM tables ......................................................................... 112
8.30.2 Adding Equations (formulas) to the BOM ...................................................... 114
8.30.3 Showing the BOM on a Drawing of a Multibody Part ................................... 114
8.30.4 Hiding or showing rows or columns in a BOM-table ...................................... 115
8.30.5 Editing the column “Description” of a BOM table ......................................... 115
8.30.6 Rounding of dimensions or values in the Cut List or BOM .............................. 116
8.30.7 Rounding a value of a linked annotation in a Drawing .................................... 117
8.30.8 Export or copy a BOM-list to Excel ............................................................... 117
8.31 Drawings with suppressed and unsuppressed Parts ......................................... 118
8.32 Hiding and unhiding lines in Drawing views ...................................................... 118
8.33 Drawing template vs Sheet Format .................................................................... 118
8.34 Create a Drawing template with a link to a Sheet Format file ............................. 120
8.35 Repair the “<MOD-DIAM>” syntax message in circular dimensions .................. 121
8.36 Repair the often occurring error: “The Sheet Format could not be located.” ...... 121
8.37 Linking Custom Properties to the Drawing Titleblock ...................................... 122
8.38 Editing Drawing Notes, Linked to File Properties .............................................. 123
8.39 Linking a Drawing note-field to a model property ............................................ 125
8.40 Notes based on the “Summary Information” fields ........................................... 126
8.41 Link a dimension of a Part to a note in a Drawing ............................................ 127
8.42 Automatically fill in your Title Block ............................................................... 128

9 Workarounds ........................................................................................................... 132

9.1 Complex sketch mirror entities ......................................................................... 132
9.2 Cosmetic thread of a Part does not show in Part or Assembly .......................... 132
9.3 Number of holes in the “Hole callout” in Drawings .......................................... 132
9.4 Saving a Toolbox Part as a standard Part .......................................................... 132
9.5 A Part with two or more bodies, partially occupying the same space ................ 133
9.6 Annotations of mirrored Parts do not show in Drawing ..................................... 133
9.7 Defining the Drawing view position by dimensions to the Drawing border ........ 133
9.8 Transparency of components in Drawings ......................................................... 133
9.9 Error message: Sketch endpoints and center points cannot be deleted ............. 133

Solidworks - Hints, Tips, Tricks and Best Practices – 3rd edition
Page 5 of 135
1 General settings

1.1 Screen settings of your monitor for properly functioning of Solidworks.

Windows Screen resolution

Set the screen resolution at 100% for correct functionality of Solidworks.

Note:

When using Windows screen size of 125%, than the checkbox for “Circular Pattern Feature” for Solid Bodies cannot be selected in some older versions of Solidworks, but you can click on the word “Bodies”.

In SW2017 the Layer menu does not show correctly when the Windows screen size is set to 125%.
Dynamic highlight from the graphics view is also a very nice option which gives you more selection possibilities for hover-over mouse in **System Settings**.

Options => System Options => Graphics => checkmark “Dynamic Highlight from graphics view”

### 1.2 The User interface:

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Menu Bar</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>Toolbars</td>
<td>2</td>
</tr>
<tr>
<td>3</td>
<td>Command Manager</td>
<td>3</td>
</tr>
<tr>
<td>4</td>
<td>Configuration Manager</td>
<td>4</td>
</tr>
<tr>
<td>5</td>
<td>Property Manager</td>
<td>5</td>
</tr>
<tr>
<td>6</td>
<td>Feature Manager Filter</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Feature Manager Design Tree</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Status Bar</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Display Manager</td>
<td></td>
</tr>
</tbody>
</table>
1.3 Feature tree icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Part (Resolved)</td>
<td>A yellow icon indicates that the component is fully loaded into memory and all of its features and mates are editable.</td>
</tr>
<tr>
<td>Subassembly</td>
<td></td>
</tr>
<tr>
<td>Flexible subassembly</td>
<td></td>
</tr>
<tr>
<td>Lightweight</td>
<td>A blue feather overlay appears on the icon of a lightweight part.</td>
</tr>
<tr>
<td>Out-of-Date Lightweight</td>
<td></td>
</tr>
<tr>
<td>Suppressed Lightweight</td>
<td></td>
</tr>
<tr>
<td>Hidden Lightweight</td>
<td>A white icon indicates that the component is active, but hidden.</td>
</tr>
<tr>
<td>Hidden, Out-of-Date, and Lightweight</td>
<td></td>
</tr>
<tr>
<td>Smart Component</td>
<td>A lightening bolt overlay appears on the icon of Smart Components.</td>
</tr>
<tr>
<td>Hidden Smart Component</td>
<td></td>
</tr>
<tr>
<td>Large Design Review</td>
<td>An eye overlay appears on the icons of all components when the assembly is opened in Large Design Review mode.</td>
</tr>
<tr>
<td>Hidden Large Design Review</td>
<td></td>
</tr>
<tr>
<td>Unresolved</td>
<td>When you open an assembly, an eye overlay indicates that the components are still being resolved. The overlay disappears when the components are fully resolved.</td>
</tr>
<tr>
<td>Envelope Single component</td>
<td>The component is an envelope.</td>
</tr>
<tr>
<td>Envelope Subassembly</td>
<td>The subassembly is an envelope.</td>
</tr>
<tr>
<td>Hidden Envelope</td>
<td>The component is an envelope and is hidden.</td>
</tr>
<tr>
<td>Suppressed Envelope</td>
<td>The component is an envelope and is suppressed.</td>
</tr>
<tr>
<td>Grouped components</td>
<td>You can automatically group the same components with the same configuration into a folder-like structure. Right-click the top-level assembly and click Tree Display &gt; Group Component Instances.</td>
</tr>
<tr>
<td>Grouped subassemblies</td>
<td>Subassemblies that have been grouped together.</td>
</tr>
<tr>
<td>Locked</td>
<td>Parts are followed by the lock icon if they have been frozen by the freeze bar.</td>
</tr>
</tbody>
</table>

1.4 Customizing the Solidworks User Interface.

You can customize the Solidworks user interface very much to your personal taste. However in a classroom it is not very convenient when everyone is using their own different settings. This is also very applicable in company departments, but it can also be understood that more experienced users need different settings than less experienced users.
1.5 **Common settings for the Keyboard shortcuts:**
Keyboard shortcuts are key combinations such as those displayed at the right of the menu, which can be customized.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom in</td>
<td>Shift+Z</td>
</tr>
<tr>
<td>Zoom out</td>
<td>Z</td>
</tr>
<tr>
<td>Zoom to fit</td>
<td>F</td>
</tr>
<tr>
<td>View Orientation menu</td>
<td>Spacebar</td>
</tr>
<tr>
<td>View Selector</td>
<td>Ctrl+Spacebar</td>
</tr>
<tr>
<td>Repeat last command</td>
<td>Enter</td>
</tr>
<tr>
<td>Rebuild the model (only new or changed Features and their childs)</td>
<td>Ctrl+B</td>
</tr>
<tr>
<td>Rebuild the model completely (all the Features)</td>
<td>Ctrl-Q</td>
</tr>
<tr>
<td>Redraw the screen</td>
<td>Ctrl+R</td>
</tr>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Shortcut bar</td>
<td>S</td>
</tr>
<tr>
<td>Help menu</td>
<td>F1</td>
</tr>
<tr>
<td>Quick snaps toolbar (toggle)</td>
<td>F3</td>
</tr>
<tr>
<td>Selection filter Toolbar (toggle)</td>
<td>F5</td>
</tr>
<tr>
<td>Spelling checker</td>
<td>F7</td>
</tr>
<tr>
<td>Display pane (toggle)</td>
<td>F8</td>
</tr>
<tr>
<td>Display Manager (toggle)</td>
<td>F9</td>
</tr>
<tr>
<td>Command Manager (toggle)</td>
<td>F10</td>
</tr>
<tr>
<td>Command Manager only (toggle)</td>
<td>F11</td>
</tr>
</tbody>
</table>

1.6 **File Locations and default Templates:**
Solidworks stores a lot of installation files with settings on the following locations:

- C:\SOLIDWORKS Data\........
- C:\Program Files\SOLIDWORKS Corp\....
- C:\ProgramData\SolidWorks\SOLIDWORKS year\.............

The settings in these files can be changed in: **Options => System options => File Locations => Edit all.**
The best thing you can do is replacing all these default settings by one new location of your choice. This is to prevent overwriting your changed settings in case of a Solidworks update or a complete new installation.
If you are working in a company, this should be network directory.
Examples of settings you can change in File Locations:

The Document Templates (in the top of the list) has some special options:

Options => System Options => File Locations => Document Templates.
Here you can edit file locations of your Part-, Assembly- and Drawing Templates.

The edits are shown as TABS when you create a new Part, Assembly or Drawing.

There is a special use for the default Templates. These are the templates for Part, Assembly and Drawing.
The default Templates are stored in:
C:\ProgramData\SOLIDWORKS\SOLIDWORKS year\template\.......

These default templates can be used for the following Features:
Insert => Mirror Part
Insert => Component, New Part
Insert => Component, New Assembly
Form New Sub-Assembly Here
File => Derived Component Part
1.7 **Copy settings and customizations before updating or new installation.**

You can customize the toolbars with **Tools => Customize**, and drag and drop the commands you’d like to a location on your toolbars.

The **Copy Settings Wizard** saves, restores and propagates system settings to users, computers, or profiles. When you select options for the Solidworks software, those settings are saved in the registry file and the software recognizes the settings from one release of Solidworks to the next. For most users, no action is necessary to maintain their settings. However, you can use the **Copy Settings Wizard** to distribute settings.

You can Save or Restore system settings for:
- Keyboard shortcuts
- Menu customization
- System options
- Toolbar layout (All toolbars or Macro toolbar only)

You save the settings to a file and then restore them to the following registries:

<table>
<thead>
<tr>
<th>Profile</th>
<th>Registry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current user</td>
<td>CURRENT_USER of current user</td>
</tr>
<tr>
<td>One or more network computers</td>
<td>LOCAL_MACHINE of selected computers</td>
</tr>
<tr>
<td>One or more roaming user profiles</td>
<td>CURRENT_USER of selected users</td>
</tr>
</tbody>
</table>

Only system administrators should copy settings to network computers or roaming user profiles. When you restore settings to network computers, the settings apply to new SolidWorks users on the specified computers. You can restore settings to roaming user profiles only if your company uses roaming user profiles.

**Saving your System Settings**

1. In the Welcome dialog box, select **Save Settings**, then click **Next**.
2. Browse to a location and file name, select the types of settings, then click **Finish**.
3. The wizard confirms that the settings have been written to the specified file. Click OK.
4. The settings files have a default extension of xxxx.sldreg. If you double-click a file with this extension, the Copy Settings Wizard appears.

Note that not all settings can be imported into a newer version of Solidworks when the user interface has changed very much in the new version.
2 General tips

2.1 Rules of thumb

The rules of thumb are sometimes quite obvious and some of them can be a matter of taste.

2.1.1 General rules of thumb

1. Do not rename or move Solidworks files with the Windows Explorer because this will break the external references. Use the Solidworks Explorer for this task.
2. Use the “Solidworks Explorer” for renaming when all your Solidworks files are closed.
3. Create a Part, a multibody-Part, or sub-Assembly of each component you want to appear in the BOM-list of the Assembly Drawing.
4. Use a document management system to organize your Solidworks files, if this is not possible keep all your Part-, sub-Assembly-, Assembly- and Drawing-files for creating an Assembly or Drawing in one directory.
5. Create procedures for keeping track of a versioning system for Drawings but also for Parts and (sub)Assemblies.
6. Create procedures to identify the status (draft, approved etc.) of your files. It is better to have short procedures than having no procedures at all.
7. Solidworks files do use lots of referenced files, so create procedures to prevent missing or deleted files.
8. Some users state that modelling practices and the order of Features should be similar to the manufacturing practices, but good modeling practices are not the same as good manufacturing practices. Some basic practices like “mirroring and patterning” are often impossible in the real manufacturing world.
9. In reality new designed models are discussed, improved and adjusted before, during and after manufacturing. Start building your model while keeping in mind that some Features, Parts and components need to be changed later.
10. If your model is easy to change, also for others than yourself, than you can be pretty sure that you have built a “good model”.
11. When you are practising with the models for the CSWA and CSWP exams, you will learn this “best modeling practice”.
12. Practice and do the CSWA and CSWP exams. They are free of costs, not too difficult and not too easy. Practice, practice, practice and you will learn to change your model easily and pass the exams.

2.1.2 Rules of thumb for Sketches in Parts

1. Keep sketches simple, preferably one sketch for each Feature when applicable.
2. Sketch as much as possible on the three standard planes; Top, Front and Right.
3. Model the Part around the origin and frequently use the Mirror Feature and Mirror Body for symmetry.
4. Use “Convert Entities” and “Power Trim” instead of sketching new lines.
5. Add relations first, than dimensions.
6. Make sketches always “fully defined” except sketches with splines (*).
7. Dimension the entities of the sketches as much as possible as you would like them to appear on the Drawing.
8. Use colors in sketches for easy understanding.
9. Sketch entities can be linear or circular patterned, but it is easier and more robust to pattern the Features or Bodies instead of Sketch entities.
10. Add some “driving dimensions” to the Sketch if they will be used later in the Drawing.
11. Do not use very complicated splines by defining not more than 3 points per spline.
12. Rename critical Sketches for easy understanding of the model for others.
13. Do not use “Split lines” early in the Feature tree, because this can cause parent/child nightmares.
14. Do not use “Blocks” in sketches, if there is a possibility that you want to update or change the Block, because lost references to changed Blocks are difficult to repair.
15. Use “Equations” for often occurring dimensions in Sketches and give them easy to recognize names.
16. Use 3D-Sketches for tube, piping and weldments, because 3D-Sketches need less reference planes.

(*) a special remark about splines:
Splines can be made “fully defined” easily, but in most models they do not need to be fully defined. If you do fully define a sketch with splines parametrically with Equations, than the model is not very stable and often will show “over defined” error messages when rebuilding your model.
Another method (not recommended) is to automatically fully define splines: click on a spline => RMB => “Fully Define Sketch”. This option adds dimension to the endpoints of a spline, but it does not define the direction-vectors and direction-strength of the spline.

2.1.3 Rules of thumb for Part-Features
1. Use bodies to pattern and mirror Features because not all Features behave well in patterns and mirrors.
2. Add Fillets and Chamfers last, preferably as Features, not in sketches. See remark at the end of this paragraph (*).
3. Avoid surface Features in preference of solid Features when possible.
4. Use the “Hole Wizard” when possible, because extruded cuts gives less options at a later modelling stage.
5. Use the “Hole wizard” after mirroring part, bodies or features, otherwise the hole callout may not be correct in the drawing.
6. Use the “linear- or circular pattern” when possible, because this enables some automatic options (propagate and rotate) for center marks in holes in Drawing views.
7. Use “Configurations” for slightly different versions of an existing Part.
8. Rename critical Features for easy understanding of the model for others.
9. If you have a lot of Features then organize the Features in folders with logical names.
10. Use in-context relations sparingly and avoid circular in-context relations (A refers to B, B refers back to A).
11. If you model a lot with “profiles” than define the cross sections as “Structural Members” in Weldments.
12. Modify “Sheet metal” Parts in the “Bended state”.
13. Use “Equations” for often occurring dimensions in Features and give them easy to recognize names.
14. Create and use library-Features for common Features.
15. When there appears a list of errors shown as a “bleeding red Feature tree”, fix it starting from the top.

(*) a special remark about using Fillets and Chamfers in Sketches and Features.
You can use Fillets and Chamfers in Sketches and Features. Both methods have their advantages and disadvantages, but generally at novice level, I recommend to create Fillets and Chamfers last, which is at the bottom end of the Feature tree.

<table>
<thead>
<tr>
<th>In Sketches</th>
<th>As Features</th>
</tr>
</thead>
<tbody>
<tr>
<td>Complexity:</td>
<td>Easier; because no parent child relations to other geometry.</td>
</tr>
<tr>
<td>Rebuild time:</td>
<td>Slower; but not noticeable in simple models.</td>
</tr>
<tr>
<td>Flexibility:</td>
<td>Better; can be reordered and suppressed in Configurations.</td>
</tr>
</tbody>
</table>

### 2.1.4 Rules of thumb for Assemblies

1. Do not use “Layout Sketches”, because they have limited functionality. In Assemblies use a “Skeleton Sketch Part” containing the sketches instead of Layout Sketches.
2. Use your own modelled set of frequently used fasteners as “Parts with Configurations” even if you have the Toolbox. This is especially for commonly used components like fasteners, such as bolts, nuts and washers because Configurations are easier and faster to change than Components.
3. Create “Reference Mates” when the Part will be frequently used in an Assemblies.
4. Create sub-Assemblies or sub-sub-Assemblies in complex models and also for a better understanding of the model.
5. Mate all nuts and washers to the bolt and not to the hole. This is easier to change and it just simplifies and standardizes the mating scheme for your models.
6. Use Weld beads in the Assembly and not in the (multibody) Part, this is more logical.
7. Use Display States to hide or show components.
8. Use Display States to hide or show a specific “appearance” of a component.
9. Do not mate any components to patterned or mirrored instances, because it makes your model slow and unstable because it might be a circular reference.
10. Do not to stack too many mates. For example, mating Part B to Part A, then mating Part C to Part B, then D to C, etc.

### 2.1.5 Rules of thumb for Drawings

1. Use well designed templates according to your “company standards” for your Drawings.
2. Use Blocks with your standard text, symbols and shapes as much as possible in Drawings.
3. Use Layers for different types of entities e.g. construction lines, center marks and dimensions.
4. Use Display States (created in the Assembly), to hide or show components in the Drawing.
5. Use Shift+drag for moving dimensions from one to another view.
6. Use Ctrl+drag for copying dimensions from one to another view.
7. Use “Auto arrange” for positioning the dimensions.

### 2.2 Display the triad

To display or hide the reference triad, click **Tools > Options > System Options > Display/Selection.** Select or clear **Display reference triad**, then click **OK**.

It is not necessary to have the triad visible, but a matter of taste.
2.3 **Create a new Coordinate System**

1. Click Coordinate System (Reference Geometry toolbar) or Insert > Reference Geometry > Coordinate System.
2. Use the Coordinate System PropertyManager to create the coordinate system.
3. You can amend your selections:
4. To change your selections, right-click in the graphics area and select Clear Selections.
5. To reverse the direction of an axis, click its Reverse Axis Direction button in the PropertyManager.
6. Click ✓.

2.4 **Other Tips**

- Double click on a sketch to show the dimensions, and when you double click on a dimension, you can edit the value.
- Double click on a Feature to show the dimensions, and when you double click on a dimension, you can edit the value.
- To show all dimensions of a Part: Annotations ➔ Show Dimensions, View ➔ Annotations.
3 Solidworks and AutoCAD

AutoCAD files can be imported in different ways and with different selection settings. As a matter of taste, I do not recommend to import AutoCAD files in Solidworks but I prefer to create new sketches instead of importing.

3.1 Importing .dxf- or .dwg-files

You can import .dxf and .dwg files to the SolidWorks software by creating a new Solidworks Drawing, or by importing the file as a sketch in a new Part. You can also import an AutoCAD file in native format:

1. In SolidWorks, click Open (Standard toolbar) or File => Open.
2. In the Open dialog box, set Files of type to Dxf or Dwg, browse to select a file, and click Open.
3. In the DXF/DWG Import Wizard, select an import method, and then click Next to access Drawing Layer Mapping and Document Settings.
4. Click Finish on any of the three screens to import the file.

To import a .dwg or .dxf file as a new Sketch:

1. Open a Solidworks Part file.
2. Select the plane for the DXF/DWG file
3. Insert => DXF/DWG

When importing a .dwg or .dxf file as a 2D sketch for a Part, you can filter out unnecessary entities.

1. Open the .dwg file.
2. In the DXF/DWG Import wizard, select Import to a new Part as and 2D sketch.
3. Click Next.
4. Select Part document options and click Next.
5. In the preview, select entities to remove and click Remove Entities.
6. To undo this action, click Undo Remove Entities.
7. Select other options and click Finish.

3.2 Exporting to .dxf-format

A lot of laser cutting machines can import the dxf-file format. You can export to dxf-format from the Part-environment or the Drawing-environment.

Part-environment
From an open Part select: File => save As. and select the option “Dxf (*.dxf)”.
Now you have 2 main options; export a view (top, front, right...) or export selectable faces, loops or edges.

Drawing-environment
From an open Drawing select: File => save As. and select the option “Dxf (*.dxf)”.
All views, notes including the border and titleblock are exported to a dxf-file with the same name.

3.3 Importing layers

When importing a .dwg or .dxf file as a 2D sketch for a Part, you can create a new sketch for each layer in the file.

1. Open a .dwg file with layers.
2. In the DXF/DWG Import wizard, select Import to a new Part as and 2D sketch.
3. Click Next.
4. Select Import each layer to a new sketch.
5. Select other options and click Next or Finish.
4 File management

Solidworks files are unfortunately not backwards compatible, so you cannot open SW2016 files with SW2015.

Solidworks searches automatically to referenced files in the same directory.

Never, ever have duplicate models of the same Part with the same filename in different locations. Be careful to uniquely name each Part. Parts with the same name, even if they are in different directories, will cause "undesirable" results, because Solidworks is often searching also in other directories.

Do not move or rename files with the Windows Explorer, but use the Solidworks Explorer for this action.

Use the “Solidworks Explorer” only when all Solidworks files are closed.

Understanding how Solidworks works with files and file-references is essential.

If you want to reduce the file size you can try the following options:

- Set the maximum number of items in the “History Folder” of the Feature tree to 1.
- Save the “File as”, and reload that file (this usually helps very well). The strange thing is that if you repeat this step once more, the file is even smaller.
- Use Design Tables instead of Equations
- Use the Freeze bar (drag it to the bottom of the Feature tree).
- Check “Purge cached configuration data” in System => System options => Performance

If you have to send your Drawing(s) including the 3D Solidworks model files to other people, you can use “Pack and Go”. This will create one zip-file including all the referenced files. File => Pack and Go => select the option Save to Zip file:

4.1 Renaming of files

Warning: do not rename the Part- or Assembly files with the Windows Explorer, because it is very likely that references to other files will break. In this case you only can repair it manually.

There are 3 good options for renaming the files:

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Close all open files and use the Solidworks Explorer for renaming the file, this will automatically update all referenced files.</td>
</tr>
<tr>
<td>2</td>
<td>Rename the Part- or Sub-Assembly file in the Feature tree of the Main-Assembly by clicking on it. This is possible since SW2016. First enable renaming by checking this system-setting: Tools =&gt; Options =&gt; System Options =&gt; FeatureManager =&gt; Allow component files to be renamed from FeatureManager tree. RMB the Part or Assembly and select “Rename Assembly” or “Rename Part”. Type a new name and press “Enter”. In the dialog box, select “Temporarily rename document” and, if prompted to rebuild, click “Yes”. The file name of the component changes in the SOLIDWORKS software, but is not yet changed in the Windows file system. Any currently open documents that references to the renamed file are updated in the SOLIDWORKS software to reference the new file name. Save the Assembly. The Rename Documents dialog box opens with a warning. Optional: to avoid broken references in documents that are not currently open select “Update where used references”.</td>
</tr>
<tr>
<td>3</td>
<td>Using the “Pack and Go” command. There are many options possible, such as “Save to folder” and “Save to Zip-file”</td>
</tr>
</tbody>
</table>
4.2 **Option “File save as” explained**

Saves the active document to disk with a new name or saves it in a different format for export to another application.

To display this dialog box:

Click **Save As** (Standard toolbar) or **File => Save As**.

Another advantage is that the new “saved as file” is usually much **smaller** than the original file, especially in Solidworks versions 2017 and older.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Save in</strong></td>
<td>Let you browse to the location where you want to save the document. Use the locations sidebar to help navigate to the location where you want to save your document. The locations sidebar is available in certain operating systems only.</td>
</tr>
<tr>
<td><strong>File name</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Save as type</strong></td>
<td>Saves the file in another file format. You can also export files.</td>
</tr>
<tr>
<td><strong>Description</strong></td>
<td>Saves your text in the custom property field for Description in Summary Information.</td>
</tr>
<tr>
<td><strong>Save As</strong></td>
<td>Saves the document to a new file name that becomes the active document without saving the original document.</td>
</tr>
<tr>
<td><strong>Save as copy and continue</strong></td>
<td>Saves the document to a new file name without replacing the active document.</td>
</tr>
<tr>
<td><strong>Save as copy and open</strong></td>
<td>Saves the document to a new file name that becomes the active document. The original document remains open. References to the original document are not automatically assigned to the copy.</td>
</tr>
<tr>
<td><strong>Include all referenced components</strong></td>
<td>Copies all referenced components to the new location, adding a prefix or suffix to the component names, as specified.</td>
</tr>
<tr>
<td><strong>Advanced</strong></td>
<td>Displays a list of the documents referenced by the currently selected Assembly or Drawing. You can edit the locations of the listed files.</td>
</tr>
</tbody>
</table>

4.3 **Macro’s**

Macros for Solidworks have the file extension **.swp** or **.swb**

You can run a macro from the Macro toolbar or the Tools menu.

To run a macro click: **Tools => Macro => Run**, in the dialog box locate the macro file and click Open.

4.4 **The “Split Feature” explained**

You can use the **Split Feature** to divide a Part into multiple bodies. You can keep the bodies within the Part or save them into separate Part files. You can save them during the creation of the **Split Feature**.

You can use the **Split Feature** to create multiple Parts from an existing Part. You can create separate Part files, and form an Assembly from the new Parts.

You can also split a single Part document into a multibody Part document.

When a Split Part is completed an alternative is to use the command: **Save Bodies** to save them.
**SOLIDWORKS**

**To split a Part:**

1. Click **Split** (Features toolbar) or **Insert => Features => Split**.

2. In the PropertyManager, set the options:
   - To split the Part using trim tools, select **Trimming Surfaces** and click **Cut Part**.
   - Split lines appear on the Part, showing the different bodies formed by the split.
   - Callout boxes appear in the graphics area for up to 10 bodies at one time. Click **Next 10** or **Previous 10** to scroll through all the callout boxes for a Part.

3. Under **Resulting Bodies**, select the bodies to save or click **Auto-assign Names**.
   - All of the saved bodies appear in the graphics area and are listed in the FeatureManager design tree under **Solid Bodies**. The software automatically names all bodies. You can change the names.

4. Double-click the body name under **File**, type a name for the new Part in the dialog box, then click **Save**.
   - The new Part name appears in the Resulting Bodies list and in the callout box. Unsaved bodies are not split and remain with the original Part.
   - If you clear the check box for a split Part after you save it, that Part is no longer saved as a separate entity. It remains with the original Part.

5. Click ✅

**Handling of Split Parts (new Parts):**

1. The new Parts are derived; they contain a reference to the parent Part. Each new Part contains a single Feature named **Stock-<parent Part name>-n-**. You can reattach a derived Part to a specified stock Part, split Feature, or body.

2. If you change the geometry of the original Part, the new Parts also change. If you change the split Feature geometry, no new derived Parts are created. The software updates the existing derived Parts, preserving parent-child relations.

3. With multibody Parts, the various split Parts are listed in the FeatureManager design tree under **Solid Bodies**.

**Handling of Split Parts (original Parts):**

1. The original Part contains all its original Features plus a new Feature called **Split**.

2. If you selected **Consume cut bodies** under **Resulting Bodies**, the solid body displayed in the graphics area is the original solid body minus the new Parts. If all bodies in the original Part were saved as split bodies, no solid body is displayed. To see the original solid body, move the rollback bar in the FeatureManager design tree above the split Feature or suppress the split Feature.

3. If you delete the split Feature in the original Part, the new Parts still exist, but the status of the external reference in the new Parts is dangling.
**SOLIDWORKS**

**Saving Split Bodies**

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Click Insert &gt; Features &gt; Save Bodies.</td>
</tr>
<tr>
<td>2</td>
<td>Select the bodies to save in the graphics area, or under [ ] in Resulting Parts. The callouts display the default path, file names, and location of the multibody Part.</td>
</tr>
<tr>
<td>3</td>
<td>Under Resulting Parts, double-click each file name under File to open the Save As dialog box. You can select a new location and file name for each Part. You can also click Auto-assign Names to select and name all bodies.</td>
</tr>
<tr>
<td>4</td>
<td>Select Consume cut bodies to copy cut-list items from multibody Parts to resulting Parts.</td>
</tr>
<tr>
<td>5</td>
<td>To create an Assembly, under Create Assembly, click Browse, select a folder to save the Assembly as SplitAssembly type (*.sldasm), and type a file name.</td>
</tr>
<tr>
<td>6</td>
<td>Click ✔</td>
</tr>
</tbody>
</table>

### 4.5 Saving bodies as a Part file

In multibody Parts it can be very useful to save one or more bodies as separate Part files.

The bodies are shown under Solid Bodies in the Feature Manager.

If you have just created a new body, rebuild and save your multibody-Part file first. RMB on Solid Bodies and select Save Bodies. Select a Part- and Assembly template; (selecting the same template as the original Part, will prevent errors). Select the bodies you want to save. (The option “Consume cut bodies” will remove the body form the original Part file.)

### 4.6 Create a Library with custom materials

To create a Library with custom materials:

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>In a Part document, RMB Material in the FeatureManager tree and select Edit Material.</td>
</tr>
<tr>
<td>2</td>
<td>In the Material dialog box, right-click any item in the material tree and select New Library.</td>
</tr>
<tr>
<td>3</td>
<td>In the “Save As”, dialog box, provide a file name in which to store the library. Use a meaningful name. The name you provide becomes the display name for the library. You cannot rename it later!</td>
</tr>
<tr>
<td>4</td>
<td>RMB in the new library in the material tree and select New Category, and type a name for the category.</td>
</tr>
<tr>
<td>5</td>
<td>If you want, you can copy materials from other Libraries in the Material tree. Paste them into the Category and customize them. (You cannot edit the properties of the Solidworks Materials or Solidworks DIN Materials.)</td>
</tr>
</tbody>
</table>
In a company, the “Custom Materials Library” should be stored on a “shared file location” so it can also be used by your team members and for easy backup reasons.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>First thing is to open the menu with System options.</td>
</tr>
<tr>
<td>2</td>
<td>Under the file locations area, find the location of the Material Databases folder. The default location is: “C:\ProgramData\Solidworks 2017\Custom Materials”.</td>
</tr>
<tr>
<td>3</td>
<td>Copy the content of the entire “Custom Materials” folder onto a file location which can be accessed by your team members.</td>
</tr>
<tr>
<td>4</td>
<td>Set the pathname in System Options of the “shared file location” in all computers of your team on top of the list, as the first place where Solidworks will look for it.</td>
</tr>
</tbody>
</table>

### 4.7 Importing STEP-files

STEP-files can be imported by File => Open => STEP. But first you better set some default import-settings.

Options => System Options => Import Checkmark “Import multiple bodies as Parts”
Options => System Options => Import
Uncheck “Enable 3D Interconnect”.
You can use other setting from the snapshot on the right, but they are less critical.

If you import a STEP file with “Enable 3D Interconnect” enabled you can break the link to the STEP-file by:
RMB at the top of the Feature tree and click “Dissolve”.

4.8 Importing coordinates from an Excel sheet (ScanTo3D)
Importing coordinates can be done with the Solidworks Addin called “ScanTo3D”.
The ScanTo3D functionality is only available in SOLIDWORKS Premium and SOLIDWORKS Professional.
To enable this add-in, click Tools => “Add-Ins...” and checkmark “ScanTo3D” option.
In the Excel file create 3 columns X, Y and Z.
If you have only X and Y data, then fill the Z-column with 0 (zero).
Save the Excel file as *.csv (comma separated value) filetype.
In the Windows explorer rename this file to *.txt (text) filetype.
Open the *.txt file in Solidworks using File => Open => Filetype: “ScanTo3D PointCloud Files”
(at the bottom of the file-types list)
5.1 Sketch

5.1.1 Creating “virtual sharps” in sketches

A virtual sharp creates a sketch point at the virtual intersection point of two sketch entities. Dimensions and relations to the virtual intersection point are retained even if the actual intersection no longer exists, such as when a corner is removed by a fillet or chamfer.

Virtual sharps appear automatically in 3D sketches for: Fillets and Sketch Chamfers.

You can delete the automatic virtual sharps if you want so.

You can add dimensions and relations to virtual sharps in 3D sketches.

To create a virtual sharp:

1. In an open sketch, hold down Ctrl and select two sketch entities.
2. Click Point (Sketch toolbar) or click Tools > Sketch Entities > Point.
3. A virtual sharp appears at the point where the sketch entities would intersect.

5.1.2 Dimensioning to circular entities

<table>
<thead>
<tr>
<th>Dimension to the center of a circle.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Solidworks automatically select the center of the circle and you can attach a dimension to it.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Dimension to edge of circle in special cases.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Since SolidWorks automatically select the center, you must force it to take the edge.</td>
</tr>
<tr>
<td>Press the SHIFT key when you select the circle and Solidworks will dimension to the edge of the circle.</td>
</tr>
</tbody>
</table>

The same method can be used in the Drawing.
5.1.3 **Dimension Diameters of a cylindrical object in a profile view (eg a Revolve)**

Select first (1) the edge of the object and then the center line (2) of the circular shape. DRAG the dimension in a perpendicular direction to the lines and click (3) somewhere there. Solidworks will automatically switch to the “diameter dimension”.

This also works for symmetric objects.

**NOTE:** the “center line” needs to be a construction line for this to work.

5.1.4 **Move a Sketch**

If you’re still in the active sketch you can select all the sketch elements to be moved, RMB and choose “Move”. That will allow you to move all selected sketch entities together, without moving them in relation to each other.

5.1.5 **Copy a Sketch**

There is a great tool “Derived sketch” for copying sketches to other planes. The plane does not have to be parallel to the original plane.
- Select the plane where you want the sketch to be placed.
- Hold Ctrl and click on the sketch you want to copy from.
- **Insert => Derived Sketch** (the previous steps are neccessary to make this command available).
- Now the Derived Sketch can be dragged into the correct position and has to be fixed with relations and or dimensions to make it fully defined.

Sketches can be copied from within a Part or Assembly (in context).

The “Derived Sketch” will update when the original is changed.

There is a disadvantage; you can not add entities to a derived sketch, because the Derived Sketch is always a copy of the original.

5.1.6 **Use colors in sketches**

For coloring a whole sketch: select the desired sketch, RMB => **Sketch color**, and select the desired color.

**Note:** the “Line Toolbar” must be set to show the colors:

(To show the “Line Toolbar” click: **View => Toolbars => Line Toolbar**.)

<table>
<thead>
<tr>
<th>Line Toolbar Colrs are shown</th>
<th>Line Toolbar Colrs are not shown.</th>
</tr>
</thead>
</table>

**Note:**
You can also change the color and thickness of individual sketch entities of an active sketch with the “Line Toolbar”. After the sketch is closed the new color of the entities are not visible anymore.
5.1.7 **Creating 3D-sketches by projecting 2D-sketches on each other**

Two 2D-sketches on a plane can be projected on each other to create a 3D-sketch (composite curve).

In this example 2 splines were created on the Top-plane as Sketch1, and 3 lines on the Front-plane as Sketch2.

**Insert => Curve => Projected Curve**
Select “Sketch on sketch”
Select Sketch1 (two splines)
Select Sketch2 (3 lines)
(The order of the selections is not important).

A projection of both Sketches is created as the yellow 3D-curve.
The new 3D-curve absorbs the two Sketches in the Feature manager tree.

5.2 **Features**
Features are usually adding or removing material from a Part.
Some Features are deforming (twist and bend) the Part, which can also (slightly) change the volume and mass of a Part!

5.2.1 **Creating an “opposite hand version” of a Part.**
There are several ways to create an opposite hand version of a Part.

**Method A:**
Click first on the plane which will be used as the mirroring face. (This is important)!!!
SOLIDWORKS

Insert => Mirror Part … (The mirrored Part will now be saved as a separate file).
This file is linked to the original file and the mirrored Part will be automatically updated when the original Part is changed.

Method B:
Sometimes it is more convenient to save the mirrored Part as a separate Configuration in the original file.
1. Features => Mirror => Bodies to mirror => uncheck “Merge solids”!!!
2. Solid bodies => Delete (delete the original bodies)
3. Create a new Configuration: Configuration Manager => Default => RMB => Add new derived Configuration.
4. Type a name for the new Configuration etc.
5. Features => “Bodies to mirror” => RMB => Configure Feature
6. There is now 1 Feature in the Configuration table.
7. Type a name for the Configuration Table and save it.
8. Features => DoubleClick on “Delete bodies” so this Feature will also appear in the table.
9. For the original Part, these two Features has to be suppressed.
10. For the mirrored Part all Features must be unsuppressed.

Method C:
Theis is a combination of method A and B.
- Click first on the plane which will be used as the mirroring face. (This is important)!!!
- Insert => Mirror Part .... and checkmark the option “Break link to original Part”
- Save this as the new original Part.
- Load this new Part and create a new Configuration: “Opposite hand”
- Suppress the “Move-copy” Feature.

Now you have one Part including the Configuration of the “opposite hand version”.
This method often feels often more “logically” than method A and B.

Method D (Assemblies):
You can also create an “opposite hand version” in the Assembly-environment.
Open an Assembly and load and mate the Part.
Click the icon “Linear Component Pattern” and select “Mirror Components”.

Select a mirror plane and the component to mirror.
Click the small blue arrow for more orientation options.

Select the icon “Create opposite hand version”. An extra linked file is created with the file name “Mirror”+Partname.sldprt.
5.2.2 Create tapered (conical) threads with the Hole Wizard
Conical or tapered threads like NPT, can be made with the Hole wizard.
In the Hole wizard menu, click in"Hole Type"; “Tapered Tap” and as the Standard; “ANSI inch” and as the
Type; “Tapered Pipe Tap” hole and select the size.

5.2.3 The Flex Feature explained.
The Flex Feature can be very useful for bending bodies like flexible rubber products.
Although most solid bodies are usually incompressible, the volume and weight of a body will change
slightly after the Flex Feature is applied.
The flex Feature calculates the extents of the Part using a bounding box. The trim planes are then initially
located at the extents of the bodies, perpendicular to the blue Z-axis of the triad.
The flex Feature affects the region between the trim planes only.
The center of the flex Feature occurs around the center of the triad location.
To manipulate the extent and location of the flex Feature, re-position the triad and trim planes. To reset
all PropertyManager values to the state they were in upon opening the flex Feature, right-click in the
graphics area and select Reset flex.

5.3 Surfaces
Surfaces are bodies without a volume or mass, but you can copy and mirror surfaces like solid bodies.
Surfaces give you much more freedom and flexibility in designing complex shapes than solid bodies.

5.3.1 Converting surfaces to solid bodies
When working with Surfaces in Solidworks, you probably want to convert a surface into solid body at
some point. (Surfaces do not have a volume or mass). This can be done using the Knit Surface or Thicken
Surface Feature. But since SW 2016 you have the ability to create a solid using the Boundary Surface- or
the Trim Surface-Features, provided the surface Features can create a closed volume from the inputs.
1

In SW2015 and older, you have to use **Knit Surface** first.

Select “Try to form solid”.
Select “Merge entities”.

2

If there is a missing surface to form a solid, then use **Fill Surface**.

Select “Merge result”.
Select “Try to form solid”.

---

5.3.2 Coating of Parts

Complete the model geometry up to the point of the coating.

1. Use the **Surface knit** command (access from either the knit icon on your surface toolbar or **Insert > Surface > Knit**) to create a skin around the model.
2. You will have to select all of the faces individually.
3. Check the ‘merge entities’ option and click OK.
4. Next, choose the **Thicken**... command (either from Insert Boss/Base or the surfaces tool bar), choose the knit surface body, specify the thickness, choose the direction to thicken, and make sure that you disable ‘merge result’.
5. Now you should have two solid bodies which you can see in the Solid Bodies folder in the Feature tree.
6. Expand the Solid Bodies folder, RMB on either of the bodies shown, choose material and specify the material for the first body. Repeat the last step for the second body.

You now have a ‘coated’ or ‘plated’ Part.

5.3.3 Using the hole wizard on non-planar (cylindrical) faces.

Creating a tapped hole on a cylindrical face (pipe) will take som extra steps versus a flat face.
Insert => Reference Geometry => Plane, select the cylindrical face so that the plane is tangential to the face. Then select another piece of geometry (in this case the Top Plane) so that you can choose the angle of the new reference plane.

Insert => Features => Hole => Wizard, and select the type of hole that you would like. Then click on the Positions tab.

Click on the “3D Sketch” button.

SOLIDWORKS allows you to sketch directly onto the cylindrical face and will dynamically preview the hole location before you click to place the hole.

Once you have clicked to place a hole, you can then switch to the sketch tools in the CommandManager Sketch tab. First add a construction line that is Coincident with the centre of the hole, and also with the circular end edge of the cylindrical face. Then add an On Plane relation between the between both ends of the line and the new created reference plane. Finally add a dimension to the line to specify the distance of the hole centre from the end of the cylinder.

5.4 Sheet Metal

Do not use the convert to sheet metal button, but start right away with a “Base Flange/Tab” Feature. This prevents the “Flatten” button not always working correctly. Create Features like cuts and holes in the “bended state”.

Solidworks - Hints, Tips, Tricks and Best Practices – 3rd edition
**5.4.1 Sheet Metal basics**

Sheet metal modelling is a special way of modelling a Part made from thin metal sheet. Solidworks uses a special set of Features for that. Some of these Features are also very useful for other industries too, like plastics, rubber, paper and carton.

**Example of a sketch for the “Base Flange” Feature.**

The left sharp corner in the sketch will have the default **inner radius R2**. As a design rule, the **inner radius** should not be lower than the material thickness.

**K-Factor** defines the position of the neutral plane in the bend. When K=0.5 the neutral plane is in the center-plane of the two surfaces. Usually “K” is between 0.25 and 0.50.

By default, the sketch dimensions 50 and 100 are the **outside dimensions** of the Part.

The radius on the right hand side remains the outer radius R10 as defined in the sketch.

**Auto relief**

On one edge the “Edge-Flange” Feature with “Material inside” was added. The “Edit Flange profile” button was pressed and the flange width was adjusted.

The “auto relief” option was set to “obround” with “ratio” 1.0. This means that the **relief gap** is the same as the material thickness (2mm).
**Edge-Flange**

On 3 edges the “Edge-Flange” Feature was added with length 20. Material “inside”.
The distance between the “Edge-Flanges” is 2mm.
The default radius remains 2mm.
The maximum bend radius of the “Edge-Flange” Feature is 179°.
Use the “Hem- or Sketched Bend-Feature” for a bend-radius larger than 179°.

The “Trim side bends” option is checked now.

**Miter-Flange**

More complex flanges with automatic mitering can be made with the “Miter Flange” Feature.
A simple sketch on a surface perpendicular to the flange is necessary.

**Hem**

The Hem-Feature also adds material and automatic mitering.
The Hem Feature is usually used for creating blunt edges or flanges with 180° bend radius.
5.4.2 **Drawing of Sheet Metal Parts**

SOLIDWORKS creates a flat-pattern configuration when the Drawing of a sheet metal Part is generated. The only difference compared to the main configuration is that the flat-pattern Feature is unsuppressed in the flat-pattern configuration. **Design changes should be made in the “main/default” configuration.** This is also called the “bended state”.

If a hole has to be created in a bend-area than you first you have to use the “Unfold” Feature on the concerned bend(s), create the hole(s) and after that use the “Fold” Feature.

It is a common practice for many SOLIDWORKS users to right-click on a Drawing view and use the Open command to access the Part. Specific to sheet metal flat-pattern Drawing views is that accessing the model this way activates the right configuration of the model.

5.4.3 **A common mistake with the “Flatten” button explained:**

Unaware of the configuration change and wanting to edit the model, users sometimes toggle the Flatten option or manually suppress the flat pattern Feature in the FeatureManager Tree. While the model may appear correct, the problem becomes obvious in the Drawing document where the flat pattern view no longer shows flat pattern, but a formed Part.

The way to correct the flat-pattern view in this scenario is to access the model, activate the flat-pattern configuration and unsuppress the flat-pattern Feature. To avoid the problem, after accessing it from the flat-pattern Drawing view, it is sufficient to switch to the configuration tab and activate the main configuration of the Part.

5.4.4 **Flat pattern and Bounding box**

Solidworks creates automatically a “derived Flat pattern Configuration” when you create a new Drawing of a formed Sheet Metal Part.
The view of the derived Flat pattern Configuration is available in Drawings. This is often used for cost estimations by using the *Bounding box area* property.

The **Bounding Box area** property can be found with:
- Click on the “Cut List” in the Feature-tree.
- Click on the “Cut-List-Item” to select the object.
- **RMB => Properties**
- Click on TAB “Cut List Summary” and a list with Cut-List properties will pop up:
  - The Bounding box area shows in the most right column.

Unfortunately this “derived Flat pattern Configuration” can be easily lost when you edit the sheet metal Part after this configurations was created. You can repair this by creating a new Drawing for this sheet metal Part.

After that, the new derived configuration is created and you can delete the new Drawing and use the old Drawing.

### 5.4.5 Sheet Metal Gauge Tables *(Bend tables)*

A Sheet Metal Gauge Table stores properties for a designated material. You can access the sheet metal gauge table from the PropertyManager while creating the base flange.

Use a simple sheet metal gauge table to assign: Gauge thickness, allowable bend radii and K-factor. There are also more complex combinations with bends possible including “bend allowance” and “bend deduction”.

**Using external Gauge Tables**

External Sheet Metal Gauge Tables are just Excel-tables and have the file extension *.XLS*

You can download an external Gauge Table and save it in the directory you prefer.

You can refer to this table when you checkmark the “Use gauge table”-option and click on the “Browse”-button.

If you think that the downloaded table will be used more often, than it is better to save it at the directory where these tables are stored. You will find this location at:
- Tools => Options => File Locations => Sheet Metal Gauge Tables
- In this case you can select the table with the button “Select Table”.
5.5 **Sheet Metal - Design Library, Library Features and Forming Tools**

The Solidworks software put this very useful Features under the chapter of Sheet Metal, but it is very useful in Weldmends too. It can not be used in combination with Surfaces.

Forming Tools can only be used in SheetMetal Parts.

A Design Libray is really very useful when a set of Features, Blocks or Parts can be used in many other Parts.

A Design Libray Feature (or Part) has the file extension: *.SLDPRT

The location(s) of the Design Library are described in: **Tools => Options => File Locations => Design Library**

The default location is: C:\ProgramData\SOLIDWORKS\SOLIDWORKS 2018\Design Library\. Before creating Library Features, you must setup a directory for your custom Features and Parts.

---

Create a directory of your choosing and add it to the Solidworks File Locations as described above.

Now when you go to the Design Library tab in the Task Pane you will find a folder to the directory you linked. Right click on this and create a new sub-folder.

---

### 5.5.1 Creating a Library Feature:

Not only often used features, but also often used blocks and parts can be put in the library for easy access and modelling.

Using the custom library features requires some prerequisites:

* Create a directory and sub-directories for custom features, blocks and parts.
* Add a file location for it in: **Tools => Options => File Locations => Design Library**.

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Creating a “place holder extrusion”, This is a simple rectangular Boss/Base or a cylinder.</td>
</tr>
<tr>
<td>2</td>
<td>Sketch the geometry you will be using with the library Feature. As you create the sketch you should avoid creating relations tied to the origin of this place holder model, otherwise SW will attempt to use this as a reference when re-using the Feature. You can either sketch off to the side or as you sketch hold the CTRL key on your keyboard to avoid creating a coincident relation to the origin.</td>
</tr>
</tbody>
</table>
Next, fully define the sizes of your sketch entities if necessary. You want to make special considerations for the dimensions or relations controlling the geometry’s position in space. These references will be used when we turn this into a library Feature in a few steps. It is no problem that this sketch is underdefined, because it has no references to the origin.

From here you can create your cut or Boss/Base Features and any additional Features you would like to incorporate into the library Feature. You can use only one Sketch or one or more Features as a Library Feature.

When you are ready you will left click on the Feature(s) to be used and drag them into the folder within your Design Library, but do not include the “place holder Feature(s)”.

The “Add to Library” PropertyManager should appear on the left allowing you to define what, where, and how you want to save into your Design Library. If you missed any Features you can still add them to the list. For the File Type dropdown you will choose “Lib Feat Part (.sldlfp)”. Pin the Design Library Property Manager.

Once complete you will see the Library Feature Part in your Design Library. Save your original model if you wish, but it is not necessary. Close the original file and then open the Library Feature Part by double clicking it. You will notice there are some unique folders in the Feature tree and all of the library Features will have an “L” over their icons.

If you wish to add additional Features to the Library Feature Part, you can always right click on them in the tree and choose “Add to Library”. An “L” should appear over the Feature’s icon.

If you want an easy way to modify the Locating Dimensions when you use this library Feature in a new Part you will want to move the appropriate dimensions into the Locating Dimensions folder. These will be used later in step #13. The Internal Dimensions folder is further explained in step #14.

Save the changes and close the Library Feature Part. You are now ready to use your library Feature in a new model. Simply drag and drop from the Design Library onto your model.

The Property Manager that appears will allow you to further define which face/plane you wish to place the Library Feature onto. If the Library Feature has Configurations you can choose it from the list. There is also a Link to library Part option which will cause the Feature to update in the future if the Library Feature Part is ever changed.

The References will list the geometries you used for positioning purposes (from step #3). Select each item and a small window will appear showing the original model. Within this model it will highlight the original edge referenced by the first dimension/relation. Within your new model you will need to select the new edge to be referenced. If there were no references used in the original Part, there will be nothing listed here.

When you have placed dimensions into the ‘Locating Dimensions’ folder within the Library Feature Part at step #9, you can easily adjust them to further control the position of the Library Feature.

Under ‘Size Dimensions’ you can check the box to override the original dimension values. If there are any dimensions you do not want the ability to change you will want to add them to the “Internal Dimensions” folder referenced in step #9.

After you confirm the options you will see a Library Folder added into your FeatureTree. Within this folder will be the library Features. You can incorporate as many Library Features as you want when creating these Library Feature Parts.
5.5.2 Form Tools
Form tools create Sheet Metal Features that would be manufactured by a punch or a stamp. Form Tools work by creating the geometry for the negative space left by a punch or a stamp. Within the geometry there are two faces specified; the stopping face and faces to remove. The stopping face corresponds to the sheet metal face where the tool is applied. Faces to remove are areas which would be left open once the tool is applied.

5.5.3 Creating a Custom Form Tool
1. Create the geometry which will represent the negative space left by the punch. In this case I’m going to use a simple countersink emboss. I have also created the top face with a split line so I can specify a face to remove in the form tool. Placeholder Boss/Base.

2. Open the Forming Tool on the Sheet Metal command tab. Or click: Insert => Sheet Metal=> Forming Tool.

3. The forming tool prompts you to pick the stopping faces and the faces to remove. In this example the stopping face is going to be the face where the Forming Tool (Green) was created, and my faces to remove is going to be the inner split circle (Pink). You can also create a form tool without picking any faces to remove.
In the forming tools properties there is another tab called **Insertion Point**. The insertion point helps you determine the precise location of the forming tool on the target Part. In this example the insertion point is on the origin point.

Once you have accepted the Form Tool, SOLIDWORKS will colour code the form tool within the graphics area. Red faces are faces to remove, yellow faces are the forming tool faces and blue faces are the stopping faces.

Once the Forming Tool has been created, the last step is to save it. The forming tool must be saved as a forming tool, by using the “save as” command, go to the pull down menu and select to save it as a Form Tool. (.sldftp)

### 5.5.4 Using a Form Tool in a Sheet Metal Part.

1. Make sure that the directories with your Form Tools are correctly set in **Tools => Options => File Locations => Design Library**.
2. Once the file location has been added it should appear within the Design Library TAB. Then you have to set that folder as being a **Form Tool folder**. RMB on the folder and click Forming Tools folder. This step lets SOLIDWORKS know that when inserting these Parts to bring them in as forming tools as oppose to derived Parts.

3. Once the forming tool folder has been created the form tool can now be drag and dropped onto the sheet metal Part from the design library using a left mouse click. 
   
   **NOTE:** When dragging the form tool the TAB key can be used to flip the orientation.

4. Once dropped, we have two tabs, **Type** and **Position**. From the **Type** tab we can then go in and specify; which face to apply it to, what angle to place it at, which configuration to use and which form tool we want to use.

5. From the **Position** tab we can give the forming tool a more precise location on the model. In this case I placed the centre of my forming tool 80mm away from the right edge and 35mm away from the top edge.
6. Click OK and the form tool will be inserted into your sheet metal Part.

7. When the Part is flattened, the form tool will remain untouched. However in **Tools – Options – Document Properties – Sheet metal**, you can specify that the form tool is suppressed in the flattened state.

### 5.6 Weldments

Solidworks has a great tool when it comes to creating weldment profiles and structures. With just a basic line sketch, it is able to turn this into a weldment structure by converting the lines into the weldments of your choice. But before you can utilize this great tool, you need to save some weldment profiles into your Solidworks directory. You can add some cross sections of steel, plastic or rubber profiles and build your own library of cross sections.

Simple Weldment constructions, including weld beads, can be made easily as a single multibody Part. The Drawing of this multibody-Part can show the all the single bodies in the Cut List table.

For more complex constructions it is more logically to create the model as an Assembly.
5.6.1 Adding weldment profiles by downloading from Solidworks

Solidworks contains many international standards of steel weldment profiles where you can immediately leverage on and start using. This is how you can get access to them:

Select Design Library / SolidWorks Content / Weldments

Hold Ctrl + any download zip file and then unzip these files
Add your extracted zip folder in weldment profile either by adding a file location on your System Options
Otherwise it will be placed in the default location for weldment profile which is at C:\Program Files\SolidWorksCorp\SolidWorks\lang\english\weldment profiles

5.6.2 Creating Custom weldment profiles

Design your own weldment profiles:
1. Open a new Part. Sketch the weldment profile that you would like. When you are sketching the profile, the pierce point (the point whereby the center of the weld structure would meet with other weld Parts) is by default located on the origin.
2. If you would like to change this, put a point on the sketch where you would like to be the pierce point. During the creation of the weld structure, you can then select the point you have created.
3. It is convenient to create more than one point, which can later be used to “locate” the profile relative to the sketch entity. You can even use some points outside the profile:
4. Check if your sketch is fully defined and also if you can extrude it. You can use a sketch with multiple closed contours, but **only one contour** can be used for the extrusion of the profile. Solidworks detects automatically if profile contains one or more holes.

5. Exit the Sketch.

6. Select the Sketch in the Feature manager tree.

7. Click **File** => **Save as**. This will save your weldment profile for future use.

8. In the dialog box select: “**Save in**”, and browse to the default directory for weldments:
   
   `C:\Program Files\SolidWorks Corp\SOLIDWORKS\lang\english\weldment profiles\folder\subfolder`

9. Select or create appropriate custom **folders** and **subfolders**. Note that subfolders must have unique names!!!

10. In the “Save as-menu”, select “**LibFeatPart**” (*sldlfp).

11. Type a name for the Filename.

12. Click Save.

### 5.6.3 Weldments and assigning materials to them

You can assign different materials to weldment bodies similar as with a multibody model.

If you have assigned a material to your custom weldment profile, you can change the material for an individual element in a bit of an unnatural way.

Click on the element you want to change the material in the Drawing area so that it is highlighted in the Cut List as in the picture to the right.

RMB on the body of the element you want to change. Now you can change the material of this element.

If you have defined a material to your custom weldment profile you can change the material for the whole Group by unchecking the checkbox; **“Transfer Material from profile”**.

After that you can assign a material to each individual element.
5.6.4 Saving custom weldment profiles at a custom location.

This a tricky and rather complex procedure because it is sensitive for errors like:

Error: “Library Feature is empty”

Procedure for saving custom weldment profiles at your custom location:

Create a new Part which is empty (no sketches).

Save it as an *.sldfp-file at the location of your custom profiles like:

```
X:\SOLIDWORKS-profiles\1st level directory name\2nd level directory name\*.sldfp
```

(`"\SOLIDWORKS-profiles\" is your top-level directory name.)

<table>
<thead>
<tr>
<th>Structural member:</th>
<th>Windows directory names:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top-level directory name is “SOLIDWORKS-profiles”</td>
<td></td>
</tr>
<tr>
<td>1st level directory name: “ISOdownloaded”</td>
<td></td>
</tr>
<tr>
<td>2nd level directory name: “RubberProfile”</td>
<td></td>
</tr>
<tr>
<td>File name of sketch “W2L rubber.sldfp”</td>
<td></td>
</tr>
</tbody>
</table>

The top-level directory name must be set as a valid directory name in the Solidworks system settings:

**Options = > System Options => File Locations.**

Then select “Weldment Profiles” in the Folders: list box and browse to your “top-level directory name” and select it. (You have to do this only once.)

Some tips when you edit your custom profile sketch:

- Use structural lines for later use of relocating of the profile in Structural members.
- Use the origin as the reference for the cutting length. Make it fully defined.

**Important first step:**

Select your sketch in the Feature Manager and **RMB => Add to library.**

Save your sketch file as a *.sldfp file in a custom directory.

Check for open contours by checking if you can extrude it.

Check if you can see that your sketch is a valid weldment profile because the icon for the sketch has changed.

Close the file and it’s ready for use!

You can edit and change the *.sldfp file later if you want, but this will create problems in previous models which uses the old version. Previous models will not update if you change the custom profile .sldfp file.

It is better to assign a versioning system in the file names of custom profiles and define this in your working procedures.

Solidworks - Hints, Tips, Tricks and Best Practices – 3rd edition
SOLIDWORKS

5.6.5 **Important notes for Weldments:**

- The profile must follow a path of a sketch with connected straight lines and or curves as Groups, but no splines!!
- When sketching with weldment profiles select first: **Structural member** => **Standard** => **Type** => **Size** and then select **Groups** and **Sketch entities**.
- Groups must be made of a continuous chain of segments or discontinuous parallel segments.
- Each sketch segment can be present in only one group.

5.6.6 **Positioning of structural members**

Solidworks positions the structural members by default with the sketch origin of the *.sldflp file on the sketch entity of the structure.
5.6.7 Creating a three way miter in weldments with Corner Treatment

The function **Corner Treatment** is an optional function in the dialog box for **Structural Members**. This function is used to set the trimming order between 2 or more groups of the same Structural Member. This function is very useful for mitering 3, 4 or even 5 way corners of a tube, pipe or a square profile.

There are a lot of hidden gems within Solidworks that you wouldn’t typically know to look for. Once such tool is the corner treatment option, **within the structural member tool**. It allows you to modify individual joints, within a single structural member.

Corner treatment allows you to set corner specific weld gaps as well as changing an option called trim order. Trim order, as the name suggests, allows you to control the hierarchy by which each group is trimmed. Trim order 1 will not be trimmed. Trim order 2 will be trimmed based on trim order 1 and so forth.

To access this option click on the pink dot at the center of a joint (within a structural member). That will bring up the following dialog box. Each individual structural member group will be set to its own trim order. If you set each group to the same trim order, Solidworks will do its best to create a compound miter.

There are limitations to this option, as you can see for the image below. For a larger number of groups or members, (in this case 5) there may be gaps. In these cases you can play around with the trim order until you get a suitable result, as well as setting them to different trim orders, so you don’t confuse Solidworks too badly.
5.6.8 **Weld beads vs Fillet beads**

Solidworks is not very good in handling weldings in models and Drawings. Users get very easy confused by the inconsistent, strange and confusing way of using two different welding type Features.

In the picture above a multibody Part is shown where the ugly cosmetic appearance with stripes of the Weld Bead can easily be recognized. There are some more important differences between Weld Beads and Fillet Beads which can highly affect your workflow. Generally, use **Fillet Beads** (cosmetic only) as much as you can, at the Part-level as a standard workflow. You can not use this Feature in an Assembly. In the Assembly you can only use Weld Beads!
### Available in Parts and Assemblies

<table>
<thead>
<tr>
<th>Available in Parts and Assemblies</th>
<th>Only available in (weldment) Parts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Does not require a Feature in the Feature tree, but it creates a Feature in the Weld Folder</td>
<td>Creates a Feature in the Feature tree and converts the Part into a Weldment Part.</td>
</tr>
<tr>
<td>Easy to apply, also on non-planar surfaces.</td>
<td>Sometimes difficult to apply on non-planar surfaces, a split line can help sometimes.</td>
</tr>
<tr>
<td>It has ugly cosmetic black/grey stripes, but it also “absorbs” appearances of the connected bodies in an unctrolled way.</td>
<td>Is a solid body with cosmetic appearance and it looks fine enough (similar to cosmetic threads).</td>
</tr>
<tr>
<td>It is not a standard solid body, but you can assign mass and density to it (**).</td>
<td>It is a solid body and has mass, volume and density. You can assign a material to it.</td>
</tr>
<tr>
<td>Also material, cost and time can be defined in the Weld Bead properties (**).</td>
<td>Cost and time can not be defined.</td>
</tr>
<tr>
<td>The size of the weldbody looks sometimes incorrect in the model.</td>
<td>The size looks OK in the model.</td>
</tr>
</tbody>
</table>

### Not visible in Drawing views!

- **The only way to show Weld Beads in Drawings, is by importing or creating “End treatments” and Annotations in the views.**
- **Weld Beads are listed with size, material, weldsymbol and density in the Weld Table.**
- **Fillet Beads are listed with only size and weldsymbol in the Weld Table.**

### Needs 2 solid bodies or components.

- **Can also be used in a single body Part.**
- **Rebuild time will increase.**
- **No effect on rebuild time.**

### Can not be used for simulations.

- **Can not be used for simulations.**

- **Weld Beads are “phantom solid bodies” and can not be mirrored.**
- **Fillet beads are solid bodies and can be mirrored, but sometimes with difficulties.**

**) The mass and volume properties of the **Weld bead** body are slightly hidden.

When you are in a Part or Assembly, click on Mass properties and check “Show weld bead mass”.

Note that the mass may be incorrect if you have customized the settings for mass.

For correct results you also have to edit the Properties of the “Fillet Weld” Feature.

Note that the “Weld Bead” Feature appears as a child of the “Fillet Weld” in the Weld Folder, which is very inconsistent.
**Modelling considerations:**
Generally, Weld Beads are only recommended when you need the Weld Bead properties separately like mass, volume, length, cost and or time.
For performance purposes and additional enhancements, it is recommended that you use the Weld Bead-Feature instead of the Fillet Bead-Feature to insert weld beads.
It is a waste of effort to model the welds as separate Parts or bodies, because you can always put the weldbeads in the Drawingview as End treatments with Annotations like the Weld symbol, size and the Caterpillar. Even when you do not use Weld Beads or Fillet Bead Features at all, you can put the weldbeads in the Drawings manually with End treatments and Annotations.
If you want to look the model more realistic, you can use the Fillet Bead Feature at the Part-level. This has also the advantage that the Annotations can be imported in the Drawing views automatically.
Unfortunately the appearance of Weld Beads is really ugly, especially with “Real View”, but it can not be changed.

### 5.6.9 Trimming of weldment profiles

The majority of weldment models have most of their errors in the trims, like missing trims, improper trims and hollow nodes.

1. Create and position the structural members (tubes) in the order that you will be fabricating the structure.
1a. Use a unique structural member for each tube. Do NOT put all of the same size tube in one structural member definition. Using a unique structural member allows for easier change of tube size.
1b. Trim the tubes as you create structural members, rather than doing all of the trims at the end of the design tree. This limits missed trims in tube clusters.
1c. Trim in the order you will place tubes. Ensure that there are no hollow nodes in any cluster
2. Trim a single tube at a time, both ends. If you are having difficulty with a trim, do one end at a time. DO NOT trim multiple tubes in one operation, this leads to confusion, errors and limits ability to parametrically change the model. Having organized trims allows for ease of modeling and verification.
3. For options, use the ‘Trim to Body’, do not ‘Allow Extension’ settings as a base point. If trimming to bodies does not create a correct resultant trim, set the Trimming Boundary to Face/Plane. Check the bodies to keep and the trimmed bodies to discard. Review that the trims have been completed using the surface are correct.

### 5.7 Mold Tools

Although Mold Tools are usually not frequently used by most users, there are some tips for beginners.

#### 5.7.1 Scaling

Molds for plastics and rubber products have to be compensated for shrinking. This can be done in 2 different ways:

1. Scale the Part.
2. Use the Scaling factor parameter in the Cavity Feature. This command is available in when a part isedited in the context of an Assembly with 2 or more components.

<table>
<thead>
<tr>
<th>1) Scale Part</th>
<th>2) Scaling factor in Cavity Feature</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Insert =&gt; Feature =&gt; Scale)</td>
<td>(Assembly =&gt; Edit Component =&gt;)</td>
</tr>
<tr>
<td>Formula</td>
<td></td>
</tr>
</tbody>
</table>
| The Scaling factor is the direct factor.
Factor 2,0 means, the Part will become twice as big as the original. | Cavity size = Part size * (1 + scaling factor/100).
So for a material with 1,8% shrinkage the Scaling factor has to be 1,8 !! |
| Remark                        |                                                   |
| For more complicated molds    | For simple molds.                                 |
| Draft                         |                                                   |
| More flexibility because all parameters are separated. | Can be used together with the Draft parameter. |

Creating a mold using the Cavity tool requires the following items:
1. Design Parts - The Parts that you want to mold.
2. A mold base - The Part that holds the cavity Feature of the design Part.
3. An interim Assembly - The Assembly in which the cavity is created.
4. Derived component Parts - The Parts that become the halves of the mold after you cut them.

5.8 Configurations
Configurations are tools for defining small differences in shape, material, or dimensions between Parts. When you have large or more differences it can become difficult to organize this with Configurations, and it is better to create a separate Part-file. Use “Display States” when you want to control variations in visibility (color, transparency, appearances) of a Part or Assembly.

General tip for Configurations:
Checkmark the option “Rebuild on Save Mark”
You can also do this by clicking on the Configuration name, RMB => “Add rebuild on Save Mark”
This will show the diskette icon before the Configuration name and ensures a more reliable rebuilding of your Configurations. The downside is that it takes more time to save your file if you have a lot of Configurations.
5.8.1 Start a new Configuration manually:

In either a Part or Assembly document, click the ConfigurationManager tab at the top of the FeatureManager design tree to change to the ConfigurationManager.

5.8.2 Adding Features to a Configuration:
Select a Feature => RMB Configure Feature => Select if the Feature should be suppressed or not => Type a name for the Table => Save the Table.
You can add more Features as table columns the same way, when the table is visible.

5.8.3 Adding Sketch Dimensions to a Configuration.
Make the Sketch dimensions visible: FeatureManager => Annotations => RMB Show Feature dimensions. Now the dimensions are visible: Select a dimension => RMB Configure Dimension. Now an extra column is added to the Configuration Table.

5.8.4 Using colors in Display-states and Configurations
When you have a Solidworks Part which has more than one configuration, you can link the model display states to the configurations. Linking Display-states to the model Configurations allows you to use this for different materials and/or colors for each Configuration.

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Open a Solidworks Part which has two or more Configurations.</td>
</tr>
<tr>
<td>2</td>
<td>Remove all Part appearances and repeat this for all Configurations.</td>
</tr>
<tr>
<td>3</td>
<td>Activate the Configuration-manager from the Solidworks Feature-manager. At the bottom of the Configuration-manager-tab, you see the Display-states group.</td>
</tr>
<tr>
<td>4</td>
<td>Right-click the current Display-state and select Properties. The Display-state Properties pane will appear. When checked, each Display-state can be linked to one Configuration. When cleared, Display-states are independent from Configurations, so all Display-states are available to all Configurations.</td>
</tr>
<tr>
<td>5</td>
<td>Under the Advanced Options section, checkmark the “Link display states to configurations” option.</td>
</tr>
</tbody>
</table>
Your Solidworks Part’s Display states are now linked to the model configurations.

Using Configuration specific colors
This is a Configuration property.

**First you must have linked Display states to Configurations**

RMB on one of the Configurations in the Configurations-pane, and select Properties.

This is different from Linking Display States to Part Configurations.

You can specify a color for your current specific Configuration by clicking the “Color”-button and picking a color from the color palette.

The Configuration specific color applies only to shaded mode.
You can also use this in Assembly Configurations.

Note:
When you have set colors for multibody Part Configurations, you can override the color of a body by applying an Appearance for that body.

5.8.5 Color hierarchy
You can apply colors on Parts, bodies, Features, surfaces, components and Assemblies.

One color can override another. The hierarchy is explained in this picture:

![Color hierarchy](image)

Note: not sure where the “Configuration specific colors” need to be positioned.
5.8.6 **Design Tables**

DesignTables are a much more advanced version of ConfigurationTables but are sometimes quirky and more difficult to set up. A design table allows you to edit multiple configurations of Parts or Assemblies by specifying parameters in an embedded Microsoft Excel worksheet. Microsoft Excel has to be installed on your computer.

Design tables are a very powerful and efficient tool for designing parametric models and keeps the file size very small.

The easiest way to set up a new Design table is:

Create 2 different Configurations, see chapter 5.8

Set dimensions to visible; Goto the Feature tree; “Annotations” and RMB => “Show Feature Dimensions”.

- Close all your other Excel files if they are open.
- Insert => Tables => Design table
- Select Source = “Auto-Create”

If you have no Dimensions or Features configured yet, the next dialog box will give you the option to add some dimensions as parameters (columns in Excel).

After that your Design Table is created and Excel opens up with your Design Table.

Since the Feature dimensions are set to visible, you can double click a dimension to add it as a parameter column in Excel.

The column header name is the Dimension-name. Column A contains the “configuration name”
Click somewhere in your graphics area to close Excel.

You can open your Design table in Configurations => Tables => Design Table. Open it by clicking “Edit table in new window”. Adding a new row will add a new configuration.

Don’t forget to save Excel after editing.

You can use Excel formulas for calculation of the parametric dimension. When you want to use an Excel formulas you first have to format the Excel cells as “General”. After you have edited the text in your cell, the values will be updated.

5.8.7 Equations in Design Tables

Format the Excel columns containing the parameters as “General” or your formulas won’t work. Use Excel formulas when the configured dimensions are related to each other.

To insert an Equation select Tools => Equations.

Note that the “decimal character” should always be a dot.

If you want to combine text and parameters in an Excel cell you can use:

```
"your-text"&C3&" more-text"&D3&"
```  

5.8.8 Cosmetic thread in configurations and design tables

Configuring Cosmetic Threads in Design Tables is not very straightforward.

For female threads (nuts) it is better to apply the cosmetic thread on a Cut-Feature as Annotation instead of using the Hole Wizard.

For male threads (bolts and screws) the Major Thread diameter is driven by a column in the Design Table.

For female threads (nuts) the Minor Thread diameter is driven by a column in the Design Table.

If you want to drive the thread diameter of a cosmetic thread by a design table, you have to change the “Thread Settings Standard” to “None”.

Set also the “Configurations” to “All configurations”.

Unfortunately the “Thread Callout” can not be used because it is now the same for all configurations.
5.9 Mates References in Parts and Assemblies

Reference Mates can save you some time when often used Parts like fasteners has to be mated in an Assembly. Mate references create automatically the pre-defined mates when you drag and drop a component into specific positions. The simplest type of mate reference exists on only one component and (in most cases) only creates one mate. The component can then be mated to any matching geometry on another Part within the Assembly.

Here are the steps to create and utilize this type of mate reference:

1. Open the Part in Solidworks.
2. Open the Mate Reference manager in the Reference Geometry dropdown or by going to Insert => Reference Geometry => Mate Reference.
3. While the Mate Reference dialog is active, select some geometry on the component that you want automatically mated when it is dropped onto the corresponding geometry in the Assembly. This will work best with a planar or cylindrical face. This geometry should populate the blue selection field in the Primary Reference Entity. Than you can choose which type of mate you desire (concentric, for example) and how you would like the alignment to turn out. The alignment can be adjusted later while the component is being inserted.

Mate References usually only works for the 1st (primary) reference, OR secondary OR tertiary rather than all 3 being satisfied. If you use the edge between the flat and cylindrical face of a bolt, this will capture both the concentric and coincident mate just like how Toolbox Fasteners are setup. If you want all 3 references to be captured and used, then you also need to create a mate reference on the receiving Part WITH THE SAME NAME (not default) and then SW can match all references.

Note that components from the Toolbox already do have Mate references, but they have default names.

5.10 Working with pictures

Pictures can be processed in different ways. Solidworks can also handle different picture formats, such as: jpg, png, tif and bmp. Note that Solidworks converts the picture format to its own appearances file format (xxxx.p2m) when it is applied on surfaces.

5.10.1 Insert a picture in a sketch for dimensioning

A reference image in your sketch can help to get the dimensions correctly and make the modeling process simpler. This is also a great technique to use when doing surface modeling.

1. Open a new sketch.
2. Draw some reference geometry (construction lines) to help positioning and sizing of the image.
3. To insert the image: click Tools => Sketch Tools => Sketch Picture.
4. Select the image file to insert and click “Open”. Now the image is in the sketch but is not sized or orientated correctly.
5. Use the command boxes to the left to change the size and orientation of the image or just drag the boxes around the image to resize and position. This is what the reference sketch made in Step 3 is used for.
6. Close out of the sketch and now you have a fully defined sketch with the image at the correct dimensions.

Note that Solidworks can be very slow when importing large pictures (>1MB).
5.10.2 Adding a Decal or Appearance

A decal is a single picture file which can be applied to a surface, body or Feature. The size and position of the single picture can be changed.

The easiest way to apply a custom decal is by selecting a decal from the standard library and edit its location: Display Manager => select the decal => RMB edit deal => Browse to your custom decal picture.

When a single picture file is used as an appearance, it is applied many times (depending on the size of the picture and the surface) to a surface, body or Feature. The size of the picture can also be changed but the number of applied pictures is automatically adjusted to fill the complete surface, body or Feature. Using picture files as an appearance is very useful for applying realistic textures to your models.

Note: to see the decals in Part-, Assembly- and Drawing-mode, you must set the settings View => Hide/Show => Decals to “on”.

### Tip:
When working with decals very often, you can think of these settings in: Options => Document properties => Model Display.

5.10.3 Deleting a Decal

Go to the DisplayManager => View Decals. Now you can select the decal and delete it.
5.10.4 Copy a picture on a surface

To copy a picture on a Surface:
1. Select the surface => Appearance => Face => Advanced => Browse.
2. Select all graphics files.
3. Select the picture to be copied on the surface.
4. Save the picture as an “appearance file”; xxxx.p2m
5. Adjust size, rotation with mapping (select projection for flat surfaces or almost flat surfaces)
6. Adjust illumination with the Illumination-tab.

5.10.5 Linking an Appearance to a Custom Material

You can link an Appearance to a Custom Material.
Select a a Material and click on the tab “Appearances”

Check the box “Apply appearance of:...”
Select a color and click on the button “Apply”, or select an Appearance form the Appearances tree.
### 5.10.6 Copy a standard decal on a cylindrical surface

In Solidworks some functions need a bit more of attention than usually. The application of a picture on a cylindrical surface is one of those. In this example the default Solidworks logo is applied on a tube.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
</table>
| **1** | The tube has a length of 1000mm and diameter of 1000mm.  
Open the Task pane on the right side of your screen and drag the default Solidworks logo on the outer surface of the tube. |
| **2** | By default Solidworks detects that the surface is cylindrical and positions the logo at the centre of the surface and position this all around by cylindrical mapping.
You can adjust size and rotation by dragging the rectangular or circular handles. |
| **3** | The position of the logo can be adjusted with the Mapping section in the Decals menu. |
| **4** | Unfortunately Solidworks projects a small distorted piece of the logo on the back side of the tube.
If this extra distorted decal on the backside is not acceptable, you can use the alternative method for adding decals to cylindrical surfaces in the next paragraph. |
5.10.7 *Alternative method for adding decals to cylindrical surfaces.*
In the Part-mode you can create a special embossed or debossed surface for the decal by using the Wrap Feature. You can apply the decal on the embossed or debossed surface.

If you don’t like a distorted decal, you must create a separate body (in a multibody-Part) or a separate Part (in an Assembly) for the decal. This is actually also more realistic, because real decals do have a mass and volume.
Note that the Part has to be the same size as the decal, or at least the same aspect ratio as the decal.
In the Assembly, this gives you the extra advantage that the decals will appear automatically in the BOM.
Of course, this method is also applicable on flat surfaces.

Note: If you don’t want to appear the decals in the BOM you can exclude this form the BOM, see chapter: “Hiding or showing rows or columns in a BOM-table”.

1. **Mutibody-Part:**
   Tube with 2 extra solid bodies for the decals. You have to apply the decal on the top surface of each of the bodies.

2. **Assembly:**
   A separate Part for the decal is created. This Part can be used in Assemblies.
   Note that the decal for some strange reasons is also projected on the backside of the Part, but it won’t be visible in the Assembly.

Note: decals can disappear in broken-out views of Drawings.

*SOLIDWORKS*
5.11 Subtract and keep bodies in multibody Parts

Make first a copy of the body to subtract with the command move/copy bodies. Then combine and subtract the copy of the body.

5.12 Using COMBINE, CAVITY and INDENT

Schedule for selecting Combine, Cavity or Indent Feature.

<table>
<thead>
<tr>
<th>Interference between:</th>
<th>Before =&gt; After</th>
<th>Best option</th>
</tr>
</thead>
<tbody>
<tr>
<td>2 components in an Assembly</td>
<td><img src="image" alt="Diagram" /></td>
<td>Use Combine (Add) at the Part level.</td>
</tr>
<tr>
<td>2 components in an Assembly</td>
<td><img src="image" alt="Diagram" /></td>
<td>Use Combine (Subtract) at the Part level.</td>
</tr>
<tr>
<td>2 components in an Assembly</td>
<td><img src="image" alt="Diagram" /></td>
<td>Use Indent (Cut) at the Part level.</td>
</tr>
<tr>
<td>2 multibody Parts</td>
<td><img src="image" alt="Diagram" /></td>
<td>Edit Part A in context. Use Indent (Cut).</td>
</tr>
<tr>
<td>2 single bodies in 1 Part</td>
<td><img src="image" alt="Diagram" /></td>
<td>Edit Part A in context. Use Cavity.</td>
</tr>
</tbody>
</table>
5.13 **Best Practice for Drawing molds for profiles or cross-sections of profiles**

_Do not use Blocks_ for defining standard cross sections of profiles, because Blocks will lose easily the “link to file” option on rebuilding. The broken link is often unnoticed and is also difficult to repair. Blocks are not intended for easy modifying, linking and updating, but they are a kind of template of its own. Therefore Blocks with standard shapes and notes, are very handy in Drawings.

Make a sketch of all the cross section areas of the profile and mold Parts.

Save the sketch as a new Part without bodies or surfaces (this file can be used later for editing changes).

Change your system settings as shown for updating possibilities of the model when the sketch is updated:

**Options => TAB System Options => External references =>**

- Open referenced documents with read-only access
- Don’t prompt to save read-only referenced documents (discard changes)
- Allow multiple contexts for parts when editing in assembly

Load referenced documents: **All**

Open a new Part.

**Insert => Part =>** select the Part with the cross sections.

**Transfer => “Absorbed Sketches” and “Unabsorbed Sketches”**.

- Absorbed sketches
- Unabsorbed sketches

Make sure that the option “Locate Part with Move…..” is off.
Click “OK” in the Property Manager and the Part will be located at the origin.

Note:
If you add extra sketches to the profile Part (without bodies) the new sketches unfortunately do not update automatically in the child Part files.
You can update this by Opening the child Part file with File => Open, select the child Part file and click on the References button. Now select the parent Part file without bodies and now the child Part file is updated.

5.14 **Using a surface for cutting a body.**

Create the surface body.

*Insert => Cut => With Surface*

Select the Surface to cut with. (The Surface body must intersect the body to cut).
Select the direction of the cut.

5.15 **Using the “Freeze bar”**

How to turn on the Freeze bar in SolidWorks:
1. Click Options in the Standard toolbar, or Tools => Options.
2. On the System Options tab, click General and select Enable Freeze bar.
3. Click OK.
The yellow freeze bar appears near the top of the Feature Manager design tree, under the Part name.

The freeze bar controls the point at which a Part’s Feature Manager design tree rebuilds. Features above the freeze bar are frozen – you cannot edit them, and they are excluded from rebuilds of the model. Freezing a portion of a model can be useful if you work with complex models with many Features. Freezing the Features helps to:

- Reduce rebuild time
- Prevent unintentional changes to the model
- Reduce file size

Feature Freeze prevents the geometry of frozen Features from being rebuilt. However, you might still experience long rebuild times due to other processes that are not addressed by Feature Freeze.

Examples of potentially time-consuming processes not addressed by Feature Freeze:
- Updating display appearances, especially on very large patterns
- Updating complex DimXpert dimension and tolerance schemes
- Updating the graphics (tessellation data) of very large, complex Parts

To freeze Features:

1. Move the pointer over the freeze bar. The pointer changes to Hand icon. Freeze bar change

2. Drag the freeze bar down below the last Feature you want to freeze. When the freeze bar is at the top of the tree, you can also right-click a Feature and click Freeze to freeze that Feature and all Features above it in the Feature Manager design tree.

Features above the freeze bar are frozen – you cannot edit them, and they are excluded from rebuilds of the model. Frozen Features are indicated by a lock icon Lock and gray text.

5.16 **Tips for using lofts**

When lofting, you have to give special consideration to the way you sketch the profiles and how you subsequently select them in the Loft command. In general, there are some basic rules you should follow for good results:
1. Create **first the profile sketches** and create the guide sketches later.

   Each profile should have the **same number of segments**.
   In the example at the right, a closed semi-circle is lofted to a hexagon via a rectangle.
   The hexagon has 6 segments, so 2 extra points are made coincident on the rectangle and 4 points on the semi-circle.

   Use the Split entities command for that:

   **Notes:**
   The profile may also be a face or a surface-body, but a sketch gives you more control.
   A profile can also be a sketch with a single point to create a spiked shape.

2. Create sketches for the guide curves and connect all the **sketch-points of the guide curves** to the **line entities of the profiles** by a **pierce-point** relation.
   Create a separate sketch or 3D-sketch for each guide curve!!
   In this example 2 guide curves were created in 2 separate sketches with a spline and a straight line.

3. You can create as many guide curves as you want.

   Create separate 2D or 3D sketches for each guide curve.

   **Note:**
   Guide curves can be circles, lines, splines or edges of other geometry, and must be coincident with the profile sketches.
Click the Lofted Boss/Base icon and select the profile sketches in a logical order and on a logical position (where you want the connector to appear).

There appears a “Connector” to control the torsion in the loft.

Drag the green dots of the Connector to logical positions (points in the profile sketches).

Select the guide curves in a logical order.

Notes:
Guide curves are optional but give you more control over the Loft. If you use guide curves, it is not necessary to drag the green points of the Connector, because the Connector is repositioned automatically.

Lofted Boss/Base created from a hexagon via a rectangle to semi-circle, using 2 guide curves with a straight line and a spline.

Note that a Lofts are interpolated geometry between profiles (and guide curves) and are not exact. There are many more options for Lofts, but so far the basic ones.
5.17 Using a Multibody-Part versus an Assembly

Multibody Parts and Assemblies both have their advantages and disadvantages. As a general rule to follow, one Part (multibody or not) should represent one Part-number in the BOM-list (Bill of Materials).

In other words; if you want a Part or a group of Parts to appear in the BOM-list of a Drawing, you should create an Assembly or Sub-Assembly.

Multibody Parts have a folder named "Solid Bodies" that appears in the FeatureManager design tree when there are solid bodies in a single Part document. The number of solid bodies in the Part document is displayed in parentheses next to the "Solid Bodies" folder.

<table>
<thead>
<tr>
<th>When to use a Multibody Part:</th>
<th>When to use an Assembly:</th>
</tr>
</thead>
<tbody>
<tr>
<td>The file represents a complete “purchased” item where individual components are not tracked. The multibody Part appears as a single item in the BOM of an Assembly.</td>
<td>Each Part has a unique name or number and is tracked or purchased individually.</td>
</tr>
<tr>
<td><strong>Weldments</strong> are multibody-Parts, and much easier to create as a single (multibody) Part file. The big advantage is that Weldment multibody-Parts do appear in the BOM-list!</td>
<td>The Assembly has movement where dynamic Assembly motion is important</td>
</tr>
<tr>
<td><strong>Clearance detection</strong> and <strong>interference detection</strong> between the Parts is NOT important.</td>
<td>The Assembly has movement where dynamic Assembly motion is important. Clearance detection and interference detection are important tests.</td>
</tr>
<tr>
<td><strong>Easy file management.</strong></td>
<td>More files to manage.</td>
</tr>
<tr>
<td><strong>Performance</strong> is improved since it is a SINGLE file.</td>
<td>Assemblies has one or more file references which slow down the performance.</td>
</tr>
<tr>
<td><strong>For security reasons.</strong> Saving as a multibody Part is a way to share your designs with SolidWorks users. This process removes the Feature History.</td>
<td></td>
</tr>
</tbody>
</table>

For security reasons you can convert an Assembly to a multibody Part:

**Select FILE => SAVE AS** and change the “Save as” type to PART .sldprt. This action has several options:

| Exterior Faces | SOLIDWORKS determines what faces are ‘exterior’ and which can be considered ‘interior’ and will save a multibody Part full of surfaces representing those exterior faces. |
| Exterior Components | Using a similar algorithm, SOLIDWORKS determines what Parts are “internal” and which are “external”. |
| All Components | This saves a Part file with bodies representing each individual instance of every Part within the Assembly. (This is the preferred method.) |

Note: changes made to the original Assembly will NOT update in the new Part file.

5.18 Converting Multibody-Parts.

You can convert a Multibody-Part to an Assembly or to individual multiple Part-files.

There is also another way to convert individual bodies to a an individual Part-files. See the following paragraphs.
5.18.1  Converting a Multibody-Part to an Assembly
To convert a Multibody-Part to an Assembly: **Insert => Features => Save Bodies.**
You can specify the location, name and Assembly-template for the Assembly-file.
You can specify if the selected bodies will remain in the Multibody-Part (consume cut bodies).
You can select the bodies which will go to the Assembly and optionally modify also the Part-name.
The Parts in the new Assembly are automatically mated to the origin by default. When you want to edit a Part, you can do this in the Multibody-Part, but beware, and carefully read this....
*The external reference back to the original master model reacts a little differently. The “Save Bodies” command is a Feature in the tree. This means that any changes to Features *before* the “Save Body” operation will alter the derived Assembly, but additional Features *after* the “Save Body” command will not propagate.*
When you delete the Feature “Save Bodies” the procedure is undone, but the Assembly-file still exists and will not be updated anymore.

5.18.2  Converting a Multibody-Part to multiple individual Parts
To convert a Multibody-Part to multiple individual Parts: **Insert => Features => Save Bodies.**
This is very similar to convert a Multibody-Parts to an Assembly, but there is need to specify a name for the Assembly of course.
You can select the bodies which will be saved as individual Part-files.
The new Parts are automatically mated to the origin by default. When you want to edit a Part, you can do this in the Multibody-Part, but beware, and carefully read this....
*The external reference back to the original master model reacts a little differently. The “Save Bodies” command is a Feature in the tree. This means that any changes to Features *before* the “Save Body” operation will alter the derived Part, but additional Features *after* the “Save Body” command will not propagate to the derived Part.*
When you delete or suppress the Feature “Save Bodies” in the Parent file, the derived Part-files will not be deleted.
The derived Parts will have the file name of the Body (this is the last added Feature name) and will have only one Feature in the Feature tree with the name “Stock- `<Parentfilename>`”.
This method can also be used when you want to show or send the Part, but not the Feature history.

Another way to convert an individual bodies to an individual Part-files; go to the Feature tree and select the folder “Solid Bodies”. Click on one of the bodies you want to save and RMB => “Insert into new Part”. From there you can select more bodies from the Feature-tree or the graphics area. The selected bodies will be save as anew Part file.
This method has 2 advantages over the previous one:
You can select one or more bodies to create a new Part-file.
There is a better external reference back to the parent model in the form of a **Stock** Feature. The new file won’t have a Feature history, but it will alter if the parent model changes. The reference is only one directional though- additions to the newly derived Part will not change the parent- ensuring this stays preserved. The Feature tree displays this reference using a special symbol.
5.19 Virtual Parts/Components

Virtual components are those that ‘live’ ONLY within the Assembly. Similar to the individual bodies in multibody Parts, virtual components do not have an external file to track.

New Parts can be created when virtual components in an Assembly or existing Parts are “converted” to virtual components.

Note that you can’t share virtual Parts between two different Assemblies (even if one Assembly is a sub Assembly of another one, virtual or not).

Create a virtual Part:
1. Select multiple Parts in the Assembly Feature Manager and choose MAKE VIRTUAL.
2. A “Warning” will appear!!
3. The resulting virtual components will NOT be updated when the original Parts changes!!
4. Virtual components are represented in the Assembly Feature Manager with square brackets “[ ]”.

When to use a virtual Parts:
• The file represents a complete ‘purchased’ item where individual components are not tracked, f.e. paint, grease or adhesive on a steel Part.
• It is an easy way to share your designs with Solidworks users. If all the Parts in the Assembly are virtual, you can send a single Assembly file and all the virtual components will be contained within it.
• Performance is improved since it is now a single file. It has not several referenced files like Assemblies with “traditional” Parts.

5.19.1 How to show virtual Parts in the BOM of a Drawing

As described before, for a purchased item like paint, grease or adhesive it can be necessary to list it in the BOM of the Drawing.

1. Create a new Part for the paint, and add some custom properties you want to be listed in the BOM, like Material, Description or Weight.
2. Edit the Custom properties.
3. Insert the Part into the Assembly, and make it fixed to the origin.
4. RMB the Part and select Make Virtual
5. The component name will appear in square brackets “[ ]”.
6. The virtual component can be listed in the BOM.
5.20 **Bottom-up versus Top-down (in context) modelling.**

When to use “Bottom-up”
Bottom-up is the most traditional method used by CAD operators. Parts are modeled and they are inserted into the Assembly using mates to position and fix them in relation to other components. Any changes to a Part will need to be done by editing it individually. This technique is practical to model Parts already designed and fabricated, like purchased Parts and components (hardware, bearings, motors, pulleys, etc.), in general, Parts that you do not design, and which do not change their shape and dimensions when your changes your design.

Bottom-Up is also a good technique for people "integrating" commercial components into an Assembly, where perhaps only one or two components are design (such as the skid base of a motor-generator set, where all other components (motor, radiator, electric generator, etc.) are purchased components.

When to use “Top-down” (in-context).
Top-down technique is normally the technique used by product design engineers. Top-down creates Assemblies where Parts are modeled "inside" the Assembly, being related to "driving" entities inside the Assembly which control the shape, Features, dimensions and position of those Parts, in a way that changes introduced to the "driving" entities "drive" the configuration of all the "in-context" modeled Parts and therefore the entire Assembly. Top-down modeling makes it possible to create parametric Assemblies, which cannot be done using the Bottom-up technique alone.

Creating a properly structured Top-down Assembly requires more analysis and work that the creation of a Bottom-up model, however the advantage of Top-down modeling for people doing product design is that very little work (and time) will be required when design changes occur, since all Parts and components will automatically update to new shapes, dimensions, position, etc. as new input parameters are entered into the "driving" entities at the Assembly level.

Which one is the better, depends on the nature of the product you are designing and the amount of changes you expect to have during the entire product life cycle.

The Top-down technique is more difficult and it also requires more work when creating the model. It will be better for people designing products from scratch (where the Assembly will need to go through many changes before reaching its "final" configuration) or for people designing products which are "design-to-order" as "variations" of a "basic" generic product.
6 Assembly modelling

6.1 Flexible sub-Assemblies in the main Assembly.

A sub-Assembly in an Assembly is rigid by default !!. Even when the sub-Assembly is not fully defined. Within the parent Assembly, the sub-Assembly acts as a single unit and its components do not move relative to each other (piston in shaft).

One of the most common issues that people have when they include sub-Assemblies within their design is that any degrees of freedom allowed within the sub-Assembly are not available when it is brought in to an Assembly, the sub-Assembly is rigid and this is often not what people expect.

Why is this?
When you insert a sub-Assembly into an Assembly the Assembly is treated as if it is a Part, thus it is completely rigid and inflexible. This speeds up the process as SOLIDWORKS does not need to constantly update all the mates within the sub-Assembly as you move the Assembly around the screen, reducing processing requirements, speeding up the process and potentially making it easier to work with that subAssembly. Thus the Assembly is fixed in the position it was saved within the sub-Assembly.

But I want my sub-Assembly to move!
SOLIDWORKS will allow movement of sub-Assemblies; we just need to specify that the Assembly is flexible. If we right click on the sub-Assembly in the tree there is an icon in the context sensitive toolbar to make sub-Assembly flexible, (prior to SOLIDWORKS 2014 this icon does not appear, instead we would need to go to the Assemblies properties and select ‘Solve As: Flexible’) with this selected you’ll notice a few changes – the icon for the sub-Assembly changes to a flexible sub-Assembly icon and more importantly, any degrees of freedom allowed in the sub-Assembly are available.

Example:
In the example below we have created a sub-Assembly of the universal joint, this has then been brought into our top level Assembly and has already been mated to the bracket using the shaft at the top of the universal joint, we wish to now add mates to control the movement of the lower yoke of the universal joint. We want the flat face at the bottom of the yoke to be parallel to the angled face of the bracket.

We want to create a mate to sit the underside face of the Yoke parallel to the angled face.
As the sub-Assembly is rigid we cannot create this mate; it requires the sub-Assembly to change position which cannot happen as the universal joint is rigid.

Specify that you wish the sub-Assembly to be made flexible.

With the sub-Assembly made flexible the mate can now be added, and the universal joint can be rotated.

6.2 Interference Detection
To open this PropertyManager:
Click Interference Detection (Assembly toolbar) or Tools > Interference Detection. Selected Components

| Components to Check | Displays components selected for the interference check. By default, the top-level Assembly appears unless you pre-select other components. When you check an Assembly for interference, all of its components are checked. If you select a single component, only the interferences that involve that component are reported. If you select two or more components, only the interferences between the selected components are reported. |

6.3 Subtract one component from another and keep both in an Assembly
Select the component to make a cavity in.
Click the icon “Edit Component” and Insert -> Feature -> Cavity
Select the Component or Part to subtract.
6.4 Create a new subAssembly from a selection of components.

You can form a subAssembly from components (individual Parts or subAssemblies) that are already in the Assembly, thereby moving the components down one level in the Assembly hierarchy. Before creating a new subAssembly, you can specify the default behavior for saving it, either as a separate external Assembly file or as a virtual component within the parent Assembly file. Click Tools > Options > System Options > Assemblies and select or clear Save new components to external files. Virtual components are saved internally in the Assembly file instead of in separate Part or subAssembly files.

**Recommendation:** Position and mate at least one of the components before you begin, then select that component first. All the components must be at the same level within a single parent Assembly. To create a new Assembly from existing components:

1. In the graphics area or the FeatureManager design tree, Ctrl + select the components.
2. Do one of the following:
   - Right-click one of the selected components, and select Form New SubAssembly.
   - Click Insert > Component > Assembly from [Selected] Components.

To form a subAssembly from components contained in a folder in the FeatureManager design tree, rightclick the folder and click Form New SubAssembly.

3. Depending on your Assemblies option setting, one of the following occurs:
   - The new subAssembly is saved as a virtual component within the parent Assembly.
   - The Save As dialog box appears, so you can save the new subAssembly in its own Assembly document. Browse to a different folder if needed, enter a File name, and click Save.

A new subAssembly is inserted at the level where the selected components were located, and the components are moved into the new subAssembly.

6.5 Positioning of identical Components in an Assembly, like bolts in holes

Position the first Component in the Assembly and fully define it with mates”. Select “Sketch driven component pattern.” Select the Component to be patterned. Select at Reference point: “Selected point”, and search the sketch with the Hole Pattern in the Feature Manager tree and RMB “visible”. Select the first point and click OK

The first Component is now twice in the Feature tree and can give an error sometimes. Find the double Component in the Feature Manager by searching “LocalSketch pattern” and delete one instance of it.

6.6 Often used fasteners like washers, bolts and nuts

The Toolbox is a very nice tool for quick downloading and positioning of fasteners. However the Toolbox is not installed in the Solidworks “standard” version. For users with the “standard” version this is a disadvantage you can resolve in the next tip.

If you often use the same type of nuts, bolts, and washers in your Assembly you can model these components as a Part with configurations. These Part-files are usually very small and can be stored in a special designated directory or in the same directory as your model if you like. The advantage of this method is that you can model the Parts to the required level of detail of your company standards.
6.7 Breaking the references of components downloaded from the Toolbox

Downloaded components from the Toolbox are not visible when your model is opened on other computers who have no internet access or to the Toolbox.

After downloading your Toolbox component, it is often a good habit to save it as a separate component (Part) in your model directory. This policy can be different in each company. However unfortunately Solidworks has not made this very easy for us.

The correct way to do this, is with a special Solidworks software tool; sldsetdocprop.exe which is located at: "C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS\Toolbox\data utilities\sldsetdocprop.exe" You can make shortcut-icon of this tool on your desktop.

Change the system settings of your Toolbox:

![System Options - Hole Wizard/Toolbox]

- Optionally you can specify a (temporary) Toolbox directory: “C:\Solidworks Data\”
- Uncheck the checkbox “Make this folder the default search location........”

When you have downloaded a Toolbox component in your Assembly, select this component by clicking on it in the Feature Tree.

RMB => Make Independent, and save the component with a new name in your model directory. The component is still a Toolbox-component.

![Set Document Property]

- Start the Solidworks Tool: sldsetdocprop.exe with the desktop-icon and select the Toolbox-component. (You can also select all Toolbox-components at once in the same directory.)
- Set Property state: “No”, and click “Update Status”.

Now the downloaded component has lost its reference to the Toolbox. You can check this in in the Feature Tree as the Toolbox-icon of the component has changed to a Part-con. You can edit use and edit the component freely as you want.

The above described procedure might not work in SW2015 because there is a known bug: SPR 919518. The workaround is:

Open the Solidworks Toolbox model then “SAVE AS” and put there the name you want and save to desired folder. Then use the “sldsetdocprop.exe” software program, click add files and select the Toolbox model you just saved as. Click the show selected property and it will show a standard which means the Toolbox is still controlling the model so “select property state No” and click update status.

When you try to click again the “show selected property” it will show “No” which means the model is not related to the Toolbox anymore and you can exit the “sldsetdocprop.exe” program. The model now is in the standard Solidworks Part format.
### Chapter 6.8 Error- and external reference symbols

<table>
<thead>
<tr>
<th>Reference symbol</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>-&gt;</td>
<td>The feature has an <strong>external reference</strong> and the file is present and unlocked. This should usually be the case!</td>
</tr>
<tr>
<td>-&gt;?</td>
<td>The feature has an <strong>external out of context reference</strong>, while the referenced file is present, but not open. The feature is not solved or not up-to-date. To solve and update the Feature, open the Assembly that contains the update path.</td>
</tr>
<tr>
<td>-&gt;*</td>
<td>The feature has an external reference to a <strong>locked file</strong>.</td>
</tr>
<tr>
<td>-&gt;x</td>
<td>The feature has a <strong>broken external reference</strong> (referenced file is missing).</td>
</tr>
<tr>
<td>(f)</td>
<td>The component is <strong>fixed</strong> in the Assembly and can not be moved.</td>
</tr>
<tr>
<td>(-)</td>
<td>The sketch or component is <strong>underdefined</strong>.</td>
</tr>
<tr>
<td>(+)</td>
<td>The sketch or component is <strong>overdefined</strong>.</td>
</tr>
<tr>
<td>(?)</td>
<td>The sketch or component is <strong>not solved</strong>.</td>
</tr>
<tr>
<td>(??)</td>
<td>This item requires a <strong>rebuild</strong>.</td>
</tr>
<tr>
<td>(???)</td>
<td>The part or Feature below has a <strong>warning</strong>.</td>
</tr>
<tr>
<td>(???)</td>
<td>The part or Feature below has an <strong>error</strong>.</td>
</tr>
<tr>
<td>(???)</td>
<td>The Part, Feature or Mate has a <strong>warning because it is overdefined</strong>. The Feature will solve but could cause problems in the feature tree.</td>
</tr>
<tr>
<td>(???)</td>
<td>An <strong>error</strong> in the Part, Feature or Mate is <strong>not solved</strong>.</td>
</tr>
</tbody>
</table>

For referenced documents, I prefer to have these documents also open. The disadvantage is a heavier system load. The setting for this option is:

**Options** => **TAB** "System Options" => **External references** => **Open referenced documents with ro access** and

**Options** => **TAB** "System Options" => **External references** => **Load referenced documents** => **All**

In case of an "**out of context mark**" ->? You can easy repair it by closing the file and reopening the file with the menu **File** => **Open** and browse to the file and select with a single click:

Click on the "**References...**" button.
**SOLIDWORKS**

DoubleClick on the Part- or component-name you want to repair and browse to the file you want to use for the reference and click on the “Open” button.

Now the Feature tree should show the repaired reference as “->”.

### 6.9 **Display States**

You can create Display States to hide or show bodies, Parts or components. You can also set different Appearances for each item in Display States.

Display States are different from Configurations, because Display States control only the visibility.

To create a new Display State:

1. Go to the Configurations TAB.
2. RMB on an empty area
3. Select Add Display State

The active Display State-name appears in angle brackets after the configuration name in the ConfigurationManager and at the top of the FeatureManager design tree.

Later, when you edit the Drawing of the Assembly, you can select the required Display State for each Drawing View.

When you have created Display States in a Part, you can use the desired Display State of this Part also in the Assembly.

To change the default Display State of a component of an Assembly, click on this Part in the Feature Tree and **RMB or LMB=> Component Properties** (click on the icon in the popup menu), and select the desired Display State from the list of **Referenced Display States**.

### 6.10 **Sketch Layout**

Sketch Layout is a sketch which is mend for defining the relations between Components in 3D space. They can be used for defining movements of components which is very handy for advanced users.

Layout Sketches are 3D sketches drawn on a grid.

These Sketches are not suitable for common design work as sketches in Parts.

Some command buttons such as “slots” are greyed out and cannot be used in Layout sketches.

### 6.11 **Mates**

Mates are constraints to define the position of the components in the Assembly.

It is usually a good idea to make the position of the first Part in the Assembly “fixed”. This means that it is oriented to the same planes as in the Part file. This can be done as follows:

1. Create a new Assembly
2. Click **Insert Components** => click the “Browse” button => and click in the “Insert component” pane at the left upper corner of the screen. (Do not click in the graphics area).

Now the first Part is in a “fixed” position and is marked with “(f)” in the Feature tree, you can mate other components to the first Part.

If you want a Part in a “not fixed position” you can make it “floating” any time by RMB the fixed component in the Feature tree and select “Float”. Now the position of the component is not fully defined and it is marked with “(·)”. To create stable and easy to change Assemblies, it is common to use the main planes of the Assembly and the Part, as much as possible in the mates.
You can also use some predefined X, Y, Z-axis to create mates. Personally I also like to use Sketches in Assemblies for using in mates. In the Drawing you can easily “Hide/Show” this sketch.

### 6.12 Easy Mates in Assemblies

An easy way to apply mates in Assemblies is:

In normal Assembly mode, select the two surfaces you want to mate while holding Ctrl, and the available mates will popup.

Sometimes when you insert a small Part in an Assembly, the fresh inserted Part is inserted far away from the Assembly and is hard to find.

In that case you select the small Part and select “Component Preview Pane”.

When you use this command for the first time, you have to customize your menu.

Select: Customize => Commands => Component Preview Pane, and drag it into the menu of your choice, like the Command Manager Menu.

When the small Part shows up in the “Component Preview Pane” on the right side of your screen, you can apply mates from there.

### 6.13 Modelling methods

Once you know the way within all the available commands for creating geometry, there will be a moment to think about the best method and order of creating your Features, Parts and Assemblies.

The table below describes some basic methods you should know about:

<table>
<thead>
<tr>
<th>Part</th>
<th>Single-body Part</th>
<th>Multi-body Part</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>An easy, robust and fast method for simple models, with only one body.</td>
<td>This is also a robust and fast method for slightly more complex models but with some disadvantages; The multi body Part appears by default as one Part in the View and BOM of a Drawing. There is no interference detection possible. To create Drawings for each body you can insert Delete/Body features and suppress each of them in Configurations.</td>
</tr>
<tr>
<td>Part-in-Part or</td>
<td></td>
<td></td>
</tr>
<tr>
<td>or Insert Part Technique or</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>A Part with reference Sketches and or surfaces is imported as the first Part of each Part. All Parts are created into the correct position relative to each other, so mates in the Assembly are not necessary. This method is not very robust, because Solidworks causes often rebuild errors in Assemblies because the Parts do not always update,</td>
<td></td>
</tr>
<tr>
<td>Assembly</td>
<td>Master Model Technique</td>
<td>Bottom-up</td>
</tr>
<tr>
<td>----------</td>
<td>------------------------</td>
<td>------------</td>
</tr>
<tr>
<td></td>
<td>even after Ctrl-Q. However this method feels logically and it is fast. This method is only recommended for simple models with less than ~15 Parts.</td>
<td>A collection of single- or multibody-Parts is positioned in the Assembly with mates, without external references to other Parts. This is a good method for simple models which do not have to be changed often. It is difficult to change the model after it is finished.</td>
</tr>
</tbody>
</table>

It is also possible to mix up some of the above methods, but this will soon create problems with rebuild errors. None of the above methods can be described as the “best method”, because it is depending on what you want to achieve. It is better to understand which method is best for your situation and workfow.
6.14 **The Skeleton Sketch Part-method (SSP)**

The Skeleton Sketch Part-method or SSP-method is the most stable method for modelling robust and easy to change models, also large ones.

A typical feature-tree of a main-Assembly according this method, looks like this:

This set of files with “empty” Parts can be used as a template for new models.

The first component in the main-Assembly is the Skeleton-Part with all the sketches, axis and planes. If preferred, there can also be surfaces in the Skeleton-Part.

The Skeleton-Part is also the first Part of each sub-Assembly (marked with red rectangles). You can add as many Parts to each sub-Assembly as you want.
**SOLIDWORKS**

**Workflow:**

1. Create first the sketches in the skeleton-Part (SSP) like front-, top- and right-views on the planes and in the correct position. Create a sketch for each feature. Create extra planes with sketches and axis when needed. Do not create the sketches in the skeleton-Part (SSP) “in context” of the Assembly.

2. When editing a Part, you edit them from the main-Assembly or sub-Assembly by selecting your Part and clicking the “Edit Component” button. To prevent creating unwanted relations, also select the command RMB “Isolate”. You can unhide the Part with only sketches (SSP), because we need to refer only to that Part.

3. To create a feature in the Part, use the sketch in the SSP and create a copy with “derived sketch”.

4. Make sure your sketch is created in the correct Part and is fully defined. The feature tree is blue colored because this is the selected Part (component) for editing.

5. A new feature Boss-Extrude1 (midplane) is created by selecting a vertex from the SSP-sketch as starting point (from) and end point (to).
The new Boss-Extrude1 feature in the new Part is linked to a sketch in the Skeleton Part (SSP). If the sketch in the SSP is changed, all Parts and Assemblies will update.

**Important notes:**
You can delete a Part from the Assembly-feature tree, but it is important to understand that the deleted Part-file still exists and still refers to the main- and sub-Assembly.
If the Part-file still exists you can decide to add it again to the Assembly later.
If you really don’t need the removed Part, than you can delete the Part-file.
The file-properties of Parts and sub-Assemblies can not be edited from the main-Assembly and must be edited by opening the individual files.

There is much more to write about this very interesting subject.
To be continued..................

**6.15 Circular reference errors and rebuilds**
An example of a basic circular reference in an Assembly with 3 Parts is described as:
- Part-A is referencing to Part-B,
- Part-B is referencing to Part-C,
- Part-C is referencing to Part-A.
Referencing is done by “in-context Features” in the Assembly.
At the moment you create this Assembly, it is not really a big problem and *Solidworks will rebuild it without warnings and problems*. The problem is that significant changes made at a later stage in Part A, B or C will cause rebuild errors which are difficult to repair in complex models. That is the reason that “Top-down” modelling, also called “in-context” modelling, is so sensitive to this kind of errors.
In the SSP (Skeleton Sketch Part-method) this is omitted because all Parts are referencing to one “Skeleton Sketch Part” which is positioned as the first Part in the main-Assembly and in all sub-Assemblies.

**6.16 Best practices for Assembly mates**
The first good practice rule is to always have the first component in an assembly fixed rather than manually mated in position. By fixing the first component the mate solver does not contain the overhead of solving the location of the first component so essentially that component is skipped since it is fixed in space.
The second good practice is to mate with faces and planes whenever possible. Mating with edges, axes and vertices should be avoided when possible as the face and plane mates restrict more degrees of freedom than the other entities therefore less mates are required.

A third good practice is to use sub-assemblies wherever possible and reduce the number of top level mates. Along with this practice it is good to limit the number of flexible sub-assemblies used, especially nested flexible sub-assemblies. When sub-assemblies are used the mates are solved at the sub-assembly level rather than at the top level assembly so it reduces the number of mates solved at the top level assembly. Flexible sub-assemblies, though, need to be solved with the top level assembly to ensure proper alignment. Likewise, nested flexible sub-assemblies are also added to the top level assembly, therefore the top level assembly now has to solve the mates of all three assemblies (top, first level flexible sub-assembly and second level flexible sub-assembly) which will impact performance.

The order of rebuilding an Assembly is as follows:
1. Solve reference geometry and sketches that are listed before Parts in order, at the top of the design tree (Layout Sketch or Skeleton Sketch).
2. Rebuild individual Parts as necessary.
3. Solve the mates and locate the Parts.
4. Solve in-context Features in Parts.
5. Solve reference geometry and sketches listed after the mates.
6. Solve Assembly Features and component patterns.
7. Loop to step 3, to solve mates that are connected to anything that was solved after the first round on the mates.
8. Continue to loop until complete.

Note:
Not sure in what order Global Variables in different Parts and Assemblies are handled in this scheme.

6.17 Global variables

Global variables are often used to create relations between dimensions and or Features in one Part, between Parts and in Assemblies.

The easiest and most logical method to create Global Variables is in the Equations dialog box.

Show the Equations in the Feature manager. Options => System Options => FeatureManager => Equations => Show.
Click on Equations in the Feature tree.

Since Global Variables can refer to almost any dimension or Feature somewhere to a Part or Sub-Assembly in the Feature tree, this is also “an invitation to create circular rebuild problems”.

Global Variables can not be pushed or pulled between Part-files, without an Assembly. With the Part-in-Part modelling-method, the GV’s can be pushed an pulled via File-Properties, but it doesn’t rebuild until the Part (with the imported Part) is changed.

6.18 Creating intelligent models

Intelligent models are models where some parameters are easy to change without rebuild errors. The parameters can be defined in different categories like; Global Variables, Equations, Configurations, Design Tables, Custom Properties and also Macros. These parameters can be applied to sketches, Parts, sub-Assemblies, main-Assemblies and Drawings.

Types of Parameters, and where they can be defined:

<table>
<thead>
<tr>
<th>Parameter / Level:</th>
<th>Sketch</th>
<th>Part</th>
<th>Sub-Assy</th>
<th>Main-Assy</th>
<th>Drawing</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configurations</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Design Tables</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Global Variables</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Custom File Properties</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Macro’s</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

A lot of Feature-parameters can directly pull information from a “Global Variable” or “Custom File Property” which is defined in the same Part or (sub-)Assembly. Some exceptions are:
- Mate distances. (Mate distances can be done by sketches in SSP).
- Spline point positions and handles.

For pulling a GV which is defined in an other Part or (sub-)Assembly you have to create first an Equation which pulls the information from a GV which is defined in that other Part or (sub-)Assembly. After that, this GV is in the same Part or sub-(Assembly) and it can be used (pulled) by a Feature.

Notes:
- Referencing to other levels in the Assembly, can only be done one level at the time because otherwise rebuild errors can occur.
- Referencing to Global Variables defined in “lightweight” (sub-)Assemblies is not possible. They have to be set to “Solved” first.
GV1 is defined in the Top-level Main Assy.
GV2 is defined in the SSP (Skeleton Sketch Part).
GV3 is defined in Sub-Assy1.
And so on........
With the SSP-method, where GV2 is defined in the SSP, GV2 can be pushed and pulled to the Equations Manager of all other Parts and (sub-)Assemblies.

Defining Global Variables in several different Parts and Assemblies can lead to circular references.
When all Global Variables are defined in the SSP (Skeleton Part), than all other Parts and Components can refer to them. This is one of the reasons that the SSP-method is robust and stable.
It gets really tricky when Configurations and Design Tables are combined with Global Variables. Global variables can be defined at the Part-level for different Configurations.
When using Configurations and Design Tables in the SSP, each instance of the SSP can have a different Configuration in each (sub-)Assembly.
In the Assembly, each instance of the Part-Configuration can be different. But this is difficult to control and often does not work well. Usually Part-Configurations has to be driven by the Assembly-Configurations, so it is better to put the Configurations and Design Tables in the Main-Assembly. From there the SSP can be controlled simultaneously for each Sub-Assy.
6.18.1  Linking “Global Variables” to “Custom File Properties”

Global Variables and Custom Properties can be linked to each other and both types can push and pull information from and to each other!!

**Define the Custom File Property, and push it to a GV.**

Once the File Property with the name “Test-FP” is defined in the File Properties menu, it can be pulled to a GV in the Equation Manager of the same Part, by clicking on the drop down box and select “File Properties”.

**Define a GV, and push it to a Custom File Property.**

Once the GV with the name “Test-GV” is defined in the Equations Manager, it can be pulled to a File Property with the name “Test-FP” of the same Part by clicking on the “Value” drop down box.

Note: when a “GV” is pushed to a “File Property” it becomes automatically also available in the Drawing of this Part or Assembly!

6.18.2  Linking a GV to an Annotation (Note) of a Drawing

You can directly link an Annotation to a File-property, but unfortunately not (by default) to a GV (Global Variable).

See also 8.38 Editing Drawing Notes, Linked to File Properties.

If you want to link the Annotation with a GV, you have to link the GV first to a File-property. Obviously this is usually done in the Part- or Assembly-file as shown in the Drawing view.

To link a GV to a File-property, see 6.18.1 Linking “Global Variables” to “Custom File Properties”

After this is done, you can link the annotation with a GV via a file-property.

6.18.3  Linking a GV (Global Variable) to a dimension of a different Part.

When GV’s are defined in the Equations Manager of a Part-file, it can be easily used to drive a dimension in the same Part, but how to push the GV to a different Part?

Solidworks - Hints, Tips, Tricks and Best Practices – 3rd edition
First there is the pre-condition that both Parts or Components, must be present in an Assembly. It must be an Assembly because referencing GV’s does not work with the “Part-in-Part” method.

Open the Part in context of the Assembly. (Edit Component).

Open the Feature Manager of the concerning Feature. In this case it is the Circular Pattern”.

Type “=” in the box for the “Number of instances”.

Click in the top of the Feature Manager to expand it.

Click on the Equations tab to expand it.

The GV “NrOfHoles” can be pulled from the Main-Assembly, but also from other Parts, just by clicking on it.

### 6.18.4 Renaming of Global Variables in the Equations Manager.

Renaming of a GV can easily done by typing a new name in the “Name” column of the Global Variable.

Except when the GV is used in Configurations! (The GV might even be linked to a Design Table).

First Mark the GV as valid for “All configurations”.

Now you can change the name of the GV, and change the validity back to “This Configuration”.
General Part- and Assembly practices

This chapter describes some hints and best practices concerning the combination of the Part- and Assembly environment.

7.1 Mirror vs Opposite hand version.

A mirrored part or component has the geometry mirrored in a plane or surface. In Solidworks a “mirrored part or component” is just a copy of the original and not an “opposite hand version”.

An opposite hand version has asymmetric geometry mirrored in a plane or surface. As a result, it has different geometry after mirroring (left becomes right and vice versa). If the “opposite hand version”-feature is used on symmetric geometry, the result is not an opposite hand version, but a mirrored version.

Part-environment:
The mirror command is available in the Part-environment for; sketch-entities, features, surfaces and solid bodies. A Part can also be saved as a mirrored Part (select mirror-face first, Insert => Mirror Part...).

This is not neccessarily an “opposite hand version” of the Part. If the Part is symmetrical around one or more planes, than the copied Part is just a “mirrored Part”.

If the Part is asymmetric around any plane, than an “opposite hand version” will be created. An “opposite hand version” has different geometry when it is mirrored. Therefore you probably want to create also a different Part-file for it which is linked to the original Part.

In the “Insert mirror Part”-menu, you can select the properties you want to transfer (copy) from the original to the mirrored Part.

After completing the menu options, the new Part is opened and you can “save as” it with the file-name of your choise.

The mirrored Part is not neccessarily an “opposite hand version” of the Part. If the Part is symmetrical around one or more planes, than the copied Part is just a “mirrored Part”.

If the Part is asymmetric around any plane, than an “opposite hand version” will be created. An “opposite hand version” has different geometry when it’s mirrored. Therefore you probably want to create also a different Part-file for it, which is linked to the original Part.

Assembly-environment:
In the Assembly-environment you can mirror a component (Insert => Mirror Components....).
In the Mirror Components menu you have several options. With the “Reorient components” buttons you can select 1 of the 4 orientation-options.

These are, by default, **not truly mirrored components** but just copies which are moved to the other side of the mirror-plane and rotated in a fuzzy way. If the component is modeled with alignment to it’s default planes and the mirror-plane is also aligned to one of the the default planes of the Assembly, then 1 of the 4 options will result in a truly mirrored component.

If the Part is asymmetric to any plane, than it can be useful to create an “opposite hand version” and create an extra Part-file, which is linked to the original Part. The new created extra Part-file will have the prefix “Mirror” in the filename.

**Warning:**
Do not use this functionality to insert the extra file “Mirrorxxxx.sldprt” as a new component in the Assembly, because it can give orientation problems.

**Drawing-environment**
Since SW2017 mirroring in the Drawing-environment is also possible.

In the drawing environment, select a Model, Relative to Model, or Predefined drawing view.

In the Drawing view PropertyManager, in the mirror panel, select Mirror view.

Under Mirror view, select Horizontal or Vertical.

This is also an easy method for creating a mirrored view, but this is not the same as an “opposite hand version” because it has identical geometry.
Depending on what you want to achieve, one option is better than the other. To choose the best workflow, you can ask yourself the following questions:

1. Is the mirrored part- or component-file, linked to the original and updateable?
2. Are appearances transferred and updatable to the mirror part?
3. Are decals transferred and updatable to the mirror part?
4. Is a true mirror necessary?
5. Does the mirrored part (opposite hand version) need a different ID-number?
6. Does the mirrored part (opposite hand version) need a separate Drawing-nr. or Drawing view?

As illustrated, you can create a mirrored part or component or an opposite hand version in the Part-environment and the Assembly-environment. Both environments have their own differences for a mirrored Part and the opposite hand version.

<table>
<thead>
<tr>
<th>Part-environment</th>
<th>Assembly-environment</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Mirrored</strong></td>
<td><strong>Opposite hand</strong></td>
</tr>
<tr>
<td><strong>Comments</strong></td>
<td>Not very useful if part is symmetric.</td>
</tr>
<tr>
<td><strong>Text is readable?</strong></td>
<td>no</td>
</tr>
<tr>
<td><strong>Separate file created?</strong></td>
<td>no</td>
</tr>
<tr>
<td><strong>Updatable separate file?</strong></td>
<td>n.a.</td>
</tr>
<tr>
<td><strong>Command</strong></td>
<td>select mirror-face, Insert =&gt; Mirror Part...</td>
</tr>
<tr>
<td><strong>Selectable:</strong></td>
<td>- bodies - surfaces - axis - planes - cosmetic threads - sketches - custom properties - coordinate systems - dimensions - hole wizard data - sheet metal information - unlocked properties - materials - visual properties (appearances)</td>
</tr>
<tr>
<td><strong>Not selectable:</strong></td>
<td>bodies: yes surfaces: yes axis: yes planes: yes sketches: no materials: yes appearances: no</td>
</tr>
<tr>
<td><strong>Copy of decals, lights and camera positions ?</strong></td>
<td>no</td>
</tr>
<tr>
<td><strong>Can separate file be modified, without breaking link?</strong></td>
<td>yes</td>
</tr>
<tr>
<td><strong>Notes</strong></td>
<td>Mirroring of features, surfaces and bodies within the Part is also very useful.</td>
</tr>
</tbody>
</table>
7.2 Optimizing Solidworks performance

There are 3 groups of effects on performance:
- various system- and document-settings
- the model or drawing itself
- the computer or network hardware

Performance itself can be subdivided in:
- loading and opening the model or drawing
- editing the model or drawing
- rebuilding time of the model or drawing (Evaluate => Performance evaluation)

There are a lot of settings you can change to influence the performance in the Part,- Assembly,-and Drawing-environment, depending on what your needs are.

The model itself has also a big effect on performance. Circular references in the model do not always give warning-, or error-messages, but can slow down the performance very much.

System options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Setting</th>
<th>Loading/opening the model or drawing</th>
<th>Editing the model or drawing</th>
<th>Rebuilding time of the model or drawing</th>
</tr>
</thead>
<tbody>
<tr>
<td>System options =&gt; General:</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show thumbnail graphics in windows explorer</td>
<td>Uncheck</td>
<td>Slightly faster</td>
<td>n.a.</td>
<td>n.a.</td>
</tr>
<tr>
<td>Enable Freeze bar</td>
<td>Checked</td>
<td>n.a.</td>
<td>Faster</td>
<td>Faster</td>
</tr>
<tr>
<td>When rebuild error occurs</td>
<td>Prompt</td>
<td>Slightly faster</td>
<td>Slightly faster</td>
<td>Slightly faster</td>
</tr>
<tr>
<td>Show latest news feeds in task pane</td>
<td>Unchecked</td>
<td>n.a.</td>
<td>Slightly faster</td>
<td>Slightly faster</td>
</tr>
<tr>
<td>System options =&gt; Drawings =&gt; Performance</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show contents while dragging Drawing view</td>
<td>Unchecked</td>
<td>n.a.</td>
<td>Slightly faster</td>
<td>n.a.</td>
</tr>
<tr>
<td>Allow auto-update when opening drawings</td>
<td>Unchecked</td>
<td>Slightly faster</td>
<td>n.a.</td>
<td>n.a.</td>
</tr>
<tr>
<td>System options =&gt; Drawings =&gt; Display style</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edge quality for shaded edge views</td>
<td>Draft quality</td>
<td>n.a.</td>
<td>Slightly faster</td>
<td>n.a.</td>
</tr>
<tr>
<td>System options =&gt; Colors</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Background appearance:</td>
<td>Plain</td>
<td>Slightly faster</td>
<td>Slightly faster</td>
<td>n.a.</td>
</tr>
<tr>
<td>Use specified color for Drawing paper</td>
<td>Checked</td>
<td>Slightly faster</td>
<td>Slightly faster</td>
<td>n.a.</td>
</tr>
<tr>
<td>System options =&gt; Display/selection</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Assembly transparency for in-context editing</td>
<td>90%</td>
<td>n.a.</td>
<td>Slightly faster</td>
<td>Slightly faster</td>
</tr>
<tr>
<td>Anti-aliasing:</td>
<td>none</td>
<td>n.a.</td>
<td>Slightly faster</td>
<td>Slightly faster</td>
</tr>
<tr>
<td>Feature</td>
<td>Default</td>
<td>Description</td>
<td>Faster</td>
<td>Slightly faster</td>
</tr>
<tr>
<td>----------------------------------------------</td>
<td>---------</td>
<td>---------------------</td>
<td>--------</td>
<td>-----------------</td>
</tr>
<tr>
<td>Verification on rebuild</td>
<td>Unchecked</td>
<td>n.a.</td>
<td>Faster</td>
<td>n.a.</td>
</tr>
<tr>
<td>Transparency high quality for normal view mode</td>
<td>Unchecked</td>
<td>n.a.</td>
<td>Slightly faster</td>
<td>Slightly faster</td>
</tr>
<tr>
<td>Transparency high quality for dynamic view mode</td>
<td>Unchecked</td>
<td>n.a.</td>
<td>Slightly faster</td>
<td>Slightly faster</td>
</tr>
<tr>
<td>Level of detail</td>
<td>Off</td>
<td>Slightly faster</td>
<td>Faster</td>
<td>n.a.</td>
</tr>
<tr>
<td>Automatically load components lightweight</td>
<td>Checked</td>
<td>Slightly faster</td>
<td>Faster</td>
<td>Slightly faster</td>
</tr>
<tr>
<td>Check out-of-date lightweight components</td>
<td>Indicate</td>
<td>Faster</td>
<td>Faster</td>
<td>n.a.</td>
</tr>
<tr>
<td>Resolve lightweight components</td>
<td>Prompt</td>
<td>Faster</td>
<td>Faster</td>
<td>n.a.</td>
</tr>
<tr>
<td>Rebuild assembly on load</td>
<td>Prompt</td>
<td>Faster</td>
<td>Faster</td>
<td>n.a.</td>
</tr>
<tr>
<td>Mate animation speed</td>
<td>Off</td>
<td>Slightly faster</td>
<td>Faster</td>
<td>Slightly faster</td>
</tr>
<tr>
<td>Purge cached configuration data</td>
<td>Checked</td>
<td>n.a.</td>
<td>Slightly faster</td>
<td>Faster</td>
</tr>
<tr>
<td>Update mass properties</td>
<td>Unchecked</td>
<td>n.a.</td>
<td>Slightly faster</td>
<td>Faster</td>
</tr>
<tr>
<td>Use shaded preview</td>
<td>Checked</td>
<td>Slightly faster</td>
<td>Faster</td>
<td>Slightly faster</td>
</tr>
<tr>
<td>Use software OpenGL</td>
<td>Unchecked</td>
<td>Much faster</td>
<td>Much faster</td>
<td>Much faster</td>
</tr>
<tr>
<td>No preview during open</td>
<td>Checked</td>
<td>Faster</td>
<td>Faster</td>
<td>n.a.</td>
</tr>
<tr>
<td>Magnetic mate pre-alignment</td>
<td>Checked</td>
<td>n.a.</td>
<td>Slightly faster</td>
<td>Faster</td>
</tr>
</tbody>
</table>

System options => Assemblies

<table>
<thead>
<tr>
<th>Feature</th>
<th>Default</th>
<th>Description</th>
<th>Faster</th>
<th>Slightly faster</th>
<th>Much faster</th>
<th>Much faster</th>
<th>Much faster</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use large assembly mode</td>
<td>Checked</td>
<td>Faster</td>
<td>Faster</td>
<td>Faster</td>
<td>Faster</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Do not save auto-recover info</td>
<td>Checked</td>
<td>n.a.</td>
<td>Slightly faster</td>
<td>Faster</td>
<td>Faster</td>
<td>Faster</td>
<td>Faster</td>
</tr>
</tbody>
</table>

Screenshot from SW2018. The sliders are somewhere in the middle for convenience by balancing between speed and user friendliness.
## SOLIDWORKS

<table>
<thead>
<tr>
<th>Hide all planes, axis, sketches, curves,...</th>
<th>Checked</th>
<th>n.a.</th>
<th>Slightly faster</th>
<th>Slightly faster</th>
</tr>
</thead>
<tbody>
<tr>
<td>Do not display edges in shaded mode</td>
<td>Checked</td>
<td>n.a.</td>
<td>Slightly faster</td>
<td>Slightly faster</td>
</tr>
<tr>
<td>Do not rebuild when switching to assembly...</td>
<td>Checked</td>
<td>n.a.</td>
<td>Slightly faster</td>
<td>Slightly faster</td>
</tr>
<tr>
<td>Envelope: Automatically load lightweight</td>
<td>Checked</td>
<td>Slightly faster</td>
<td>n.a.</td>
<td>Slightly faster</td>
</tr>
</tbody>
</table>

### System options => External references

<table>
<thead>
<tr>
<th>Load referenced documents</th>
<th>Prompt</th>
<th>Faster</th>
<th>n.a.</th>
<th>n.a.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search file locations for external references</td>
<td>Uncheck</td>
<td>Faster</td>
<td>n.a.</td>
<td>n.a.</td>
</tr>
</tbody>
</table>

### System options => FeatureManager

| Use transparent flyout FeatureManager tree | Uncheck | n.a. | Slightly faster | n.a. |

### System options => View

| Zoom to fit when changing.. | Uncheck | n.a. | Slightly faster | n.a. |
| View transition | Off | n.a. | Slightly faster | n.a. |
| Hide/show component | Off | n.a. | Slightly faster | n.a. |
| Isolate | Off | n.a. | Slightly faster | n.a. |
| View selector | Off | n.a. | Slightly faster | n.a. |

### System options => Search

| Index only when ...idle | Checked | Slightly faster | n.a. | n.a. |
| Always index | Unchecked | Slightly faster | n.a. | n.a. |

### Document settings:

<table>
<thead>
<tr>
<th>Option</th>
<th>Setting</th>
<th>Loading/opening the model or drawing</th>
<th>Editing the model or drawing</th>
<th>Rebuilding time of the model or drawing</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shaded and draft quality HLR/HLV</td>
<td>Low</td>
<td>Much faster (smaller files)</td>
<td>Much faster</td>
<td>Much faster</td>
</tr>
<tr>
<td>Optimize edge length...</td>
<td>Unchecked</td>
<td>Faster</td>
<td>Faster</td>
<td>Slightly faster</td>
</tr>
<tr>
<td>Save tessellation with ... (1)</td>
<td>Slower</td>
<td>Faster</td>
<td>Slower</td>
<td></td>
</tr>
<tr>
<td>Wireframe and high quality HLR/HLV resolution</td>
<td>Low</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Actually these “Document settings” have the largest effect on performance speed, however when the sliders for “Shaded and draft quality and “Wireframe” are set somewhere in the middle, it is usually a good balance between speed and visual quality.

(1) Unchecking “Save tessellation..” will result in faster file-saving and smaller files but slower loading/opening of the file. For more convenience it is best to leave this setting as “Checked”.

7.3 Optimizing performance in “Large Assemblies”
Apart from the settings mentioned in the previous paragraph (System options => Assemblies), there are some additional remarks for optimizing the performance of large assemblies.

**Mates**
Mates in the main-Assembly slow down the total performance. If you have >150 mates, than you can improve performance by putting the parts with many mates in a sub-Assembly.
Use faces for mating screws and nuts, not axis!!
Avoid advanced- and mechanical-mates when possible.
Do not mate to extrude- or cut-features which were created in the Assembly.

**Fasteners and Threads**
Use simplified- or cosmetic-threads for fasteners.
Use the “Hole series” Assembly-Feature to create holes in multiple components.
Lightweight-mode and Large assembly-mode
Open the large Assembly in “lightweight-mode” or “large Assembly-mode”.
File => Open => click on a part or Assembly and you get this menu:

In “lightweight-mode” only a subset of its model-data is loaded in memory. The remaining model-data is loaded on an as-needed basis.

When a component is lightweight, a feather appears on the component icon in the FeatureManager design tree.

If you want to change the lightweight-component to normal (resolved) than RMB on the lightweight component in the Feature tree and click “Set to resolved”.

“Large Assembly Mode” is a collection of system settings that improves the performance of assemblies. You can turn on Large Assembly Mode at any time, or you can set a threshold for the number of components (default = 500), and have Large Assembly Mode turn on automatically when that threshold is reached. To turn Large Assembly Mode on or off:

Click Large Assembly Mode (Assembly toolbar) or Tools => Large Assembly Mode.

Display states vs Configurations
Configurations always need a rebuild after editing and Display states not. So if you only need to hide or show components doing this by Display states is faster.

Some examples of a Socket Head Cap Screw M16x60mm in a pattern of 20x20 in a Part file.

<table>
<thead>
<tr>
<th>Thread:</th>
<th>No thread</th>
<th>Cosmetic thread</th>
<th>Real thread</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Image Quality slider set in the middle.</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Part rebuild time (1 body)</td>
<td>0.05 sec</td>
<td>0.06 sec</td>
<td>0.17 sec</td>
</tr>
<tr>
<td>Part rebuild time (20x20 pcs pattern)</td>
<td>0.50 sec</td>
<td>0.48 sec</td>
<td>0.83 sec</td>
</tr>
<tr>
<td>Part file size (1 body)</td>
<td>108 kB</td>
<td>160 kB</td>
<td>505 kB</td>
</tr>
<tr>
<td>Part file size (20x20 pcs pattern)</td>
<td>6.829 kB</td>
<td>7.358 kB</td>
<td>155.493 kB</td>
</tr>
<tr>
<td>Assembly with 20x20 pcs pattern; Open time:</td>
<td>0.12 sec</td>
<td>0.13 sec</td>
<td>1.24 sec</td>
</tr>
<tr>
<td>File-size:</td>
<td>307 kB</td>
<td>316 kB</td>
<td>733 kB</td>
</tr>
<tr>
<td>Triangles:</td>
<td>280.800</td>
<td>280.800</td>
<td>6.535.200</td>
</tr>
<tr>
<td><strong>Image Quality slider set to the left.</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Part rebuild time (1 body)</td>
<td>0.05 sec</td>
<td>0.05 sec</td>
<td>0.17 sec</td>
</tr>
<tr>
<td>Part rebuild time (20x20 pcs pattern)</td>
<td>0.50 sec</td>
<td>0.50 sec</td>
<td>0.83 sec</td>
</tr>
</tbody>
</table>

Solidworks - Hints, Tips, Tricks and Best Practices – 3rd edition
**Conclusions:**
The model with cosmetic thread has slightly larger file size and is slightly slower than the model with no thread.
“Real thread” is no option because it has extremely large file size (many triangles) and is very slow.
Patterning a Component in the Assembly is faster than in the Part-environment and also give smaller files. **The “Image quality slider” has the largest effect on performance speed and on file-size** in the Part-environment, but not so much in the Assembly-environment. Unfortunately when the slider is completely to the left, Parts or components can look very ugly and sometimes the appearance is also changed; see the 3 pictures in the top-row of the table above.
When the pattern in the Assembly is increased to 200x20 components, Solidworks opens the model automatically in Large Assembly-mode, and even with 4000 fasteners it is no problem to load, edit and save the model.
Using the Freeze bar can help in the Part-environment because the model is not rebuilding each time after editing or adding features.
From experiences, I can also tell that saving a model with the “save As…” command can reduce file size very much (I did not use this with the models in the table above).
8.1 **Creating a “virtual sharp” in a Drawing**
Select the 2 lines which can cross each other virtually, and sketch a point there.
This is actually the same method as used in Sketches.

8.2 **1st Angle vs 3rd Angle Projection in Drawings**
If the Projected View command creates a Top view of your Part below the Front view instead of above it, you are probably experiencing 1st Angle Projection (default in DIN and ISO standards) which is used in Europe (excl. U.K.) and Asia.
3rd Angle Projection is default in ANSI, ASME and BSI standards and is more common in the U.K, USA, Canada and Australia.
This setting is found in the Sheet Property settings.
To change it, right-click on the Drawing sheet and choose Properties. You will see a radio button where you can switch from 1st Angle Projection to 3rd Angle Projection.
You should now use Save As to save a corrected version of your Drawing Template (see other tech tip above), since the 3rd Angle Projection setting depends on the settings of the Drawing Template for new Drawing files.

8.3 **Inserting Surfaces in Solidworks Drawing Views.**
Surfaces do not appear in Solidworks Drawing views by default.
When used as reference geometry, surfaces are usually not required in a production Drawing. However, when the entire model or some of its elements are designed as surface bodies, the Drawing is incomplete if surfaces are not displayed.
Surface bodies can be inserted in Drawing views as model items:
**Insert => Model Items => Reference Geometry => Surfaces.**
In the Source/Destination section, the source can be selected as entire model or a Feature, and the import can be applied to all or selected views.

8.4 **Align the Drawing view by an edge of the model.**
The easiest method is a command that is rather hidden in the “Tools” menu.
**Select first** the edge you want use for alignment in the model.
Tools => Align Drawing view => Horizontal Edge.

Another slightly more complicated method is by creating a named view (also called alternative view or saved view) for the Part or Assembly. Open the Part or Assembly

Click on a face you want to use.
Click the icon make Normal To.
Click on the View Toolbar
Pick the New View icon.

The Named View dialog box will appear (note: the model will revert to the view to be saved.) Enter the name for the new view in the View Name box. Hit OK. The named view is now also available in Drawings.

Important note:
Models which are not aligned with all 3 planes, cannot be fully aligned this way. Some extra steps are necessary.
Sketch a vertical or horizontal line in the view, and measure the angle between the new sketched line and the edge in the model view.
Rotate the view exactly with the same angle and delete the sketched line.

8.5 Create Notes with Multiple Leader Lines in Drawings

This is one of those functionalities in SolidWorks that is hiding in plain sight. There are no pull-down menus or dialog check-boxes to do this, because it uses the Windows Control-drag method.
First, click on the note to select it. When it highlights, you will see a square, green drag-handle at the end of the leader arrow. Place your cursor directly over this drag handle, hold down the Ctrl key, and drag and-drop a copy of the leader to a new location. Repeat this if you want more than two leaders.

8.6 Moving or copying dimensions from one view to another

You can copy dimensions from one view to another view with: Ctrl+ drag
You can move dimensions from one view to another view with: SHIFT+ drag
Sometimes it seems impossible to create a dimension in a child view (detail- or section view), especially with dimensions which should be foreshortened such as in large flanges with a small groove.
Solidworks support foreshortened dimensions since a few years in Section Views and Detail Views, however it is one of the most user unfriendly Features.
Flange with a small groove of 10mm x 30mm and an inner diameter of 1500mm.
The 1500mm dimension can be easily applied to the Front- and Half-section view, but not to the Detail view.
For the Half-section view the dimension could be applied after switching to “Hidden Lines Visible”.

The dimension 1500mm can be applied to the Detail view as follows:
Set the Half-section view in the “Hidden Lines Visible” mode.
Drag the detail-circle “B” outwards to a larger diameter until it shows the full Part in the detail view.
Now you can apply the 1500mm dimension in the Detail view, but not foreshortened!
Drag the detail-circle “B” inwards until it is back in its original diameter.

To get the foreshortened dimension correctly in the Detail-view, some different (not user friendly) steps are neccessary:
The dimension “1500mm” must be present in the model! If the model is already “fully defined” you can add it as a “driven dimension”.

Import all dimensions in the Front-view by: clicking on the icon “Model items”; source = Entire model, Destination view(s) = Front view, Dimensions = Marked for Drawing + Not marked for Drawing, eliminate duplicates => OK.

Delete all unnecessary dimensions in the Front-view.

Now you can Ctrl+drag the dimension of 1500mm to the Half-section View and the Detail-View.

In the Detail-View RMB on the dimension => “Display options” => “Foreshortened”.

If you Ctrl+drag the 1500mm dimension from the Half-section view directly to the Detail-view, the dimension is automatically foreshortened.

This isn’t all, because depending on your company standards you maybe want the foreshortened dimension with a zig-zag leader.

Tools => Options => Dimensions => Diameter

Now you can uncheck “Automatic” and select the button for the zig-zag leader.

8.7 Color of Drawing items like Lines and Dimensions

The color of Drawing items is controlled by the “Line format Toolbar” and the “Drawing Layer”.

The color setting in the Line Format Toolbar is overriding the color-setting in the Drawing Layer!

If you can not change the color of your dimension with the Drawing layer color, you have also to change your setting in the Line Format Toolbar to “Default” and than the color will change to your Layer color.
8.8 Dimensioning the “Arc Length” in a Drawing view

1. Select one end point of the arc.
2. Select the other end point of the arc.
3. Select the arc itself.

The order of clicks is important!

8.9 Timesaving by “reusing” Drawings of similar Parts

1. **Open the original Drawing.** This will be the Drawing that has the original Part. Make sure the Part is fully dimensioned and you have all the views you need.
2. **Save As... a new Drawing.** Save the Drawing with a new name to the location where you need it.
3. **Close the Drawing.** Close down the Drawing after you have saved it.
4. **Open the Drawing.** Here’s the trick. Go to File, Open..., but before you actually open it, select References... down by all the check boxes.
5. **Replace the reference.** Double-click on the original Part that is shown, then select the other Part you need to detail. Hit Open, then OK and open up the Drawing.

You should see your Part change and you may need to move some dimensions, but you just saved a load of time by not re-creating the Drawing all over again and again. Save your Drawing and do it the same for the others.

**Other Applications.**

You can also do this if you need to add more Parts on a single Drawing. After you do the above process, select all the views of the new Part, Copy (Ctrl-C) them, create a new sheet in your original Drawing and Paste (Ctrl-V) the views to get them on the sheet. You can also use this for more complicated Parts and Assemblies. This reinforces how important it is to use a standard method of creating Parts, Assemblies and Drawings.
### 8.10 Timesaving with “automatic dimensioning”

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Insert the Model Items into the Drawing. Set source = Entire model Check button “Import items into all views”</td>
</tr>
<tr>
<td>2</td>
<td>Once they are inserted, they are being placed accordingly to their position in the model, which is to say pretty random.</td>
</tr>
<tr>
<td>3</td>
<td>Let’s select all these dimensions with a window (feel free to use the F5 shortcut key to access the dimension filter):</td>
</tr>
<tr>
<td></td>
<td>![Dimension Filter Image]</td>
</tr>
<tr>
<td>4</td>
<td>Once the dimensions are selected make sure you do not move your mouse too far. There is one very shy icon not too far from your cursor. Have you spotted it?</td>
</tr>
<tr>
<td>5</td>
<td>If by any change you moved your mouse and the icon disappeared, don’t be upset, it can be called back by pressing the &lt;Ctrl&gt; key on your keyboard. It will re-appear close to your cursor.</td>
</tr>
<tr>
<td>6</td>
<td>Now let’s select this Icon. It will expand into a mini toolbar: Magic! One click and most of my dimensions moved nicely in positions that make sense. Is SolidWorks reading my mind?</td>
</tr>
</tbody>
</table>

---

*Solidworks - Hints, Tips, Tricks and Best Practices – 3rd edition*
8.11 Auto arrange dimensions

Dimensioning a Drawing can be pretty messy as in the example to the right. To fix this in flash, SolidWorks introduced Auto Arrange Dimensions in the SW2011 release. This function will automatically arrange the selected dimensions for you. The procedure is as follows:

1. Box-select all of the dimensions.

2. Next, move the mouse pointer over the Dimension Palette rollover button to display the dimension palette. (Incidentally, if you mouse AWAY from the Dimension Palette rollover button, it will disappear. To get it back just hit the Ctrl button on your keyboard.)

3. On the Dimension Pallete, click Auto Arrange Dimensions in the lower left corner.

4. Click in the graphics area to turn off the Dimension Pallete – Easy!

5. When you use Auto Arrange Dimensions, the selected dimensions are placed as follows:
   - spaced from smallest to largest
   - aligned and centered, if possible
   - spaced with the offset distances defined in Document Properties => Dimensions
   - adjusted to avoid overlapping
   - staggered, if necessary
8.12 Inserting chamfer dimensions into a Drawing

1. Click Chamfer Dimension \[ \text{Chamfer Dimension} \] on the Dimensions/Relations toolbar or click Tools > Dimensions > Chamfer. The pointer changes to \[ \text{Chamfer Dimension} \].

2. Select the chamfered edge, select one of the lead-in edges, and then click in the graphics area to place the dimension. You must select the chamfered edge first. However, the dimension does not appear until you subsequently select one of the lead-in edges. Use rapid dimensioning to place evenly spaced dimensions. Alternatively, move the pointer outside of the rapid dimension selector to place the dimension. The Dimension PropertyManager appears, and the tool remains active for you to dimension other chamfers.

3. Click \[ \text{OK} \].

8.13 Create an annotation with multiple arrows

1. Create a normal annotation with one arrow first.
2. Click on the annotation to highlight it, then click on the blue box at the end of the arrow point while holding down Ctrl and drag to the new location.

8.14 Create multiple instances of annotations

1. Click the appropriate tool from the Annotations toolbar, or click Insert, Annotations and select a tool from the menu.
2. Type in text and select options in the PropertyManager or dialog box.
3. With the PropertyManager or dialog box still open, click in the graphics area to place the annotation.
4. Click as many times as necessary if you need to place multiple copies.
5. If the annotation has a leader, click to place the leader, then click again to place the annotation.
6. You can change text and other items in the PropertyManager or dialog box for each instance of the annotation.
7. Click OK \[ \text{OK} \].
8.15 Center marks

There are several ways to apply centermarks at circular entities.

**Manually (one by one)**

Select a circular entity.
Click in the TAB “Annotations” on the icon

You can apply some special settings like “Extended lines” and “Angle”.

Do not set the “Layer” setting to “None”.

**Automatic propagation of one Center Mark**

Select a circular entity.
Click the icon “Center Mark”
Click on the small “square arrow icon”.
This icon appears only when the holes are created with the linear- or circular Sketch-pattern or Feature-pattern. It does not work when multiple holes are made with the Extruded-cut Feature.

All instances of the circular entities have “Center Marks” now and have a correct rotation.
**Center Mark for all holes in a view**

Select a **Drawing view only** by clicking on the dashed orange rectangle surrounding a Drawing view. Click the icon “Center Mark”. Checkmark “For all holes” in the Auto Insert menu. Click OK.

Do not set the “Layer” setting to “None”.

**Center Marks automatically in a new Drawing view**

This is probably the best method for automatic creation of “Center Marks”. You have to checkmark “Center marks-holes -Part” and or “Center marks-holes -Assembly” in Options => Document properties => Detailing. Set the checkmark in the “Auto insert on view creation” section. The will automatically create the “Center Marks” when you insert a new Drawing view.

**Deleting of Center Marks**

Deleting of “Center Marks” can be done manually one by one or automatically. For automatic deletion; click on one of the entities of the Center Marks and RMB, click “Select Center Mark Set” and press the “Delete” button.

### 8.16 Changing the fontsize of the roughness symbol

Sometimes the roughness-symbol and the roughness-value appears too large in the Drawing view. This is because by default the fontsize of Annotations like the roughness-symbol is linked to the Drawing standard and also to the Document settings of your Drawing.

You can unlink it with the Format menu by unchecking “Use document font”. After unlinking you can change the font and fontsize.

### 8.17 Foreshortened dimensions

To have a foreshortened diameter dimension, the diameter being dimensioned will have to be cut off in the view. Since SW2016, Foreshortened dimensions, are supported for all Views. You can simply select an edge in a detail view created from either a Standard- or Section view and it will become foreshortened automatically. If you need to select other edges that are initially not visible, you can expand the detail view circle, add the dimension and reduce the detail circle, then right-click the dimension on the side you need foreshortened and select **Display Options > Foreshorten**.
For SW2015 and older versions, it requires some more work to do to get this done in Section Views. (For the Standard View this is easy: click dimension => RMB => Display Options => Foreshortened). To employ a foreshortened diameter dimension in a Section-view, there is some preparation needed within the model. You cannot just insert your model into a Drawing and add a non-imported dimension onto a circular Feature. Because of the way Hole Wizard functions, foreshortening will also not work for holes created with it. SolidWorks only enables this function for imported dimensions (dimensions inserted from model).

To create foreshortened dimensions in Drawings in Detail-Views, see also chapter 8.6

<table>
<thead>
<tr>
<th></th>
<th>Create a detail view which cuts across a circular Feature.</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>If the center of the circle appears in the detail, select the detail view by LMB clicking it. If the center does not appear in the detail, then select the parent view instead.</td>
</tr>
<tr>
<td>3</td>
<td>Insert model items. This can be done by Insert pulldown &gt; Model Items. One of the dimensions to appear will be the diameter of the circular Feature.</td>
</tr>
<tr>
<td>4</td>
<td>Click OK in the PropertyManager Pane to accept and close Model Items panel. If already in the detail view, you are done. The dimension will appear as a foreshortened linear diameter dimension. However, if working in the parent view, a few more steps are required to get the desired effect.</td>
</tr>
<tr>
<td>5</td>
<td>Hold down the SHIFT key. Select the diameter dimension by clicking and hold the LMB over it.</td>
</tr>
<tr>
<td>6</td>
<td>Drag the dimension in the detail view. Let go of the LMB and SHIFT key. This will copy your dimension into the detail view. The dimension will appear as a foreshortened linear diameter dimension.</td>
</tr>
<tr>
<td>7</td>
<td>Delete the dimension from the parent view.</td>
</tr>
</tbody>
</table>

There are some limitations; tapered, cylindrical or curved surfaces won’t work. It needs to be a straight cylinder.

### 8.18 Dual dimensions e.g. mm and inches.

When you usually dimension in mm and want the same dimension also in inches, then click on the dimension in the Drawing. At the bottom of the Dimension-menu click Dual Dimension. The length in inches is then added in brackets [ ].
8.19 **Section views**

Solidworks has a few different types of Section Views.
- Standard Section views (see 8.19.1).
- Half-section view (see 8.19.2), which is very suitable for rotational symmetric Parts.
- Broken-Out section view (see 8.19.3), which cuts away a portion, to expose the inside.
- Foreshortened section views (see 8.19.4).

**Special note:**
According to most Drawing standards, some Parts are not cut and therefore also not hatched in section views. These Parts are:
- Webs, ribs
- Shafts
- Fasteners (bolts, nuts, screws, washers)
- Rivets
- Keys
- Pins

General rule: when the cutting plane passes through the centre of these Parts, they should not be sectioned but they are shown in outside view.

In the “Drawing View Properties” menu, click on the TAB “Section Scope” and checkmark the Exclude fasteners option.

How does Solidworks know that your Part is a Fastener?
Well, you have tell this to Solidworks by creating a Custom Property with the name “IsFastener” in the Part. The Type of Property should be “Text” and the value should be “1”.

You can also mark the checkbox “Show excluded Fasteners” and click on the Parts you want to exclude from being sectioned in the Drawing view.

8.19.1 **Section view on specific positions:**
Create sketch in the view. This maybe more than one line, and may also contain angles. Select all the sketch elements.
Select “Section view”.

8.19.2 **Half-section view**
Half-section view are often used for rotation-symmetric Parts.
Usually the top side is the view to the cutted surface which has to be hatched.
The bottom side of the half-section view, is the view from the non-cutted side.

Click on the view which has to be cutted.

In the TAB “View Layout” click on the icon “Section View”.

Click on the button “Half Section”.

Select one of the Half Section options in the menu “Section View Assist”.

Drag the Assist lines to the centerpoint of your view and click there.

The Half-section view should be positioned “behind” the cutting plane.

For a half section view of the isometric view you need some extra steps.

First you have to create a half section view as described. Click on this half section view and RMB and select Isometric Section View.

The half section view will change in an Isometric Half Section View and you can edit it like a standard isometric view.
8.19.3 Create a Broken-Out section view

A broken-out section view cuts away a portion of an Assembly in a Drawing view, to expose the inside. Cross hatching is automatically generated on the sectioned faces of all components.

A broken-out section is not a separate view, but it is Part of an existing Drawing view. A closed profile, usually a spline, defines the broken-out section. Material is removed to a specified depth to expose inner details.

Specify the depth by setting a number or by selecting geometry in a Drawing view.

1. Click Broken-out Section (Drawing toolbar), or click: Insert => Drawing View => Broken-out Section.

2. The pointer changes to: If you want a profile other than a spline, create and select a closed profile before clicking the Broken-out Section tool. Sketch a profile.

3. Set options in the Section View dialog box. If you do not want to exclude components or fasteners from the broken-out section view, click OK.

4. Set options in the Broken-out Section PropertyManager. Use 3D Drawing view mode to select an obscured edge for the depth of a broken-out section view.

5. Click ✓.

Limitations:
- You cannot create a broken-out section on a detail-, section-, or alternate-position view.
- If you create a broken-out section of an exploded view, you cannot collapse the exploded view.
8.19.4 **The two types of Section Views with cutting lines explained**

Actually there are 2 types of section Views when a cutting lines are used for sectioning the cut. After the selection of the cutting lines and selecting => View Layout = Section View, Solidworks automatically asks which of the 2 types must be used: the Foreshortened Section View or the Standard Section View.

<table>
<thead>
<tr>
<th>Foreshortened Section View</th>
<th>Standard Section View</th>
</tr>
</thead>
<tbody>
<tr>
<td>(The red construction lines are not Part of any Drawing standard and are only for educational use) Note the difference of the horizontal dimension 100 in Section A-A and 120mm in Section B-B. In section B-B the total length of the cutting section is taken into account. It’s a small difference but important enough to be always checked when a cross section view is present in a Drawing.</td>
<td></td>
</tr>
</tbody>
</table>

8.19.5 **Alternate Position View**

Alternate Position Views indicate the range of motion of an assembly component by showing it in different positions. You can overlay one or more Alternate Position Views on the original view in a phantom font.

1. Insert a model view of the assembly using the orientation needed for the Alternate Position View. Position the assembly in its starting position.

2. Click Alternate Position View (Drawing toolbar), or click Insert => Drawing View => Alternate Position. The Alternate Position PropertyManager appears. You are prompted to select a drawing view in which to insert the alternate position.

3. Choose an existing Configuration or a new Configuration
8.20 Working with hatches

When working with black and white hatches, it is best to change some settings for more flexibility in changing hatches:

- Uncheck: “Auto hatching”
- Uncheck: Material crosshatch
- Apply to: Region
- Type of hatch: as you like
- Scale: as you like
- Angle: as you like
- Use: shaded with edges
- Use: Draft quality

- Uncheck: Surface Bodies

Do a full rebuild by hitting Ctrl + Q to make all changes effective and visible.

Note:
Even with these settings as outlined above, the hatches on cross-section Views, do not always work correctly in SW2015.
Tip:
When a hatch cannot be changed or deleted, it is probably on a wrong layer.
Hatches in Cross section views are by default placed on Layer “None” !!!
Click on the hatched area and check your layer settings.
To activate the Layers toolbar click; View => Toolbars => Layer

8.21 Create colored hatches in Drawings
By default, hatched lines and solids in Drawing views are black on screens and pdf-documents.
You can change the color of the lines or fill with the “Line Format” toolbar.
First make the “Line Format” toolbar visible by clicking: View => Toolbars => Lines format.
Select the hatch and click the Line icon in the “Line Format” toolbar.

The solid hatch color will override Part and component (Assembly) appearances.

8.22 Create a watermark in a Drawing
Right click on the Drawing and select “Edit Sheet Format” and then insert your note. At this point while your note is still selected you can see under the “Text Format” section of the property manager there is an option called “Behind sheet”. This option instructs SOLIDWORKS to display the annotation note behind Drawing objects.
Check the box and then right-click on the Drawing sheet again and this time select “Edit sheet”. Now you can see that SOLIDWORKS has moved the note behind your view and as a result it is no longer covering the lines and dimensions in your view.

8.23 Inserting a Block in a Drawing
Insert => Annotations => Block, and browse to your block file.

8.24 Perspective View on a Drawing
The icon that changes display mode to “Perspective” within Parts and Assemblies is not available within the Drawing environment, however it is possible to place a perspective view into a Drawing. To show a Drawing view with perspective (so the Part appears tapered toward a vanishing point on the horizon), you need to create a custom view in the model file (Part or Assembly).
1. Open the model.
2. Go to View => Display => Perspective.
3. Zoom/Pan/Rotate to position the model as you wish.
4. Hit the spacebar to bring up the View Orientation dialog box.
5. Click the icon that looks like a blue telescope with an orange starburst behind it. This allows you to save the current view settings in the file. Type in a name for your custom view.
6. Create or open a Drawing of the Part/Assembly.
7. Choose Insert => Drawing View => Model View, and choose your custom view name from the list of possible views to place on the sheet.
8.25 **Change the orientation of a dimension of an isometric view.**
Click on the dimension to be changed.
RMB => Display Options => Change plane (The Change Plane option is not always visible/possible.)

8.26 **Create a custom view in a Part or Assembly for using in a Drawing.**
1. Press the SPACE bar to see all possible orientation views.
2. Click the icon “New view”
3. Give the new view a name, and the new view is selectable when you hit the SPACE bar.
4. The view can also be selected for editing when you hit the SPACE bar.
5. This view can now also be selected in Drawings.

8.27 **Inserting “End Treatment” Symbols in Drawing Documents**
To automatically insert “end treatment” symbols in Drawing documents:
1. Click Model Items (Annotation toolbar) or Insert, Model Items and under Annotations, select End Treatment.
2. To open the “End Treatment” Property-manager:
3. In a Drawing document, click on the “End Treatment” icon (Annotation toolbar) or Insert > Annotations => End Treatment.

8.28 **Defining a thread callout in a Drawing**
First check the settings:
Menu => Tools => Options.
In the “Document Properties” tab, there is “Detailing” on the left box.
Click “Detailing” and find “shaded cosmetic threads” in “display category”. Check the option.
1. Go to a circular item in a Drawing.
2. Move your mouse pointer on the cosmetic thread line until the circular edge is highlighted with the text description of the cosmetic thread.
3. Click right mouse button and select “Insert Callout”.
4. The Drawing shows now the thread callout which was previously defined in the cosmetic tread on a circular surface of a Part-model.
Tip:
It is easier to create holes with the Hole Wizard and apply the Cosmetic Thread option inside the Hole Wizard. In this case the correct settings for the diameter and thread depth are automatically applied in the Drawing and can be made easy visible with the standard Annotations.
8.29 **Show a model's sketch in the Drawing.**

In the Feature Tree of your Drawing find the view you want to show the sketch in, expand the model and find the sketch. RMB select “show” and then make sure you have “sketches set as visible” in your View settings for the document.

Showing the sketch isn’t always the best way to go. Sometimes you don’t need the whole sketch. An alternative solution is to make the sketch visible, then use Convert Entities in the Drawing to put curves on the Drawing view. After that, you can turn the model sketch off again.

8.30 **BOM tables or BOM-lists**

BOM-tables (Bill Of Materials) are generally used in Assembly Drawings and show a list of Parts in the Assembly with additional info such as; description, Part number, quantity or weight.

The default BOM-table has filename: “bom-standard.sldbomtbt”.

The default BOM-table has column names: ITEM NO., PART NUMBER, DESCRIPTION and QTY.

The “PART NUMBER” column is by default linked to the filename:

The column “DESCRIPTION” is by default linked to nothing.

The default BOM looks like the picture below and is rather useless.

<table>
<thead>
<tr>
<th>ITEM NO.</th>
<th>PART NUMBER</th>
<th>DESCRIPTION</th>
<th>QTY.</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>200 Top</td>
<td></td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>210 Frontleg</td>
<td></td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>210 Frontleg</td>
<td></td>
<td>1</td>
</tr>
<tr>
<td>4</td>
<td>220 Backleg</td>
<td></td>
<td>1</td>
</tr>
<tr>
<td>5</td>
<td>220 Backleg</td>
<td></td>
<td>1</td>
</tr>
<tr>
<td>6</td>
<td>230 Backpanel</td>
<td></td>
<td>1</td>
</tr>
<tr>
<td>7</td>
<td>240 Bottompanel</td>
<td></td>
<td>1</td>
</tr>
<tr>
<td>8</td>
<td>250 Sidepanel</td>
<td></td>
<td>1</td>
</tr>
<tr>
<td>9</td>
<td>250 Sidepanel</td>
<td></td>
<td>1</td>
</tr>
</tbody>
</table>

It is also possible to create a BOM-list based on an Excel sheet, but this is not recommended because the table behaves strangely very often.

8.30.1 **General tips for BOM tables**

Avoid Manual Editing

The SolidWorks BOM is automated completely…. or should be! There’s no reason to add something manually. You can go beyond the standard Quantity, Part Number and Description columns in your BOM by adding some Custom Properties to your Component.

1. Open the Part.
2. Go to File => Properties.
3. Hit the “Custom” tab and enter “Property Name”, Type and Value. Hit OK.
4. In your Drawing. Right click on a column and select Insert => Column left/right or select right above the column you want to change.
5. Choose Custom Property and scroll down to select your new property.

Avoid Reference Parts showing in the BOM.

It’s sometimes very tempting to right-click on a row and select Delete or Hide for a Part or sub-Assembly that is for reference only. Don’t do that. There’s a better way.

<table>
<thead>
<tr>
<th></th>
<th>Open your Assembly</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Right-click on the Part and select Component Properties.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>3</td>
<td>This is the most right icon:</td>
</tr>
<tr>
<td>4</td>
<td>On the bottom right, select “Exclude from bill of materials”</td>
</tr>
</tbody>
</table>

**Avoid the Configuration Name in the BOM**

If you have one configuration showing, you don’t need the name to show in the BOM Quantity Column. It’s just silly. To get this changed setting working, you’ll have to re-insert your BOM. Also, you’ll want to check this setting when creating new Drawing templates. It will store it so you don’t have to keep changing it.

1. Go to Tools Options
2. Select the Document Properties Tab
3. Select the Tables section under Detailing
4. Check the Restrict top level only BOMs to one configuration option

**Avoid a disorganized BOM.**

Most of the time we insert a BOM and we go on with the default settings, but one of those can lead to a disorganized BOM. There’s an option that will make your BOM match how you have items listed in your model’s FeatureManager. You have to have a table already created to access this options.

1. Right-click on the table and select Properties...
2. In the Item Numbers section select “Follow Assembly Order”.

**Avoid ridiculously large column widths in the BOM table**

Sometimes the column width makes the BOM span an entire paper width. It is very simple to shrink the column widths and have your BOM looking nice: double-click the right edge of a Column.

**Open a Part from the BOM for editing:**

While working in a Drawing with a BOM, there are many times you want to open a Part while working. Solidworx has made this very easy, especially if the Part we need is not seen in the Drawing directly (internal Part). From the BOM right click on the Part you want/need to open and choose the Open option.
8.30.2 Adding Equations (formulas) to the BOM.
You can add easily simple calculations in the BOM list e.g. multiplication of column E (QTY) and F (Cost) = G (totalcost).

Select header of column G by clicking on it.
Select the “Equation”-symbol from the context menu.
Edit the Equation: ‘Cost’ * ‘QTY.’{3} by selecting these Columns. {3} is the number of decimals defined in “Precision”.
Click ✅.

The total of a column e.g. total of column G (totalcost) can be calculated by inserting an extra row at the bottom of the list (click on last row => Insert => Row below).

Select the cell in the empty row below column G by clicking on it.
Select the “Equation”-symbol from the context menu.
Select as a Function: “Total”
Click ✅.

8.30.3 Showing the BOM on a Drawing of a Multibody Part
This is requires much more actions than an Assembly-BOM, so you can consider this as a rather complicated workaround.

1. Open the Multibody Part.
2. Click on Weldment on Weldment toolbar or Insert => Weldments => Weldment.
3. This will convert the Part into a weldment-multibody Part and will add a cut list.
4. RMB on the cut list and select update. This will update the cut list.
5. RMB on cut list item 1 and select “Properties”.
6. You may see the “Material” property there. If you need you can assign a different material to each body. For this, expand the cut list and right-click on the body. Select “Material” and then select the material you want to set.
7. Go back to cut list item 1 properties (as in step 5)
8. You can see the updated material property. Add a new property named “Description” and add value as Plate. You can add any value as per need.
9. Switch to Cut list item 2 and also add the description property. We’ll not change the material here.
10. Click “OK” at the bottom of the cut list properties window to close and apply the settings/changes.
11. Save your file.
12. Now switch to Drawing mode and insert a view.
13. Right click on view or sheet and select Tables > Weldment Cut list or Insert > Tables > **Weldment Cut list**.

14. If you haven’t selected a view, you will be prompted to select a view. To select, simple click on the view.

15. The Weldment cut list property manager will appear.

16. Set the cut list template and choose any specific configuration if you need.

17. Finally click on OK and place the cut list at the appropriate place or if you want to set the position use anchor.

### 8.30.4 Hiding or showing rows or columns in a BOM-table.

1. Click the table. The table toolbar appears:
   ![Click Hide/Show](image)

2. The pointer changes to:
   - Click row numbers to select rows to hide. Click a row twice to clear selection.

3. Click column headings to select columns to hide.

4. Click Hide/Show to hide the selected rows and columns.

   ![BOM table](image)

<table>
<thead>
<tr>
<th>ITEM NO.</th>
<th>PART NUMBER</th>
<th>DESCRIPTION</th>
<th>QTY.</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Center</td>
<td></td>
<td>1</td>
</tr>
<tr>
<td>4</td>
<td>End Cap</td>
<td></td>
<td>2</td>
</tr>
<tr>
<td>5</td>
<td>Arrow</td>
<td>Foam with 3 fins</td>
<td>3</td>
</tr>
<tr>
<td>6</td>
<td>Adhesive</td>
<td></td>
<td>1</td>
</tr>
</tbody>
</table>

   Note that the BOM-items are not renumbered after hiding some rows.

   The above method is easy, but it is not always the best way to hide some Parts or Components.

   A better method for hiding Parts or Components in the BOM is:
   - Open the Assembly file and select the Part/Component to hide.
   - RMB and click the icon “Component Properties...” in the right upper corner of the popup.
   - In the next menu you can check the checkbox “Exclude from bill of materials”.
   - The BOM-items are in adjacent order!

### 8.30.5 Editing the column “Description” of a BOM table

The “Description” field in the default BOM is automatically populated by the value of a custom property. This Custom Property is defined in each Part or Assembly being referenced by the Bill of Materials. As a result of this relationship, you can double-click one of the description entries and you’ll see a warning message indicating that you are about to break a parametric link. The proper way of editing a Part or Assembly’s Description is to edit its custom properties. (File => Properties => Tab “Custom”).

Solidworks - Hints, Tips, Tricks and Best Practices – 3rd edition
8.30.6 Rounding of dimensions or values in the Cut List or BOM

Rounding individual dimensions in Drawing tables is rather complicated.

The example shows a BOM with a custom property “weight [kg]” with 3 decimals; 95.689

Rounding of values in the BOM is probably one of those hidden Features you hardly can find out yourself because it does not feel very logically.

If you want the value to be rounded to 1 decimal, you have to use an equation with a function for precision. \{1\}1*’weight [kg]’.

Note that the function for precision comes first in the equation. After that you have to multiply the custom property with 1.
### 8.30.7 Rounding a value of a linked annotation in a Drawing

The number of decimals is controlled by the Document Settings. But when you want to round a specific value of a linked Annotation to less decimals, than there is no formula for directly doing this.

For example the number of decimals is set to 2 of a Drawing document, and you want to put the weight of a component without decimals in a linked Annotation of the Drawing.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Create an Equation in the Part-or Assembly-file shown in the Drawing View.</td>
</tr>
<tr>
<td>2</td>
<td>For the weight this can be:</td>
</tr>
<tr>
<td>3</td>
<td>Create a new custom property in the same Part- or Assembly-document which is referencing the new Equation.</td>
</tr>
<tr>
<td>4</td>
<td>In the Drawing-document you can now link the Annotation to the “rounded custom property”.</td>
</tr>
<tr>
<td>5</td>
<td>Note 1:</td>
</tr>
<tr>
<td></td>
<td>In this example the prerequisite is that in the Document properties for the Part- and the Drawing document, the unit for mass has to be customized to [kg].</td>
</tr>
<tr>
<td>6</td>
<td>Note 2:</td>
</tr>
<tr>
<td></td>
<td>The number of decimals in the Equation and Custom property only override the number of decimals set in the Document custom properties, if it is less than that.</td>
</tr>
</tbody>
</table>

### 8.30.8 Export or copy a BOM-list to Excel

This is not possible with a simple copy and paste command.

To export a BOM-list to Excel, click on the upper-left corner of the BOM-list.

In the popup-menu select “Save as” and select a filename and as the file type: Excel (*.xlsx)

After that, you can open the Excel file, and as you can see also the column width is identical as in the BOM-list.

Note: the Excel-file has no link to the Drawing-file and will not update automatically.
8.31 Drawings with suppressed and unsuppressed Parts

To have Drawing views with suppressed Parts, you must specify a different configuration to show the Part(s) suppressed and unsuppressed and then import the different named views into the Drawing. Open the Part- or Assembly file. To access its custom properties, click the File drop-down menu then select Properties. This brings up the Custom Properties window. You have two types of custom properties available, Custom and Configuration Specific. Custom properties are applied at the Part level, while Configuration Specific properties are, as the name indicates, specific to a single configuration of the Part. The Description property we are looking for is a Part-level property, found on the “Custom”. Update this field, and the BOM will automatically update.

Tip: if you want to show or hide some of the components of an Assembly, you simply click on this component in the Feature tree of the View and then RMB select “Show/Hide”.

8.32 Hiding and unhiding lines in Drawing views

The easiest way to hide individual lines in Drawing views is via the Line Format toolbar.

<table>
<thead>
<tr>
<th>View =&gt; Toolbars =&gt; Line Format.</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Now you can change the color and thickness and visibility of individual lines.</td>
<td></td>
</tr>
</tbody>
</table>

You can show the hidden lines again by selecting the view, click on the “Hide/Show edges” icon in the Line Format toolbar.

The hidden lines are shown by default in orange colour in the selected view. You can individually select the lines you want to unhide by clicking on them.

You can also use the filter in the “Hide/Show Edges” menu.

8.33 Drawing template vs Sheet Format

Many people get confused when it comes to creating custom Drawing Templates and Sheet Formats in Solidworks. It’s not as straightforward as Part and Assembly templates due to the fact that each sheet can have different sheet sizes and title blocks. Because of this extra detail, the information is split into two files. Understanding what information is contained in each file and how they interact with each other, is important to create a proper Drawing template.

It is important to understand that the Drawing Template (fonts etc.), is the parent file, and the Sheet format (title block etc.) is the child file.
<table>
<thead>
<tr>
<th>Drawing Template (xxxx.drwdot)</th>
<th>Sheet Format (xxxx.slddrt)</th>
</tr>
</thead>
<tbody>
<tr>
<td>All settings under: <strong>Tools =&gt; Options =&gt; Document Properties</strong> tab.</td>
<td>All information stored in Sheet Format ([RMB on Sheet =&gt; Edit Sheet Format]); this includes: sheet size, sheet-orientation, borders, titleblocks, layers, logos, etc.</td>
</tr>
<tr>
<td><strong>Drafting Standard</strong></td>
<td>All table anchors (BOM, Weldment Cut List, etc)</td>
</tr>
<tr>
<td>- Annotations</td>
<td></td>
</tr>
<tr>
<td>- Borders</td>
<td></td>
</tr>
<tr>
<td>- Dimensions</td>
<td></td>
</tr>
<tr>
<td>- Centerlines/Center Marks</td>
<td></td>
</tr>
<tr>
<td>It contains the units, drafting standard, font selections, arrow sizes and pre-defined views.</td>
<td></td>
</tr>
<tr>
<td>All existing sheets.</td>
<td>It contains the sheet size, sheet-orientation, borders, titleblocks, layers, logos, etc.</td>
</tr>
<tr>
<td>All sheet formats on existing sheets.</td>
<td></td>
</tr>
</tbody>
</table>

The default path for **Drawing Templates (xxxx.drwdot)** is:  
C:\ProgramData\SolidWorks\SOLIDWORKS xxxx\templates\.....  
The default path for **Sheet Format files (xxxx.slddrt)** is:  
C:\ProgramData\SolidWorks\SOLIDWORKS xxxx\lang\english\sheetformat\......

The link from the **Drawing template** to the **Sheet Format** file is somewhat hidden and is specified in Sheet Properties ([RMB => Properties]).

The **Sheet Format** (title block etc.) is saved within the **Drawing template** (fonts etc.), but if for some reason you need to change the Sheet Format of a Drawing, you RMB in a Drawing and go to properties and there you can browse to a different Sheet Format file and use that instead.

Do not use the default file locations for your custom templates, but create a path on a network which is also available for you coworkers.
The alternative file locations can be set in: **Tools => Options => System options => File Locations => Document Templates** for the Drawing Template (xxxx.drwdot), and **Tools => Options => System options => File Locations => Sheet Format** for the Sheet Format file (xxxx.slddrt).

A “**Drawing template**” can hold more than one **Sheet format** if it contains more than 1 page.  
As mentioned in the Drawing Template file, any existing sheet in the template already contains a **Sheet Format**. However whenever a new sheet is added, it references the **Sheet Format link that is specified in**
the active sheet properties. This is why a saved out Sheet Format with a link in the Drawing Template is key, otherwise you will receive the error “The sheet format could not be located.”

When you create a new Drawing with the command File => New you get this menu:

The icons (files) listed here, are the Drawing templates (xxxx.drwdot) that you have specified in the path;
Tools => Options => System Options tab => File Locations => Document Templates.

You can specify more than one path if you like. The directory names are shown as a TAB’s in the menu.

8.34 Create a Drawing template with a link to a Sheet Format file.
1. Start a blank new Drawing via File => New
2. Edit the Sheet Properties (RMB on the Drawing => Properties) and choose the sheet size (A, B, C, etc), set the Sheet Scale, etc. Click OK.
3. Edit the Sheet Format (RMB on the Drawing => Edit Sheet Format) and customize the titleblock, border and anchors.
4. Accept the changes and return to the Sheet via the Confirmation Corner (top right of the graphics area).

5. Save the Sheet Format file by going to File => Save Sheet format. This will save a xxxx.slddrt file. It is recommended to save this in a custom location that is easy to find. The path can be specified under Tools => Options => System Options tab => File Locations => Sheet Formats.

6. Return to the Sheet Properties (RMB => Properties), and select “Browse” for the Sheet Format. Select the xxxx.slddrt file that you just saved.

7. Edit any other Sheet Properties (Type of Projection, Sheet Scale, etc) and click OK.

8. Add any predefined views, Tables or Notes as needed.

9. Go to File => Save As and choose to save as the Drawing Template (.drwdot) filetype. Save in a custom location that is easy to find. This path can be specified under Tools => Options => System Options tab => File Locations => Templates.

8.35 Repair the “<MOD-DIAM>” syntax message in circular dimensions

In this picture the text “<MOD-DIAM>” has been replaced by what should be the diameter symbol: Ø. The error occurs because Solidworks can’t find a symbol-library-file called “Gtol.sym”. Fortunately there is an easy fix for this.

Try to find the “Gtol.sym” file on your system. The default location for the file is located in:
C:\Program Files\SolidWorks\lang\English or
C:\ProgramData\SOLIDWORKS xxxx\lang\English

If you cannot find the “Gtol.sym” file on your system, simply copy the file from another computer and place it in one of the above file locations.

In Solidworks go to Tools => Options => System Options => File location. Then select the “Symbol Library File” from the drop down box and make sure it is pointing to the location where your “Gtol.sym” file is located. If it is not pointing to the right location, delete the existing address and add the correct address to the list.

Now the problem should be resolved and the diameter symbol should be displayed in your Solidworks Drawing.

8.36 Repair the often occurring error: “The Sheet Format could not be located.”

Quick fix:
Browse to select the Sheet Format each time you add another sheet.

Solid fix:
The first step is to have your Sheet Format file saved. Some companies have a different sheet format for the first page and additional pages. This solution works regardless of whether the first page is different than the second or not.

Right-click on the sheet and select the “Properties” option.
Notice that there is a file path that points to a sheet format in the dialog box. This is the “Second Page Variable”. This is the file and file path that SW uses when adding the second page. We are going to change this. Type in the name of the sheet format that you want to use (such as SHEET 2.SLDDRT). Do not include a file path.

Click on OK. SW will give you an error message that the “Sheet format could not be located.” SW will now show you the same display message but won’t allow you to select “OK”.

Click Cancel. Now the second page variable is set.

Save your template. You can check what sheet format your template is looking at, to verify it worked.

Move your template and sheet format to your network or a folder that doesn’t get removed when you install a new version of SW.

Set your SW Template folders and sheet format paths in Options. Now when you add a second page, it just works as you would expect.

---

8.37 **Linking Custom Properties to the Drawing Titleblock**

It can be very advantageous to have some of the fields in the Drawing Titleblock auto-populating with information from the referenced model or Assembly.
Create a Part that has the properties you want linked to the title block.

To add properties select Properties from the File pulldown.

Insert a Drawing view of the Part into a Drawing that will be used as your Drawing template. Right click on blank area of the Drawing sheet and select Edit Sheet Format. Create a Note.

From the Note Properties select the Link to Property icon.

Use the option: “Model in view specified in sheet properties”. After all the properties have been linked, delete the model. Save the Drawing as a template (*.drwdot).

8.38 Editing Drawing Notes, Linked to File Properties

You can link Drawing notes to the File properties of the Drawing and components. After inserting the note, click the “Link to Property” button in the PropertyManager. You have 4 options from where to grab the custom properties.

“Link to Property” button:
Search for “Link to Property” in the SolidWorks Help for a description of each option. The drop-down menu allows you to select the custom property from the specified file. Once finished you will notice that the note adds the corresponding value for the custom property. If you edit the note and click “Link to Property” again it just adds another link and doesn’t automatically remove the previous value. You could delete the previous value and add another link, but there is an option to edit the equation.

Right-click the note and select “Edit Text in Window.” This will open a dialog box showing the equation of the link. The 4 options that were provided in “Link to Property” correspond to the following equations:

<table>
<thead>
<tr>
<th>Equation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$PRP:“Custom Property Name”</td>
<td>$PRP points to the Drawing.</td>
</tr>
<tr>
<td>$PRPVIEW:“Custom Property Name”</td>
<td>$PRPVIEW points to overall model for the view that the note is attached to. If you didn’t double-click the view before adding the note, you can turn on and attach a leader to the model, and then hide the leader again.</td>
</tr>
<tr>
<td>$PRPSHEET:“Custom Property Name”</td>
<td>$PRPSHEET points to the overall model referenced in the default view specified in the sheet properties. By default it is set as the first view on the sheet.</td>
</tr>
<tr>
<td>$PRPMODEL:“Custom Property Name”</td>
<td>$PRPMODEL points to one component of the Assembly. You will need to have a leader attached to the component (the leader can be hidden).</td>
</tr>
</tbody>
</table>
8.39 **Linking a Drawing note-field to a model property.**

Usually information is pushed from a model to a Drawing, but a special Drawing field can also push information to the model.

1. Start with creating a new Custom Property in the model (Part or Assembly).
   In this example a Custom Property named “Version” is created.
   Set the default value to “-”, so it will be easier to find it in the Drawing.
   Close the model.

2. Open the Drawing file and RMB “Edit Sheet Format”.
   Create a note somewhere in the Drawing sheet and fill in the formula;
   `$PRPSHEET:"Name of the Custom Property"` Select OK.
While still in “Edit Sheet Format”-mode, RMB somewhere in an empty space in the Drawing sheet and select “Edit Title Block fields”.

Click on your new note, so it will be added to the list of Text Fields.

RMB somewhere in an empty space in the Drawing sheet and select “Edit Sheet”-mode.

If you want to edit the new field, just click on it. After editing, click OK and rebuild the Drawing. The updated value will be pushed to the custom property of the model.

Note: if you update the value of this Custom Property, from the within the model, the Drawing will also update.

8.40 Notes based on the “Summary Information” fields

For example the information stored in the “Comments field” is stored in the Part property: “$PRP:”SW-Comments”.

You can edit this information in a Part or Assembly: File > Properties > Summary > Comments.

You can create a note which is linked to this property in the Drawing. The content of these fields can be pushed to a drawing document.

All “Summary Information” fields:

<table>
<thead>
<tr>
<th>Fields</th>
<th>Solidworks code</th>
<th>Editable</th>
</tr>
</thead>
<tbody>
<tr>
<td>Author:</td>
<td>$PRPSHEET:”SW-Author(Author)”</td>
<td>Yes</td>
</tr>
<tr>
<td>Keywords:</td>
<td>$PRPSHEET:”SW-Keywords(Keywords)”</td>
<td>Yes</td>
</tr>
<tr>
<td>Comments:</td>
<td>$PRPSHEET:”SW-Comments(Comments)”</td>
<td>Yes</td>
</tr>
<tr>
<td>Title:</td>
<td>$PRPSHEET:”SW-Title(Title)”</td>
<td>Yes</td>
</tr>
</tbody>
</table>
8.41 Link a dimension of a Part to a note in a Drawing

In the Part (or Assembly) you first have to create in the Equations-menu a new GV (Global Variable) with a name of your choice. (Do not use reserved name such as “diameter”).

Link the GV to your dimension (or Feature).

Create in the Part (or Assembly) a new CP (Custom Property) and link it to the new created GV.

In this example the new CP is “CircleCP” and the value is linked to the new GV “Circle@Part10.SLDPRT”

Save and close the Part (or Assembly) and open your Drawing. Open the Drawing and select the Drawing view and create a Note.

Link the note to the new created File Property (Custom Property). In this example “CircleCP”
8.42 **Automatically fill in your Title Block**

Every time that you create a Drawing document, you need to fill in the title block, including your name and the date that you created it. However, it gets repetitive if you have to do this every time. SolidWorks provides you the ability to do this automatically whenever you start a new Drawing document. Let's see how to automatically fill in the drawn by and created date information.
Open a new Drawing document. Note that you'll need to do this for each of the different sheet formats that you use. For this tip, in the Sheet Format/Size dialog box, make sure that the Standard sheet size radio button is selected and pick A-Landscape from the menu. Right below the menu is the name of the template, a-landscape.slddrt. If it's not, browse to that file. Make sure that Display sheet format is checked and click OK.

In the Model View PropertyManager, click the Cancel button. You should see a blank piece of paper with a border and title block. Pull down the “File” menu and pick Properties. In the Summary Information dialog box, on the Custom tab, click in the box below Property Name and pull down the “Property Name” menu and pick DrawnBy. Click in the Value / Text Expression box a exactly what will appear in the title block. Click OK, and type your initials.

Note that your initials are automatically placed in the title block, the bottom right of your Drawing.

Now, to automatically fill in the date, right click on the sheet and select Edit Sheet Format. As you may notice, the lines turn blue and a few custom properties of Parts or Assemblies are already linked to fields in the system sheet formats. That’s what the $PRPSHEET means. Place the cursor in the middle of the Drawn/Date box where the date should appear.
When the $PRP:”DrawnDate” flyout appears, click the left mouse button as shown below. A little green box will appear where you click.

In the Note PropertyManager, under Text Format, click the Link to Property button.

In the Link to Property dialog box, pick the Current document radio button. Then, pull down the menu and pick “SW-Created Date”. Below that, pull down the menu and pick Short Date. Uncheck the Show Time check box. This will place the current date in to the title block of your Drawing.

If you wanted the date the model was created in your Drawing, pick the “Model in view specified in sheet properties” radio button. Finally, click OK to close the dialog box.

You should now see the current date in your title block. Right click on the date and pick Edit Text in Window. (For SolidWorks 2007 and before, right click on the date and pick Properties).

Delete $PRP:”DrawnDate” as shown below and click OK.

Press the Escape key and then right click on the sheet and pick Edit Sheet. The lines on the title block turn gray, indicating that the Drawing sheet is now active. Remember that “SW-Created Date” is static.

In other words, when you create a new Drawing document, the current date will be inserted. But thereafter, when you reopen any of your saved Drawing documents, the date remains the date the document was created, not changing to the current date.
To make this work for future Drawing documents, you’ll have to save it. You can replace the existing sheet format or save it as a new one. To do this, pull down the "File" menu and pick “Save Sheet Format”. In the Save Sheet Format dialog box, under “File name”, rename the file to “a – landscape date.slddrt” and click Save. Finally, open a new Drawing document. In the Sheet Format/Size dialog box, pick “a – landscape date” from the list of available sheet formats, as shown below. Click OK.

In the Model View PropertyManager, click the Cancel button. In your title block, you should see that your initials and the created date are already filled in for you. So, every time that you use this new customized Sheet Format, you don’t have to worry about filling out your name and the date the Drawing was created. SolidWorks automatically does it for you. Look around the title block for other fields that you may want to have filled in automatically.
9 **Workarounds**

Some “workarounds” for Solidworks 2015 for subjects which can be very frustrating. I have not tested these workarounds in SW2016-2018.

9.1 **Complex sketch mirror entities**

Complex sketches can be difficult to mirror at sketch level and often gives errors of over-defined entities. In that case you can create another sketch on the same plane and use convert entities, than the sketch can be easily mirrored at sketch level.

9.2 **Cosmetic thread of a Part does not show in Part or Assembly**

There are several reasons why the cosmetic thread Feature do not show in an Assembly.

Check all the settings listed below.

<table>
<thead>
<tr>
<th></th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>In the Hole wizard menu options, check if Cosmetic thread is selected.</td>
</tr>
<tr>
<td>2</td>
<td>All Annotations: View menu =&gt; All Annotations</td>
</tr>
<tr>
<td>3</td>
<td>Cosmetic Threads: Right click on Annotations folder =&gt; Details =&gt; Cosmetic threads checkbox</td>
</tr>
<tr>
<td>4</td>
<td>Display Annotations: Right click on Annotations folder =&gt; Display Annotations</td>
</tr>
<tr>
<td>5</td>
<td>Use Assembly settings for all components: Options =&gt; System Options =&gt; Right click on Annotations folder =&gt; Details =&gt; Use Assembly settings for all components checkbox.</td>
</tr>
</tbody>
</table>

Even if the above settings are correct, sometimes the Cosmetic thread does not show.

In that case you have to edit the component and look for the Cosmetic thread Feature in the Feature tree. RMB on the Cosmetic thread Feature and click on “Edit Feature” and close it, now it should show!

9.3 **Number of holes in the “Hole callout” in Drawings**

You always have to check the number of holes in the “Hole callout Annotation”.

If you have mirrored Features or bodies with holes, than the number of holes might be incorrect because usually only the number of holes in the first Feature or body are represented.

If this is the case, you have to correct this manually!

The alternative is: create all holes of the same dimension in one Feature and face.

9.4 **Saving a Toolbox Part as a standard Part**

Just changing and saving the file property with “Sldsetdocprop.exe” does not work. Open first the Solidworks Toolbox model and use “SAVE AS” and put there the name of your choice, and save it to the desired folder. Then use the “Sldsetdocprop.exe” software program, click add files and select the Toolbox model you just saved as. Click the show selected property and it will show a standard which means the Toolbox is still controlling the model so “select property state No” and click update status.

When you try to click again the “show selected property” it will show “No” which means the model is not related to the Toolbox anymore and you can exit the “sldsetdocprop.exe” program. The model now is in the standard Solidworks Part format.
9.5 **A Part with two or more bodies, partially occupying the same space.**

This is actually not a workaround but a general remark.
You can calculate the mass properties of each separate body in a multi body Part.
When you calculate the mass properties of the total Part, Solidworks gives you the sum of the mass properties of each individual body, which is actually impossible. **Solidworks does not warn you when solid bodies occupy (partially) the same space.**
This is also the case when components in an Assembly (partially) occupy the same space.

9.6 **Annotations of mirrored Parts do not show in Drawing**

Annotations such as Weld beads and Cosmetic threads do not show in “opposite hand mirrored” Parts. This is probably because these Features are not solid bodies.
I do not know a good workaround for this. The only way seems to put these Features another time in the mirrored Part.
Often it is acceptable practice not to dimension the other hand version and just add an Annotation with some remarks like “RH version of Part xxx. All dimensions same as left UOS (unless otherwise specified)”.

9.7 **Defining the Drawing view position by dimensions to the Drawing border.**

In Solidworks you can not directly dimension the border of the Drawing view or the Part itself, to the border of the Drawing sheet.
Dimensioning is only possible within the selected Drawing view.
When you use multiple-page Drawings, you cannot precisely define the position of the views to the borders.
The best option you have is not very precise, but as far as I know, there is not a good alternative.
Position the Drawing view on the Drawing sheet as good as possible where you want it. Then select the Drawing view by clicking on it, use RMB => “Lock View Position”. Now your view has a locked position and when you copy this Drawing Sheet and paste it, the new sheet has also this Drawing view on exactly the same locked position.

9.8 **Transparency of components in Drawings**

There is no straight forward method to make some components in a Drawing transparent. This can be useful to show components behind glass doors.
The workaround for this is via an “alternate position view”. The alternate position view is projected on top the standardview and you can show different configurations in both of these views.

1. Create an extra derived configuration in the Assembly and name it; “Transparent”.
2. In the “Transparent” configuration hide the Components you want to be transparent.
3. Create an alternate position view and assign the the transparent configuration to it.

9.9 **Error message: Sketch endpoints and center points cannot be deleted.....**

The full error message is: “Sketch endpoints and center points cannot be deleted unless the endpoint is a split point of a curve.”
Sometimes it is not possible to delete some leftovers in Sketches like center points of Sketch fillets.

All standard selection and deletion methods does not work in such a case.

And you when you try to delete it, you receive a popup message:

You can hide these points in Tools => Options => System Options => Sketch.

Uncheck “Display arc centerpoints....”

Uncheck “Display entity points in Part....”

If hiding is not what you want, than you can delete them with a special method:

The only way is make these unwanted points A split point on a curve like an arc.

Create a 3-point arc with 1 or 2 unwanted points as the begin- and endpoint of the arc.

Tools => Sketch Tools => Split Entities and click twice somewhere on the arc to create some split points.

Drag the unwanted points on top of the split points and a cicle is created.

You can delete the circle if you use the delete command 2 or 3 times!
10 Fasteners

If you send your models with Tollbox Parts to other users, the user with the standard version of Solidworks van not see these Parts. In this case it is better to create your own set of fasteners or download some fasteners.

There are some very good sources for downloading fastener Parts, but sometimes there are some other disadvantages.

Sources for downloading fasteners as Parts:

<table>
<thead>
<tr>
<th>Website</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td><a href="http://www.mcmaster.com">www.mcmaster.com</a></td>
<td>No login or registration needed.</td>
</tr>
<tr>
<td></td>
<td>Filesize can be large, because of helix thread Features.</td>
</tr>
<tr>
<td><a href="http://www.tracePartsonline.net">www.tracePartsonline.net</a></td>
<td>A free user account is needed.</td>
</tr>
<tr>
<td><a href="http://www.grabcad.com">www.grabcad.com</a></td>
<td>A free user account is needed.</td>
</tr>
<tr>
<td></td>
<td>Content, amount and quality depending on user uploads.</td>
</tr>
<tr>
<td><a href="http://www.3dmodelspace.com">www.3dmodelspace.com</a></td>
<td>No account needed. No Solidworks format but STEP and Parasolid.</td>
</tr>
<tr>
<td>b2b.Partcommunity.com</td>
<td>User account needed.</td>
</tr>
<tr>
<td><a href="http://www.Partcloud.net">www.Partcloud.net</a></td>
<td>Native Solidworks file format is not available, only STEP.</td>
</tr>
<tr>
<td>free3d.com</td>
<td>Free models in various formats, including Solidworks.</td>
</tr>
<tr>
<td>downloadfree3d.com</td>
<td>Free models in various formats, but only few Solidworks models.</td>
</tr>
<tr>
<td><a href="http://www.3dcontentcentral.com">www.3dcontentcentral.com</a></td>
<td>A free user account is needed.</td>
</tr>
<tr>
<td></td>
<td>Many free models, also in Solidworks format.</td>
</tr>
<tr>
<td></td>
<td>Solidworks has a setting in the System Options, for the location of your downloaded files form this source.</td>
</tr>
</tbody>
</table>

10.1 Standards for Fasteners

In Europe, the country specific standards are more and more replaced by EN or EN-ISO standards. However the very well known German DIN standards are still well known and even valid in some cases. For fasteners the old withdrawn DIN standards are often referred, but doing this in new Drawings is actually incorrect for all withdrawn standards.

Note that the Solidworks Toolbox is still using some withdrawn DIN-standards without any warnings.