Solidworks - Hints, Tips, Tricks and Best Practices.
A comprehensive list of useful tips and techniques.

A collection of hundreds of Solidworks tips, tricks, best practices and useful techniques collected from the internet, Solidworks Forums and other fora. Most of it is edited with my own experiences in SW2015 and also to create a more consistent look. The subjects are listed and sorted by the Solidworks main chapters; Sketches, Parts, Weldments, Surfaces, Sheet Metal, Assemblies and Drawings. Most of the subjects are written for beginner’s level (CSWA and CSWP) and requires some basic understanding of Solidworks.

Henk de Bruijn
30-December-2016
1 Table of Contents

1 Table of Contents .................................................................................................1
2 General settings ...................................................................................................4
  2.1 Screen settings of your monitor for properly functioning of Solidworks .............4
  2.2 The User interface ..............................................................................................5
  2.3 Customizing the Solidworks User Interface .......................................................5
  2.4 Common settings for the Keyboard shortcuts ....................................................5
  2.5 Copy settings and customizations before updating or new installation ...............6
3 General tips ..........................................................................................................7
  3.1 Rules of thumb ...................................................................................................7
  3.1.1 General rules of thumb ..................................................................................7
  3.1.2 Rules of thumb for Sketches .........................................................................8
  3.1.3 Rules of thumb for Features ..........................................................................9
  3.1.4 Rules of thumb for Assemblies ......................................................................9
  3.1.5 Rules of thumb for Drawings .........................................................................9
  3.2 Display the triad .................................................................................................9
  3.3 Create a new Coordinate System ......................................................................9
  3.4 Optimizing Solidworks settings for maximum performance ..............................9
  3.5 Other Tips .......................................................................................................9
4 Solidworks and AutoCAD .......................................................................................10
  4.1 Importing .dxf or .dwg files .............................................................................10
  4.2 Importing layers ...............................................................................................10
5 File management ....................................................................................................11
  5.1 Option “File save as” explained .......................................................................11
  5.2 The “Split feature” explained ..........................................................................12
  5.3 Saving bodies as a part file ..............................................................................13
6 Part modelling ........................................................................................................14
  6.1 Sketch ..............................................................................................................14
  6.1.1 Creating “virtual sharps” in sketches .............................................................14
  6.1.2 Dimension to circular entities ......................................................................14
  6.1.3 Dimension Diameters of a cylindrical object in a profile view (eg a Revolve) .15
  6.2 Features ..........................................................................................................15
  6.2.1 Creating an “opposite hand version” of a Part .............................................15
  6.2.2 Create tapered (conical) threads with the Hole Wizard .................................15
  6.2.3 The Flex feature explained ..........................................................................15
  6.3 Surfaces ..........................................................................................................16
  6.3.1 Converting surfaces to solid bodies .............................................................16
  6.3.2 Coating of parts ...........................................................................................17
  6.4 Sheet Metal ......................................................................................................17
  6.4.1 Drawing of Sheet Metal Parts ......................................................................17
  6.4.2 A common mistake with the “Flatten” button explained: .........................17
  6.5 Weldments ........................................................................................................17
  6.5.1 Adding weldment profiles by downloading from Solidworks ....................18

Solidworks - Hints, Tips, Tricks and Best Practices – V2.0
6.5.2 Creating Custom weldment profiles ............................................................. 18
6.5.3 Saving custom weldment profiles at a custom location ................................ 19
6.5.4 Important notes for Weldments: ................................................................. 20
6.5.5 Mirror Weld beads ...................................................................................... 20
6.6 Mold Tools .................................................................................................... 20
6.6.1 Scaling ....................................................................................................... 20
6.7 Configurations ............................................................................................... 21
6.7.1 Start a new Configuration manually: ......................................................... 21
6.7.2 Adding Features to a Configuration ............................................................ 21
6.7.3 Adding Sketch Dimensions to a Configuration .......................................... 21
6.8 Configuration specific colors ....................................................................... 21
6.8.1 Design Tables ............................................................................................ 22
6.9 Equations ..................................................................................................... 22
6.10 Mates References in Parts .......................................................................... 22
6.11 Working with pictures ................................................................................ 22
6.11.1 Insert a picture in a sketch for dimensioning ........................................ 22
6.11.2 Adding a decal or an appearance ............................................................. 23
6.11.3 Deleting a Decal ....................................................................................... 23
6.11.4 Copy a picture on a surface .................................................................... 23
6.12 Subtract and keep bodies in multibody parts ............................................. 23
6.13 Using COMBINE, CAVITY and INDENT .................................................. 24
6.14 Best Practice for drawing molds for profiles or cross-sections of profiles .... 25
6.15 Using a surface for cutting a body ............................................................... 25
6.16 Using the “Freeze bar” ............................................................................... 26
6.17 Tips for using lofts ...................................................................................... 26
6.18 Using a Multibody Part versus an Assembly ............................................. 27
6.19 Virtual Parts/Components .......................................................................... 28
6.20 Bottom-up versus Top-down (in context) modelling ................................ 28

7 Assembly modelling ...................................................................................... 30
7.1 Flexible sub-assemblies in the main assembly ........................................... 30
7.2 Interference Detection ................................................................................ 31
7.3 Subtract one component from another and keep both in an Assembly ....... 31
7.4 Create a new subassembly from a selection of components ...................... 32
7.5 Positioning of identical Components in an Assembly, like bolts in holes .... 32
7.6 Often used fasteners like washers, bolts and nuts ...................................... 32
7.7 Breaking the references of components downloaded from the Toolbox ...... 33
7.8 External reference symbols in the feature tree, like a question mark .......... 34
7.9 Display States .............................................................................................. 34
7.10 Sketch Layout ............................................................................................ 34
7.11 Mates ......................................................................................................... 34
7.12 Easy Mates in Assemblies ......................................................................... 35

8 Drawings ....................................................................................................... 36
8.1 Creating a “virtual sharp” in a drawing ...................................................... 36
8.2 3rd Angle vs 1st Angle Projection in Drawings ............................................ 36
8.3 Inserting Surfaces in Solidworks Drawing Views ....................................... 36
8.4 Align the Drawing view by an edge of the model ....................................... 36
8.5 Create Notes with Multiple Leader Lines in Drawings .............................. 37
8.6 Dimensioning the “Arc Length” in a drawing view .................................................. 37
8.7 Timesaving by “reusing” drawings of similar parts ................................................. 37
8.8 Timesaving with “automatic dimensioning” ............................................................. 38
8.9 Auto arrange dimensions ......................................................................................... 38
8.10 Inserting chamfer dimensions into a drawing ....................................................... 39
8.11 Create an annotation with multiple arrows .......................................................... 39
8.12 Create multiple instances of annotations ............................................................... 39
8.13 Foreshortened dimensions ..................................................................................... 40
8.14 Dual dimensions e.g. mm and inches ..................................................................... 41
8.15 Section view on specific positions: ......................................................................... 41
8.16 Create a Broken-Out section view ......................................................................... 41
8.17 The two types of Section Views with cutting lines explained .................................. 41
8.18 Working with hatches ............................................................................................. 42
8.19 Create colored hatches in drawings ....................................................................... 43
8.20 Create a watermark in a drawing ........................................................................... 43
8.21 Inserting a Block in a Drawing ............................................................................... 43
8.22 Perspective View on a Drawing .............................................................................. 43
8.23 Change the orientation plane of a dimension in an isometric view ....................... 44
8.24 Create a custom view in a part or assembly for using in a drawing ...................... 44
8.25 Inserting End Treatment Symbols in Drawing Documents ..................................... 44
8.26 Defining a thread callout in a drawing ................................................................... 44
8.27 Show a model’s sketch in the drawing ................................................................. 45
8.28 BOM tables or BOM-lists ....................................................................................... 45
8.28.1 General tips for BOM tables .............................................................................. 45
8.28.2 Adding Equations (formulas) to the BOM. ........................................................ 46
8.28.3 Showing the BOM on a Drawing of a Multibody Part ....................................... 46
8.28.4 Hiding or showing rows or columns in a BOM-table ....................................... 47
8.28.5 Editing the column “Description” of a BOM table ........................................... 48
8.28.6 Rounding of dimensions in the Cutlist (BOM table) .......................................... 48
8.29 Drawings with suppressed and unsuppressed parts ............................................. 48
8.30 Drawing template vs Sheet Format ....................................................................... 48
8.31 Create a Drawing template with a link to a Sheet Format file. .............................. 49
8.32 Repair the often occurring error: “The Sheet Format could not be located.” .......... 50
8.33 Linking Custom Properties to the Drawing Titleblock ......................................... 50
8.34 Editing Drawing Notes, Linked to File Properties ............................................... 51
8.35 Automatically fill in your Title Block .................................................................... 53

9 Workarounds ............................................................................................................. 56

9.1 Complex sketch mirror entities .............................................................................. 56
9.2 Cosmetic thread of a part does not show in Part or Assembly ............................... 56
9.3 Individual rounding of dimensions in a Cut list (BOM-table). ................................. 56
9.4 Number of holes in the “Hole callout” in drawings ............................................... 56
9.5 Saving a Toolbox part as a standard part ............................................................... 56
9.6 A part with 2 or more bodies (partially) occupying the same space ...................... 57
9.7 Annotations of mirrored parts do not show in Drawing ....................................... 57
2 General settings

2.1 Screen settings of your monitor for properly functioning of Solidworks.

Windows Screen resolution

Set the screen resolution at 100% for correct functionality of Solidworks.

Note:

When using Windows screen size of 125%, than the checkbox for “Circular Pattern Feature” for Solid Bodies cannot be selected, but you can click on the word “Bodies”.

Dynamic highlight

Dynamic highlight from graphics view is also a very nice option in System Settings.
2.2 The User interface:

<table>
<thead>
<tr>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
<th>7</th>
<th>8</th>
<th>9</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu Bar</td>
<td>Toolbars</td>
<td>Command Manager</td>
<td>Configuration Manager</td>
<td>Property Manager</td>
<td>Feature Manager Filter</td>
<td>Feature Manager Design Tree</td>
<td>Status Bar</td>
<td>Display Manager</td>
</tr>
</tbody>
</table>

1 = Heads-up View Toolbar  
2 = SOLIDWORKS Search  
3 = Help flyout menu  
4 = Task Pane  
5 = Graphics area

2.3 Customizing the Solidworks User Interface.

You can customize the Solidworks user interface very much to your personal taste. However in a classroom it is not very convenient when everyone is using their own different settings. This is also very applicable in company departments, but it can also be understood that more experienced users need different settings than less experienced users.

For customization the user interface see document link: [Customizing SolidWorks User Interface.pdf](#)

2.4 Common settings for the Keyboard-shortcuts:

Keyboard shortcuts are key combinations such as those displayed at the right of the menu, which can be customized.

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom in</td>
<td>Shift+Z</td>
</tr>
<tr>
<td>Zoom out</td>
<td>Z</td>
</tr>
<tr>
<td>Zoom to fit</td>
<td>F</td>
</tr>
<tr>
<td>View Orientation menu</td>
<td>Spacebar</td>
</tr>
<tr>
<td>View Selector</td>
<td>Ctrl+Spacebar</td>
</tr>
<tr>
<td>Repeat last command</td>
<td>Enter</td>
</tr>
<tr>
<td>Rebuild the model</td>
<td>Ctrl+B</td>
</tr>
<tr>
<td>Redraw the screen</td>
<td>Ctrl+R</td>
</tr>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
</tbody>
</table>
2.5 **Copy settings and customizations before updating or new installation.**

The **Copy Settings Wizard** saves, restores and propagates system settings to users, computers, or profiles. When you select options for the Solidworks software, those settings are saved in the registry file and the software recognizes the settings from one release of Solidworks to the next. For most users, no action is necessary to maintain their settings. However, you can use the **Copy Settings Wizard** to distribute settings.

You can Save or Restore system settings for:
- Keyboard shortcuts
- Menu customization
- System options
- Toolbar layout (All toolbars or Macro toolbar only)

You save the settings to a file and then restore them to the following registries:

<table>
<thead>
<tr>
<th>Profile</th>
<th>Registry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current user</td>
<td>CURRENT_USER of current user</td>
</tr>
<tr>
<td>One or more network computers</td>
<td>LOCAL_MACHINE of selected computers</td>
</tr>
<tr>
<td>One or more roaming user profiles</td>
<td>CURRENT_USER of selected users</td>
</tr>
</tbody>
</table>

Only system administrators should copy settings to network computers or roaming user profiles. When you restore settings to network computers, the settings apply to new SolidWorks users on the specified computers. You can restore settings to roaming user profiles only if your company uses roaming user profiles.

**Saving your System Settings**

1. In the Welcome dialog box, select Save Settings, then click **Next**.
2. Browse to a location and file name, select the types of settings, then click **Finish**.
3. The wizard confirms that the settings have been written to the specified file. Click **OK**.
4. The settings files have a default extension of `xxxx.sldreg`. If you double-click a file with this extension, the Copy Settings Wizard appears.
3 General tips

3.1 Rules of thumb
The rules of thumb are sometimes quite obvious and some of them can be a matter of taste.

3.1.1 General rules of thumb
5. Do not rename or move Solidworks files with the Windows Explorer because this will break the external references. Use the Solidworks Explorer for this task.
6. Only use the “Solidworks Explorer” for renaming when all your Solidworks files are closed.
7. Create a part or a multibody-part, or sub-assembly of each component you want to appear in the BOM-list of the main Assembly Drawing.
8. Use a document management system to organize your Solidworks files, if this is not possible keep all your Part-, sub-Assembly-, Assembly- and Drawing-files for creating an Assembly or Drawing in one directory.
9. Create procedures for keeping track of a versioning system for Drawings but also for Parts and (sub)-Assemblies.
10. Create procedures to identify the status (draft, approved etc.) of your files. It is better to have short procedures than having no procedures at all.
11. Solidworks files do use lots of referenced files, so create procedures to prevent missing or deleted files.
12. Some users state that modelling practices and the order of features should be similar to the manufacturing practices, but good modeling practices are not the same as good manufacturing practices. Some basic practices like “mirroring and patterning as much as possible” are often impossible in the real manufacturing world.
13. In reality, new designed models are discussed and improved or adjusted before and after manufacturing, so start building your model, while keeping in mind that some features and parts need to be changed later.
14. If your model is easy to change, also for others, than you can be pretty sure that you have built a “good model”.
15. When you are working with the models of the CSWA and CSWP practicing exams, you will learn this “best modeling practice”.
16. Practice and do the CSWA and CSWP exams. They are free of costs, not too difficult and not too easy. Practice, practice, practice and you will learn to change your model easily and pass the exams.

3.1.2 Rules of thumb for Sketches
1. Keep sketches simple, preferably one sketch for each feature when applicable.
2. Sketch as much as possible on the three standard planes; Top, Front and Right.
3. Model the part around the origin and frequently use the Mirror Feature and Mirror Body for symmetry.
4. Use “Convert Entities” and “Power Trim” instead of sketching new lines.
5. Add relations first, than dimensions.
6. Make sketches always “fully defined” except sketches with splines (*).
7. Dimension the entities of the sketches as much as possible as you would like them to have in the Drawing.
8. Sketch entities can be linear or circular patterned, but it is easier, and therefore preferred, to pattern the Features or Bodies instead of Sketch entities.
9. Add some driving dimensions to the Sketch if they will be used later in the Drawing.
10. Do not use very complicated splines by defining not more than 3 points per spline.

Solidworks - Hints, Tips, Tricks and Best Practices – V2.0
11. Rename critical Sketches for easy understanding of the model for others.
12. Do not use “Split lines” early in the feature tree, because this can cause parent/child nightmares.
13. Do not use “Blocks” in sketches, if there is a possibility that you want to update or change the Block. Referenced Blocks are difficult to update.
14. Use “Equations” for often occurring dimensions in Sketches and give them easy to recognize names.

(*) a special remark about splines:
Splines can be made “fully defined” easily, but in most models they do not need to be fully defined. If you do fully define a sketch with splines parametrically with Equations, than the model is not very stable and often will show “over defined” error messages when rebuilding your model.

3.1.3 Rules of thumb for Features

1. Use bodies to pattern and mirror features, because not all features behave well in patterns and mirrors.
2. Add Fillets and Chamfers last, preferably as features, not in sketches. See remark at the end of this paragraph (*).
3. Avoid surface features in preference of solid features when possible.
4. Use the “Hole Wizard” when possible, because extruded cuts gives less options at a later modelling stage.
5. Use “Configurations” for slightly different versions of an existing part.
6. Rename critical Features for easy understanding of the model for others.
7. Use in-context relations sparingly and avoid circular in-context relations (A references B, B refs back to A).
8. If you model a lot with profiles than define the cross sections as “Structural Members” in Weldments.
9. Modify “Sheet metal” parts in the “Bended state”.
10. Use “Equations” for often occurring dimensions in Features and give them easy to recognize names.
11. Create and use feature library features for common features.
12. When there appears a list of errors shown as a “bleeding red Feature tree”, fix it starting from the top.

(*) a special remark about using Fillets and Chamfers in Sketches and Features.

You can use Fillets and Chamfers in Sketches and as Features. Both methods have their advantages and disadvantages, but generally at novice level, I recommend to create Fillets and Chamfers in Features at last at the end of the Feature tree.

<table>
<thead>
<tr>
<th></th>
<th>In Sketches</th>
<th>As Features</th>
</tr>
</thead>
<tbody>
<tr>
<td>Complexity:</td>
<td>More complex sketches.</td>
<td>Easier; because no parent child relations to other geometry.</td>
</tr>
<tr>
<td>Rebuild time:</td>
<td>Faster</td>
<td>Slower; but not noticeable in simple models.</td>
</tr>
<tr>
<td>Flexibility:</td>
<td>Poor</td>
<td>Better; can be reordered and suppressed.</td>
</tr>
</tbody>
</table>
3.1.4 Rules of thumb for Assemblies

1. Use your own modelled set of frequently used fasteners as “Parts with Configurations” even if you have the Toolbox. This is especially for commonly used components like bolts, nuts and washers because Configurations are easier and faster to change than Components.
2. Create “Reference Mates” when the Part will be frequently used in an Assembly.
3. Create sub-Assemblies or sub-sub-Assemblies in complex models and also for a better understanding of the model.
4. Mate all nuts and washers to the bolt and not to the hole. This is easier to change and it just simplifies and standardizes the mating scheme for your models.
5. Use Weld beads in the Assembly and not in the (multibody) Part, this is more logical.
6. Use Display States to hide or show components.

3.1.5 Rules of thumb for Drawings

1. Use well designed templates according to your “company standards” for your Drawings.
2. Use Blocks with your standard text, symbols and shapes as much as possible in Drawings.
3. Use “Layers” for different colors of lines in your Drawings.
4. Use Display States (created in the Assembly), to hide or show components in the Drawing.

3.2 Display the triad

To display or hide the reference triad, click Tools > Options > System Options > Display/Selection. Select or clear Display reference triad, then click OK.
It is not necessary to have the triad visible, but a matter of taste.

3.3 Create a new Coordinate System

1. Click Coordinate System (Reference Geometry toolbar) or Insert > Reference Geometry > Coordinate System.
2. Use the Coordinate System PropertyManager to create the coordinate system.
3. You can amend your selections:
4. To change your selections, right-click in the graphics area and select Clear Selections.
5. To reverse the direction of an axis, click its Reverse Axis Direction button in the PropertyManager.
6. Click ✓.

3.4 Optimizing Solidworks settings for maximum performance

See document link: Maximizing Solidworks Performance.pdf

3.5 Other Tips

- Double click on a feature to show the dimensions, and when you double click on a dimension, you can edit the value.
- To show all dimensions of a part: Annotations => Show Dimensions, View => Annotations.
4  **Solidworks and AutoCAD**

AutoCAD files can be imported in different ways and with different selection settings. As a matter of taste, I do not recommend to import AutoCAD files in Solidworks but I prefer to create new sketches instead of importing.

4.1  **Importing .dxf or .dwg files**

You can import .dxf and .dwg files to the SolidWorks software by creating a new Solidworks Drawing, or by importing the file as a sketch in a new part. You can also import an AutoCAD file in native format:

1. In SolidWorks, click Open (Standard toolbar) or File => Open.
2. In the Open dialog box, set Files of type to Dxf or Dwg, browse to select a file, and click Open.
3. In the DXF/DWG Import Wizard, select an import method, and then click Next to access Drawing Layer Mapping and Document Settings.
4. Click Finish on any of the three screens to import the file.

To import a .dwg or .dxf file as a new Sketch:

1. Open a Solidworks part file.
2. Select the plane for the DXF/DWG file
3. Insert => DXF/DWG

When importing a .dwg or .dxf file as a 2D sketch for a part, you can filter out unnecessary entities.

1. Open the .dwg file.
2. In the DXF/DWG Import wizard, select Import to a new part as and 2D sketch.
3. Click Next.
4. Select part document options and click Next.
5. In the preview, select entities to remove and click Remove Entities.
6. To undo this action, click Undo Remove Entities.
7. Select other options and click Finish.

4.2  **Importing layers**

When importing a .dwg or .dxf file as a 2D sketch for a part, you can create a new sketch for each layer in the file.

1. Open a .dwg files with layers.
2. In the DXF/DWG Import wizard, select Import to a new part as and 2D sketch.
3. Click Next.
4. Select Import each layer to a new sketch.
5. Select other options and click Next or Finish.
5  **File management**

Solidworks files are unfortunately not backwards compatible, so you cannot open SW2016 files with SW2015.

Solidworks searches automatically to referenced files in the same directory. Never, ever have duplicate models of the same Part with the same filename in different locations. Be careful to uniquely name each part. Parts with the same name, even if they are in different directories, will cause "undesirable" results, because Solidworks searches automatically also in other directories.

Do not move or rename files with the Windows Explorer, but use the Solidworks Explorer for this action. Use the “Solidworks Explorer” only when all Solidworks files are closed. Understanding how Solidworks works with files and file-references is essential.

See document link: **Solidworks File Management Guidelines.pdf**

If you want to reduce the file size you can:
- Set the maximum number of items in the “History Folder” of the Feature tree to 1.
- Save the “File as”, and reload that file (this usually can help very well).

If you have to send your Drawing(s) including the 3D Solidworks model files to other people, you can use “Pack and Go”. This will create one zip-file including all the referenced files. **File => Pack and Go => select the option Save to Zip file:**

5.1  **Option “File save as” explained**

Saves the active document to disk with a new name or saves it in a different format for export to another application.

To display this dialog box:

Click **Save As** (Standard toolbar) or **File => Save As**.

<table>
<thead>
<tr>
<th>Save in</th>
<th>Let you browse to the location where you want to save the document. Use the locations sidebar to help navigate to the location where you want to save your document. The locations sidebar is available in certain operating systems only.</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td></td>
</tr>
<tr>
<td>Save as type</td>
<td>Saves the file in another file format. You can also export files.</td>
</tr>
<tr>
<td>Description</td>
<td>Saves your text in the custom property field for Description in Summary Information.</td>
</tr>
<tr>
<td>Save As</td>
<td>Saves the document to a new file name that becomes the active document without saving the original document.</td>
</tr>
<tr>
<td>Save as copy and continue</td>
<td>Saves the document to a new file name without replacing the active document.</td>
</tr>
<tr>
<td>Save as copy and open</td>
<td>Saves the document to a new file name that becomes the active document. The original document remains open. References to the original document are not automatically assigned to the copy.</td>
</tr>
<tr>
<td>Include all referenced components</td>
<td>Copies all referenced components to the new location, adding a prefix or suffix to the component names, as specified.</td>
</tr>
<tr>
<td>Advanced</td>
<td>Displays a list of the documents referenced by the currently selected assembly or drawing. You can edit the locations of the listed files.</td>
</tr>
</tbody>
</table>
5.2 The “Split feature” explained

You can use the Split feature to divide a part into multiple bodies. You can keep the bodies within the part or save them into separate part files. You can save them during the creation of the Split feature. You can also split a single part document into a multibody part document.

When a Split part is completed an alternative is to use the command: Save Bodies to save them.

To split a part:

1. Click Split (Features toolbar) or Insert => Features => Split.

2. In the PropertyManager, set the options:
   - To split the part using trim tools, select Trimming Surfaces and click Cut Part.
   - Split lines appear on the part, showing the different bodies formed by the split.
   - Callout boxes appear in the graphics area for up to 10 bodies at one time. Click Next 10 or Previous 10 to scroll through all the callout boxes for a part.

3. Under Resulting Bodies, select the bodies to save under [x], or click Auto-assign Names.
   - All of the saved bodies appear in the graphics area and are listed in the FeatureManager design tree under [x] Solid Bodies. The software automatically names all bodies. You can change the names.

4. Double-click the body name under File, type a name for the new part in the dialog box, then click Save.
   - The new part name appears in the Resulting Bodies list and in the callout box. Unsaved bodies are not split and remain with the original part.
   - If you clear the check box [x]for a split part after you save it, that part is no longer saved as a separate entity. It remains with the original part.

5. Click [✓]

Handling of Split Parts (new parts)

1. The new parts are derived; they contain a reference to the parent part. Each new part contains a single feature named Stock-<parent part name>-n-. You can reattach a derived part to a specified stock part, split feature, or body.

2. If you change the geometry of the original part, the new parts also change. If you change the split feature geometry, no new derived parts are created. The software updates the existing derived parts, preserving parent-child relations.

3. With multibody parts, the various split parts are listed in the FeatureManager design tree under [x] Solid Bodies.

Handling of Split Parts (original parts)

1. The original part contains all its original features plus a new feature called Split.

2. If you selected Consume cut bodies under Resulting Bodies, the solid body displayed in the graphics area is the original solid body minus the new parts. If all bodies in the original part were saved as split bodies, no solid body is displayed. To see the original solid body, move the rollback bar in the FeatureManager design tree above the split feature or suppress the split feature.

3. If you delete the split feature in the original part, the new parts still exist, but the status of the external reference in the new parts is dangling.
### Saving Split Bodies

1. Click Insert > Features > Save Bodies.
2. Select the bodies to save in the graphics area, or under in Resulting Parts. The callouts display the default path, file names, and location of the multibody part.
3. Under Resulting Parts, double-click each file name under File to open the Save As dialog box. You can select a new location and file name for each part. You can also click Auto-assign Names to select and name all bodies.
4. Select Consume cut bodies to copy cut-list items from multibody parts to resulting parts.
5. To create an assembly, under Create Assembly, click Browse, select a folder to save the assembly as SplitAssembly type (*.sldasm), and type a file name.
6. Click ✓

### 5.3 Saving bodies as a part file

In multibody parts it can be very useful to save one or more bodies as separate part files.

The bodies are show under Solid Bodies in the Feature Manager.

If you have just created a new body, rebuild and save your multibody-part file first. RMB on Solid Bodies and select Save Bodies.

Select a Part- and Assembly template; (selecting the same template as the original part, will prevent errors).

Select the bodies you want to save.

(The option “Consume cut bodies” will remove the body form the original part file.)
6  Part modelling

6.1  Sketch

6.1.1  Creating “virtual sharps” in sketches

A virtual sharp creates a sketch point at the virtual intersection point of two sketch entities. Dimensions and relations to the virtual intersection point are retained even if the actual intersection no longer exists, such as when a corner is removed by a fillet or chamfer.

Virtual sharps appear automatically in 3D sketches for: Fillets and Sketch Chamfers
You can delete the automatic virtual sharps.
You can add dimensions and relations to virtual sharps in 3D sketches.

To create a virtual sharp:

1. In an open sketch, hold down Ctrl and select two sketch entities.
2. Click Point (Sketch toolbar) or click Tools > Sketch Entities > Point.
3. A virtual sharp appears at the point where the sketch entities would intersect.

6.1.2  Dimension to circular entities

| Dimension to center of circle.  
| Solidworks automatically select the center.  
| Just select the circle itself and the line. |

| Dimension to edge of circle in special cases.  
| Since SolidWorks automatically select the center, you must force it to take the edge.  
| Use the SHIFT key when you select the circle, and Solidworks will dimension to the edge of the circle. |
6.1.3 Dimension Diameters of a cylindrical object in a profile view (eg a Revolve)

Select the two lines:
Select the centerline and the edge of the circular shape, and DRAG the dimension in a perpendicular direction to the lines.
Solidworks will switch automatically to the diameter.

NOTE: the “center line” does not need to be a construction line for this to work. However the center line DOES NEED to be a construction line for a REVOLVE to work.

6.2 Features

Features are usually adding or removing material from a part. Some Features are deforming (twist and bend) the part, which can also (slightly) change the volume of a part!

6.2.1 Creating an “opposite hand version” of a Part.

Method A:
Klick first on the plane which will be used as the mirroring face. (This is important)!!!
Insert => Mirror part .... (The mirrored part will now be saved as a separate file).
This file is linked to the original file and the mirrored part will be automatically updated when the original part is changed.

Method B:
Sometimes it is more convenient to save the mirrored Part as a separate Configuration in the original file.

1. Features => Mirror => Bodies to mirror => no Merge solids!!!
2. Solid bodies => Delete (delete the original bodies)
3. Create a new Configuration: Configuration Manager => Default => RMB => Add new derived Configuration.
4. Type a name for the Configuration etc.
5. Features => “Bodies to mirror” => RMB => Configure Feature
6. There is now 1 Feature in the Configuration table.
7. Type a name for the Configuration Table and save it.
8. Features => DoubleClick on “Delete bodies” so this Feature will also appear in the table.
9. For the original part, these two Features has to be suppressed.
10. For the mirrored part all Features must be unsuppressed.

6.2.2 Create tapered (conical) threads with the Hole Wizard

Conical or tapered threads like NPT, can be made with the Hole wizard.
In the Hole wizard menu, click in “Hole Type”; “Tapered Tap” and as the Standard; “ANSI inch” and as the Type; “Tapered Pipe Tap” hole and select the size.

6.2.3 The Flex feature explained.

The Flex feature can be very useful for bending bodies like flexible rubber products. Although most solid bodies are usually incompressible, the volume and weight of a body will change slightly after the Flex feature is applied.
The flex feature calculates the extents of the part using a bounding box. The trim planes are then initially located at the extents of the bodies, perpendicular to the blue Z-axis of the triad.
The flex feature affects the region between the trim planes only.
The center of the flex feature occurs around the center of the triad location.
To manipulate the extent and location of the flex feature, re-position the triad and trim planes. To reset all PropertyManager values to the state they were in upon opening the flex feature, right-click in the graphics area and select Reset flex.

6.3 Surfaces
Surfaces are bodies without a volume or mass, but you can copy and mirror surfaces like solid bodies. Surfaces give you much more freedom and flexibility in designing complex shapes than solid bodies.

6.3.1 Converting surfaces to solid bodies
When working with Surfaces in Solidworks, you probably want to convert a surface into solid body at some point. (Surfaces do not have a volume or mass). This can be done using the Knit Surface or Thicken Surface feature. But in SW 2016 you have the ability to create a solid using the Boundary Surface or the Trim Surface features, provided the surface features can create a closed volume from the inputs.

1  In SW2015 and older, you have to use Knit Surface first.
Select Try to form solid.
Select Merge entities.

2  If there is a missing surface to form a solid, then use Fill Surface.
Select Merge result.
Select Try to form solid.
6.3.2 **Coating of parts**

Complete the model geometry to the point of coating.

1. Use the “Surface knit” command (access from either the knit icon on your surface toolbar or **Insert > Surface > Knit...**) to create a skin around the model.
2. You will have to select all of the faces individually.
3. Check the ‘merge entities’ option and click OK.
4. Next, choose the **Thicken...** command (either from Insert Boss/Base or the surfaces tool bar), choose the knit surface body, specify the thickness, choose the direction to thicken, and make sure that you disable ‘merge result’.

Now you should have two solid bodies which you can see from the Solid Bodies folder in the feature tree. Expand the Solid Bodies folder, right click on either of the bodies shown, choose material and specify the material for the first body. Repeat the last step for the second body. You now have a ‘coated’ or ‘plated’ part.

6.4 **Sheet Metal**

Do not use the convert to sheet metal button, but start right away with a “Base Flange/Tab” feature. This prevents the “Flatten” button not always working correctly.

Create features like cuts and holes in the “bended state”.

For a summary of basic sheet metal features see document link: [Introduction to SheetMetal](#)

6.4.1 **Drawing of Sheet Metal Parts**

SOLIDWORKS creates a flat-pattern configuration when the drawing of a sheet metal part is generated. The only difference compared to the main configuration is that the flat-pattern feature is unsuppressed in the flat-pattern configuration. **Design changes should be made in the main/default configuration.**

It is a common practice for many SOLIDWORKS users to right-click on a drawing view and use the Open command to access the part. Specific to sheet metal flat-pattern drawing views is that accessing the model this way activates the right configuration of the model.

6.4.2 **A common mistake with the “Flatten” button explained:**

Unaware of the configuration change and wanting to edit the model, users sometimes toggle the Flatten option or manually suppress the flat pattern feature in the FeatureManager Design Tree. While the model may appear correct, the problem becomes obvious in the drawing document where the flat pattern view no longer shows flat pattern, but a formed part.

The way to correct the flat-pattern view in this scenario is to access the model, activate the flat-pattern configuration and unsuppress the flat-pattern feature. To avoid the problem, after accessing it from the flat-pattern drawing view, it is sufficient to switch to the configuration tab and activate the main configuration of the part.

6.5 **Weldments**

Solidworks has a great tool when it comes to creating weldment profiles and structures. With just a basic line sketch, it is able to turn this into a weldment structure by converting the lines into the weldments of your choice. But before you can utilize this great tool, you need to save some weldment profiles into your Solidworks directory. You can add some cross sections of plastic profiles and build your own library of cross sections.
6.5.1 **Adding weldment profiles by downloading from Solidworks**

Solidworks contains many international standards of steel weldment profiles where you can immediately leverage on and start using. This is how you can get access to them:

- Select Design Library / SolidWorks Content / Weldments

- Hold CTRL + any download zip file and then unzip these files

- Add your extracted zip folder in weldment profile either by adding a file location on your System Options

- Otherwise it will be placed in the default location for weldment profile which is at C:\Program Files\SolidWorks Corp\SolidWorks\lang\english\weldment profiles

6.5.2 **Creating Custom weldment profiles**

Design your own weldment profiles:

1. Open a new part. Sketch the weldment profile that you would like. When you are sketching the profile, the pierce point (the point whereby the center of the weld structure would meet with other weld parts) is by default located on the origin.
2. If you would like to change this, input a point on the sketch where you would like the pierce point. During the creation of the weld structure, you can then select the point you have created.
3. Exit the sketch. Now in the feature manager tree, select the sketch you just created and click File >> Save As. What you are doing now is to save it as a weld profile for future use. This is done by:

In the dialog box:
1. In Save in, browse to C:\Program Files\SolidWorks Corp 2016\SolidWorks\lang\english\weldment profiles and select or create appropriate Custom and subfolders. Note: subfolders must have unique names !!!
2. In Save as type, select “LibFeat Part” (*.sldlfp).
3. Type a name for the Filename.
4. Click Save.

6.5.3 **Saving custom weldment profiles at a custom location.**

This a tricky and rather complex procedure because it is sensitive for errors like:

Error:“Library Feature is empty”

Procedure for saving custom weldment profiles at your custom location:
Create a new part which is empty (no sketches).
Save it as an *.sldlfp-file at the location of your custom profiles like:

`X:\SOLIDWORKS-profiles\1st level directory name\2nd level directory name\*.sldlfp`

(“\SOLIDWORKS-profiles\” is your top-level directory name.)

<table>
<thead>
<tr>
<th>Structural member:</th>
<th>Windows directory names:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top-level directory name</td>
<td>“SOLIDWORKS-profiles”</td>
</tr>
<tr>
<td>1st level directory name</td>
<td>“ISOdownloaded”</td>
</tr>
<tr>
<td>2nd level directory name</td>
<td>“RubberProfile”</td>
</tr>
<tr>
<td>File name of sketch</td>
<td>“W2L rubber.sldlfp”</td>
</tr>
</tbody>
</table>

The top-level directory name must be set as a valid directory name in the Solidworks system settings: Options => System Options => File Locations.

Then select “Weldment Profiles” in the Folders: listbox and browse to your “top-level directory name” and select it. (You have to do this only once.)

Some tips when you edit your custom profile sketch:
- Use structural lines for later use of relocating of the profile in Structural members.
- Use the origin as the reference for the cutting length.
- Make it fully defined.

Save your sketch. It will now be automatically saved as an *.sldlfp file in your custom directory.
Check for open contours by checking if you can extrude it.
(You can delete the extrude feature after checking that.)

Just one more not very intuitive, thing to do which is therefore often forgotten !!!

Select your sketch in the Feature Manage and RMB => Add to library.
Now you can see that your sketch is a valid weldment profile because the icon for the sketch has changed.

Close the file and it’s ready for use!
You can edit and change the *.sldfp file later if you want, but this will create problems in previous models which uses the old version.
It is better to assign a versioning system in the file names of custom profiles and define this in your working procedures.

6.5.4 **Important notes for Weldments:**
- The profile must follow a path of a sketch with connected straight lines and or curves as Groups, but no splines!!
- When drawing with weldment profiles select first: Structural member => Standard => Type => Size and then select Groups and Sketch entities.

6.5.5 **Mirror Weld beads**
Note that Weld beads are not bodies and have no volume and mass
Weld beads cannot be mirrored like solid bodies.

6.6 **Mold Tools**
Although Mold Tools are usually not frequently used by most users, there are some tips for beginners.

6.6.1 **Scaling**
For molds, plastics and rubber design you have to compensate for shrinkage, which can be done in 2 different ways:
1. Scale the Part instead of using the scale in the Cavity Feature.
2. Use the Scaling factor parameter in the Cavity Feature.

<table>
<thead>
<tr>
<th>Formula</th>
<th>1) Scale Part</th>
<th>2) Scaling factor in Cavity Feature</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>The Scaling factor is the direct factor. Factor 2.0 means, the part will become twice as big as the original.</td>
<td>Cavity size = part size * (1 + scaling factor/100) So for a material with 1.8% shrinkage the Scaling factor has to be 1.8 !!</td>
</tr>
<tr>
<td>Remark</td>
<td>For more complicated molds</td>
<td>For simple molds.</td>
</tr>
<tr>
<td>Draft</td>
<td>More flexibility because all parameters are separated.</td>
<td>Can be used together with the Draft parameter.</td>
</tr>
</tbody>
</table>

Creating a mold using the Cavity tool requires the following items:
1. Design parts - The parts that you want to mold.
2. A mold base - The part that holds the cavity feature of the design part.
3. An interim assembly - The assembly in which the cavity is created.
4. Derived component parts - The parts that become the halves of the mold after you cut them.
6.7 **Configurations**

Configurations are tools for defining small differences in shape, material, or dimensions between parts. When you have large or more differences it can become difficult to organize this with Configurations, and it is better to create a separate part-file.

6.7.1 **Start a new Configuration manually:**

In either a part or assembly document, click the ConfigurationManager tab at the top of the FeatureManager design tree to change to the ConfigurationManager.

6.7.2 **Adding Features to a Configuration:**

Select a **Feature** => RMB **Configure Feature** => Select if the Feature should be suppressed or not => Type a name for the Table => Save the Table.

You can add more Features as table columns the same way, when the table is visible.

6.7.3 **Adding Sketch Dimensions to a Configuration.**

Make the Sketch dimensions visible: FeatureManager => Annotations => RMB Show Feature dimensions.

Now the dimensions are visible: Select a dimension => RMB Configure Dimension. Now an extra column is added to the Configuration Table.

6.8 **Configuration specific colors**

When you have a SOLIDWORKS part which have more than one configuration, you can link the model display states to the configurations. Linking the display states to the model configurations allow you to use for example different material and/or color for each configuration.

On this step of this tutorial, we setup the SOLIDWORKS model’s Display States to be linked to the model configurations to allow the different colors for the configurations.

**Linking Display States to Part Configurations:**

By first, open any SOLIDWORKS part document which have more than two configurations. Then refer to the following steps to link the display states to the model configurations:

1. Activate the ConfigurationManager from the SOLIDWORKS feature manager. At the bottom of the ConfigurationManager tab, you see the Display States group.
2. Right-click the current display state and select Properties. The Display State Properties pane appear.
3. Under the Advanced Options section, select the Link display states to configurations option.

Your SOLIDWORKS part’s display states are now linked to the model configurations.

Note:

When you have checked the checkbox “Use configuration specific color” and you have specified the color, than the part must not have any Appearances.
6.8.1 **Design Tables**

DesignTables are a much more advanced version of ConfigurationTables, and are much more difficult to use. This is not recommended for beginners.

6.9 **Equations**

Use Equations when dimensions are related to each other, like the circumference and the radius of a circle, or have the same ratio.

To insert an Equation select *Tools => Equations*.

Note that the “decimal character” should always be a dot.

6.10 **Mates References in Parts**

Reference Mates can save a lot of time when often used Parts like fasteners has to be mated in an Assembly. Mate references create automatically pre-defined mates when you drag and drop the component into specific positions.

The simplest type of mate reference exists on only one component and (in most cases) only creates one mate. The component can then be mated to any matching geometry on another part within the assembly. Here are the steps to create and utilize this type of mate reference:

1. Open the Part in Solidworks.
2. Open the Mate Reference manager in the Reference Geometry dropdown or by going to *Insert => Reference Geometry => Mate Reference*.
3. While the Mate Reference dialog is active, select some geometry on the component that you want automatically mated when it is dropped onto the corresponding geometry in the assembly. This will work best with a planar or cylindrical face. This geometry should populate the blue selection field in the Primary Reference Entity. Than you can choose which type of mate you desire (concentric, for example) and how you would like the alignment to turn out. The alignment can be adjusted later while the component is being inserted.

There can be more than one Mate reference be applied to a part, but this is more complicated and needs a separate tutorial.

Note that components from the Toolbox already do have Mate references.

6.11 **Working with pictures**

Pictures can be processed in different ways.

6.11.1 **Insert a picture in a sketch for dimensioning**

A reference image in your sketch can help to get the dimensions correctly and make the modeling process simpler. This is also a great technique to use when doing surface modeling.

1. Open a new sketch.
2. Draw some reference geometry (construction lines) to help in positioning and sizing of the image.
3. Now to insert the image: go to “Tools”, “Sketch Tools”, and “Sketch Picture”.
4. Select the image file to insert and click “Open”. Now the image is in the sketch but is not sized or orientated correctly.
5. Use the command boxes to the left to change the size and orientation of the image or just drag the boxes around the image to re size and position. This is what the reference sketch made in Step 3 is used for.
6. Close out of the sketch and now you have a fully defined sketch with the image at the correct dimensions.
6.11.2 Adding a decal or an appearance

A decal is a single picture file which can be applied to a surface, body or feature. The size and position of the single picture can be changed.

The easiest way to apply a custom decal is by selecting a decal from the standard library and edit its location: Display Manager => select the decal => RMB edit deal => Browse to your custom decal picture.

When a single picture file is used as an appearance, it is applied many times (depending on the size of the picture and the surface) to a surface, body or feature. The size of the picture can also be changed but the number of applied pictures is automatically adjusted to fill the complete surface, body or feature. Using picture files as an appearance is very useful for applying realistic textures to your models.

6.11.3 Deleting a Decal

Go to the DisplayManager => View Decals.
Now you can select the decal and delete it.

6.11.4 Copy a picture on a surface

To copy a picture on a Surface:
1. Select the surface > Appearance > Face > Advanced > Browse.
2. Select all graphics files.
3. Select the picture to be copied on the surface.
4. Save the picture as appearance file; xxxx.p2m
5. Adjust size, rotation with mapping (select projection for flat surfaces)
6. Adjust illumination with the Illumination-tab.

6.12 Subtract and keep bodies in multibody parts

Make first a copy of the body to subtract with the command move/copy bodies.
Then combine and subtract the copy of the body.
## 6.13 Using COMBINE, CAVITY and INDENT

Schedule for selecting Combine, Cavity or Indent feature.

<table>
<thead>
<tr>
<th>Interference between:</th>
<th>Before =&gt; After</th>
<th>Best option</th>
</tr>
</thead>
<tbody>
<tr>
<td>2 components in an assembly</td>
<td>![Diagram 1]</td>
<td>Use Combine (Add) at the part level.</td>
</tr>
<tr>
<td>2 components in an assembly</td>
<td>![Diagram 2]</td>
<td>Use Combine (Subtract) at the part level.</td>
</tr>
<tr>
<td>2 components in an assembly</td>
<td>![Diagram 3]</td>
<td>Use Indent (Cut) at the part level.</td>
</tr>
</tbody>
</table>
6.14 **Best Practice for drawing molds for profiles or cross-sections of profiles**

**Do not use Blocks** for defining standard cross sections of profiles, because Blocks will lose easily the “link to file” option on rebuilding. The broken link is often unnoticed and is also difficult to repair. Blocks are not intended for easy modifying, linking and updating, but they are a kind of template of its own. Therefore Blocks with standard shapes and notes, are very handy in Drawings.

Make a sketch of all the cross section areas of the profile and mold parts.

Save the sketch as a new Part without bodies or surfaces (this file can be used later for editing changes). Open a new Part.

**Insert => Part** => select the part with the cross sections.

**Transfer => Unabsorbed Sketches.**

Make sure that the option “Locate Part with Move.....” is off.

Click “OK” in the Property Manager and the part will be located at the origin.

**Note:**
If you add extra sketches to the profile Part (without bodies) the new sketches do not update automatically in the child Part file.

You can update this by Opening the child part file with File => Open, select the child Part file and click on the **References** button. Now select the parent Part file without bodies and now the child Part file is updated.

6.15 **Using a surface for cutting a body.**

Create the surface body.

**Insert => Cut => With Surface**

Select the Surface to cut with. (The Surface body must intersect the body to cut).
Select the direction of the cut.

6.16 Using the “Freeze bar”

How to turn on the Freeze bar in SolidWorks 2012:
1. Click Options in the Standard toolbar, or Tools > Options.
2. On the System Options tab, click General and select Enable Freeze bar.
3. Click OK.

The yellow freeze bar appears near the top of the Feature Manager design tree, under the part name.

The freeze bar controls the point at which a part’s Feature Manager design tree rebuilds. Features above the freeze bar are frozen – you cannot edit them, and they are excluded from rebuilds of the model. Freezing a portion of a model can be useful if you work with complex models with many features. Freezing the features helps to:
• Reduce rebuild time
• Prevent unintentional changes to the model

Feature Freeze prevents the geometry of frozen features from being rebuilt. However, you might still experience long rebuild times due to other processes that are not addressed by Feature Freeze. Examples of potentially time-consuming processes not addressed by Feature Freeze:
• Updating display appearances, especially on very large patterns
• Updating complex DimXpert dimension and tolerance schemes
• Updating the graphics (tessellation data) of very large, complex parts

To freeze features:
1. Move the pointer over the freeze bar. The pointer changes to Hand icon. Freeze bar change

2. Drag the freeze bar down below the last feature you want to freeze. When the freeze bar is at the top of the tree, you can also right-click a feature and click Freeze to freeze that feature and all features above it in the Feature Manager design tree.

Features above the freeze bar are frozen – you cannot edit them, and they are excluded from rebuilds of the model. Frozen features are indicated by a lock icon Lock and gray text.

6.17 Tips for using lofts

When lofting, you have to give special consideration to the way you sketch the profiles and how you subsequently select them in the Loft command. In general, there are 3 rules you should follow for good results:

1. Create first the profile sketches, than create guide sketches. Connect all the guide sketch-end-points to the profile lines with pierce-point relations.

2. Pick the same corresponding spot on each profile. The system connects to points you pick. If you are careless, the resulting feature will twist. If the profiles are circles there are no ends to pick as there are on rectangles. That makes picking corresponding spots tricky at best. In this situation, put a sketch point on each circle and pick them when you select the profiles.
Each profile should have the **same number of segments**. In the example at the right, a closed semi-circle (2 segments) was lofted to a rectangle (4 segments). As you can see, the system blended one side of the rectangle into part of the arc, another side into the remainder of the arc, and so on. This does not give a good result. However, if you subdivide the arc, you can control exactly which portion of the arc corresponds to each side of the rectangle.

### 6.18 Using a Multibody Part versus an Assembly

Multibody parts and assemblies both have their **advantages and disadvantages**. As a general rule to follow, one part (multibody or not) should represent one **part number** in the BOM-list (Bill of Materials).

Multibody parts have a folder named "Solid Bodies" that appears in the FeatureManager design tree when there are solid bodies in a single part document. The number of solid bodies in the part document is displayed in parentheses next to the "Solid Bodies" folder.

<table>
<thead>
<tr>
<th>When to use a Multi body Part:</th>
<th>When to use an Assembly:</th>
</tr>
</thead>
<tbody>
<tr>
<td>The file represents a complete “purchased” item where individual components are not tracked. The multibody part appears as a single item in the BOM of an Assembly.</td>
<td>Each part has a unique name or number and is tracked or <strong>purchased individually</strong>.</td>
</tr>
<tr>
<td><strong>Weldments</strong> are multibody-parts, and much easier to create as a single (multibody) part file. The big advantage is that Weldment multibody-parts do appear in the BOM-list!</td>
<td>The assembly has movement where dynamic assembly motion is important</td>
</tr>
<tr>
<td><strong>Clearance detection and interference detection</strong> between the parts is NOT important.</td>
<td><strong>Clearance detection and interference detection</strong> are important tests.</td>
</tr>
<tr>
<td><strong>Easy file management.</strong></td>
<td>More files to manage.</td>
</tr>
<tr>
<td><strong>Performance</strong> is improved since it is a SINGLE file.</td>
<td><strong>Assemblies</strong> has one or more file references which slow down the performance.</td>
</tr>
<tr>
<td>For <strong>security reasons</strong>.</td>
<td></td>
</tr>
</tbody>
</table>

You can convert an Assembly to a multibody part:

**Select FILE => SAVE AS** and change the "**Save as**" type to PART .sldprt.

This action has several options:

<table>
<thead>
<tr>
<th>Exterior Faces</th>
<th>SOLIDWORKS determines what faces are ‘exterior’ and which can be considered ‘interior’ and will save a multibody part full of surfaces representing those exterior faces.</th>
</tr>
</thead>
</table>

Solidworks - Hints, Tips, Tricks and Best Practices – V2.0
6.19 Virtual Parts/Components

Virtual components are those that ‘live’ ONLY within the assembly. Similar to the individual bodies in multibody parts, virtual components do not have an external file to track.

New parts can be created when virtual components in an assembly or existing parts are “converted” to virtual components.

Create a virtual Part:
1. Select multiple parts in the Assembly Feature Manager and choose MAKE VIRTUAL.
2. A “Warning” will appear!!
3. The resulting virtual components will NOT be updated when the original parts changes!!
4. Virtual components are represented in the Assembly Feature Manager with square brackets “[ ]”.

When to use a virtual Parts:
- The file represents a complete ‘purchased’ item where individual components are not tracked.
- Easier way to share your designs with even Solidworks users. If all the parts in the assembly are virtual, you can send a single assembly file and all the virtual components will be contained within it.
- Performance is improved since it is now a SINGLE file, not several referenced files like assemblies full of “traditional” Parts.

6.20 Bottom-up versus Top-down (in context) modelling.

When to use “Bottom-up”
Bottom-up is the most traditional method used by CAD operators. Parts are modeled and them are inserted into the assembly using mates to position and fix them in relation to other components. Any changes to a part will need to be done by editing it individually. This technique is practical to model parts already designed and fabricated, like purchased parts and components (hardware, bearings, motors, pulleys, etc.), in general, parts that you do not design, and which do not change their shape and dimensions based on changes on your design, parts which change in model or change to a different component as your design changes (a 5 HP motor to replace a 3HP one when your design change to a larger size machine, or a 4” pipe elbow to replace a 6” pipe elbow, etc.)

Bottom-Up is also a good technique for people "integrating" commercial components into an assembly, where perhaps only one or two components are design (such as the skid base of a motor-generator set, where all other components (motor, radiator, electric generator, etc.) are purchased components.

When to use “Top-down” (in-context).
Top-down technique is normally the technique used by product design engineers. Top-down create assemblies where parts are modeled "inside" the assembly, being related to "driving" entities inside the assembly which control the shape, features, dimensions and position of those parts, in a way that changes introduced to the "driving" entities "drive" the configuration of all the "in-context" modeled parts and
therefore the entire assembly. Top-down modeling make possible the creation of parametric assemblies and "true" KBE systems, which cannot be done using the Bottom-up technique alone.

Creating a properly structured Top-down assembly requires more analysis and work that the creation of a Bottom-up model, however, the advantage of top-down modeling for people doing product design is that very little work (and time) will be required when design changes occur, since all parts and components will automatically update to new shapes, dimensions, position, etc. as new input parameters are entered into the "driving" entities at the assembly level.

Which one is the better, depends on the nature of the product you are designing and the amount of changes you expect to have during the entire product life cycle.

The Top-down technique is more difficult and it also requires more work when creating the model. It will be better for people designing products from scratch (where the assembly will need to go through many changes before reaching its "final" configuration) or for people designing products which are "design-to-order" as "variations" of a "basic" generic product.
7 **Assembly modelling**

7.1 **Flexible sub-assemblies in the main assembly.**

A sub-assembly in an assembly is rigid by default !!. Even when the sub-assembly is not fully defined. Within the parent assembly, the sub-assembly acts as a single unit and its components do not move relative to each other (piston in shaft). One of the most common issues that people have when they include sub-assemblies within their design is that any degrees of freedom allowed within the sub-assembly are not available when it is brought in to an assembly, the sub-assembly is rigid and this is often not what people expect.

Why is this?

When you insert a sub-assembly into an assembly the assembly is treated as if it is a part, thus it is completely rigid and inflexible. This speeds up the process as SOLIDWORKS does not need to constantly update all the mates within the sub-assembly as you move the assembly around the screen, reducing processing requirements, speeding up the process and potentially making it easier to work with that sub-assembly. Thus the assembly is fixed in the position it was saved within the sub-assembly. But I want my sub-assembly to move!

SOLIDWORKS will allow movement of sub-assemblies; we just need to specify that the assembly is flexible. If we right click on the sub-assembly in the tree there is an icon in the context sensitive toolbar to make sub-assembly flexible, (prior to SOLIDWORKS 2014 this icon does not appear, instead we would need to go to the assemblies properties and select ‘Solve As: Flexible’) with this selected you’ll notice a few changes – the icon for the sub-assembly changes to a flexible sub-assembly icon and more importantly, any degrees of freedom allowed in the sub-assembly are available.

Rigid and Flexible assemblies have different icons in the feature tree.

![Rigid and Flexible Icon](image)

Example:

In the example below we have created a sub-assembly of the universal joint, this has then been brought into our top level assembly and has already been mated to the bracket using the shaft at the top of the universal joint, we wish to now add mates to control the movement of the lower yoke of the universal joint. We want the flat face at the bottom of the yoke to be parallel to the angled face of the bracket.

We want to create a mate to sit the underside face of the Yoke parallel to the angled face.
As the sub-assembly is rigid we cannot create this mate; it requires the sub-assembly to change position which cannot happen as the universal joint is rigid.

Specify that you wish the sub-assembly to be made flexible.

With the sub-assembly made flexible the mate can now be added, and the universal joint can be rotated.

### 7.2 Interference Detection

To open this PropertyManager:

Click Interference Detection (Assembly toolbar) or Tools > Interference Detection.

**Selected Components**

| Components to Check: | Displays components selected for the interference check. By default, the top-level assembly appears unless you pre-select other components. When you check an assembly for interference, all of its components are checked. If you select a single component, only the interferences that involve that component are reported. If you select two or more components, only the interferences between the selected components are reported. |

### 7.3 Subtract one component from another and keep both in an Assembly

Select the component to make a cavity in.

Edit Component

**Insert -> Feature -> Cavity**

Select the Component to subtract.
7.4 **Create a new subassembly from a selection of components.**

You can form a subassembly from components (individual parts or subassemblies) that are already in the assembly, thereby moving the components down one level in the assembly hierarchy. Before creating a new subassembly, you can specify the default behavior for saving it, either as a separate external assembly file or as a virtual component within the parent assembly file. Click **Tools > Options > System Options > Assemblies** and select or clear **Save new components to external files**. Virtual components are saved internally in the assembly file instead of in separate part or subassembly files.

**Recommendation:** Position and mate at least one of the components before you begin, then select that component first.

All the components must be at the same level within a single parent assembly.

To form a new assembly from existing components:

1. In the graphics area or the FeatureManager design tree, **Ctrl + select the components**.
2. Do one of the following:
   - Right-click one of the selected components, and select **Form New Subassembly**.
   - Click **Insert > Component > Assembly from [Selected] Components**.

To form a subassembly from components contained in a folder in the FeatureManager design tree, right-click the folder and click **Form New Subassembly**.

3. Depending on your **Assemblies** option setting, one of the following occurs:
   - The new subassembly is saved as a virtual component within the parent assembly.
   - The Save As dialog box appears, so you can save the new subassembly in its own assembly document. Browse to a different folder if needed, enter a **File name**, and click **Save**.

A new subassembly is inserted at the level where the selected components were located, and the components are moved into the new subassembly.

7.5 **Positioning of identical Components in an Assembly, like bolts in holes**

Position the first Component in the Assembly and fillly define it with “mates”.
Select “Sketch driven component pattern.”
Select the Component to be patterned.
Select at Reference point: “Selected point”, and search the sketch with the Hole Pattern in de feature manager tree and RMB “visible”.
Select the first point and click OK
The first Component is now twice in the Feature tree and can give an error sometimes.
Find the double Component in de Feature Manager by searching “LocalSketch pattern” and delete one instance of it.

7.6 **Often used fasteners like washers, bolts and nuts**

The Toolbox is a very nice tool for quick downloading and positioning of fasteners. However the Toolbox is not installed in the Solidworks “standard” version. For users with the “standard” version this is a disadvantage you can resolve in the next tip.
If you often use the same type of nuts, bolts, and washers in your assembly you can model these components as a part with configurations. These part-files are usually very small and can be stored in a special designated directory or in the same directory as your model if you like. The advantage of this method is that you can model the parts to the required level of detail of your company standards.
7.7 **Breaking the references of components downloaded from the Toolbox**

Downloaded components from the Toolbox are not visible when your model is opened on other computers who have no internet access or to the Toolbox. After downloading your Toolbox component, it is often a good habit to save it as a separate component (part) in your model directory. This policy can be different in each company! However unfortunately Solidworks has not made this very easy for us.

The correct way to do this, is with a special Solidworks Software Tool; **sldsetdocprop.exe** which is located at: "C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS\Toolbox\data utilities\sldsetdocprop.exe"

You can make shortcut-icon of this tool on your desktop.

**Change the system settings of your Toolbox:**

| ![System Options - Hole Wizard/Toolbox](image) | **Optionally you can specify a (temporary) Toolbox directory: “C:\Solidworks Data\”**  

Uncheck the checkbox “Make this folder the default search location..........” |

When you have downloaded a Toolbox component in your assembly, select this component by clicking on it in the Feature Tree.  
RMB => Make Independent, and save the component with a new name in your model directory. The component is still a Toolbox-component.!

| ![Set Document Property](image) | **Start the Solidworks Tool: sldsetdocprop.exe with the desktop-icon and select the Toolbox-component. (You can also select all Toolbox-components at once in the same directory.)**  

Set Property state: “No”, and click **Update Status**.  |

Now the downloaded component has lost its reference to the Toolbox. You can check this in in the Feature Tree as the Toolbox-icon of the component has changed to a part-con  
You can edit use and edit the component freely as you want.

The above described procedure might not work in SW2015 because there is a known bug: SPR 919518. **The work around is:**  
Open the Solidworks Toolbox model then **“SAVE AS”** and put there the name you want and save to desired folder. Then use the **“Sldsetdocprop.exe”** software program, click add files and select the Toolbox model you just saved as. Click the show selected property and it will show a standard which means the Toolbox is still controlling the model so **“select property state No”** and click update status.  
When you try to click again the **“show selected property”** it will show **“No”** which means the model is not related to the Toolbox anymore and you can exit the **“sldsetdocprop.exe”** program. The model now is in the standard Solidworks part format.
7.8 **External reference symbols in the feature tree, like a question mark.**

<table>
<thead>
<tr>
<th>Reference symbol</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>-&gt;</td>
<td>Referenced file is present (this is usually the case)</td>
</tr>
<tr>
<td>-&gt;?</td>
<td>Out of context (the referenced file is present, but not open)</td>
</tr>
<tr>
<td>-&gt;*</td>
<td>Reference file is Locked</td>
</tr>
<tr>
<td>-&gt;x</td>
<td>Broken (the referenced file is missing)</td>
</tr>
</tbody>
</table>

For referenced documents, I prefer to have these documents also open. The disadvantage is a heavier system load. The setting for this is:

**Options => TAB System Options => External references => Open referenced documents with ro access**

and

**Options => TAB System Options => External references => Load referenced documents => All**

7.9 **Display States**

You can create Display States to hide or show bodies, parts or components. You can also set different Appearances for each item in Display States.

Display States are different from Configurations, because Display States control only the visibility.

To create a new Display State:
1. Go to the Configurations TAB.
2. RMB on an empty area
3. Select Add Display State

The active Display State-name appears in angle brackets after the configuration name in the ConfigurationManager and at the top of the FeatureManager design tree.

Later, when you edit the Drawing of the Assembly, you can select the required Display State for each Drawing View.

7.10 **Sketch Layout**

Sketch Layout is a sketch which is mend for defining the relations between Components in 3D space. They can be used for defining movements of components which is very handy for advanced users.

Layout Sketches are 3D sketches drawn on a grid.

These Sketches are not suitable for common design work as sketches in Parts.

Some command buttons such as “slots” are greyed out and cannot be used in Layout sketches.

7.11 **Mates**

Mates are constraints to define the position of the components in the Assembly.

It is usually a good idea to make the position of the first Part in the Assembly “fixed”. This means that it is oriented to the same planes as in the Part file. This can be done as follows:

1. Create a new Assembly
2. Click **Insert Components** => click the “Browse” button => and click ✔ in the “Insert component” pane at the left upper corner of the screen. (Do not click in the graphics area).

Now the first Part is in a “fixed” position and is marked with “(f)” in the Feature tree, you can mate other components to the first Part.

If you want a Part in a “not fixed position” you can make it “floating” any time by RMB the fixed component in the Feature tree and select “Float”. Now the position of the component is not fully defined and it is marked with “(-)”. 

Solidworks - Hints, Tips, Tricks and Best Practices – V2.0
To create stable and easy to change Assemblies, it is common to use the main planes of the Assembly and the Part, as much as possible in the mates.
You can also use some predefined X, Y, Z-axis to create mates.
Personally I also like to use Sketches in Assemblies for using in mates. In the Drawing you can easily “Hide /Show” this sketch.

7.12 **Easy Mates in Assemblies**

An easy way to apply mates in Assemblies is:
In normal Assembly mode, select the two surfaces you want to mate while holding CTRL, and the available mates will popup.
8 Drawings

8.1 Creating a “virtual sharp” in a drawing
Select the 2 lines which can cross each other virtually, and sketch a point there.

8.2 3rd Angle vs 1st Angle Projection in Drawings
If the Projected View command creates a Top view of your part below the Front view instead of above it, you are probably experiencing 1st Angle Projection instead of 3rd Angle Projection which is much more common in the USA.
This setting is found in the Sheet Property settings.
To change it, right-click on the drawing sheet and choose Properties. You will see a radio button where you can switch from 1st Angle Projection to 3rd Angle Projection.
You should now use Save As to save a corrected version of your Drawing Template (see other tech tip above), since the 3rd Angle Projection setting depends on the settings of the Drawing Template for new drawing files.

<table>
<thead>
<tr>
<th>Projection</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>First angle</td>
<td><img src="image" alt="first_angle" /></td>
</tr>
<tr>
<td>Third angle</td>
<td><img src="image" alt="third_angle" /></td>
</tr>
</tbody>
</table>

8.3 Inserting Surfaces in Solidworks Drawing Views.
Surfaces do not appear in Solidworks Drawing views by default.
When used as reference geometry, surfaces are usually not required in a production drawing. However, when the entire model or some of its elements are designed as surface bodies, the drawing is incomplete if surfaces are not displayed.
Surface bodies can be inserted in drawing views as model items:
**Insert** => **Model Items** => **Reference Geometry** => **Surfaces**.
In the Source/Destination section, the source can be selected as entire model or a feature, and the import can be applied to all or selected views.

8.4 Align the Drawing view by an edge of the model.
The easiest method is a command that is rather hidden in the “Tools” menu.
Select first the edge in the model.
**Tools => Align Drawing view => Horizontal Edge.**

Another slightly more complicated method is by creating a **named view** (also called **alternative view** or **saved view**) for the part or assembly.

Open the part or assembly
Click on a face you want to use.
Click the icon make Normal To.
Click on the View Toolbar
Pick the **New View** icon

The Named View dialog box will appear (note: the model will revert to the view to be saved.) Enter the name for the new view in the **View Name** box. Hit **OK**.
The named view is now also available in Drawings.

Models which are not aligned with all 3 planes, cannot be fully aligned this way. Some extra steps are necessary.
Sketch a vertical or horizontal line in the view, and measure the angle between the new sketched line and the edge in the model view.
Rotate the view exactly with the same angle and delete the sketched line.

**8.5 Create Notes with Multiple Leader Lines in Drawings**

This is one of those functionalities in SolidWorks that is hiding in plain sight. There are no pull-down menus or dialog check-boxes to do this, because it uses the Windows Control-drag method.
First, click on the note to select it. When it highlights, you will see a square, green drag-handle at the end of the leader arrow. Place your cursor directly over this drag handle, hold down the Ctrl key, and drag-and-drop a copy of the leader to a new location. Repeat if you want more than two leaders.

**8.6 Dimensioning the “Arc Length” in a drawing view**

1. Select one end point of the arc
2. Select other end point of the arc
3. Select the arc itself

**8.7 Timesaving by “reusing” drawings of similar parts**

1. **Open the original drawing.** This will be the drawing that has the original part. Make sure the part is fully dimensioned and you have all the views you need.
2. **Save As... a new drawing.** Save the drawing with a new name to the location where you need it.
3. **Close the drawing.** Close down the drawing after you have saved it.
4. **Open the drawing.** Here’s the trick. Go to **File, Open...**, but before you actually open it, select **References...** down by all the check boxes.
5. **Replace the reference.** Double-click on the original part that is shown, then select the other part you need to detail. Hit **Open**, then **OK** and open up the drawing.

You should see your part change and you may need to move some dimensions, but you just saved a load of time by not re-creating the drawing all over again and again. Save your drawing and do it the same for the others.

**Other Applications.**
You can also do this if you need to add more parts on a single drawing. After you do the above process, select all the views of the new part, Copy (Ctrl-C) them, create a new sheet in your original drawing and Paste (Ctrl-V) the views to get them on the sheet. You can also use this for more complicated parts and
assemblies. This reinforces how important it is to use a standard method of creating parts, assemblies and drawings.

### 8.8 Timesaving with “automatic dimensioning”

1. Insert the Model Items into the drawing.  
   Set source = Entire model  
   Check button “Import items into all views”

2. Once they are inserted, they are being placed accordingly to their position in the model, which is to say pretty random.

3. Let’s select all these dimensions with a window (feel free to use the F5 shortcut key to access the dimension filter):

   ![Selection Filter](image)

   With the dimension filter on, I insure nothing else gets selected

4. Once the dimensions are selected make sure you do not move your mouse too far. There is one very shy icon not too far from your cursor. Have you spotted it?

5. If by any change you moved your mouse and the icon disappeared, don’t be upset, it can be called back by pressing the <CTRL> key on your keyboard. It will re-appear close to your cursor.

6. Now let’s select this Icon. It will expand into a mini toolbar: Magic! One click and most of my dimensions moved nicely in positions that make sense. Is SolidWorks reading my mind?

### 8.9 Auto arrange dimensions

Dimensioning a drawing can be pretty messy as in the example to the right. To fix this in flash, SolidWorks introduced Auto Arrange Dimensions in the SW2011 release. This function will automatically arrange the selected dimensions for you. The procedure is as follows:

1. Box-select all of the dimensions.
2 Next, move the mouse pointer over the Dimension Palette rollover button Dimension-palette-rollover to display the dimension palette. (Incidentally, if you mouse AWAY from the Dimension Palette rollover button, it will disappear. To get it back just hit the CTRL button on your keyboard.)

3 On the Dimension Palette, click Auto Arrange Dimensions in the lower left corner

4 Click in the graphics area to turn off the Dimension Palette – Easy!

5 When you use Auto Arrange Dimensions, the selected dimensions are placed as follows:

   - Spaced from smallest to largest
   - Aligned and centered, if possible
   - Spaced with the offset distances defined in Document Properties – Dimensions
   - Adjusted to avoid overlapping
   - Staggered, if necessary

8.10 Inserting chamfer dimensions into a drawing

1 Click Chamfer Dimension on the Dimensions/Relations toolbar or click Tools > Dimensions > Chamfer.
   The pointer changes to

2 Select the chamfered edge, select one of the lead-in edges, and then click in the graphics area to place the dimension. You must select the chamfered edge first. However, the dimension does not appear until you subsequently select one of the lead-in edges.
   Use rapid dimensioning to place evenly spaced dimensions. Alternatively, move the pointer outside of the rapid dimension selector to place the dimension.
   The Dimension PropertyManager appears, and the tool remains active for you to dimension other chamfers.

3 Click ✓.

8.11 Create an annotation with multiple arrows

1. Create a normal annotation with one arrow first.
2. Click on the annotation to highlight it, then click on the blue box at the end of the arrow point while holding down Ctrl and drag to the new location.

8.12 Create multiple instances of annotations

1. Click the appropriate tool from the Annotations toolbar, or click Insert, Annotations and select a tool from the menu.
2. Type in text and select options in the PropertyManager or dialog box.
3. With the PropertyManager or dialog box still open, click in the graphics area to place the annotation.
4. Click as many times as necessary if you need to place multiple copies.
5. If the annotation has a leader, click to place the leader, then click again to place the annotation.
6. You can change text and other items in the PropertyManager or dialog box for each instance of the annotation.
7. Click OK ✔

8.13 Foreshortened dimensions

To have a foreshortened diameter dimension, the diameter being dimensioned will have to be cut off in the view. Since SW2016, Foreshortened dimensions, are supported for all Views.

You can simply select an edge in a detail view created from either a Standard- or Section view and it will become foreshortened automatically. If you need to select other edges that are initially not visible, you can expand the detail view circle, add the dimension and reduce the detail circle, then right-click the dimension on the side you need foreshortened and select Display Options > Foreshorten.

For SW2015 and older versions, it requires some more work to do to get this in Section Views. (For the Standard View this is easy: click dimension => RMB => Display Options => Foreshortened).

To employ a foreshortened diameter dimension in a Section View, there is some preparation needed within the model. You cannot just insert your model into a drawing and add a non-imported dimension onto a circular feature. Because of the way Hole Wizard functions, foreshortening will also not work for holes created with it. SolidWorks only enables this function for imported dimensions (dimensions inserted from model).

1. Create a detail view which cuts across a circular feature.
2. If the center of the circle appears in the detail, select the detail view by LMB clicking it. If the center does not appear in the detail, then select the parent view instead.
3. Insert model items. This can be done by Insert pulldown > Model Items. One of the dimensions to appear will be the diameter of the circular feature.
4. Click OK in the PropertyManager Pane to accept and close Model Items panel. If already in the detail view, you are done. The dimension will appear as a foreshortened linear diameter dimension. However, if working in the parent view, a few more steps are required to get the desired effect.
5. Hold down the SHIFT key. Select the diameter dimension by clicking and hold the LMB over it.
6. Drag the dimension in the detail view. Let go of the LMB and SHIFT key. This will copy your dimension into the detail view. The dimension will appear as a foreshortened linear diameter dimension.
7. Delete the dimension from the parent view.

There are some limitations; tapered, cylindrical or curved surfaces won’t work. It needs to be a straight cylinder.
8.14 **Dual dimensions e.g. mm and inches.**

When you usually dimension in mm and want the same dimension also in inches, then click on the dimension in the drawing.

At the bottom of the Dimension-menu click Dual Dimension.

The length in inches is then added in brackets [ ].

![Dual Dimension](image)

8.15 **Section view on specific positions:**

Create sketch in the view. This maybe more than one line, and may also contain angles.

Select all the sketch elements.

Select “Section view”.

8.16 **Create a Broken-Out section view**

A broken-out section view cuts away a portion of an assembly in a drawing view, to expose the inside. Cross hatching is automatically generated on the sectioned faces of all components.

A broken-out section is not a separate view, but part of an existing drawing view. A closed profile, usually a spline, defines the broken-out section. Material is removed to a specified depth to expose inner details.

Specify the depth by setting a number or by selecting geometry in a drawing view.

1. Click Broken-out Section (Drawing toolbar), or click Insert > Drawing View > Broken-out Section. The pointer changes to:

   ![Broken-out Section](image)

   If you want a profile other than a spline, create and select a closed profile before clicking the Broken-out Section tool.

2. Sketch a profile.

3. Set options in the Section View dialog box. If you do not want to exclude components or fasteners from the broken-out section view, click OK.

4. Set options in the Broken-out Section PropertyManager. Use 3D drawing view mode to select an obscured edge for the depth of a broken-out section view.

5. Click .

Limitations:
- You cannot create a broken-out section on a detail-, section-, or alternate-position view.
- If you create a broken-out section of an exploded view, you cannot collapse the exploded view.

8.17 **The two types of Section Views with cutting lines explained**

Actually there are 2 types of section Views when a cutting lines are used for sectioning the cut.
After the selection of the cutting lines and selecting => View Layout = Section View, Solidworks automatically asks which of the 2 types must be used: the Foreshortened Section View or the Standard Section View.

Foreshortened Section View

(The red construction lines are not part of any drawing standard and are only for educational use)

Note the difference of the horizontal dimension 100 in Section A-A and 120mm in Section B-B.

In section B-B the total length of the cutting section is taken into account.
It’s a small difference but important enough to be always checked when a cross section view is present in a drawing.

8.18 Working with hatches

When working with (black and white) hatches it is best to change some settings for more flexibility in changing hatches:

- Uncheck: “Auto hatching”
- Uncheck: Material crosshatch
- Apply to: Region
- Type of hatch: as you like
- Scale: as you like
- Angle: as you like
- Use: shaded with edges
- Use: Draft quality
- Uncheck: Surface Bodies
Note:
Even with these settings as outlined above, the hatches on cross-section Views, do not always work correctly in SW2015.

Tip:
When a hatch cannot be changed or deleted, it is probably on a wrong layer.
Hatches in Cross section views are automatically placed on Layer “None” !!!
Click on the hatched area and check your layer settings.
To activate the Layers Toolbar click; View => Toolbars => Layer

8.19 Create colored hatches in drawings
By default, hatched lines and solids in drawing views are black on screens and prints.
You can change the color by placing the hatch on a different colored layer.
First make the “Layers Toolbar” visible by: View => Toolbars => Layer, and click the checkmark.
The “Layer Toolbar” appears in the left bottom corner of your screen.
Create a new Layer, with a new name, and set the color as you want.
Create the hatch on an area (region or view), click “Format” and select the Layer with the new color.
The solid hatch color will override part and component (assembly) appearances.

8.20 Create a watermark in a drawing
Right click on the drawing and select “Edit Sheet Format” and then insert your note. At this point while your note is still selected you can see under the “Text Format” section of the property manager there is an option called “Behind sheet”. This option instructs SOLIDWORKS to display the annotation note behind drawing objects.
Check the box and then right-click on the drawing sheet again and this time select “Edit sheet”. Now you can see that SOLIDWORKS has moved the note behind your view and as a result it is no longer covering the lines and dimensions in your view.

8.21 Inserting a Block in a Drawing
Insert => Annotations => Block, and browse to you block file.

8.22 Perspective View on a Drawing
The icon that changes display mode to “Perspective” within parts and assemblies is not available within the drawing environment, however it is possible to place a perspective view into a drawing. To show a drawing view with perspective (so the part appears tapered toward a vanishing point on the horizon), you need to create a custom view in the model file (part or assembly).
1. Open the model.
2. Go to View > Display > Perspective.
3. Zoom/Pan/Rotate to position the model as you wish.
4. Hit the spacebar to bring up the View Orientation dialog box.
5. Click the icon that looks like a blue telescope with an orange starburst behind it. This allows you to save the current view settings in the file. Type in a name for your custom view.
6. Create or open a drawing of the part/assembly.
7. Choose Insert – Drawing View – Model View, and choose your custom view name from the list of possible views to place on the sheet.

8.23 Change the orientation plane of a dimension in an isometric view.
Click on the dimension to be changed.
RMB => Display Options => Change plane (The Change Plane option is not always visible/possible.)

8.24 Create a custom view in a part or assembly for using in a drawing.
1. Press the SCPACE bar to see all possible orientation views.

2. Click on the dimension to be changed.
3. RMB => Display Options => Change plane (The Change Plane option is not always visible/possible.)

4. Give the new view a name, and the new view is selectable when you hit the SPACE bar.
5. The view can also be selected for editing when you hit the SPACE bar.
6. This view can also be selected in drawings.

8.25 Inserting End Treatment Symbols in Drawing Documents
To automatically insert end treatment symbols in drawing documents:
1. Click Model Items (Annotation toolbar) or Insert, Model Items and under Annotations, select End Treatment.
2. To open the End Treatment PropertyManager:
3. In a drawing document, click End Treatment (Annotation toolbar) or Insert > Annotations > End Treatment.

8.26 Defining a thread callout in a drawing
First check the settings:
Menu => Tools => Options.
In the “Document Properties” tab, there is “Detailing” on the left box.
Click “Detailing” and find “shaded cosmetic threads” in “display category”. Check the option.
1. Go to a circular item in a drawing.
2. Move your mouse pointer on the cosmetic thread line until the circular edge is highlighted with the text description of the cosmetic thread.
3. Click right mouse button and select “Insert Callout”.
4. The Drawing shows now the thread callout which was previously defined in the cosmetic tread on a circular surface of a part-model.

Tip:
It is easier to create holes with the Hole Wizard and apply the Cosmetic Thread option inside the Hole Wizard. In this case the correct settings for the diameter and thread depth are automatically applied in the Drawing and can be made easy visible with the standard Annotations.
8.27 **Show a model’s sketch in the drawing.**

In the Feature Tree of your drawing find the view you want to show the sketch in, expand the model and find the sketch. RMB select “show” and then make sure you have “sketches set as visible” in your View settings for the document.

Showing the sketch isn’t always the best way to go. Sometimes you don’t need the whole sketch. An alternative solution is to make the sketch visible, then use Convert Entities in the drawing to put curves on the drawing view. After that, you can turn the model sketch off again.

8.28 **BOM tables or BOM-lists**

BOM-tables (Bill Of Materials) are generally used in assembly drawings and show a list of parts in the assembly with additional info such as; description, part number, quantity or weight.

8.28.1 **General tips for BOM tables**

**Avoid Manual Editing**

The SolidWorks BOM is automated…. or should be, completely. There’s no reason to have to add something manually. You can go beyond the standard Quantity, Part Number and Description columns in your BOM by adding a Custom Property to your Component.

1. Open the part
2. Go to File => Properties
3. Hit the Custom Tab and enter Property Name, Type and Value. Hit OK.
4. In your drawing. Right click on a column and select Insert => Column left/right or select right above the column you want to change
5. Choose Custom Property and scroll down to select your new property

**Avoid Reference parts showing in the BOM.**

It’s sometimes very tempting to right-click on a row and select Delete or Hide for a part or sub-assembly that is for reference only. Don’t do that. There’s a better way.

1. Open your assembly
2. Right-click on the part and select Component Properties.

3. This is the most right icon:

4. On the bottom right, select Exclude from bill of materials:

**Avoid the Configuration Name in the BOM**

If you have one configuration showing, you don’t need the name to show in the BOM Quantity Column. It’s just silly. For the following options change to work, you’ll have to re-insert your BOM. Also, you’ll want to check this setting when creating new drawing templates. It will store it so you don’t have to keep changing it.

1. Go to Tools Options
2. Select the Document Properties Tab
3. Select the Tables section under Detailing
4. Check the Restrict top level only BOMs to one configuration option
Avoid a disorganized BOM.
Most of the time we insert a BOM and go with the default settings, but one of those can lead to a disorganized BOM. There’s an option that will make your BOM match how you have items listed in your model’s FeatureManager. You have to have a table already created to access this options.
1. Right-click on the table and select Properties...
2. In the Item Numbers section select “Follow Assembly Order”.

Avoid ridiculously large column widths in the BOM table
Sometimes the column width makes the BOM span an entire paper width. It is very simple to shrink the column widths and have your BOM looking nice: double-click the right edge of a Column.

Open a part from the BOM for editing:
While working in a drawing with a BOM many times you want/need to open a part while working from time to time. Solidworks has made this very easy, especially if the part we need is not seen in the drawing directly (internal part). From the BOM right click on the part you want/need to open and choose the Open option.

8.28.2 Adding Equations (formulas) to the BOM.
You can add easily simple calculations in the BOM list e.g. multiplication of column E (QTY) and F (Cost) = G (totalcost).

Select header of column G by clicking on it.
Select the “Equation”-symbol from the context menu.
Edit the Equation: ‘Cost’ * ‘QTY.’(3) by selecting these Columns.
(3) is the number of decimals defined in “Precision”.

The total of a column e.g. total of column G (totalcost) can be calculated by inserting an extra row at the bottom of the list (click on last row => Insert => Row below).

Select the cell in the empty row below column G by clicking on it.
Select the “Equation”-symbol from the context menu.
Select as a Function: “Total”

8.28.3 Showing the BOM on a Drawing of a Multibody Part
This is requires much more actions than an Assembly-BOM, so you can consider this as a rather complicated workaround.
1. Open the Multibody Part.
2. Click on Weldment on Weldment toolbar or Insert => Weldments => Weldment.
3. This will convert the part into a weldment-multibody part and will add a cut list.
4. RMB on the cut list and select **update**. This will update the cut list.
5. RMB on cut list item 1 and select “Properties”.
6. You may see the “Material” property there. If you need you can assign a different material to each body. For this, expand the cut list and right-click on the body. Select **Material** and then select the material you want to set.
7. Go back to cut list item 1 properties (as in step 5)
8. You can see the updated material property. Add a new property named “Description” and add value as Plate. You can add any value as per need.
9. Switch to Cut list item 2 and also add the description property. We’ll not change the material here.
10. Click “OK” at the bottom of the cut list properties window to close and apply the settings/changes.
11. Save your file.
12. Now switch to drawing mode and insert a view.
13. Right click on view or sheet and select Tables > Weldment Cut list or Insert > Tables > **Weldment Cut list**.
14. If you haven’t selected a view, you will be prompted to select a view. To select, simple click on the view.
15. The Weldment cut list property manager will appear.
16. Set the cut list template and choose any specific configuration if you need.
17. Finally click on OK and place the cut list at the appropriate place or if you want to set the position use anchor.

### 8.28.4 Hiding or showing rows or columns in a BOM-table.

Click the table.
The table toolbar appears:

Click Hide/Show.

The pointer changes to .

Click row numbers to select rows to hide.
Click a row twice to clear selection.

Click column headings to select columns to hide.
Click Hide/Show to hide the selected rows and columns.

<table>
<thead>
<tr>
<th>ITEM NO.</th>
<th>PART NUMBER</th>
<th>DESCRIPTION</th>
<th>QTY.</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Center</td>
<td></td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>Flange</td>
<td></td>
<td>2</td>
</tr>
<tr>
<td>3</td>
<td>Flanger</td>
<td></td>
<td>2</td>
</tr>
<tr>
<td>4</td>
<td>End Cap</td>
<td>Foam with 3 fins</td>
<td>3</td>
</tr>
<tr>
<td>6</td>
<td>Adhesive</td>
<td></td>
<td>1</td>
</tr>
</tbody>
</table>

---

Solidworks - Hints, Tips, Tricks and Best Practices – V2.0
8.28.5 Editing the column “Description” of a BOM table

The Description field in the default Bill of Materials is automatically populated by the value of a custom property. This Custom Property is defined in each Part or Assembly being referenced by the Bill of Materials. As a result of this relationship, if you double-click one of the description entries you’ll see a warning message indicating that you are about to sever a parametric link. The proper way of editing a Part or Assembly’s Description is to edit its custom properties. (File => Properties => Tab “Custom”).

8.28.6 Rounding of dimensions in the Cutlist (BOM table).

Rounding individual dimensions in Drawing tables is rather complicated. This is because the decimals in Drawing tables (including the BOM and the Cutlist) are controlled by the setting of Tools => Options => Document properties. Find “Tables”, then find “General table”, change from “smart” to “show”. Then to change from 3 place dim to say 2 place dim, you would need to change that at your unit’s level. This will change all dimensions on the drawing.

There is a rather complicated workaround for individual rounding dimensions for experienced users. This can be done by creating a new custom property, show this as a new column in the table and hide the original column.

8.29 Drawings with suppressed and unsuppressed parts

To have Drawing views with suppressed parts, you must specify a different configuration to show the part(s) suppressed and unsuppressed and then import the different named views into the drawing. Open the part- or assembly file. To access its custom properties, click the File drop-down menu then select Properties. This brings up the Custom Properties window. You have two types of custom properties available, Custom and Configuration Specific. Custom properties are applied at the Part level, while Configuration Specific properties are, as the name indicates, specific to a single configuration of the Part. The Description property we are looking for is a Part-level property, found on the “Custom”. Update this field, and the BOM will automatically update.

Tip: if you want to show or hide some of the components of an assembly, you simply click on this component in the feature tree of the View and then RMB select “Show/Hide”.

8.30 Drawing template vs Sheet Format

Many people get confused when it comes to creating custom Drawing Templates and Sheet Formats in Solidworks. It’s not as straight forward as Part and Assembly templates due to the fact that each sheet can potentially have different sheet sizes and title blocks. Because of this extra detail, the information is broken out into two files. Understanding what information is contained in each file and how they interact with each other is important to create a proper drawing template.

<table>
<thead>
<tr>
<th>Sheet Format (xxxx.slddrt)</th>
<th>Drawing Template (xxxx.drwdot)</th>
</tr>
</thead>
<tbody>
<tr>
<td>All information stored in Sheet Format (right-click on sheet &gt; Edit Sheet Format); this includes:</td>
<td>All settings under:</td>
</tr>
<tr>
<td>sheet size, sheet-orientation, borders, title-blocks, layers, logos, etc</td>
<td>Tools &gt; Options &gt; Document Properties tab.</td>
</tr>
<tr>
<td>All table anchors (BOM, Weldment Cutlist, etc)</td>
<td>All existing sheets.</td>
</tr>
<tr>
<td></td>
<td>All sheet formats on existing sheets.</td>
</tr>
<tr>
<td></td>
<td>All existing predefined views.</td>
</tr>
</tbody>
</table>

Solidworks - Hints, Tips, Tricks and Best Practices – V2.0
A **Drawing template** can hold more than 1 **Sheet format** if it contains more than 1 page. As mentioned in the Drawing Template file, any existing sheet in the template already contains a **Sheet Format**. However whenever a new sheet is added, it references the **Sheet Format** link that is specified in the active sheet properties. This is why a saved out Sheet Format with a link in the Drawing Template is key, otherwise you will receive the error “The sheet format could not be located.”

---

**8.31 Create a Drawing template with a link to a Sheet Format file.**

1. Start a blank new drawing via **File => New**
2. Edit the Sheet Properties (**RMB on the drawing => Properties**) and choose the sheet size (A, B, C, etc), set the Sheet Scale, etc. Click OK.
3. Edit the Sheet Format (**RMB on the drawing => Edit Sheet Format**) and customize the title block, border and anchors.
4. Accept the changes and return to the Sheet via the Confirmation Corner (top right of the graphics area).
5. Save the Sheet Format file by going to **File => Save Sheet format**. This will save a `xxxx.slddr` file. It is recommended to save this in a **custom location that is easy to find**. This path can be specified under **Tools => Options => System Options tab => File Locations => Sheet Formats**.
6. Return to the sheet Properties (right-click on drawing > Properties), and choose to Browse for the Sheet Format. Select the `sldfmt` file that you just saved.
7. Edit any other Sheet Properties (Type of Projection, Sheet Scale, etc) and click OK
8. Add any predefined views as needed
9. Go to **File => Save As** and choose to save as the Drawing Template (`.drwdot`) filetype. **Save in a custom location that is easy to find**. This path can be specified under **Tools => Options => System Options tab => File Locations => Templates**.
8.32  Repair the often occurring error: “The Sheet Format could not be located.”

Quick fix:
Browse to select the Sheet Format each time you add another sheet.

Solid fix:
The first step is to have your Sheet Format file saved. Some companies have a different sheet format for the first page and additional pages. This solution works regardless of whether the first page is different than the second or not.

Right-click on the sheet and select the “Properties” option.

1 Notice that there is a file path that points to a sheet format in the dialog box. This is the “Second Page Variable”. This is the file and file path that SOLIDWORKS uses when adding the second page. We are going to change this. Type in the name of the sheet format that you want to use (such as SHEET 2.SLDDRT). Do not include a file path.

2 Click on OK. SOLIDWORKS will give you an error message that the “Sheet format could not be located.” SOLIDWORKS will now show you the same display message but won’t allow you to select “OK”.

3 Click Cancel. Now the second page variable is set.

4 Save your template. You can check what sheet format your template is looking at to verify it worked.

5 Move your template and sheet format to your network or a folder that doesn’t get removed when you install a new version of SOLIDWORKS.

6 Set your SOLIDWORKS Template folders and sheet format paths in Options. Now when you add a second page, it just works as you would expect.

8.33  Linking Custom Properties to the Drawing Titleblock

It can be very advantageous to have some of the fields in the Drawing Titleblock auto-populating with information from the referenced model or assembly.

Create a part that has the properties you want linked to the title block.

To add properties select Properties from the File pull-down.
Insert a drawing view of the part into a drawing that will be used as your drawing template. Right click on blank area of the drawing sheet and select **Edit Sheet Format**. Create a Note.

From the Note Properties select the **Link to Property** icon.

Use the option: “Model in view specified in sheet properties”. After all the properties have been linked, delete the model. Save the drawing as a template (*.drwdot).

### 8.34 Editing Drawing Notes, Linked to File Properties

As you may know, you are able to link drawing notes to the file properties of the drawing and components. After inserting the note, click the **“Link to Property”** button in the PropertyManager. You have 4 options from where to grab the custom properties.

Search for “**Link to Property**” in the SolidWorks Help for a description of each option. The drop-down menu allows you to select the custom property from the specified file. Once finished you will notice that the note adds the corresponding value for the custom property. If you edit the note and click “Link to Property” again it just adds another link and doesn’t automatically remove the previous value. You could delete the previous value and add another link, but there is an option to edit the equation.
Right-click the note and select “Edit Text in Window.” This will open a dialog box showing the equation of the link. The 4 options that were provided in “Link to Property” correspond to the following equations:

- $\text{PRP:”Custom Property Name”}$
  - $\text{PRP}$ points to the drawing.

- $\text{PRPVIEW:”Custom Property Name”}$
  - $\text{PRPVIEW}$ points to overall model for the view that the note is attached to. If you didn’t double-click the view before adding the note, you can turn on and attach a leader to the model, and then hide the leader again.

- $\text{PRPSHEET:”Custom Property Name”}$
  - $\text{PRPSHEET}$ points to the overall model referenced in the default view specified in the sheet properties. By default it is set as the first view on the sheet.

- $\text{PRPMODEL:”Custom Property Name”}$
  - $\text{PRPMODEL}$ points to one component of the assembly. You will need to have a leader attached to the component (and can be hidden).
8.35 **Automatically fill in your Title Block**

Every time that you create a drawing document, you need to fill in the title block, including your name and the date that you created it. However, it gets repetitive if you have to do this every time. SolidWorks provides you the ability to do this automatically whenever you start a new drawing document. Let’s see how to automatically fill in the drawn by and created date information.

Open a new drawing document. Note that you’ll need to do this for each of the different sheet formats that you use. For this tip, in the Sheet Format/Size dialog box, make sure that the Standard sheet size radio button is selected and pick A - Landscape from the menu. Right below the menu is the name of the template, a - landscape.slddrt. If it’s not, browse to that file. Make sure that Display sheet format is checked and click OK.

In the Model View PropertyManager, click the Cancel button. You should see a blank piece of paper with a border and title block.

Pull down the “File” menu and pick Properties. In the Summary Information dialog box, on the Custom tab, click in the box below Property Name and pull down the “Property Name” menu and pick DrawnBy. Click in the Value / Text Expression box and type your initials. Note that what you type is exactly what will appear in the title block. Click OK.

Now, to automatically fill in the date, right click on the sheet and select Edit Sheet Format.

As you may notice, the lines turn blue and a few custom properties of parts or assemblies are already linked to fields in the system sheet formats.

That’s what the $PRPSHEET means. Place the cursor in the middle of the Drawn/Date box where the date should appear.
When the $PRP:“DrawnDate” flyout appears, click the left mouse button as shown below. A little green box will appear where you click.

In the Note PropertyManager, under Text Format, click the **Link to Property** button.

![Link to Property dialog box](image)

In the Link to Property dialog box, pick the Current document radio button. Then, pull down the menu and pick SW-Created Date. Below that, pull down the menu and pick Short Date. Uncheck the Show Time check box. This will place the current date in to the title block of your drawing.

If you wanted the date the model was created in your drawing, pick the Model in view specified in sheet properties radio button. Finally, click OK to close the dialog box.

You should now see the current date in your title block. Right click on the date and pick Edit Text in Window. (For SolidWorks 2007 and before, right click on the date and pick Properties).

Delete $PRP:“DrawnDate” as shown below and click OK.

![Edit Text Window](image)

Press the Escape key and then right click on the sheet and pick Edit Sheet. The lines on the title block turn gray, indicating that the drawing sheet is now active. Remember that SW-Created Date is static. In other words, when you create a new drawing document, the current date will be inserted. But thereafter, when you reopen any of your saved drawing documents, the date remains the date the document was created, not changing to the current date.
To make this work for future drawing documents, you'll have to save it. You can replace the existing sheet format or save it as a new one. To do this, pull down the “File” menu and pick Save Sheet Format. In the Save Sheet Format dialog box, under File name, rename the file to “a – landscape date.slddrt” and click Save. Finally, open a new drawing document. In the Sheet Format/Size dialog box, pick a – landscape date from the list of available sheet formats, as shown below. Click OK.

In the Model View PropertyManager, click the Cancel button. In your title block, you should see that your initials and the created date are already filled in for you. So, every time that you use this new customized sheet format, you don't have to worry about filling out your name and the date the drawing was created. SolidWorks automatically does it for you. Look around the title block for other fields that you may want to have filled in automatically.
9 Workarounds
Some “workarounds” for Solidworks 2015 for subjects which can be very frustrating.
I have not tested these workarounds in SW2016 and SW2017.

9.1 Complex sketch mirror entities
Complex sketches can be difficult to mirror at sketch level and often gives errors of over defined entities.
In that case you can create another sketch on the same plane and use convert entities, than the sketch can be easily mirrored at sketch level.

9.2 Cosmetic thread of a part does not show in Part or Assembly
There are several reasons why the cosmetic thread feature do not show in an Assembly.
Check all the settings listed below.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>In the Hole wizard menu options, check if Cosmetic thread is selected.</td>
</tr>
<tr>
<td>2</td>
<td>All Annotations: View menu &gt; All Annotations</td>
</tr>
<tr>
<td>3</td>
<td>Cosmetic Threads: Right click on Annotations folder &gt; Details &gt; Cosmetic threads checkbox</td>
</tr>
<tr>
<td>4</td>
<td>Display Annotations: Right click on Annotations folder &gt; Display Annotations</td>
</tr>
<tr>
<td>5</td>
<td>Use assembly settings for all components: Options=&gt; System Options = &gt; Right click on Annotations folder &gt; Details &gt; Use assembly settings for all components checkbox.</td>
</tr>
</tbody>
</table>

Even if the above settings are correct, sometimes the Cosmetic thread does not show.
In that case you have to edit the component and look for the Cosmetic thread feature in the Feature tree.
RMB on the Cosmetic thread Feature and click on “Edit Feature” and close it, now it should show!

9.3 Individual rounding of dimensions in a Cut list (BOM-table).
Individual rounding of dimensions can be done by creating a new custom property.
Show this property as a new column in the table and hide the original column.
See also chapter 7.26.5.

9.4 Number of holes in the “Hole callout” in drawings
You always have to check the number of holes in the “Hole callout Annotation”.
If you have mirrored features or bodies with holes, than the number of holes might be incorrect because usually only the number of holes in the first feature or body are represented.
If this is the case, you have to correct this manually!
The alternative is: create all holes of the same dimension in one feature and face.

9.5 Saving a Toolbox part as a standard part
When just changing and saving the file property with “Sldsetdocprop.exe” does not work.
Open the Solidworks Toolbox model then “SAVE AS” and put there the name you want and save to desired folder. Then use the “Sldsetdocprop.exe” software program, click add files and select the Toolbox.
model you just saved as. Click the show selected property and it will show a standard which means the Toolbox is still controlling the model so “select property state No” and click update status.
When you try to click again the “show selected property” it will show “No” which means the model is not related to the Toolbox anymore and you can exit the “sldsetdocprop.exe” program. The model now is in the standard Solidworks part format.

9.6 **A part with 2 or more bodies (partially) occupying the same space.**

Maybe not a workaround but a general remark.
You can calculate the mass properties of each separate body.
When you calculate the mass properties of the total part, Solidworks gives you the sum of the mass properties of each individual body, which is actually impossible. Solidworks does not warn you that bodies do occupy the same space.

9.7 **Annotations of mirrored parts do not show in Drawing**

Annotations such as Weld beads and Cosmetic threads do not show in “opposite hand mirrored” parts.
This is probably because these features are not solid bodies.
I do not know a good workaround for this. The only way seems to put these features another time in the mirrored part, which is very annoying.