AnsweredAssumed Answered

SW 2018 Install error: The Windows Installer for this product component did not run as expected: register_i386_SldShellExtServerExe

Question asked by Brad Huitt on Jul 16, 2018
Latest reply on Jul 16, 2018 by Brad Huitt

When trying to install Solidworks 2018 SP3 on this Win 7 pro machine, I was getting the error:

"Internal error: The Windows Installer for this product component did not run as expected: register_i386_SldShellExtServerExe." and also error in log "** Install FAILED with code 1603".


I had tried removing all of the C++ redistributables, rebooting, then installing, as well as another solution mentioned which is renaming these registry entries:




And also I tried un-checking the option to install the "Visual Studio Tools..." under Solidworks.


SW 2017 SP 4.1 is still installed and I tried upgrading that installation, as well as installing a separate new 2018 SP3 installation.  Anti-virus is disabled, UAC disabled, and I'm running the installation as Admin.


No luck


But then I figured out how to solve this problem by checking the Windows updates.  This computer is running Windows 7 Professional with SP1 (which meets the Solidworks 2018 minimum requirements), but the last update was installed in 2014.   I ran windows update and it told me I had to install a windows update "update".  I agreed to that and installed it, then restarted the computer.  I ran windows update again and it found 73 critical updates and several optional updates.  I checked to make sure I wasn't installing the KB3072630 windows update (as that one has apparently caused problems with installing in the past) then I installed the critical updates (no optional updates).  Once that was done I let the computer reboot and tried the installation again and it worked perfectly.


I can't tell you exactly which update or updates solved the problem, but this worked for me.