AnsweredAssumed Answered

SW 2018 flexible assembly constraint issues

Question asked by Dennis Parr on May 3, 2018
Latest reply on May 4, 2018 by Dennis Parr

I use flexible sub-assemblies with multiple configurations to represent various motion positions.  Very often, when I open the top level assembly the constraints will be broken.  I saw a thread for SW 2015 having this problem, which I remember was fixed with an SP. Haven't seen it crop up again until now.

 

If I edit the flexible sub-assembly in-place, and conduct a rebuild, the broken constraints will be repaired... sometimes. Other times I have to open the flexible assembly and toggle between configurations. Rebuild, save, go back to the top level assembly and the constraints are repaired.... sometimes. If this doesn't work, I locate a failed constraint, suppress it. Rebuild the assembly. Then unsuppress the constraint that was previously failed and the constraint issue is repaired. When none of these work. I save everything. Close the file. Close SW and start it back up. Open the assembly and nothing is wrong. If that doesn't work, I've changed the flexible assembly to not be flexible. Rebuild. Everything is fixed. Then make the assembly flexible again.

 

I've been working on a batch of punching dies (8 so far and growing) and I have to go through this at least 2-3 times EVERY time I have any of these assemblies open. I have to go through 1 or all of the work-arounds until one of them works.

 

Dell Precision 5810

           OS: Windows 10 Pro x64-bit

         CPU: Intel(R) Xeon(R) E5-1603 v3 @ 2.8GHz

         Ram: 16.0 GB

Video Card: NVIDIA Quadro K1200

 

Is anyone else having this problem? I hoping because it was an issue that showed up in SW 2015 and hasn't cropped up until we upgraded to SW 2018 it is an issue that SW can fix with a service pack like they did with 2015.

Outcomes