2 Replies Latest reply on Jan 24, 2018 8:50 PM by Ivan Qiu

    SW freezes when saving

    Ivan Qiu

      I recently replaced my graphics card to a Quadro P2000 and now almost every time I try to save a file or an assembly everything freezes. I can still rotate and zoom in on the part, but nothing else will respond until I end the process in my task manager. This seems to be file and part independent since the same thing will happen with a new part, and sometimes it wont happen at all.


      I'm closing the program every 5-10 minutes and it's making Solidworks impossible to use. I have tried the most current gpu firmware, as well as SW recommended firmware with no success. I have also tried running in openGL mode with no success. I'm running Solidworks 2018 x64 SP1.0.

        • Re: SW freezes when saving
          Jim Wilkinson

          Hi Ivan,


          If you can still rotate and zoom in on the part, it sounds like there may be some non-modal dialog popping up, but off screen, but I'm uncertain of what non-modal dialog may be coming up in the save process. To confirm that there is in fact a dialog popping up, you can try hitting ESC to see if that dialog closes and control comes back as normal. This won't definitely confirm it because ESC does not close all dialogs, but it does for most. You could also try Alt-tab to see if you can see the dialog in that screen and switch to it. Or, you can look in the Windows task-bar and see if there is an icon for it and then press shift and push the right mouse button on the icon and select move and use the arrow keys to see if you can move it onto the screen.


          I hope this helps,


            • Re: SW freezes when saving
              Ivan Qiu

              Hi Jim,


              This worked out, thanks for your help. Pressing escape did allow me to return. Turns out after I upgraded to SW 2018 it was asking me to save my old outdated files as 2018 files in a pop-up off screen. I still can not find the dialog box when things seem frozen but I realized this was the issue the after the couple times it did appear correctly. Thanks!