AnsweredAssumed Answered

Solidworks Electrical weird routing results

Question asked by Arutram Liemd on Jan 18, 2018
Latest reply on Oct 17, 2018 by David Dubois


I have been testing Solidworks Electrical for a while now and made ~80% of first project - made most of the electrical schematics (2D). Because of setbacks with 3D Electrical which I explained in post I couldn’t make any progress with 3D. Now the issues reported in that post were solved with SW2017 SP5 and SW2018. But new issue has emerged. I did mention the issue in previous post but since is different issue it justifies a new post.


After routing the wires in assembly, I noticed some wires were routed rather strangely:




Some wires weren’t routed along defined paths or better say, were routed along wrong paths – crossing inserted elements, some % of length does snap on path, but then just snaps on different location. Here I am using predefined routing parameters (50mm, 500mm, 0.5mm). If I lower the distance I get better results:


But still, routing in SW 2017 SP4 works better (with both parameter settings):



As I understand the basis for routing is Graph – when Soldiworks starts to route it first reads the Graph. I presume that it reads the same graph which we can draw with Draw Graph command (in routing manager).

This is the result I get

top SW2017SP5/SW2018 greater distance (left) vs lower distance (right);

bottom SW2017SP4:

RG_1.png RG_2.png



We can see the graph makes more sense with SW2017SP4. With lower distance settings we get much clearer graph even with SP5 and SW2018.

Correct me if I am wrong, but the function of this graph is to find the shortest path (with defined parameters and some defined “shape” perpendicular, straight line, no crossing/jumps etc.) for route.

It seems like the algorithm for this graph is broken with SW2017SP5 and SW2018 – it outputs all available paths between components and even vertices. And when it routs it chooses the shortest path (which can be the “wrong” path).


Can someone verify this is the bug in SW or is just mine projects. I tried example projects (Ascensor) In SW2017SP4/SP5 and SW2018SP1. All yielded same results. Then I created some simple projects with every version (started from scratch), just simple terminal blocks and 3D components - still the same.


Was this issue reported and how do you deal with this?


Update (14.9.2018)

Nothing much has changed in SW2018SP4. Function "Draw Graph" produces the same result as SW2017SP5 and SW2018SP0/1 - multiple connections/lines per connection points.


Routing results are as good as the Graph. Which means more than not routing yields bad result.

Some1 should really check this bug.


Update (20.11.2018)

Problem persists in SW 2018 SP5 and SW 2019 SP0.


Update (12.02.2020)

Seems like the problem has been resolved since SW 2020 SP0.1.



Best Regards!



Using Windows 10 Pro 1709